Update to 0.90p11
PR: 21795 Submitted by: Ports Fury
This commit is contained in:
parent
40db428c9c
commit
bd46978ddb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33742
3 changed files with 22 additions and 22 deletions
|
@ -6,10 +6,10 @@
|
|||
#
|
||||
|
||||
PORTNAME= cqcam
|
||||
PORTVERSION= 0.90p9
|
||||
PORTVERSION= 0.90p11
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.cs.duke.edu/~reynolds/cqcam/
|
||||
DISTNAME= ${PORTNAME}-0.90pre9
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/pre/}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
@ -17,36 +17,36 @@ MAINTAINER= ports@FreeBSD.org
|
|||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
INSTALL_TARGET= bininstall
|
||||
|
||||
USE_XLIB= yes
|
||||
USE_GTK= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-asm
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -pedantic" \
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --disable-asm
|
||||
INSTALL_TARGET= bininstall
|
||||
|
||||
MAN1= cqcam.1
|
||||
MLINKS= cqcam.1 webcam.1 \
|
||||
cqcam.1 xcqcam.1
|
||||
|
||||
CQCAM_DOCS= README docs/APINOTES docs/CHANGES docs/README.webcam \
|
||||
PORTDOCS= README docs/APINOTES docs/CHANGES docs/README.webcam \
|
||||
docs/refresh.html docs/webcam.html
|
||||
|
||||
post-install:
|
||||
.for file in cqcam gtkcam webcam xcqcam
|
||||
@strip ${PREFIX}/bin/${file}
|
||||
.endfor
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/cqcam.1 ${PREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/cqcam.1 ${MANPREFIX}/man/man1
|
||||
@${MKDIR} ${PREFIX}/share/examples/cqcam
|
||||
${INSTALL_DATA} ${WRKSRC}/.cqcrc ${PREFIX}/share/examples/cqcam/sample.cqcrc
|
||||
${INSTALL_DATA} ${WRKSRC}/webcam/nph-webcam ${PREFIX}/share/examples/cqcam/sample.nph-webcam
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/cqcam
|
||||
.for file in ${CQCAM_DOCS}
|
||||
.for file in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/cqcam
|
||||
.endfor
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${SED} -e "s:/usr/local:${PREFIX}:" ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (cqcam-0.90pre9.tgz) = 1732df04cb536da102f54de187243fa7
|
||||
MD5 (cqcam-0.90pre11.tgz) = 93a5bde5e9118d2db0d7d36196ac5967
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- configure.orig Mon Feb 1 16:01:12 1999
|
||||
+++ configure Mon Mar 13 03:54:42 2000
|
||||
@@ -1108,8 +1108,8 @@
|
||||
echo "configure:1109: checking if the compiler understands -pipe" >&5
|
||||
--- configure.orig Thu Aug 17 19:41:42 2000
|
||||
+++ configure Sat Oct 7 06:30:04 2000
|
||||
@@ -1182,8 +1182,8 @@
|
||||
echo "configure:1183: checking if the compiler understands -pipe" >&5
|
||||
OLDCC="$CC"
|
||||
OLDCXX="$CXX"
|
||||
- CC="$CC -pipe"
|
||||
|
@ -9,27 +9,27 @@
|
|||
+ CC="$CC"
|
||||
+ CXX="$CXX"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 1115 "configure"
|
||||
#line 1189 "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -1655,7 +1655,7 @@
|
||||
@@ -1707,7 +1707,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-lgtk `$gtkbin""gtk-config --libs` $LIBS"
|
||||
+LIBS="`$gtkbin""$GTK_CONFIG --libs` $LIBS"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 1661 "configure"
|
||||
#line 1713 "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -1694,7 +1694,7 @@
|
||||
@@ -1746,7 +1746,7 @@
|
||||
|
||||
echo $ac_n "checking GTK+ version""... $ac_c" 1>&6
|
||||
echo "configure:1697: checking GTK+ version" >&5
|
||||
echo "configure:1749: checking GTK+ version" >&5
|
||||
- GTKV=`$gtkbin""gtk-config --version`
|
||||
+ GTKV=`$gtkbin""$GTK_CONFIG --version`
|
||||
echo "$ac_t""$GTKV" 1>&6
|
||||
case "$GTKV" in
|
||||
1.0.*)
|
||||
@@ -1890,8 +1890,8 @@
|
||||
@@ -1942,8 +1942,8 @@
|
||||
OS_LIBCQCAM_OBJS=''
|
||||
;;
|
||||
freebsd*)
|
||||
|
@ -40,11 +40,11 @@
|
|||
OS_LIBCQCAM_OBJS=''
|
||||
;;
|
||||
bsdi*)
|
||||
@@ -2124,6 +2124,7 @@
|
||||
@@ -2178,6 +2178,7 @@
|
||||
s%@x_includes@%$x_includes%g
|
||||
s%@bingroup@%$bingroup%g
|
||||
s%@gtkbin@%$gtkbin%g
|
||||
+s%@GTK_CONFIG@%$GTK_CONFIG%g
|
||||
s%@GTK_CFLAGS@%$GTK_CFLAGS%g
|
||||
s%@xviewlib@%$xviewlib%g
|
||||
|
||||
CEOF
|
||||
|
|
Loading…
Reference in a new issue