devel/heaptrack: update to 1.3.0, latest upstream

Heaptrack traces all memory allocations and annotates these events with
stack traces. Dedicated analysis tools then allow you to interpret the
heap memory profile to, e.g., find hotspots that need to be optimized
to reduce the memory footprint of your application.

Release notes are here:
	https://invent.kde.org/sdk/heaptrack/-/releases/v1.3.0

Version 1.3.0 comes with quite some important new features, notably
time based filtering capabilities and support for custom suppressions.
This commit is contained in:
Adriaan de Groot 2021-12-19 23:27:45 +01:00
parent d50b72ba9f
commit bd77def3cc
4 changed files with 30 additions and 31 deletions

View file

@ -1,14 +1,13 @@
PORTNAME= heaptrack PORTNAME= heaptrack
DISTVERSIONPREFIX= v DISTVERSION= 1.3.0
DISTVERSION= 1.2.0-43
PORTREVISION= 1
CATEGORIES= devel kde CATEGORIES= devel kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/
MAINTAINER= kde@FreeBSD.org MAINTAINER= kde@FreeBSD.org
COMMENT= Heap memory profiler COMMENT= Heap memory profiler
LICENSE= LGPL21 LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING LICENSE_FILE= ${WRKSRC}/LICENSES/GPL-2.0-or-later.txt
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \ LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
libunwind.so:devel/libunwind \ libunwind.so:devel/libunwind \
@ -23,6 +22,4 @@ USE_KDE= auth auth codecs completion config config \
USE_QT= concurrent core dbus gui network widgets xml \ USE_QT= concurrent core dbus gui network widgets xml \
buildtools_build qmake_build buildtools_build qmake_build
KDE_INVENT= 1c2d406387dc59e7ebba727fd42a647f2f38bba4 sdk
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1620381505 TIMESTAMP = 1639951579
SHA256 (sdk-heaptrack-1c2d406387dc59e7ebba727fd42a647f2f38bba4_GL0.tar.gz) = 749d8d653b9ba2d728c69d0b8ce4d39a79d130b9c33d92c7a615a38a981ee7db SHA256 (heaptrack-1.3.0.tar.xz) = b9bb8458110d6eb5da0884cd53562cc2efc3928cfd3c3a6a1c67ea09b5747e04
SIZE (sdk-heaptrack-1c2d406387dc59e7ebba727fd42a647f2f38bba4_GL0.tar.gz) = 1118883 SIZE (heaptrack-1.3.0.tar.xz) = 5521900

View file

@ -1,21 +0,0 @@
--- src/track/heaptrack_inject.cpp.orig 2020-06-01 22:47:27 UTC
+++ src/track/heaptrack_inject.cpp
@@ -66,8 +66,18 @@ using Dyn = ElfW(Dyn);
using Rel = ElfW(Rel);
using Rela = ElfW(Rela);
using Sym = ElfW(Sym);
+#if __WORDSIZE == 64
using Sxword = ElfW(Sxword);
using Xword = ElfW(Xword);
+#else
+// FreeBSD elf32.h doesn't define Elf32_Sxword or _Xword. This is used in struct
+// elftable, where it's used as a tag value. Our Elf32_Dyn uses Elf32_Sword there,
+// as does the Linux definition (and the standard); the El64_Dyn uses Sxword.
+//
+// Linux elf.h defines Elf32_Sxword as a 64-bit quantity, so let's do that
+using Sxword = int64_t;
+using Xword = uint64_t;
+#endif
}
void overwrite_symbols() noexcept;

View file

@ -12,4 +12,27 @@ share/icons/hicolor/22x22/apps/heaptrack.png
share/icons/hicolor/32x32/apps/heaptrack.png share/icons/hicolor/32x32/apps/heaptrack.png
share/icons/hicolor/48x48/apps/heaptrack.png share/icons/hicolor/48x48/apps/heaptrack.png
share/icons/hicolor/64x64/apps/heaptrack.png share/icons/hicolor/64x64/apps/heaptrack.png
share/locale/ast/LC_MESSAGES/heaptrack.mo
share/locale/ca/LC_MESSAGES/heaptrack.mo
share/locale/ca@valencia/LC_MESSAGES/heaptrack.mo
share/locale/cs/LC_MESSAGES/heaptrack.mo
share/locale/da/LC_MESSAGES/heaptrack.mo
share/locale/de/LC_MESSAGES/heaptrack.mo
share/locale/en_GB/LC_MESSAGES/heaptrack.mo
share/locale/es/LC_MESSAGES/heaptrack.mo
share/locale/fr/LC_MESSAGES/heaptrack.mo
share/locale/gl/LC_MESSAGES/heaptrack.mo
share/locale/ia/LC_MESSAGES/heaptrack.mo
share/locale/ko/LC_MESSAGES/heaptrack.mo
share/locale/nl/LC_MESSAGES/heaptrack.mo
share/locale/nn/LC_MESSAGES/heaptrack.mo
share/locale/pl/LC_MESSAGES/heaptrack.mo
share/locale/pt/LC_MESSAGES/heaptrack.mo
share/locale/pt_BR/LC_MESSAGES/heaptrack.mo
share/locale/ru/LC_MESSAGES/heaptrack.mo
share/locale/sk/LC_MESSAGES/heaptrack.mo
share/locale/sv/LC_MESSAGES/heaptrack.mo
share/locale/tr/LC_MESSAGES/heaptrack.mo
share/locale/uk/LC_MESSAGES/heaptrack.mo
share/locale/zh_CN/LC_MESSAGES/heaptrack.mo
share/metainfo/org.kde.heaptrack.appdata.xml share/metainfo/org.kde.heaptrack.appdata.xml