Update to 0.6.15 release.

This commit is contained in:
Alex Dupre 2008-08-26 13:33:25 +00:00
parent 9ab35a0cac
commit bd9f73b777
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=219217
4 changed files with 37 additions and 23 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= openct
DISTVERSION= 0.6.14
PORTVERSION= 0.6.15
CATEGORIES= security
MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
http://www.opensc-project.org/files/${PORTNAME}/testing/
@ -14,46 +14,48 @@ MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
MAINTAINER= ale@FreeBSD.org
COMMENT= A middleware framework for smart card terminals
OPTIONS= USB "Install libusb for USB tokens/readers support" on \
PCSC "Install pcsc-lite to build the PC/SC->OpenCT frontend" off
OPTIONS= PCSC "Enable PC/SC support" off
USE_AUTOTOOLS= libltdl:15
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
USE_RC_SUBR= openct
SUB_FILES= etoken.conf
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ENV= LTLIB_CFLAGS="-I${LOCALBASE}/include" \
LTLIB_LIBS="-L${LOCALBASE}/lib -lltdl"
CONFIGURE_ARGS= --with-ifddir=${PREFIX}/lib/ifd \
--localstatedir=/var
MAN1= openct-tool.1
DOC_FILES= README export-wiki.sh export-wiki.xsl trac.css *.html api
DOC_FILES= trac.css *.html
PORTDOCS= *
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_USB) || exists(${LOCALBASE}/lib/libusb-0.1.so)
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
.endif
.if defined(WITH_PCSC) || exists(${LOCALBASE}/lib/libpcsclite.so)
.if defined(WITH_PCSC)
LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
CONFIGURE_ARGS+=--enable-pcsc
PLIST_SUB+= PCSC=""
.else
PLIST_SUB+= PCSC="@comment "
.endif
post-patch:
@${REINPLACE_CMD} 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
${WRKSRC}/configure
post-install:
${INSTALL_DATA} ${WRKSRC}/etc/openct.conf ${PREFIX}/etc/openct.conf-sample
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKDIR}/etoken.conf ${EXAMPLESDIR}
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC}/doc && ${CP} -R ${DOC_FILES} ${DOCSDIR})
@(cd ${WRKSRC}/doc/nonpersistent/wiki.out/ && ${CP} -R ${DOC_FILES} ${DOCSDIR})
.endif
@${CAT} ${PKGMESSAGE}

View file

@ -1,3 +1,3 @@
MD5 (openct-0.6.14.tar.gz) = 04a5c0c7dedcb1ca0d550b1970fbf3b7
SHA256 (openct-0.6.14.tar.gz) = 3df187f63eb6694652098238bdf967b304dad8f62e9219be4cf3b6d5ec5db58b
SIZE (openct-0.6.14.tar.gz) = 670510
MD5 (openct-0.6.15.tar.gz) = 70205beac03974e266fc259b6c9feaa8
SHA256 (openct-0.6.15.tar.gz) = 737cafaef803e21d63c61a196b07b61c1ba47320a24b9c7c2790c68f92719b6a
SIZE (openct-0.6.15.tar.gz) = 673265

View file

@ -0,0 +1,15 @@
--- etc/Makefile.in.orig 2008-08-26 15:00:26.000000000 +0200
+++ etc/Makefile.in 2008-08-26 15:00:52.000000000 +0200
@@ -459,11 +459,7 @@
uninstall-nodist_udevSCRIPTS uninstall-sysconfDATA
install-exec-hook: install-sysconfDATA openct.conf
- if [ -f "$(DESTDIR)$(sysconfdir)/openct.conf" ]; then \
- $(INSTALL_DATA) openct.conf "$(DESTDIR)$(sysconfdir)/openct.conf.new"; \
- else \
- $(INSTALL_DATA) openct.conf "$(DESTDIR)$(sysconfdir)/openct.conf"; \
- fi
+ $(INSTALL_DATA) openct.conf "$(DESTDIR)$(sysconfdir)/openct.conf-sample"; \
.in:
sed \

View file

@ -1,14 +1,11 @@
$FreeBSD$
--- etc/openct.conf.in.orig
+++ etc/openct.conf.in
--- etc/openct.conf.in.orig 2008-07-27 11:54:37.000000000 +0200
+++ etc/openct.conf.in 2008-08-26 13:00:58.000000000 +0200
@@ -2,7 +2,7 @@
debug = 0;
#
# Enable hot plugging
-hotplug = yes;
+hotplug = no;
#
# Path to ifdhandler
ifdhandler = SBINDIR/ifdhandler;