Removal of arabic/katoob

This software is no longer necessary due to developments
	in pango.

PR:		ports/123248
Submitted by:	"Samy Al Bahra" <sbahra@kerneled.org>
This commit is contained in:
Edwin Groothuis 2008-04-30 07:50:15 +00:00
parent 94e3ce48e5
commit bdb4e2cd6f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=212329
10 changed files with 1 additions and 129 deletions

1
MOVED
View file

@ -3467,3 +3467,4 @@ www/firefox15||2008-04-30|Has expired: Obsolete version, use Firefox 2.0 or grea
www/phpadsnew||2008-04-30|Has expired: replaced by www/openx
x11-wm/yawm||2008-04-30|Has expired: project no longer exists
x11-wm/uwm||2008-04-30|Has expired: Version branch long since retired
arabic/katoob||2008-04-30|Removed on maintainers request due to inactivity of project

View file

@ -8,7 +8,6 @@
SUBDIR += arabtex
SUBDIR += aspell
SUBDIR += kacst_fonts
SUBDIR += katoob
SUBDIR += kde3-i18n
SUBDIR += khotot
SUBDIR += koffice-i18n

View file

@ -1,41 +0,0 @@
# New ports collection makefile for: katoob
# Date created: 13th September 2003
# Whom: Pav Lucistnik <pav@oook.cz>
#
# $FreeBSD$
#
PORTNAME= katoob
PORTVERSION= 0.3.5
PORTREVISION= 11
CATEGORIES= arabic
MASTER_SITES= SF/arabeyes
MAINTAINER= sbahra@gwu.edu
COMMENT= Light-weight, bidirectional editor for arabic texts
MAN1= katoob.1
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gtk20
WANT_GNOME= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Broken with gcc 4.2
.endif
.if ${HAVE_GNOME:Mgtksourceview}!="" || defined(WITH_HIGHLIGHTING)
CONFIGURE_ARGS+= "--enable-highlight"
USE_GNOME+= gtksourceview
.endif
.if defined(WITH_SPELLCHECKER) || exists(${LOCALBASE}/lib/libaspell.so.16)
CONFIGURE_ARGS+= "--enable-spell"
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
MD5 (katoob-0.3.5.tar.gz) = a05723c7aee914c51226270aa3d61ff9
SHA256 (katoob-0.3.5.tar.gz) = 213dde01195dbb10ff1710aff7c3948e3c20c7a0c227ca05e0665922b7bb2c64
SIZE (katoob-0.3.5.tar.gz) = 427297

View file

@ -1,10 +0,0 @@
--- src/conf.c Tue Aug 26 07:54:35 2003
+++ src/conf.c.patch Mon May 24 16:57:43 2004
@@ -798,6 +798,7 @@
if (!fp)
{
g_warning ("Can't open the printing configuration file.");
+ return;
}
fprintf (fp, "font_family = %s\n", encode_font (PConf->font_family));

View file

@ -1,21 +0,0 @@
--- src/init.c Tue Aug 26 07:54:35 2003
+++ /home/samy/development/katoob/src/init.c Thu Aug 28 00:36:48 2003
@@ -101,7 +101,18 @@
katoob->xkb_grps[i] =
XGetAtomName (GDK_DISPLAY (), kbinfo->names->groups[i]);
}
+ else
+ {
+ katoob->xkb_grps[i] = NULL;
+ }
}
+ }
+
+/* Let's NULL all the remaining array. */
+ while (grpnum < XkbNumKbdGroups)
+ {
+ katoob->xkb_grps[grpnum] = NULL;
+ ++grpnum;
}
XkbGetControls (GDK_DISPLAY (), XkbAllControlsMask, kbinfo);

View file

@ -1,14 +0,0 @@
--- src/katoob.h.orig Thu May 20 12:44:35 2004
+++ src/katoob.h Thu May 20 12:44:48 2004
@@ -25,11 +25,6 @@
#ifndef __KATOOB_H__
#define __KATOOB_H__
-#define G_DISABLE_DEPRECATED 1
-#define GDK_DISABLE_DEPRECATED 1
-#define GDK_PIXBUF_DISABLE_DEPRECATED 1
-#define GTK_DISABLE_DEPRECATED 1
-
#include <gtk/gtk.h>
#include "encodings.h"
#ifdef ENABLE_HIGHLIGHT

View file

@ -1,14 +0,0 @@
--- src/search.c Tue Aug 26 07:54:37 2003
+++ src/search.c.patch Mon May 24 17:07:16 2004
@@ -266,9 +266,8 @@
tmp = katoob_document_get_last_replaced (doc);
if ((tmp) && (replace))
{
- gtk_entry_set_text (GTK_ENTRY (entry2), g_strdup (tmp));
- g_free (tmp);
- tmp = NULL;
+ gtk_entry_set_text (GTK_ENTRY (entry2), tmp);
+ tmp = NULL;
}
}

View file

@ -1,8 +0,0 @@
Katoob is a light weight, multi lingual,
BIDI-aware text editor based on the Gtk+ 2
library. It supports opening and saving files
in multiple encodings. The main support was
for Arabic language but more languages are
currently supported.
WWW: http://www.arabeyes.org/project.php?proj=Katoob

View file

@ -1,17 +0,0 @@
bin/katoob
share/applications/katoob.desktop
share/katoob/close.png
share/katoob/emulator/arabic
share/katoob/green.png
share/katoob/katoob.png
share/katoob/katoob-small.png
share/katoob/landscape.png
share/katoob/portrait.png
share/katoob/red.png
share/pixmaps/katoob-icon.png
share/locale/ar/LC_MESSAGES/katoob.mo
share/locale/pl/LC_MESSAGES/katoob.mo
share/locale/sv/LC_MESSAGES/katoob.mo
@dirrm share/katoob/emulator
@dirrm share/katoob
@dirrmtry share/applications