Remove expired port:

2012-07-21 devel/acpicatools: It's quite obsolete and is already in base system for a long time
This commit is contained in:
Alex Kozlov 2012-07-22 01:19:31 +00:00
parent 57c4712e84
commit bdf53c2691
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=301295
9 changed files with 1 additions and 165 deletions

1
MOVED
View file

@ -3554,3 +3554,4 @@ www/zope211||2012-07-16|End Of Life reached
archivers/zlib||2012-07-18|Removed in favor of base system zlib
devel/app|devel/papp|2012-07-18|Project renamed upstream
databases/redis-scripting|databases/redis-devel|2012-07-19|Removed, please use databases/redis-devel instead.
devel/acpicatools||2012-07-22|Has expired: It's quite obsolete and is already in base system for a long time

View file

@ -25,7 +25,6 @@
SUBDIR += abi-compliance-checker
SUBDIR += ace
SUBDIR += ace+tao-doc
SUBDIR += acpicatools
SUBDIR += activitymail
SUBDIR += adabooch
SUBDIR += adabooch-doc-html

View file

@ -1,34 +0,0 @@
# New ports collection makefile for: acpicatools
# Date created: 25 Jun 2001
# Whom: Mitsuru IWASAKI <iwasaki@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= acpicatools
PORTVERSION= 20030523.0
CATEGORIES= devel
MASTER_SITES= http://people.FreeBSD.org/~iwasaki/acpi/:g1 \
http://ftp.osuosl.org/pub/FreeBSD/distfiles/:g2
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:g1,g2 \
acpica-unix-20030523.tar.gz:g2
MAINTAINER= ports@FreeBSD.org
COMMENT= Some utilities for Intel ACPICA (Debugger, ASL Compiler and etc.)
DEPRECATED= It's quite obsolete and is already in base system for a long time
EXPIRATION_DATE=2012-07-21
NO_WRKSUBDIR= yes
MAN8= acpidump.8
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
${WRKDIR}/Makefile*
.include <bsd.port.post.mk>

View file

@ -1,4 +0,0 @@
SHA256 (acpicatools-20030523.0.tar.gz) = 083bb941c6e1a3b82bf599bf7e94817453dfcf7eb689a8f73bdb2599a7ec33f9
SIZE (acpicatools-20030523.0.tar.gz) = 62007
SHA256 (acpica-unix-20030523.tar.gz) = 5db2a296dc2d3490925e8da81949802fb2f717e87d676a24ed442a6667136c6d
SIZE (acpica-unix-20030523.tar.gz) = 627560

View file

@ -1,11 +0,0 @@
--- acpica-unix-20030523/compiler/aslutils.c.orig Thu Jun 12 15:48:25 2003
+++ acpica-unix-20030523/compiler/aslutils.c Thu Jun 12 15:48:34 2003
@@ -126,7 +126,7 @@
#ifdef _USE_BERKELEY_YACC
extern const char * const AslCompilername[];
-static const char * const *yytname = &AslCompilername[255];
+static const char * const *yytname = &AslCompilername[254];
#else
extern const char * const yytname[];
#endif

View file

@ -1,70 +0,0 @@
--- acpica-unix-20030523/include/platform/acfreebsd.h.orig Sat May 24 09:10:56 2003
+++ acpica-unix-20030523/include/platform/acfreebsd.h Fri Jun 13 00:17:53 2003
@@ -126,7 +126,25 @@
/* FreeBSD uses GCC */
#include "acgcc.h"
+#if 0
#include <machine/acpica_machdep.h>
+#endif
+
+#ifdef _KERNEL
+#include "opt_acpi.h"
+#endif
+
+#ifdef ACPI_DEBUG
+#define ACPI_DEBUG_OUTPUT /* for backward compatibility */
+#endif
+
+#ifdef _KERNEL
+#include "opt_acpi.h"
+#endif
+
+#ifdef ACPI_DEBUG
+#define ACPI_DEBUG_OUTPUT /* for backward compatibility */
+#endif
#ifdef _KERNEL
#include <sys/ctype.h>
@@ -135,15 +153,11 @@
#include <sys/libkern.h>
#include <machine/stdarg.h>
-#define asm __asm
-#define __cli() disable_intr()
-#define __sti() enable_intr()
-
-#ifdef ACPI_DEBUG_OUTPUT
#ifdef DEBUGGER_THREADING
#undef DEBUGGER_THREADING
#endif /* DEBUGGER_THREADING */
#define DEBUGGER_THREADING 0 /* integrated with DDB */
+#ifdef ACPI_DEBUG_OUTPUT
#include "opt_ddb.h"
#ifdef DDB
#define ACPI_DEBUGGER
@@ -157,6 +171,7 @@
#define __cli()
#define __sti()
+#define ACPI_FLUSH_CPU_CACHE()
#endif /* _KERNEL */
@@ -196,5 +211,16 @@
return ((char *)s);
}
#endif /* _KERNEL */
+
+#if defined(__ia64__) || defined(__x86_64__)
+#define ACPI_MACHINE_WIDTH 64
+#define COMPILER_DEPENDENT_INT64 long
+#define COMPILER_DEPENDENT_UINT64 unsigned long
+#else
+#define ACPI_MACHINE_WIDTH 32
+#define COMPILER_DEPENDENT_INT64 long long
+#define COMPILER_DEPENDENT_UINT64 unsigned long long
+#define ACPI_USE_NATIVE_DIVIDE
+#endif
#endif /* __ACFREEBSD_H__ */

View file

@ -1,38 +0,0 @@
--- acpica-unix-20030523/osunixxf.c.orig 2003-05-24 03:11:02.000000000 +0300
+++ acpica-unix-20030523/osunixxf.c 2007-08-28 15:57:49.000000000 +0300
@@ -452,7 +452,7 @@
ACPI_STATUS
AcpiOsMapMemory (
ACPI_PHYSICAL_ADDRESS where,
- UINT32 length,
+ ACPI_SIZE length,
void **there)
{
*there = (void *) (UINT32) where;
@@ -478,7 +478,7 @@
void
AcpiOsUnmapMemory (
void *where,
- UINT32 length)
+ ACPI_SIZE length)
{
return;
@@ -499,7 +499,7 @@
void *
AcpiOsAllocate (
- UINT32 size)
+ ACPI_SIZE size)
{
void *Mem;
@@ -815,7 +815,7 @@
UINT32 milliseconds)
{
- sleep ((seconds * 1000) + milliseconds);
+ usleep ((seconds * 1000) + milliseconds);
return;
}

View file

@ -1,4 +0,0 @@
Acpicatools contains some Intel ACPICA-based utilities for
FreeBSD, such as ASL compiler and AML debugger.
WWW: http://developer.intel.com/technology/iapc/acpi/index.htm

View file

@ -1,3 +0,0 @@
bin/acpicadb
bin/iasl
bin/acpidump