textproc/py-sphinx-book-theme: Add py-sphinx-book-theme 0.1.10

sphinx-book-theme is an interactive book theme for Sphinx.

This is a lightweight Sphinx theme designed to mimic the look-and-feel of an
interactive book. It has the following primary features:
- Bootstrap 4 for visual elements and functionality.
- Flexible content layout that is inspired by beautiful online books, such as
  the Edward Tufte CSS guide
- Visual classes designed for Jupyter Notebooks. Cell inputs, outputs, and
  interactive functionality are all supported.
- Launch buttons for online interactivity. For pages that are built with
  computational material, connect your site to an online BinderHub for
  interactive content.

WWW: https://github.com/executablebooks/sphinx-book-theme
This commit is contained in:
Po-Chuan Hsieh 2022-01-24 02:05:36 +08:00
parent ebe92d11ad
commit bdf8e17ce7
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
5 changed files with 55 additions and 0 deletions

View file

@ -1470,6 +1470,7 @@
SUBDIR += py-sphinx-autoapi
SUBDIR += py-sphinx-autobuild
SUBDIR += py-sphinx-autodoc-typehints
SUBDIR += py-sphinx-book-theme
SUBDIR += py-sphinx-copybutton
SUBDIR += py-sphinx-inline-tabs
SUBDIR += py-sphinx-intl

View file

@ -0,0 +1,26 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= sphinx-book-theme
PORTVERSION= 0.1.10
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Clean book theme for scientific explanations and documentation with Sphinx
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.6.1<5:www/py-beautifulsoup@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}docutils>=0.17.1:textproc/py-docutils@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydata-sphinx-theme>=0.7.2<0.8:textproc/py-pydata-sphinx-theme@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx>=3,1<5,1:textproc/py-sphinx@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1642102117
SHA256 (sphinx-book-theme-0.1.10.tar.gz) = c74d7deb36e6fea4bcb3a979d162d9fd80e93b7ea4da78ebf8286da4b898582a
SIZE (sphinx-book-theme-0.1.10.tar.gz) = 63301

View file

@ -0,0 +1,11 @@
--- setup.py.orig 2022-01-10 10:21:14 UTC
+++ setup.py
@@ -29,7 +29,7 @@ setup(
packages=find_packages(),
install_requires=[
"beautifulsoup4>=4.6.1,<5",
- "docutils>=0.15,<0.17",
+ "docutils>=0.17.1",
'importlib-resources>=3.0,<3.5; python_version < "3.7"',
"pydata-sphinx-theme~=0.7.2",
"pyyaml",

View file

@ -0,0 +1,14 @@
sphinx-book-theme is an interactive book theme for Sphinx.
This is a lightweight Sphinx theme designed to mimic the look-and-feel of an
interactive book. It has the following primary features:
- Bootstrap 4 for visual elements and functionality.
- Flexible content layout that is inspired by beautiful online books, such as
the Edward Tufte CSS guide
- Visual classes designed for Jupyter Notebooks. Cell inputs, outputs, and
interactive functionality are all supported.
- Launch buttons for online interactivity. For pages that are built with
computational material, connect your site to an online BinderHub for
interactive content.
WWW: https://github.com/executablebooks/sphinx-book-theme