Add feappv 2.0, finite Element Analysis Program "personal version".

This is a FEA program used in a classic FEM book. A complete (commercial)
version is available here:

	<http://www.ce.berkeley.edu/~rlt/feap/>

The "personal version" is very limited, but it keeps the same format as
the complete (commercial) version and cad/netgen can produce files for it.

PR:		ports/95210
Submitted by:	Pedro F. Giffuni <giffunip (at) asme.org>
This commit is contained in:
Thierry Thomas 2006-04-03 19:57:24 +00:00
parent baa30a697e
commit be07d2f546
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=158739
6 changed files with 108 additions and 0 deletions

View file

@ -18,6 +18,7 @@
SUBDIR += dxf2fig
SUBDIR += electric
SUBDIR += fandango
SUBDIR += feappv
SUBDIR += geda
SUBDIR += geda-symbols
SUBDIR += geda-symcheck

46
cad/feappv/Makefile Normal file
View file

@ -0,0 +1,46 @@
# New ports collection makefile for: FEAPpv
# Date created: 29 Feb 2006
# Whom: Pedro F. Giffuni
#
# $FreeBSD$
#
PORTNAME= feappv
PORTVERSION= 2.0
CATEGORIES= cad science
MASTER_SITES= http://www.ce.berkeley.edu/~rlt/feappv/
MASTER_SITE_SUBDIR= feap
DISTFILES= ${PORTNAME}20${EXTRACT_SUFX}
.ifndef NOPORTDOCS
DISTFILES+= manual.pdf
.endif
DIST_SUBDIR= feap
EXTRACT_ONLY= ${PORTNAME}20${EXTRACT_SUFX}
MAINTAINER= giffunip@asme.org
COMMENT= Finite Element Analysis Program "personal version"
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -L
WRKSRC= ${WRKDIR}/ver20
USE_XLIB= yes
FFLAGS?= -O2
MAKEFILE= makefile
ALL_TARGET= install
post-patch:
@${REINPLACE_CMD} -e 's+%%FC%%+${FC}+g; s+%%CC%%+${CC}+g; \
s+%%FFLAGS%%+${FFLAGS}+g; s+%%CFLAGS%%+${CFLAGS}+g; \
s+/usr/X11R6+${X11BASE}+g; s+%%WRKSRC%%+${WRKSRC}+;' \
${WRKSRC}/makefile.in
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/main/feappv ${PREFIX}/bin/feappv
@${INSTALL_DATA} ${WRKSRC}/Feappv.a ${PREFIX}/lib/libfeappv.a
.ifndef NOPORTDOCS
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/manual.pdf ${DOCSDIR}
.endif
.include <bsd.port.mk>

6
cad/feappv/distinfo Normal file
View file

@ -0,0 +1,6 @@
MD5 (feap/feappv20.zip) = c391da6625324517edea3400297fcf52
SHA256 (feap/feappv20.zip) = aefc7aef83f76341ac1454ead24a38c19018a48603e056dd746c386632670435
SIZE (feap/feappv20.zip) = 603366
MD5 (feap/manual.pdf) = 4cb6dae046916a0858ed98022edf1368
SHA256 (feap/manual.pdf) = 09c8ea7bd9e14081806c32a6d2462a78208cb649273924f1c5cb747e3c8da53f
SIZE (feap/manual.pdf) = 686661

View file

@ -0,0 +1,38 @@
--- makefile.in.orig Thu Apr 7 10:34:22 2005
+++ makefile.in Sat Apr 1 16:26:47 2006
@@ -1,11 +1,11 @@
# Which compilers to use
-FF = g77
-CC = gcc
+FF ?= %%FC%%
+CC ?= %%CC%%
# What optimization level to use
-FFOPTFLAG = -O2
-CCOPTFLAG = -O2
+FFOPTFLAG += %%FFLAGS%%
+CCOPTFLAG += %%CFLAGS%% -I/usr/X11R6/include
# Source Types
FSOURCE =
@@ -17,16 +17,15 @@
# What options to be used by the compiler
FOPTIONS =
-COPTIONS =
-
+COPTIONS =
# What options to be used by the loader
LDOPTIONS = -L/usr/X11R6/lib -lX11 -lm
# Location of feap include files
-FINCLUDE = /home/rlt/Feappv/ver20/include
+FINCLUDE = %%WRKSRC%%/include
# What archiving to use
AR = ar rv
# Archive name
-ARFEAP = /home/rlt/Feappv/ver20/Feappv.a
+ARFEAP = %%WRKSRC%%/Feappv.a

13
cad/feappv/pkg-descr Normal file
View file

@ -0,0 +1,13 @@
FEAPpv is a general purpose finite element analysis program which is
designed for research and educational use. The program is described in the
references:
The Finite Element Method, 6th ed., Vols. 1 and 2, by O.C. Zienkiewicz and
R.L. Taylor, Elsevier, Oxford, 2005.
FEAPpv is designed to be compatible for compilation in UNIX/LINUX and
Windows PC environments.
WWW: http://www.ce.berkeley.edu/~rlt/feappv/
No support on use of the program will be provided.

4
cad/feappv/pkg-plist Normal file
View file

@ -0,0 +1,4 @@
bin/feappv
lib/libfeappv.a
%%PORTDOCS%%%%DOCSDIR%%/manual.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%