add wmdrawer 0.9.17.1
A dockapp which provides a drawer to launch applications
This commit is contained in:
parent
a7c64082f9
commit
be3c8e68c8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=78387
6 changed files with 94 additions and 0 deletions
|
@ -112,6 +112,7 @@
|
|||
SUBDIR += wmappl
|
||||
SUBDIR += wmbutton
|
||||
SUBDIR += wmcliphist
|
||||
SUBDIR += wmdrawer
|
||||
SUBDIR += wmfstatus
|
||||
SUBDIR += wmmatrix
|
||||
SUBDIR += wmmenu
|
||||
|
|
25
x11/wmdrawer/Makefile
Normal file
25
x11/wmdrawer/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: wmDrawer
|
||||
# Date created: Apr 6, 2003
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= wmdrawer
|
||||
PORTVERSION= 0.9.17.1
|
||||
CATEGORIES= x11 windowmaker
|
||||
MASTER_SITES= http://people.easter-eggs.org/~valos/wmdrawer/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A dockapp which provides a drawer to launch applications
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOME= gtk20
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV= DOCSDIR=${DOCSDIR}
|
||||
|
||||
MANCOMPRESSED= yes
|
||||
MAN1= wmdrawer.1x
|
||||
|
||||
.include <bsd.port.mk>
|
1
x11/wmdrawer/distinfo
Normal file
1
x11/wmdrawer/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (wmdrawer-0.9.17.1.tar.gz) = bb7cfd5a8d5e6d6ab0920536e17e36d6
|
45
x11/wmdrawer/files/patch-Makefile
Normal file
45
x11/wmdrawer/files/patch-Makefile
Normal file
|
@ -0,0 +1,45 @@
|
|||
--- Makefile.orig Fri Mar 28 01:08:16 2003
|
||||
+++ Makefile Sun Apr 6 12:31:26 2003
|
||||
@@ -3,13 +3,13 @@
|
||||
|
||||
DESTDIR =
|
||||
|
||||
-PREFIX = $(DESTDIR)/usr/local
|
||||
-DOCDIR = $(PREFIX)/share/doc
|
||||
+#PREFIX = $(DESTDIR)/usr/local
|
||||
+#DOCDIR = $(PREFIX)/share/doc
|
||||
|
||||
-USE_GDKPIXBUF = 1
|
||||
-#USE_GDKPIXBUF2 = 1
|
||||
+#USE_GDKPIXBUF = 1
|
||||
+USE_GDKPIXBUF2 = 1
|
||||
|
||||
-CC = gcc
|
||||
+#CC = gcc
|
||||
|
||||
ifdef USE_GDKPIXBUF
|
||||
PIXBUF_DEF = -DUSE_GDKPIXBUF
|
||||
@@ -19,7 +19,7 @@
|
||||
|
||||
ifdef USE_GDKPIXBUF2
|
||||
PIXBUF_DEF = -DUSE_GDKPIXBUF2
|
||||
-CFLAGS = -O3 -Wall `pkg-config --cflags gdk-pixbuf-xlib-2.0` -I/usr/X11R6/include
|
||||
+CFLAGS += `pkg-config --cflags gdk-pixbuf-xlib-2.0` -I/usr/X11R6/include
|
||||
LDFLAGS = `pkg-config --libs gdk-pixbuf-xlib-2.0` -rdynamic -lX11 -lXi -lXext -L/usr/X11R6/lib
|
||||
endif
|
||||
|
||||
@@ -40,10 +40,10 @@
|
||||
$(RM) *.o $(PRGS)
|
||||
|
||||
install : wmdrawer
|
||||
- $(INSTALL) -m 755 wmdrawer $(PREFIX)/bin
|
||||
- $(INSTALL) -m 644 doc/wmdrawer.1x.gz $(PREFIX)/man/man1
|
||||
- $(INSTALL) -d $(DOCDIR)/wmdrawer
|
||||
- $(INSTALL) -m 644 wmdrawerrc.example AUTHORS ChangeLog COPYING INSTALL README TODO $(DOCDIR)/wmdrawer
|
||||
+ $(BSD_INSTALL_PROGRAM) -m 755 wmdrawer $(PREFIX)/bin
|
||||
+ $(BSD_INSTALL_DATA) -m 644 doc/wmdrawer.1x.gz $(PREFIX)/man/man1
|
||||
+ $(INSTALL) -d $(DOCSDIR)
|
||||
+ $(BSD_INSTALL_DATA) -m 644 wmdrawerrc.example AUTHORS ChangeLog COPYING INSTALL README TODO $(DOCSDIR)
|
||||
|
||||
uninstall: clean
|
||||
$(RM) $(PREFIX)/bin/wmdrawer
|
13
x11/wmdrawer/pkg-descr
Normal file
13
x11/wmdrawer/pkg-descr
Normal file
|
@ -0,0 +1,13 @@
|
|||
wmDrawer is a dock application (dockapp) which provides a drawer (retractable
|
||||
button bar) to launch applications.
|
||||
* The drawer is retractable and animated.
|
||||
* Several columns of buttons can be defined in the drawer.
|
||||
* The configuration file is automaticaly reloaded if it changes.
|
||||
* Multiple instances of the program can run at the same time.
|
||||
* Button's highlight under mouse cursor.
|
||||
* Drawer's transparency (need SHAPE extension).
|
||||
* Ability to launch several apps at once from the drawer. By holding down
|
||||
the key Shift or by using mouse buttons middle or right instead of left,
|
||||
you can keep the drawer opened.
|
||||
|
||||
WWW: http://people.easter-eggs.org/~valos/wmdrawer/
|
9
x11/wmdrawer/pkg-plist
Normal file
9
x11/wmdrawer/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/wmdrawer
|
||||
%%DOCSDIR%%/AUTHORS
|
||||
%%DOCSDIR%%/COPYING
|
||||
%%DOCSDIR%%/ChangeLog
|
||||
%%DOCSDIR%%/INSTALL
|
||||
%%DOCSDIR%%/README
|
||||
%%DOCSDIR%%/TODO
|
||||
%%DOCSDIR%%/wmdrawerrc.example
|
||||
@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue