Add gtkspell2, a GTK+ 2 spell checking component. There is a gtkspell
out there for GTK+ 1.2, but it doesn't appear to be in the tree. If for some reason, it ever gets imported, this port won't collide with it.
This commit is contained in:
parent
ce57dbfea7
commit
be76297b53
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=64668
13 changed files with 115 additions and 0 deletions
|
@ -73,6 +73,7 @@
|
|||
SUBDIR += gsed
|
||||
SUBDIR += gtk-doc
|
||||
SUBDIR += gtkdiff
|
||||
SUBDIR += gtkspell2
|
||||
SUBDIR += gutenbook
|
||||
SUBDIR += gutenmark
|
||||
SUBDIR += gxditview
|
||||
|
|
33
textproc/gtkspell/Makefile
Normal file
33
textproc/gtkspell/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# New ports collection makefile for: gtkspell2
|
||||
# Date created: 19 Aug 2002
|
||||
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gtkspell2
|
||||
PORTVERSION= 2.0.2
|
||||
CATEGORIES= textproc gnome
|
||||
MASTER_SITES= http://gtkspell.sourceforge.net/download/
|
||||
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20 \
|
||||
pspell.4:${PORTSDIR}/textproc/pspell
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOMENG= yes
|
||||
USE_GNOME= gnomeprefix gnomehack
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
|
||||
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
1
textproc/gtkspell/distinfo
Normal file
1
textproc/gtkspell/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (gtkspell-2.0.2.tar.gz) = 385daba9bebfdc7fdbdf524e07deb920
|
10
textproc/gtkspell/files/patch-configure
Normal file
10
textproc/gtkspell/files/patch-configure
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- configure.orig Mon Aug 19 13:43:43 2002
|
||||
+++ configure Mon Aug 19 13:43:59 2002
|
||||
@@ -7524,6 +7524,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
1
textproc/gtkspell/pkg-comment
Normal file
1
textproc/gtkspell/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A GTK+ 2 spell checking component
|
5
textproc/gtkspell/pkg-descr
Normal file
5
textproc/gtkspell/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
GtkSpell provides MSWord/MacOSX-style highlighting of misspelled words in a
|
||||
GtkTextView widget as you type. Right-clicking a misspelled word pops up a menu
|
||||
of suggested replacements.
|
||||
|
||||
WWW: http://gtkspell.sourceforge.net/
|
7
textproc/gtkspell/pkg-plist
Normal file
7
textproc/gtkspell/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
include/gtkspell-2.0/gtkspell/gtkspell.h
|
||||
lib/libgtkspell.a
|
||||
lib/libgtkspell.so
|
||||
lib/libgtkspell.so.0
|
||||
libdata/pkgconfig/gtkspell-2.0.pc
|
||||
@dirrm include/gtkspell-2.0/gtkspell
|
||||
@dirrm include/gtkspell-2.0
|
33
textproc/gtkspell2/Makefile
Normal file
33
textproc/gtkspell2/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# New ports collection makefile for: gtkspell2
|
||||
# Date created: 19 Aug 2002
|
||||
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gtkspell2
|
||||
PORTVERSION= 2.0.2
|
||||
CATEGORIES= textproc gnome
|
||||
MASTER_SITES= http://gtkspell.sourceforge.net/download/
|
||||
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20 \
|
||||
pspell.4:${PORTSDIR}/textproc/pspell
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOMENG= yes
|
||||
USE_GNOME= gnomeprefix gnomehack
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
|
||||
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
1
textproc/gtkspell2/distinfo
Normal file
1
textproc/gtkspell2/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (gtkspell-2.0.2.tar.gz) = 385daba9bebfdc7fdbdf524e07deb920
|
10
textproc/gtkspell2/files/patch-configure
Normal file
10
textproc/gtkspell2/files/patch-configure
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- configure.orig Mon Aug 19 13:43:43 2002
|
||||
+++ configure Mon Aug 19 13:43:59 2002
|
||||
@@ -7524,6 +7524,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
1
textproc/gtkspell2/pkg-comment
Normal file
1
textproc/gtkspell2/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A GTK+ 2 spell checking component
|
5
textproc/gtkspell2/pkg-descr
Normal file
5
textproc/gtkspell2/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
GtkSpell provides MSWord/MacOSX-style highlighting of misspelled words in a
|
||||
GtkTextView widget as you type. Right-clicking a misspelled word pops up a menu
|
||||
of suggested replacements.
|
||||
|
||||
WWW: http://gtkspell.sourceforge.net/
|
7
textproc/gtkspell2/pkg-plist
Normal file
7
textproc/gtkspell2/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
include/gtkspell-2.0/gtkspell/gtkspell.h
|
||||
lib/libgtkspell.a
|
||||
lib/libgtkspell.so
|
||||
lib/libgtkspell.so.0
|
||||
libdata/pkgconfig/gtkspell-2.0.pc
|
||||
@dirrm include/gtkspell-2.0/gtkspell
|
||||
@dirrm include/gtkspell-2.0
|
Loading…
Reference in a new issue