- Add missing dependency
- Fix build with clang 6
This commit is contained in:
parent
e52b21d28d
commit
be831110a8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=473068
2 changed files with 15 additions and 1 deletions
|
@ -16,12 +16,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
|||
USES= tar:bzip2 desktop-file-utils
|
||||
GNU_CONFIGURE= yes
|
||||
USE_SDL= sdl image
|
||||
USE_XORG= x11
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
CONFIGURE_ENV= AUTOMAKE="${TRUE}" ACLOCAL="${TRUE}" MISSING="${TRUE}"
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -lpthread
|
||||
CPPFLAGS+= -I${LOCALBASE}/include -DINSTALL_BASE_PATH=\"\\\"${DATADIR}\\\"\"
|
||||
|
||||
CXXFLAGS+= -Wno-c++11-narrowing
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
OPTIONS_DEFINE= MOREFPS
|
||||
|
@ -41,6 +44,6 @@ post-patch-MOREFPS-on:
|
|||
${WRKSRC}/Config.h
|
||||
|
||||
post-build:
|
||||
${STRIP_CMD} ${WRKSRC}/${PORTNAME}
|
||||
@${STRIP_CMD} ${WRKSRC}/${PORTNAME}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
games/numptyphysics/files/patch-Game.cpp
Normal file
11
games/numptyphysics/files/patch-Game.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Game.cpp.orig 2008-11-11 16:54:38 UTC
|
||||
+++ Game.cpp
|
||||
@@ -1495,7 +1495,7 @@ void init( bool useDummyVideo=false )
|
||||
throw "Couldn't initialize SDL";
|
||||
}
|
||||
|
||||
- if ( mkdir( (string(getenv("HOME"))+"/"USER_BASE_PATH).c_str(),
|
||||
+ if ( mkdir( (string(getenv("HOME"))+"/" USER_BASE_PATH).c_str(),
|
||||
0755)==0 ) {
|
||||
printf("created user dir\n");
|
||||
} else if ( errno==EEXIST ){
|
Loading…
Reference in a new issue