upgrade to 0.62
PR: 45463 Submitted by: maintainer
This commit is contained in:
parent
44dc00c162
commit
bee7e2deef
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70464
20 changed files with 162 additions and 204 deletions
|
@ -6,38 +6,35 @@
|
|||
#
|
||||
|
||||
PORTNAME= flow-tools
|
||||
PORTVERSION= 0.57
|
||||
PORTVERSION= 0.62
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.eng.oar.net/pub/flow-tools/
|
||||
|
||||
MAINTAINER= .@babolo.ru
|
||||
|
||||
SCRIPTS= flow-mirror flow-rsync flow-search
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--localstatedir=${PREFIX}
|
||||
|
||||
MAN1= flow-capture.1 flow-gen.1 flow-split.1 flow-cat.1 \
|
||||
flow-header.1 flow-stat.1 flow-dscan.1 flow-import.1 \
|
||||
flow-tools-examples.1 flow-expire.1 flow-merge.1 \
|
||||
flow-tools.1 flow-export.1 flow-print.1 flow-xlate.1 \
|
||||
flow-fanout.1 flow-receive.1 flow-filter.1 flow-send.1 \
|
||||
flow-tag.1
|
||||
MAN1= flow-capture.1 flow-cat.1 flow-dscan.1 flow-expire.1 \
|
||||
flow-export.1 flow-fanout.1 flow-filter.1 flow-gen.1 \
|
||||
flow-header.1 flow-import.1 flow-merge.1 flow-nfilter.1 \
|
||||
flow-print.1 flow-receive.1 flow-report.1 flow-send.1 \
|
||||
flow-split.1 flow-stat.1 flow-tag.1 flow-tools.1 \
|
||||
flow-tools-examples.1 flow-xlate.1
|
||||
|
||||
post-patch:
|
||||
${TOUCH} -r ${WRKSRC}/configure.in.orig ${WRKSRC}/configure.in
|
||||
${TOUCH} -r ${WRKSRC}/configure.orig ${WRKSRC}/configure
|
||||
${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' \
|
||||
${WRKSRC}/docs/flow-print.1 ${WRKSRC}/docs/flow-tag.1
|
||||
${TOUCH} -r ${WRKSRC}/Makefile.am.orig ${WRKSRC}/Makefile.am
|
||||
${REINPLACE_CMD}\
|
||||
-e 's|@localstatedir@/sym/|${PREFIX}/share/flow-tools/|' \
|
||||
-e 's|@localstatedir@/cfg/|${PREFIX}/etc/flow-tools/|' \
|
||||
${WRKSRC}/docs/flow-*.1.in ${WRKSRC}/docs/flow-*.html.in
|
||||
|
||||
pre-build:
|
||||
${RM} ${WRKSRC}/src/ftbuild.h
|
||||
|
||||
post-install:
|
||||
.for i in ${SCRIPTS}
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/bin/${i} ${PREFIX}/bin
|
||||
pre-install:
|
||||
.for I in ${MAN1}
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/${I} ${PREFIX}/man/man1/
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (flow-tools-0.57.tar.gz) = 6b26d229d7fd74bf515b1513b573859a
|
||||
MD5 (flow-tools-0.62.tar.gz) = 68ec3cd86903370c019f12593f437f78
|
||||
|
|
19
net-mgmt/flow-tools/files/patch-Makefile
Normal file
19
net-mgmt/flow-tools/files/patch-Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- Makefile.am Thu Aug 8 09:32:32 2002
|
||||
+++ Makefile.am Sun Aug 25 02:32:20 2002
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS = lib src docs configs bin
|
||||
+SUBDIRS = lib src docs configs
|
||||
|
||||
EXTRA_DIST = bin/flow-mirror bin/flow-rsync bin/flow-search utils/* \
|
||||
SECURITY contrib/* configs/*
|
||||
--- Makefile.in Fri Aug 9 05:06:16 2002
|
||||
+++ Makefile.in Sun Aug 25 02:44:57 2002
|
||||
@@ -81,7 +81,7 @@
|
||||
am__include = @am__include@
|
||||
am__quote = @am__quote@
|
||||
install_sh = @install_sh@
|
||||
-SUBDIRS = lib src docs configs bin
|
||||
+SUBDIRS = lib src docs configs
|
||||
|
||||
EXTRA_DIST = bin/flow-mirror bin/flow-rsync bin/flow-search utils/* \
|
||||
SECURITY contrib/* configs/*
|
|
@ -9,12 +9,12 @@
|
|||
+ftcfgdir=$(localstatedir)/etc/flow-tools
|
||||
ftcfg_DATA = map filter-acl
|
||||
|
||||
--- configs/Makefile.in Sat Dec 29 01:05:48 2001
|
||||
--- configs/Makefile.in Fri Aug 9 05:06:41 2002
|
||||
+++ configs/Makefile.in Sat Jan 12 08:04:39 2002
|
||||
@@ -66,10 +66,10 @@
|
||||
YACC = @YACC@
|
||||
YLIB = @YLIB@
|
||||
|
||||
@@ -81,10 +81,10 @@
|
||||
am__include = @am__include@
|
||||
am__quote = @am__quote@
|
||||
install_sh = @install_sh@
|
||||
-ftsymdir = $(localstatedir)/sym
|
||||
+ftsymdir = $(localstatedir)/share/flow-tools
|
||||
ftsym_DATA = asn ip-prot tcp-port
|
||||
|
@ -22,5 +22,5 @@
|
|||
-ftcfgdir = $(localstatedir)/cfg
|
||||
+ftcfgdir = $(localstatedir)/etc/flow-tools
|
||||
ftcfg_DATA = map filter-acl
|
||||
subdir = configs
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = ../config.h
|
||||
|
|
|
@ -1,22 +1,22 @@
|
|||
--- configure.in Sat Dec 29 01:02:24 2001
|
||||
+++ configure.in Sat Jan 12 08:43:07 2002
|
||||
@@ -8,7 +8,7 @@
|
||||
--- configure.in.orig Wed Oct 16 01:28:23 2002
|
||||
+++ configure.in Sun Nov 17 05:14:42 2002
|
||||
@@ -6,7 +6,7 @@
|
||||
AM_INIT_AUTOMAKE(flow-tools, 0.62)
|
||||
AM_CONFIG_HEADER(lib/ftconfig.h:lib/ftconfig.h.in)
|
||||
|
||||
CFLAGS="-g -Wall"
|
||||
|
||||
-localstatedir="/var/ft"
|
||||
+localstatedir="${prefix}"
|
||||
-CFLAGS="-g -Wall"
|
||||
+CFLAGS+="-g -Wall"
|
||||
|
||||
dnl Checks for programs.
|
||||
AC_PROG_CC
|
||||
--- configure Sat Dec 29 01:05:33 2001
|
||||
+++ configure Sat Jan 12 08:42:27 2002
|
||||
@@ -783,7 +783,7 @@
|
||||
--- configure.orig Wed Oct 16 01:28:44 2002
|
||||
+++ configure Sun Nov 17 05:13:42 2002
|
||||
@@ -1583,7 +1583,7 @@
|
||||
|
||||
CFLAGS="-g -Wall"
|
||||
|
||||
-localstatedir="/var/ft"
|
||||
+localstatedir="${prefix}"
|
||||
|
||||
# Extract the first word of "gcc", so it can be a program name with args.
|
||||
set dummy gcc; ac_word=$2
|
||||
-CFLAGS="-g -Wall"
|
||||
+CFLAGS+="-g -Wall"
|
||||
|
||||
ac_ext=c
|
||||
ac_cpp='$CPP $CPPFLAGS'
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- docs/flow-print.1 Sun Dec 23 06:06:02 2001
|
||||
+++ docs/flow-print.1 Sat Jan 12 07:43:42 2002
|
||||
@@ -102,7 +102,7 @@
|
||||
None known\&.
|
||||
.SH "FILES"
|
||||
.PP
|
||||
-Symbols are located in \fB/var/ft/sym/*\fP
|
||||
+Symbols are located in \fB/usr/local/share/flow-tools/*\fP
|
||||
.SH "AUTHOR"
|
||||
.PP
|
||||
Mark Fullmer maf@splintered\&.net
|
|
@ -1,11 +0,0 @@
|
|||
--- docs/flow-tag.1 Mon Apr 22 11:42:06 2002
|
||||
+++ docs/flow-tag.1 Mon Apr 22 11:42:43 2002
|
||||
@@ -189,7 +189,7 @@
|
||||
.fi
|
||||
.PP
|
||||
.PP
|
||||
-First populate \fB/var/ft/sym/tags\fP for \fBflow-stat\fP to use as symbols\&.
|
||||
+First populate \fB/usr/local/etc/flow-tools/tag_defs\fP for \fBflow-stat\fP to use as symbols\&.
|
||||
.PP
|
||||
.nf
|
||||
\f(CW0x0001 OSU
|
|
@ -1,21 +1,29 @@
|
|||
--- lib/ftpaths.h.in Sun Apr 21 04:08:41 2002
|
||||
--- lib/ftpaths.h.in Thu Aug 15 17:28:04 2002
|
||||
+++ lib/ftpaths.h.in Mon Apr 22 11:29:07 2002
|
||||
@@ -29,12 +29,12 @@
|
||||
@@ -29,16 +29,16 @@
|
||||
#ifndef FTPATHS_H
|
||||
#define FTPATHS_H
|
||||
|
||||
-#define FT_PATH_MAP "@localstatedir@/cfg/map"
|
||||
+#define FT_FILE_MAP "@localstatedir@/etc/flow-tools/map"
|
||||
-#define FT_PATH_CFG_MAP "@localstatedir@/cfg/map"
|
||||
-#define FT_PATH_CFG_TAG "@localstatedir@/cfg/tag"
|
||||
-#define FT_PATH_CFG_FILTER "@localstatedir@/cfg/filter"
|
||||
-#define FT_PATH_CFG_STAT "@localstatedir@/cfg/stat"
|
||||
+#define FT_PATH_CFG_MAP "@localstatedir@/etc/flow-tools/map"
|
||||
+#define FT_PATH_CFG_TAG "@localstatedir@/etc/flow-tools/tag"
|
||||
+#define FT_PATH_CFG_FILTER "@localstatedir@/etc/flow-tools/filter"
|
||||
+#define FT_PATH_CFG_STAT "@localstatedir@/etc/flow-tools/stat"
|
||||
|
||||
-#define FT_PATH_IP_PROT "@localstatedir@/sym/ip-prot"
|
||||
-#define FT_PATH_IP_CLASS "@localstatedir@/sym/ip-class"
|
||||
-#define FT_PATH_TCP_PORT "@localstatedir@/sym/tcp-port"
|
||||
-#define FT_PATH_ASN "@localstatedir@/sym/asn"
|
||||
-#define FT_PATH_TAG "@localstatedir@/cfg/tag_defs"
|
||||
+#define FT_PATH_IP_PROT "@localstatedir@/share/flow-tools/ip-prot"
|
||||
+#define FT_PATH_IP_CLASS "@localstatedir@/share/flow-tools/ip-class"
|
||||
+#define FT_PATH_TCP_PORT "@localstatedir@/share/flow-tools/tcp-port"
|
||||
+#define FT_PATH_ASN "@localstatedir@/share/flow-tools/asn"
|
||||
+#define FT_PATH_TAG "@localstatedir@/etc/flow-tools/tag_defs"
|
||||
-#define FT_PATH_SYM_IP_PROT "@localstatedir@/sym/ip-prot"
|
||||
-#define FT_PATH_SYM_IP_CLASS "@localstatedir@/sym/ip-class"
|
||||
-#define FT_PATH_SYM_IP_TYPE "@localstatedir@/sym/ip-type"
|
||||
-#define FT_PATH_SYM_TCP_PORT "@localstatedir@/sym/tcp-port"
|
||||
-#define FT_PATH_SYM_ASN "@localstatedir@/sym/asn"
|
||||
-#define FT_PATH_SYM_TAG "@localstatedir@/sym/tag"
|
||||
+#define FT_PATH_SYM_IP_PROT "@localstatedir@/share/flow-tools/ip-prot"
|
||||
+#define FT_PATH_SYM_IP_CLASS "@localstatedir@/share/flow-tools/ip-class"
|
||||
+#define FT_PATH_SYM_IP_TYPE "@localstatedir@/share/flow-tools/ip-type"
|
||||
+#define FT_PATH_SYM_TCP_PORT "@localstatedir@/share/flow-tools/tcp-port"
|
||||
+#define FT_PATH_SYM_ASN "@localstatedir@/share/flow-tools/asn"
|
||||
+#define FT_PATH_SYM_TAG "@localstatedir@/share/flow-tools/tag"
|
||||
|
||||
#endif /* FTPATHS_H */
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- src/Makefile.am Sat Dec 29 01:23:03 2001
|
||||
+++ src/Makefile.am Sat Jan 12 09:42:38 2002
|
||||
@@ -12,7 +12,7 @@
|
||||
|
||||
force_build:
|
||||
|
||||
-ftbuild.h: ftbuild.sh force_build
|
||||
+ftbuild.h: ftbuild.sh
|
||||
./ftbuild.sh
|
||||
|
||||
flow_import_SOURCES = flow-import.c ftbuild.h
|
||||
--- src/Makefile.in Sat Dec 29 01:27:29 2001
|
||||
+++ src/Makefile.in Sat Jan 12 09:43:42 2002
|
||||
@@ -531,7 +531,7 @@
|
||||
|
||||
force_build:
|
||||
|
||||
-ftbuild.h: ftbuild.sh force_build
|
||||
+ftbuild.h: ftbuild.sh
|
||||
./ftbuild.sh
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
@ -9,11 +9,10 @@ bin/flow-gen
|
|||
bin/flow-header
|
||||
bin/flow-import
|
||||
bin/flow-merge
|
||||
bin/flow-mirror
|
||||
bin/flow-nfilter
|
||||
bin/flow-print
|
||||
bin/flow-receive
|
||||
bin/flow-rsync
|
||||
bin/flow-search
|
||||
bin/flow-report
|
||||
bin/flow-send
|
||||
bin/flow-split
|
||||
bin/flow-stat
|
||||
|
|
|
@ -6,38 +6,35 @@
|
|||
#
|
||||
|
||||
PORTNAME= flow-tools
|
||||
PORTVERSION= 0.57
|
||||
PORTVERSION= 0.62
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.eng.oar.net/pub/flow-tools/
|
||||
|
||||
MAINTAINER= .@babolo.ru
|
||||
|
||||
SCRIPTS= flow-mirror flow-rsync flow-search
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--localstatedir=${PREFIX}
|
||||
|
||||
MAN1= flow-capture.1 flow-gen.1 flow-split.1 flow-cat.1 \
|
||||
flow-header.1 flow-stat.1 flow-dscan.1 flow-import.1 \
|
||||
flow-tools-examples.1 flow-expire.1 flow-merge.1 \
|
||||
flow-tools.1 flow-export.1 flow-print.1 flow-xlate.1 \
|
||||
flow-fanout.1 flow-receive.1 flow-filter.1 flow-send.1 \
|
||||
flow-tag.1
|
||||
MAN1= flow-capture.1 flow-cat.1 flow-dscan.1 flow-expire.1 \
|
||||
flow-export.1 flow-fanout.1 flow-filter.1 flow-gen.1 \
|
||||
flow-header.1 flow-import.1 flow-merge.1 flow-nfilter.1 \
|
||||
flow-print.1 flow-receive.1 flow-report.1 flow-send.1 \
|
||||
flow-split.1 flow-stat.1 flow-tag.1 flow-tools.1 \
|
||||
flow-tools-examples.1 flow-xlate.1
|
||||
|
||||
post-patch:
|
||||
${TOUCH} -r ${WRKSRC}/configure.in.orig ${WRKSRC}/configure.in
|
||||
${TOUCH} -r ${WRKSRC}/configure.orig ${WRKSRC}/configure
|
||||
${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' \
|
||||
${WRKSRC}/docs/flow-print.1 ${WRKSRC}/docs/flow-tag.1
|
||||
${TOUCH} -r ${WRKSRC}/Makefile.am.orig ${WRKSRC}/Makefile.am
|
||||
${REINPLACE_CMD}\
|
||||
-e 's|@localstatedir@/sym/|${PREFIX}/share/flow-tools/|' \
|
||||
-e 's|@localstatedir@/cfg/|${PREFIX}/etc/flow-tools/|' \
|
||||
${WRKSRC}/docs/flow-*.1.in ${WRKSRC}/docs/flow-*.html.in
|
||||
|
||||
pre-build:
|
||||
${RM} ${WRKSRC}/src/ftbuild.h
|
||||
|
||||
post-install:
|
||||
.for i in ${SCRIPTS}
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/bin/${i} ${PREFIX}/bin
|
||||
pre-install:
|
||||
.for I in ${MAN1}
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/${I} ${PREFIX}/man/man1/
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (flow-tools-0.57.tar.gz) = 6b26d229d7fd74bf515b1513b573859a
|
||||
MD5 (flow-tools-0.62.tar.gz) = 68ec3cd86903370c019f12593f437f78
|
||||
|
|
19
net/flow-tools/files/patch-Makefile
Normal file
19
net/flow-tools/files/patch-Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- Makefile.am Thu Aug 8 09:32:32 2002
|
||||
+++ Makefile.am Sun Aug 25 02:32:20 2002
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS = lib src docs configs bin
|
||||
+SUBDIRS = lib src docs configs
|
||||
|
||||
EXTRA_DIST = bin/flow-mirror bin/flow-rsync bin/flow-search utils/* \
|
||||
SECURITY contrib/* configs/*
|
||||
--- Makefile.in Fri Aug 9 05:06:16 2002
|
||||
+++ Makefile.in Sun Aug 25 02:44:57 2002
|
||||
@@ -81,7 +81,7 @@
|
||||
am__include = @am__include@
|
||||
am__quote = @am__quote@
|
||||
install_sh = @install_sh@
|
||||
-SUBDIRS = lib src docs configs bin
|
||||
+SUBDIRS = lib src docs configs
|
||||
|
||||
EXTRA_DIST = bin/flow-mirror bin/flow-rsync bin/flow-search utils/* \
|
||||
SECURITY contrib/* configs/*
|
|
@ -9,12 +9,12 @@
|
|||
+ftcfgdir=$(localstatedir)/etc/flow-tools
|
||||
ftcfg_DATA = map filter-acl
|
||||
|
||||
--- configs/Makefile.in Sat Dec 29 01:05:48 2001
|
||||
--- configs/Makefile.in Fri Aug 9 05:06:41 2002
|
||||
+++ configs/Makefile.in Sat Jan 12 08:04:39 2002
|
||||
@@ -66,10 +66,10 @@
|
||||
YACC = @YACC@
|
||||
YLIB = @YLIB@
|
||||
|
||||
@@ -81,10 +81,10 @@
|
||||
am__include = @am__include@
|
||||
am__quote = @am__quote@
|
||||
install_sh = @install_sh@
|
||||
-ftsymdir = $(localstatedir)/sym
|
||||
+ftsymdir = $(localstatedir)/share/flow-tools
|
||||
ftsym_DATA = asn ip-prot tcp-port
|
||||
|
@ -22,5 +22,5 @@
|
|||
-ftcfgdir = $(localstatedir)/cfg
|
||||
+ftcfgdir = $(localstatedir)/etc/flow-tools
|
||||
ftcfg_DATA = map filter-acl
|
||||
subdir = configs
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = ../config.h
|
||||
|
|
|
@ -1,22 +1,22 @@
|
|||
--- configure.in Sat Dec 29 01:02:24 2001
|
||||
+++ configure.in Sat Jan 12 08:43:07 2002
|
||||
@@ -8,7 +8,7 @@
|
||||
--- configure.in.orig Wed Oct 16 01:28:23 2002
|
||||
+++ configure.in Sun Nov 17 05:14:42 2002
|
||||
@@ -6,7 +6,7 @@
|
||||
AM_INIT_AUTOMAKE(flow-tools, 0.62)
|
||||
AM_CONFIG_HEADER(lib/ftconfig.h:lib/ftconfig.h.in)
|
||||
|
||||
CFLAGS="-g -Wall"
|
||||
|
||||
-localstatedir="/var/ft"
|
||||
+localstatedir="${prefix}"
|
||||
-CFLAGS="-g -Wall"
|
||||
+CFLAGS+="-g -Wall"
|
||||
|
||||
dnl Checks for programs.
|
||||
AC_PROG_CC
|
||||
--- configure Sat Dec 29 01:05:33 2001
|
||||
+++ configure Sat Jan 12 08:42:27 2002
|
||||
@@ -783,7 +783,7 @@
|
||||
--- configure.orig Wed Oct 16 01:28:44 2002
|
||||
+++ configure Sun Nov 17 05:13:42 2002
|
||||
@@ -1583,7 +1583,7 @@
|
||||
|
||||
CFLAGS="-g -Wall"
|
||||
|
||||
-localstatedir="/var/ft"
|
||||
+localstatedir="${prefix}"
|
||||
|
||||
# Extract the first word of "gcc", so it can be a program name with args.
|
||||
set dummy gcc; ac_word=$2
|
||||
-CFLAGS="-g -Wall"
|
||||
+CFLAGS+="-g -Wall"
|
||||
|
||||
ac_ext=c
|
||||
ac_cpp='$CPP $CPPFLAGS'
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- docs/flow-print.1 Sun Dec 23 06:06:02 2001
|
||||
+++ docs/flow-print.1 Sat Jan 12 07:43:42 2002
|
||||
@@ -102,7 +102,7 @@
|
||||
None known\&.
|
||||
.SH "FILES"
|
||||
.PP
|
||||
-Symbols are located in \fB/var/ft/sym/*\fP
|
||||
+Symbols are located in \fB/usr/local/share/flow-tools/*\fP
|
||||
.SH "AUTHOR"
|
||||
.PP
|
||||
Mark Fullmer maf@splintered\&.net
|
|
@ -1,11 +0,0 @@
|
|||
--- docs/flow-tag.1 Mon Apr 22 11:42:06 2002
|
||||
+++ docs/flow-tag.1 Mon Apr 22 11:42:43 2002
|
||||
@@ -189,7 +189,7 @@
|
||||
.fi
|
||||
.PP
|
||||
.PP
|
||||
-First populate \fB/var/ft/sym/tags\fP for \fBflow-stat\fP to use as symbols\&.
|
||||
+First populate \fB/usr/local/etc/flow-tools/tag_defs\fP for \fBflow-stat\fP to use as symbols\&.
|
||||
.PP
|
||||
.nf
|
||||
\f(CW0x0001 OSU
|
|
@ -1,21 +1,29 @@
|
|||
--- lib/ftpaths.h.in Sun Apr 21 04:08:41 2002
|
||||
--- lib/ftpaths.h.in Thu Aug 15 17:28:04 2002
|
||||
+++ lib/ftpaths.h.in Mon Apr 22 11:29:07 2002
|
||||
@@ -29,12 +29,12 @@
|
||||
@@ -29,16 +29,16 @@
|
||||
#ifndef FTPATHS_H
|
||||
#define FTPATHS_H
|
||||
|
||||
-#define FT_PATH_MAP "@localstatedir@/cfg/map"
|
||||
+#define FT_FILE_MAP "@localstatedir@/etc/flow-tools/map"
|
||||
-#define FT_PATH_CFG_MAP "@localstatedir@/cfg/map"
|
||||
-#define FT_PATH_CFG_TAG "@localstatedir@/cfg/tag"
|
||||
-#define FT_PATH_CFG_FILTER "@localstatedir@/cfg/filter"
|
||||
-#define FT_PATH_CFG_STAT "@localstatedir@/cfg/stat"
|
||||
+#define FT_PATH_CFG_MAP "@localstatedir@/etc/flow-tools/map"
|
||||
+#define FT_PATH_CFG_TAG "@localstatedir@/etc/flow-tools/tag"
|
||||
+#define FT_PATH_CFG_FILTER "@localstatedir@/etc/flow-tools/filter"
|
||||
+#define FT_PATH_CFG_STAT "@localstatedir@/etc/flow-tools/stat"
|
||||
|
||||
-#define FT_PATH_IP_PROT "@localstatedir@/sym/ip-prot"
|
||||
-#define FT_PATH_IP_CLASS "@localstatedir@/sym/ip-class"
|
||||
-#define FT_PATH_TCP_PORT "@localstatedir@/sym/tcp-port"
|
||||
-#define FT_PATH_ASN "@localstatedir@/sym/asn"
|
||||
-#define FT_PATH_TAG "@localstatedir@/cfg/tag_defs"
|
||||
+#define FT_PATH_IP_PROT "@localstatedir@/share/flow-tools/ip-prot"
|
||||
+#define FT_PATH_IP_CLASS "@localstatedir@/share/flow-tools/ip-class"
|
||||
+#define FT_PATH_TCP_PORT "@localstatedir@/share/flow-tools/tcp-port"
|
||||
+#define FT_PATH_ASN "@localstatedir@/share/flow-tools/asn"
|
||||
+#define FT_PATH_TAG "@localstatedir@/etc/flow-tools/tag_defs"
|
||||
-#define FT_PATH_SYM_IP_PROT "@localstatedir@/sym/ip-prot"
|
||||
-#define FT_PATH_SYM_IP_CLASS "@localstatedir@/sym/ip-class"
|
||||
-#define FT_PATH_SYM_IP_TYPE "@localstatedir@/sym/ip-type"
|
||||
-#define FT_PATH_SYM_TCP_PORT "@localstatedir@/sym/tcp-port"
|
||||
-#define FT_PATH_SYM_ASN "@localstatedir@/sym/asn"
|
||||
-#define FT_PATH_SYM_TAG "@localstatedir@/sym/tag"
|
||||
+#define FT_PATH_SYM_IP_PROT "@localstatedir@/share/flow-tools/ip-prot"
|
||||
+#define FT_PATH_SYM_IP_CLASS "@localstatedir@/share/flow-tools/ip-class"
|
||||
+#define FT_PATH_SYM_IP_TYPE "@localstatedir@/share/flow-tools/ip-type"
|
||||
+#define FT_PATH_SYM_TCP_PORT "@localstatedir@/share/flow-tools/tcp-port"
|
||||
+#define FT_PATH_SYM_ASN "@localstatedir@/share/flow-tools/asn"
|
||||
+#define FT_PATH_SYM_TAG "@localstatedir@/share/flow-tools/tag"
|
||||
|
||||
#endif /* FTPATHS_H */
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- src/Makefile.am Sat Dec 29 01:23:03 2001
|
||||
+++ src/Makefile.am Sat Jan 12 09:42:38 2002
|
||||
@@ -12,7 +12,7 @@
|
||||
|
||||
force_build:
|
||||
|
||||
-ftbuild.h: ftbuild.sh force_build
|
||||
+ftbuild.h: ftbuild.sh
|
||||
./ftbuild.sh
|
||||
|
||||
flow_import_SOURCES = flow-import.c ftbuild.h
|
||||
--- src/Makefile.in Sat Dec 29 01:27:29 2001
|
||||
+++ src/Makefile.in Sat Jan 12 09:43:42 2002
|
||||
@@ -531,7 +531,7 @@
|
||||
|
||||
force_build:
|
||||
|
||||
-ftbuild.h: ftbuild.sh force_build
|
||||
+ftbuild.h: ftbuild.sh
|
||||
./ftbuild.sh
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
@ -9,11 +9,10 @@ bin/flow-gen
|
|||
bin/flow-header
|
||||
bin/flow-import
|
||||
bin/flow-merge
|
||||
bin/flow-mirror
|
||||
bin/flow-nfilter
|
||||
bin/flow-print
|
||||
bin/flow-receive
|
||||
bin/flow-rsync
|
||||
bin/flow-search
|
||||
bin/flow-report
|
||||
bin/flow-send
|
||||
bin/flow-split
|
||||
bin/flow-stat
|
||||
|
|
Loading…
Reference in a new issue