[new port] TiLP: TI calculator link program
TiLP is a Linking Program to send/receive files to/from your TI calculator. PR: ports/56137 Submitted by: Tijl Coosemans <tijl@ulyssis.org>
This commit is contained in:
parent
cf6262ef49
commit
bf02ecd7e2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=88791
10 changed files with 267 additions and 0 deletions
|
@ -51,6 +51,7 @@
|
||||||
SUBDIR += sms_client
|
SUBDIR += sms_client
|
||||||
SUBDIR += snooper
|
SUBDIR += snooper
|
||||||
SUBDIR += sredird
|
SUBDIR += sredird
|
||||||
|
SUBDIR += tilp
|
||||||
SUBDIR += tits
|
SUBDIR += tits
|
||||||
SUBDIR += tkhylafax
|
SUBDIR += tkhylafax
|
||||||
SUBDIR += tkscanfax
|
SUBDIR += tkscanfax
|
||||||
|
|
51
comms/tilp/Makefile
Normal file
51
comms/tilp/Makefile
Normal file
|
@ -0,0 +1,51 @@
|
||||||
|
# New ports collection makefile for: tilp
|
||||||
|
# Date created: 27 August 2003
|
||||||
|
# Whom: Tijl Coosemans <tijl@ulyssis.org>
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= tilp
|
||||||
|
PORTVERSION= 6.68
|
||||||
|
CATEGORIES= comms
|
||||||
|
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||||
|
MASTER_SITE_SUBDIR= tilp
|
||||||
|
|
||||||
|
MAINTAINER= tijl@ulyssis.org
|
||||||
|
COMMENT= TI Linking Program
|
||||||
|
|
||||||
|
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||||
|
LIB_DEPENDS= ticalcs-4.5:${PORTSDIR}/devel/libticalcs \
|
||||||
|
ticables.10:${PORTSDIR}/comms/libticables \
|
||||||
|
tifiles.5:${PORTSDIR}/devel/libtifiles \
|
||||||
|
intl.4:${PORTSDIR}/devel/gettext
|
||||||
|
|
||||||
|
USE_GNOME= gtk20 libglade2
|
||||||
|
USE_X_PREFIX= yes
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
USE_LIBTOOL= yes
|
||||||
|
USE_GMAKE= yes
|
||||||
|
|
||||||
|
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
|
||||||
|
LDFLAGS="-L${LOCALBASE}/lib"
|
||||||
|
|
||||||
|
MAN1= tilp.1
|
||||||
|
|
||||||
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
.if defined(WITH_JPEG) || exists(${LOCALBASE}/lib/libjpeg.so.9)
|
||||||
|
LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
|
||||||
|
.else
|
||||||
|
pre-everything::
|
||||||
|
@${ECHO_MSG}
|
||||||
|
@${ECHO_MSG} "======================================================="
|
||||||
|
@${ECHO_MSG} "If you want to compile with JPEG support, hit Ctrl-C"
|
||||||
|
@${ECHO_MSG} "right now and use \"make WITH_JPEG=yes\""
|
||||||
|
@${ECHO_MSG} "======================================================="
|
||||||
|
@${ECHO_MSG}
|
||||||
|
.endif #WITH_JPEG
|
||||||
|
|
||||||
|
post-install:
|
||||||
|
${MKDIR} ${PREFIX}/lib/tilp
|
||||||
|
|
||||||
|
.include <bsd.port.post.mk>
|
1
comms/tilp/distinfo
Normal file
1
comms/tilp/distinfo
Normal file
|
@ -0,0 +1 @@
|
||||||
|
MD5 (tilp-6.68.tar.gz) = 42ae4134fb486e12a38744a52ab773a6
|
10
comms/tilp/files/patch-Makefile.in
Normal file
10
comms/tilp/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- Makefile.in.orig Wed Aug 27 22:44:39 2003
|
||||||
|
+++ Makefile.in Wed Aug 27 22:45:35 2003
|
||||||
|
@@ -185,7 +185,6 @@
|
||||||
|
# subdirectories to scan
|
||||||
|
SUBDIRS = \
|
||||||
|
glade help icons man misc pixmaps src win32 \
|
||||||
|
- plugins registry \
|
||||||
|
po intl
|
||||||
|
|
||||||
|
|
11
comms/tilp/files/patch-man-Makefile.in
Normal file
11
comms/tilp/files/patch-man-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- man/Makefile.in.orig Wed Aug 27 23:02:13 2003
|
||||||
|
+++ man/Makefile.in Wed Aug 27 23:03:09 2003
|
||||||
|
@@ -393,7 +393,7 @@
|
||||||
|
groff -Tascii -man $(man_MANS) > Manpage
|
||||||
|
gcc cleaner.c -o cleaner
|
||||||
|
./cleaner Manpage
|
||||||
|
- dos2unix Manpage.txt
|
||||||
|
+# dos2unix Manpage.txt
|
||||||
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||||
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||||
|
.NOEXPORT:
|
10
comms/tilp/files/patch-src-action.c
Normal file
10
comms/tilp/files/patch-src-action.c
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- src/action.c.orig Mon Apr 21 15:44:39 2003
|
||||||
|
+++ src/action.c Mon Apr 21 15:49:32 2003
|
||||||
|
@@ -23,6 +23,7 @@
|
||||||
|
|
||||||
|
#include <gtk/gtk.h>
|
||||||
|
#include <glade/glade.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
#include <string.h>
|
||||||
|
|
||||||
|
#include "action.h"
|
11
comms/tilp/files/patch-src-tilp_misc.c
Normal file
11
comms/tilp/files/patch-src-tilp_misc.c
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- src/tilp_misc.c.orig Mon Apr 21 14:30:31 2003
|
||||||
|
+++ src/tilp_misc.c Mon Apr 21 12:44:08 2003
|
||||||
|
@@ -78,7 +78,7 @@
|
||||||
|
options.web_options = g_strdup("");
|
||||||
|
strcpy(options.left_font_name, "");
|
||||||
|
strcpy(options.right_font_name,
|
||||||
|
- "-adobe-courier-medium-r-*-*-*-125-*-*-*-*-*-*");
|
||||||
|
+ "-adobe-courier-medium-r-*-*-*-120-*-*-*-*-*-*");
|
||||||
|
options.console_mode = !0;
|
||||||
|
locale = setlocale(LC_ALL, NULL);
|
||||||
|
strcpy(options.locale, locale);
|
19
comms/tilp/files/patch-src-tilp_plugin.c
Normal file
19
comms/tilp/files/patch-src-tilp_plugin.c
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
--- src/tilp_plugin.c.orig Wed Apr 23 20:51:57 2003
|
||||||
|
+++ src/tilp_plugin.c Thu Apr 24 13:33:41 2003
|
||||||
|
@@ -168,6 +168,7 @@
|
||||||
|
g_dir_close(dir);
|
||||||
|
DISPLAY(_("Done !\n"));
|
||||||
|
|
||||||
|
+#ifndef __BSD__
|
||||||
|
// Scan registry
|
||||||
|
DISPLAY(_("Scanning registry... "));
|
||||||
|
#ifdef __WIN32__
|
||||||
|
@@ -229,7 +230,7 @@
|
||||||
|
}
|
||||||
|
fclose(reg);
|
||||||
|
DISPLAY(_("Done !\n"));
|
||||||
|
-
|
||||||
|
+#endif
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
8
comms/tilp/pkg-descr
Normal file
8
comms/tilp/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
||||||
|
TiLP stands for 'Ti Linking Program' or 'Tilp is a Linking Program' (GNU
|
||||||
|
recursive acronyms). TiLP is a program allowing a computer or a workstation
|
||||||
|
to communicate with a Texas Instruments graphing calculator.
|
||||||
|
|
||||||
|
WWW: http://tilp.info/
|
||||||
|
|
||||||
|
- Tijl Coosemans
|
||||||
|
tijl@ulyssis.org
|
145
comms/tilp/pkg-plist
Normal file
145
comms/tilp/pkg-plist
Normal file
|
@ -0,0 +1,145 @@
|
||||||
|
bin/tilp
|
||||||
|
include/tilp/tilp_plugin.h
|
||||||
|
share/tilp/COPYING
|
||||||
|
share/tilp/RELEASE
|
||||||
|
share/tilp/glade/about-2.glade
|
||||||
|
share/tilp/glade/about-2.gladep
|
||||||
|
share/tilp/glade/action-2.glade
|
||||||
|
share/tilp/glade/action-2.gladep
|
||||||
|
share/tilp/glade/clist_rbm-2.glade
|
||||||
|
share/tilp/glade/clist_rbm-2.gladep
|
||||||
|
share/tilp/glade/clock-2.glade
|
||||||
|
share/tilp/glade/clock-2.gladep
|
||||||
|
share/tilp/glade/comm-2.glade
|
||||||
|
share/tilp/glade/comm-2.gladep
|
||||||
|
share/tilp/glade/extprgms-2.glade
|
||||||
|
share/tilp/glade/extprgms-2.gladep
|
||||||
|
share/tilp/glade/general-2.glade
|
||||||
|
share/tilp/glade/general-2.gladep
|
||||||
|
share/tilp/glade/manpage-2.glade
|
||||||
|
share/tilp/glade/manpage-2.gladep
|
||||||
|
share/tilp/glade/pbars-2.glade
|
||||||
|
share/tilp/glade/pbars-2.gladep
|
||||||
|
share/tilp/glade/release-2.glade
|
||||||
|
share/tilp/glade/release-2.gladep
|
||||||
|
share/tilp/glade/screen_options-2.glade
|
||||||
|
share/tilp/glade/screen_options-2.gladep
|
||||||
|
share/tilp/glade/screenshot-2.glade
|
||||||
|
share/tilp/glade/screenshot-2.gladep
|
||||||
|
share/tilp/glade/tilp-2.glade
|
||||||
|
share/tilp/glade/tilp-2.gladep
|
||||||
|
share/tilp/glade/user_boxes-2.glade
|
||||||
|
share/tilp/glade/user_boxes-2.gladep
|
||||||
|
share/tilp/help/FAQ.html
|
||||||
|
share/tilp/help/Image12.png
|
||||||
|
share/tilp/help/Image13.png
|
||||||
|
share/tilp/help/Image15.png
|
||||||
|
share/tilp/help/Image17.png
|
||||||
|
share/tilp/help/Image18.png
|
||||||
|
share/tilp/help/Image20.png
|
||||||
|
share/tilp/help/Makefile
|
||||||
|
share/tilp/help/Makefile.am
|
||||||
|
share/tilp/help/Makefile.in
|
||||||
|
share/tilp/help/Manual_en.html
|
||||||
|
share/tilp/help/Manual_fr.html
|
||||||
|
share/tilp/help/action.png
|
||||||
|
share/tilp/help/blank.png
|
||||||
|
share/tilp/help/comm_cable.png
|
||||||
|
share/tilp/help/comm_calc.png
|
||||||
|
share/tilp/help/comm_misc.png
|
||||||
|
share/tilp/help/dirlist.png
|
||||||
|
share/tilp/help/ext_prgms.png
|
||||||
|
share/tilp/help/general_calc.png
|
||||||
|
share/tilp/help/general_comp.png
|
||||||
|
share/tilp/help/logo_lpg.png
|
||||||
|
share/tilp/help/logo_tilp.png
|
||||||
|
share/tilp/help/popup_menu.png
|
||||||
|
share/tilp/help/screen_box.png
|
||||||
|
share/tilp/help/screen_options_1.png
|
||||||
|
share/tilp/help/screen_options_2.png
|
||||||
|
share/tilp/help/screenshot_linux.png
|
||||||
|
share/tilp/help/screenshot_win32.png
|
||||||
|
share/tilp/icons/App_Var.ico
|
||||||
|
share/tilp/icons/Application.ico
|
||||||
|
share/tilp/icons/Asm_Program.ico
|
||||||
|
share/tilp/icons/Backup.ico
|
||||||
|
share/tilp/icons/Certificate.ico
|
||||||
|
share/tilp/icons/Complex.ico
|
||||||
|
share/tilp/icons/Complex_List.ico
|
||||||
|
share/tilp/icons/Complex_Matrix.ico
|
||||||
|
share/tilp/icons/Complex_Vector.ico
|
||||||
|
share/tilp/icons/Constant.ico
|
||||||
|
share/tilp/icons/Data.ico
|
||||||
|
share/tilp/icons/Diff_Equ.ico
|
||||||
|
share/tilp/icons/Equation.ico
|
||||||
|
share/tilp/icons/Expression.ico
|
||||||
|
share/tilp/icons/Figure.ico
|
||||||
|
share/tilp/icons/Function.ico
|
||||||
|
share/tilp/icons/GDB.ico
|
||||||
|
share/tilp/icons/Group.ico
|
||||||
|
share/tilp/icons/Group_Backup.ico
|
||||||
|
share/tilp/icons/Group_Var.ico
|
||||||
|
share/tilp/icons/List.ico
|
||||||
|
share/tilp/icons/Macro.ico
|
||||||
|
share/tilp/icons/Matrix.ico
|
||||||
|
share/tilp/icons/OS_upgrade.ico
|
||||||
|
share/tilp/icons/Parametric.ico
|
||||||
|
share/tilp/icons/Picture.ico
|
||||||
|
share/tilp/icons/Polar.ico
|
||||||
|
share/tilp/icons/Program.ico
|
||||||
|
share/tilp/icons/Range.ico
|
||||||
|
share/tilp/icons/Real.ico
|
||||||
|
share/tilp/icons/String.ico
|
||||||
|
share/tilp/icons/TIicon1.ico
|
||||||
|
share/tilp/icons/TIicon2.ico
|
||||||
|
share/tilp/icons/TIicon3.ico
|
||||||
|
share/tilp/icons/TIicon4.ico
|
||||||
|
share/tilp/icons/Table_Setup.ico
|
||||||
|
share/tilp/icons/Text.ico
|
||||||
|
share/tilp/icons/Unknown.ico
|
||||||
|
share/tilp/icons/Vector.ico
|
||||||
|
share/tilp/icons/Window_Setup.ico
|
||||||
|
share/tilp/icons/Y_Var.ico
|
||||||
|
share/tilp/icons/Zipped.ico
|
||||||
|
share/tilp/icons/Zoom.ico
|
||||||
|
share/tilp/icons/test.ico
|
||||||
|
share/tilp/icons/up.ico
|
||||||
|
share/tilp/Manpage.txt
|
||||||
|
share/tilp/pixmaps/attr_archived.xpm
|
||||||
|
share/tilp/pixmaps/attr_locked.xpm
|
||||||
|
share/tilp/pixmaps/clist_dir.xpm
|
||||||
|
share/tilp/pixmaps/clist_doc.xpm
|
||||||
|
share/tilp/pixmaps/clist_dotdot.xpm
|
||||||
|
share/tilp/pixmaps/clist_down.xpm
|
||||||
|
share/tilp/pixmaps/clist_up.xpm
|
||||||
|
share/tilp/pixmaps/ctree_close_dir.xpm
|
||||||
|
share/tilp/pixmaps/ctree_open_dir.xpm
|
||||||
|
share/tilp/pixmaps/ctree_var.xpm
|
||||||
|
share/tilp/pixmaps/icon.xpm
|
||||||
|
share/tilp/pixmaps/logo.xpm
|
||||||
|
share/tilp/pixmaps/mini_keyboard.xpm
|
||||||
|
share/tilp/pixmaps/mini_screen.xpm
|
||||||
|
share/tilp/pixmaps/no.xpm
|
||||||
|
share/tilp/pixmaps/screendump.xpm
|
||||||
|
share/tilp/pixmaps/tb_calc_backup.xpm
|
||||||
|
share/tilp/pixmaps/tb_calc_dirlist.xpm
|
||||||
|
share/tilp/pixmaps/tb_calc_recv.xpm
|
||||||
|
share/tilp/pixmaps/tb_calc_restore.xpm
|
||||||
|
share/tilp/pixmaps/tb_calc_screen.xpm
|
||||||
|
share/tilp/pixmaps/tb_calc_send.xpm
|
||||||
|
share/tilp/pixmaps/tb_exit.xpm
|
||||||
|
share/tilp/pixmaps/tb_floppy.xpm
|
||||||
|
share/tilp/pixmaps/tb_help.xpm
|
||||||
|
share/tilp/pixmaps/tb_mkdir.xpm
|
||||||
|
share/tilp/pixmaps/tb_ready.xpm
|
||||||
|
share/tilp/pixmaps/tb_refresh.xpm
|
||||||
|
share/tilp/pixmaps/tb_trash.xpm
|
||||||
|
share/tilp/pixmaps/yes.xpm
|
||||||
|
@exec mkdir %D/lib/tilp
|
||||||
|
@dirrm share/tilp/pixmaps
|
||||||
|
@dirrm share/tilp/icons
|
||||||
|
@dirrm share/tilp/help
|
||||||
|
@dirrm share/tilp/glade
|
||||||
|
@dirrm share/tilp
|
||||||
|
@dirrm lib/tilp
|
||||||
|
@dirrm include/tilp
|
Loading…
Reference in a new issue