net-p2p/monero-cli: Fix compilation on i386

This commit is contained in:
Vasil Dimov 2017-11-11 15:36:29 +00:00
parent 018adb7f69
commit bf23b78ddf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=453977

View file

@ -0,0 +1,14 @@
https://github.com/monero-project/monero/pull/2793
--- CMakeLists.txt.orig 2017-11-11 15:31:39 UTC
+++ CMakeLists.txt
@@ -682,7 +682,7 @@ endif()
if(ANDROID)
set(ATOMIC libatomic.a)
endif()
-if(CMAKE_C_COMPILER_ID STREQUAL "Clang" AND ARCH_WIDTH EQUAL "32" AND NOT IOS)
+if(CMAKE_C_COMPILER_ID STREQUAL "Clang" AND ARCH_WIDTH EQUAL "32" AND NOT IOS AND NOT FREEBSD)
find_library(ATOMIC atomic)
list(APPEND EXTRA_LIBRARIES ${ATOMIC})
endif()