- Update to 5.2.6
ChangeLog: - Support for FILO - Support for USB disks - btext console - Fixes for eepro100, rtl8139, sis900, tlan, tulip and via-rhine drivers - Added drivers for mtd80x and Davicom based cards PR: ports/101721 Submitted by: me (stas) Approved by: maintainer timeout (3,5 months)
This commit is contained in:
parent
97772c33d5
commit
bf33f3e5b8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=177847
5 changed files with 34 additions and 55 deletions
|
@ -6,8 +6,8 @@
|
|||
#
|
||||
|
||||
PORTNAME= etherboot
|
||||
PORTVERSION= 5.2.4
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 5.2.6
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= net
|
||||
#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
#MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -16,7 +16,7 @@ MASTER_SITES= http://etherboot.sourceforge.net/ \
|
|||
http://etherboot.berlios.de/dist/
|
||||
|
||||
MAINTAINER= ambrisko@freebsd.org
|
||||
COMMENT= Network boot of FreeBSD a.out/ELF kernels. Replaces/improves netboot.
|
||||
COMMENT= Network boot of FreeBSD a.out/ELF kernels (improved netboot)
|
||||
|
||||
NO_PACKAGE= lots of configuration necessary
|
||||
USE_BZIP2= 1
|
||||
|
@ -25,9 +25,11 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
|
|||
USE_PERL5_BUILD=yes
|
||||
ONLY_FOR_ARCHS= i386
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
do-install:
|
||||
@${ECHO} Refer ${DESCR} and ${WRKDIR}/${PKGNAME}/doc for how to
|
||||
@${ECHO} build and install the rom/floppy image.
|
||||
@exit 1
|
||||
@${FALSE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (etherboot-5.2.4.tar.bz2) = 932260ae1f14a2fc8f3f81823406d254
|
||||
SHA256 (etherboot-5.2.4.tar.bz2) = 42a3b5c9eaffceaad9c6ba8f86e654ad82a9a0139e886cf96da54a0738e00cab
|
||||
SIZE (etherboot-5.2.4.tar.bz2) = 765452
|
||||
MD5 (etherboot-5.2.6.tar.bz2) = af5ae9150beda715deb22a5904a0c8e4
|
||||
SHA256 (etherboot-5.2.6.tar.bz2) = f7de9d265347ee27680b436edc4b97fb2a5936bbc9f57bf2a3f8ead9d92d01c6
|
||||
SIZE (etherboot-5.2.6.tar.bz2) = 926924
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
diff -urp ./arch/i386/core/freebsd_loader.c /data/home/ambrisko/stable/usr/ports/net/etherboot/work.good/etherboot-5.2.4/src/arch/i386/core/freebsd_loader.c
|
||||
--- ./arch/i386/core/freebsd_loader.c Sun Feb 22 17:26:09 2004
|
||||
+++ /data/home/ambrisko/stable/usr/ports/net/etherboot/work.good/etherboot-5.2.4/src/arch/i386/core/freebsd_loader.c Wed Jun 30 13:53:10 2004
|
||||
@@ -168,7 +168,7 @@ static int elf_freebsd_debug_loader(unsi
|
||||
for (j=0; j < estate.e.elf32.e_phnum; j++)
|
||||
{
|
||||
/* Check only for loaded sections */
|
||||
- if ((estate.p.phdr32[i].p_type | 0x80) == (PT_LOAD | 0x80))
|
||||
+ if ((estate.p.phdr32[j].p_type | 0x80) == (PT_LOAD | 0x80))
|
||||
{
|
||||
/* Only the extra symbols */
|
||||
if ((shdr[i].sh_offset >= estate.p.phdr32[j].p_offset) &&
|
||||
@@ -288,7 +290,7 @@ static void elf_freebsd_boot(unsigned lo
|
||||
/* Assumes size of long is a power of 2... */
|
||||
bsdinfo.bi_esymtab = (symstr_load +
|
||||
sizeof(long) +
|
||||
- *((long *)symstr_load) +
|
||||
+ *((long *)phys_to_virt(symstr_load)) +
|
||||
sizeof(long) - 1) & ~(sizeof(long) - 1);
|
||||
|
||||
/* Where we will build the meta data... */
|
||||
diff -urp ./core/elf_loader.c /data/home/ambrisko/stable/usr/ports/net/etherboot/work.good/etherboot-5.2.4/src/core/elf_loader.c
|
||||
--- ./core/elf_loader.c Sun Feb 22 17:26:09 2004
|
||||
+++ /data/home/ambrisko/stable/usr/ports/net/etherboot/work.good/etherboot-5.2.4/src/core/elf_loader.c Wed Jun 30 11:38:53 2004
|
||||
@@ -268,6 +268,7 @@ static sector_t elf32_download(unsigned
|
||||
}
|
||||
if (estate.segment == -1) {
|
||||
if (elf_freebsd_debug_loader(offset)) {
|
||||
+ estate.segment = 0; /* -1 makes it not read anymore */
|
||||
continue;
|
||||
}
|
||||
/* No more segments to be loaded, so just start the
|
||||
Only in /data/home/ambrisko/stable/usr/ports/net/etherboot/work.good/etherboot-5.2.4/src/core: elf_loader.c.orig
|
|
@ -1,17 +1,3 @@
|
|||
--- ./arch/i386/include/bits/string.h.orig Sat Dec 4 09:31:24 2004
|
||||
+++ ./arch/i386/include/bits/string.h Sat Dec 4 09:33:37 2004
|
||||
@@ -65,9 +65,10 @@ __asm__ __volatile__(
|
||||
return dest;
|
||||
}
|
||||
|
||||
+#ifndef __FreeBSD__
|
||||
#define memcmp __builtin_memcmp
|
||||
#define __HAVE_ARCH_MEMCMP
|
||||
-
|
||||
+#endif
|
||||
|
||||
#define __HAVE_ARCH_MEMSET
|
||||
static inline void *memset(void *s, int c,size_t count)
|
||||
--- drivers/disk/ide_disk.c.orig Sat Dec 4 09:24:19 2004
|
||||
+++ drivers/disk/ide_disk.c Sat Dec 4 15:57:18 2004
|
||||
@@ -592,7 +592,8 @@ static int init_drive(struct harddisk_in
|
||||
|
|
24
net/etherboot/files/patch-c99
Normal file
24
net/etherboot/files/patch-c99
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- filo/usb/ohci.c.orig Wed Aug 9 22:33:30 2006
|
||||
+++ filo/usb/ohci.c Wed Aug 9 22:34:47 2006
|
||||
@@ -1155,10 +1155,10 @@
|
||||
|
||||
int timeout = 30;
|
||||
int smm_timeout = 50; /* 0,5 sec */
|
||||
+ ohci_t *ohci = &_ohci_x[controller];
|
||||
|
||||
debug("Resetting OHCI\n");
|
||||
ohci_regs = (ohci_regs_t *)hc_base[controller];
|
||||
- ohci_t *ohci = &_ohci_x[controller];
|
||||
|
||||
#ifndef __hppa__
|
||||
/* PA-RISC doesn't have SMM, but PDC might leave IR set */
|
||||
@@ -1204,8 +1204,8 @@
|
||||
u32 mask;
|
||||
unsigned int fminterval;
|
||||
int delaytime;
|
||||
- ohci_regs = (ohci_regs_t *)hc_base[controller];
|
||||
ohci_t *ohci = &_ohci_x[controller];
|
||||
+ ohci_regs = (ohci_regs_t *)hc_base[controller];
|
||||
|
||||
debug("Starting OHCI\n");
|
||||
|
Loading…
Reference in a new issue