Upgrade, 10.11 -> 12.12.
Suggested by: Bill Fenner <fenner@parc.xerox.com> (Closing PR #2554.)
This commit is contained in:
parent
8a34fc281a
commit
bf71549f77
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=5525
4 changed files with 42 additions and 44 deletions
|
@ -1,19 +1,24 @@
|
|||
# New ports collection makefile for: sox - Sound Exchange
|
||||
# Version required: 10p11
|
||||
# Version required: 12p12
|
||||
# Date created: 17 Oct 1994
|
||||
# Whom: torstenb
|
||||
#
|
||||
# $Id: Makefile,v 1.7 1996/11/15 23:14:24 obrien Exp $
|
||||
# $Id: Makefile,v 1.8 1996/11/18 11:21:36 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= sox10p11
|
||||
PKGNAME= sox-10.11
|
||||
DISTNAME= soxgamma
|
||||
PKGNAME= sox-12.12
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ftp://nic.switch.ch/software/sources/audio/
|
||||
EXTRACT_SUFX= .tar.Z
|
||||
MASTER_SITES= http://www.spies.com/Sox/Archive/
|
||||
|
||||
MAINTAINER= torstenb@FreeBSD.ORG
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
MAKEFILE= Makefile.unx
|
||||
MAN1= sox.1
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/sox ${PREFIX}/bin
|
||||
@${INSTALL_MAN} ${WRKSRC}/sox.man ${PREFIX}/man/man1/sox.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (sox10p11.tar.Z) = 2cd81eafbe532644eaf3904d643045d8
|
||||
MD5 (soxgamma.tar.gz) = ed5586a59ee9fed5e7cea90e46a6c51b
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
*** sbdsp.c.orig Mon Jul 26 12:58:00 1993
|
||||
--- sbdsp.c Mon Oct 31 18:26:56 1994
|
||||
*** sbdsp.c.orig Thu Aug 18 06:11:01 1994
|
||||
--- sbdsp.c Mon Jan 27 02:47:53 1997
|
||||
***************
|
||||
*** 21,27 ****
|
||||
#include <i386/isa/sblast.h>
|
||||
|
@ -18,18 +18,18 @@
|
|||
#include <sys/sb.h>
|
||||
#endif
|
||||
***************
|
||||
*** 77,83 ****
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_VOICE, &off);
|
||||
*** 78,84 ****
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_SPEED, &ft->info.rate);
|
||||
#elif defined(LINUXSOUND)
|
||||
#else
|
||||
#if defined(LINUXSOUND)
|
||||
! ioctl(fileno(ft->fp), SNDCTL_DSP_SPEED, ft->info.rate);
|
||||
#else
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_VOICE, 0);
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_SPEED, ft->info.rate);
|
||||
--- 77,87 ----
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_VOICE, &off);
|
||||
--- 78,88 ----
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_SPEED, &ft->info.rate);
|
||||
#elif defined(LINUXSOUND)
|
||||
#else
|
||||
#if defined(LINUXSOUND)
|
||||
! #if SOUND_VERSION >= 200
|
||||
! ioctl(fileno(ft->fp), SOUND_PCM_WRITE_RATE, &ft->info.rate);
|
||||
! #else
|
||||
|
@ -39,17 +39,17 @@
|
|||
ioctl(fileno(ft->fp), DSP_IOCTL_VOICE, 0);
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_SPEED, ft->info.rate);
|
||||
***************
|
||||
*** 143,149 ****
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_SPEED, &ft->info.rate);
|
||||
#elif defined(LINUXSOUND)
|
||||
*** 148,154 ****
|
||||
#else
|
||||
#if defined(LINUXSOUND)
|
||||
ioctl(fileno(ft->fp), SNDCTL_DSP_SYNC, 0);
|
||||
! ioctl(fileno(ft->fp), SNDCTL_DSP_SPEED, ft->info.rate);
|
||||
#else
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_VOICE, 1);
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_SPEED, ft->info.rate);
|
||||
--- 147,157 ----
|
||||
ioctl(fileno(ft->fp), DSP_IOCTL_SPEED, &ft->info.rate);
|
||||
#elif defined(LINUXSOUND)
|
||||
--- 152,162 ----
|
||||
#else
|
||||
#if defined(LINUXSOUND)
|
||||
ioctl(fileno(ft->fp), SNDCTL_DSP_SYNC, 0);
|
||||
! #if SOUND_VERSION >= 200
|
||||
! ioctl(fileno(ft->fp), SOUND_PCM_WRITE_RATE, &ft->info.rate);
|
||||
|
|
|
@ -1,23 +1,16 @@
|
|||
*** Makefile.unx.orig Mon Jul 26 12:58:00 1993
|
||||
--- Makefile.unx Mon Oct 31 19:19:42 1994
|
||||
***************
|
||||
*** 122,128 ****
|
||||
--- 122,139 ----
|
||||
# AR = ar r
|
||||
# RANLIB = ranlib
|
||||
|
||||
+
|
||||
+ # FreeBSD 1.x / 2.x
|
||||
+ CFLAGS = -O -DLINUXSOUND -D_HAVE_PARAM_H
|
||||
+ CC = cc
|
||||
+ AR = ar r
|
||||
+ RANLIB = ranlib
|
||||
+
|
||||
all: sox
|
||||
+
|
||||
+ install:
|
||||
+ cp sox ${PREFIX}/bin/sox
|
||||
+ cp sox.man ${PREFIX}/man/man1/sox.1
|
||||
|
||||
sox: sox.o $(SOUNDLIB)
|
||||
$(CC) $(CFLAGS) -o sox sox.o $(SOUNDLIB) -lm
|
||||
--- Makefile.unx.orig Sat Oct 8 09:14:48 1994
|
||||
+++ Makefile.unx Mon Jan 27 15:09:32 1997
|
||||
@@ -153,6 +153,13 @@
|
||||
# RM = del /q
|
||||
|
||||
|
||||
+
|
||||
+# FreeBSD 1.x / 2.x / 3.x
|
||||
+CFLAGS = -O -DLINUXSOUND -D_HAVE_PARAM_H
|
||||
+CC = cc
|
||||
+AR = ar r
|
||||
+RANLIB = ranlib
|
||||
+
|
||||
all: sox
|
||||
|
||||
sox: sox.o $(SOUNDLIB)
|
||||
|
|
Loading…
Reference in a new issue