Initial import of hexedit version 0.9.3.

View and edit files in hexadecimal or ASCII.

PR:		7506
Submitted by:	Andrey Zakhvatov <andy@icc.surw.chel.su>
This commit is contained in:
Steve Price 1998-08-10 00:31:41 +00:00
parent f7a21ee128
commit bf873ad2a4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=12402
6 changed files with 68 additions and 0 deletions

33
editors/hexedit/Makefile Normal file
View file

@ -0,0 +1,33 @@
# New ports collection makefile for: hexedit
# Version required: 0.9.3
# Date created: 5 August 1998
# Whom: Andrey Zakhvatov
#
# $Id$
#
DISTNAME= hexedit-0.9.3
CATEGORIES= editors
MASTER_SITES= http://www.chez.com/prigaux/
EXTRACT_SUFX= .src.tgz
MAINTAINER= andy@icc.surw.chel.su
LIB_DEPENDS= ncurses\\.4\\.:${PORTSDIR}/devel/ncurses
ALL_TARGET=
WRKSRC= ${WRKDIR}/hexedit
MAN1= hexedit.1
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/hexedit ${PREFIX}/bin
@ ${INSTALL_MAN} ${WRKSRC}/hexedit.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/hexedit
.for file in COPYING Changes TODO
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/hexedit
.endfor
.endif
.include <bsd.port.mk>

1
editors/hexedit/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (hexedit-0.9.3.src.tgz) = 81268b02efee3786c91eb30778fe8afc

View file

@ -0,0 +1,19 @@
--- Makefile Sun Jul 26 14:10:26 1998
+++ /home/andy/tmp/wrk/Makefile Wed Aug 5 15:44:32 1998
@@ -1,14 +1,14 @@
PROJECT = hexedit
VERSION = 0.9.3
-CC=gcc
+#CC=gcc
TARSOURCE = $(PROJECT)-$(VERSION).src.tgz
DYNAMICBIN = $(PROJECT)-$(VERSION).bin.i386.dynamic.tgz
HTMLSITE = $(PROJECT)-html-site.tar
HTMLFILES = $(PROJECT).html
TMPFILES = $(DYNAMICBIN) $(TARSOURCE) $(HTMLFILES)
-CFLAGS = -Wall -O2
+CFLAGS+= -I/usr/local/include/ncurses -I/usr/local/include -L/usr/local/lib -lncurses
LOADLIBES = -lcurses
.PHONY: clean tgz docs

View file

@ -0,0 +1 @@
View and edit files in hexadecimal or ASCII.

View file

@ -0,0 +1,8 @@
Hexedit view and edit files in hexadecimal or in ASCII.
hexedit shows a file both in ASCII and in hexadecimal.
The file can be a device as the file is not whole read.
You can modify the file and search through it.
You have also copy&paste, and save to file functions.
Modifications are shown in bold.
http://www.chez.com/prigaux/hexedit.html

View file

@ -0,0 +1,6 @@
bin/hexedit
man/man1/hexedit.1.gz
share/doc/hexedit/COPYING
share/doc/hexedit/Changes
share/doc/hexedit/TODO
@dirrm share/doc/hexedit