- Removed unnecessary diff

=Version 1.3.15=

2013-12-02  David Freese  <w1hkj@w1hkj.com>

        3422195: 64 bit void pointer
        fa317c3: tty search
        7732b22: TT566
        6964cb6: TS590S/TS990S/TS2000 controls
        5b340a9: FTdx1200
        e199a62: Send cmd debug
        718f46f: TS-990
        05898d5: Sliders
        c13a20e: Notch controls
        86f1d0b: 7600 split
        9f08704: Restore debug

PR:		ports/188537
Submitted by:	maintainer
This commit is contained in:
Diane Bruce 2014-04-12 23:43:51 +00:00
parent cbb716d97e
commit bf9a7946d7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=351160
3 changed files with 5 additions and 40 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= flrig
PORTVERSION= 1.3.13
PORTVERSION= 1.3.15
CATEGORIES= comms hamradio
MASTER_SITES= http://www.w1hkj.com/downloads/flrig/ \
${MASTER_SITE_LOCAL}
@ -24,12 +24,7 @@ OPTIONS_DEFINE= NATIVE_OPT
NATIVE_OPT_DESC= Enable Native Optimizations
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MNATIVE_OPT}
CONFIGURE_ARGS+=--enable-optimizations=native
.else
CONFIGURE_ARGS+=--enable-optimizations=none
.endif
NATIVE_OPT_CONFIGURE_ON+= --enable-optimizations=native
NATIVE_OPT_CONFIGURE_OFF+= --enable-optimizations=none
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (flrig-1.3.13.tar.gz) = c5238bc72dc04a2b2ba741e093672990ec9ceecc7bfc4137b76d9e01a89dfdbb
SIZE (flrig-1.3.13.tar.gz) = 578415
SHA256 (flrig-1.3.15.tar.gz) = 1c6163b3b1a410829a2ac4bd68f857d7c25419041bd30eb003bd0aff22348818
SIZE (flrig-1.3.15.tar.gz) = 596888

View file

@ -1,30 +0,0 @@
--- src/debug.cxx.orig 2013-08-29 02:59:21.000000000 -0700
+++ src/debug.cxx 2014-04-11 03:02:01.000000000 -0700
@@ -126,7 +126,7 @@
vsnprintf(sztemp, sizeof(sztemp), fmt, args);
estr.append(sztemp);
- vfprintf(wfile, fmt, args);
+ fputs(sztemp, wfile);
va_end(args);
@@ -149,16 +149,14 @@
vsnprintf(sztemp, sizeof(sztemp), fmt, args);
estr.append(sztemp);
- vfprintf(wfile, fmt, args);
+ fputs(sztemp, wfile);
va_end(args);
fflush(wfile);
if (tty) {
if (level <= DEBUG_LEVEL && level >= QUIET_LEVEL) {
- va_start(args, format);
- vfprintf(stderr, fmt, args);
- va_end(args);
+ fputs(sztemp, stderr);
}
}