- Update to 1.9.0

- Optionally use icu.32 instead of icu2.x

PR:		ports/78436
Submitted by:	maintainer
This commit is contained in:
Volker Stolz 2005-03-08 10:18:49 +00:00
parent 8deea0a6c7
commit bfa84448ef
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=130603
6 changed files with 202 additions and 55 deletions

View file

@ -7,7 +7,7 @@
# ------------------------------------------------------------------------------
PORTNAME= xalan-c
PORTVERSION= 1.8.0
PORTVERSION= 1.9.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML:S/$/:msax,docs/}
MASTER_SITE_SUBDIR= ${PORTNAME}/source/:msax ${PORTNAME}/docs/:docs
@ -57,6 +57,10 @@ USE_GMAKE= yes
MAKE_ENV+= XALANCROOT=${WRKSRC}
MAKE_ENV+= XERCESCROOT=${XERCESCROOT}
.if ( ${OSVERSION} < 500000 )
EXTRA_CFLAGS= -ftemplate-depth-20
.endif
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= runConfigure
CONFIGURE_ENV+= XALANCROOT=${WRKSRC}
@ -64,7 +68,7 @@ CONFIGURE_ENV+= XERCESCROOT=${XERCESCROOT}
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -l ${PTHREAD_LIBS} \
-z -I${LOCALBASE}/include -C --prefix=${PREFIX}
-z ${EXTRA_CFLAGS} -I${LOCALBASE}/include -C --prefix=${PREFIX}
.if defined(WITH_INMEM)
LOCALSYS= inmem
@ -99,7 +103,7 @@ PLIST_SUB+= LOCALSYS_NLS="@comment "
.if defined(WITH_TRANSCODER_ICU)
PKGNAMESUFFIX+= -icu
LIB_DEPENDS+= icuuc.28:${PORTSDIR}/devel/icu2
LIB_DEPENDS+= icuuc.32:${PORTSDIR}/devel/icu
ICUROOT?= ${LOCALBASE}
CONFIGURE_ENV+= XALAN_USE_ICU=1
CONFIGURE_ENV+= ICUROOT=${ICUROOT}
@ -158,7 +162,15 @@ pre-extract:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/check-config-options
post-patch:
${RM} -f ${WRKSRC}/src/xalanc/PlatformSupport/XalanArrayAllocator.hpp.orig
${RM} -f ${WRKSRC}/src/xalanc/ICUBridge/ICUFormatNumberFunctor.hpp.orig \
${WRKSRC}/src/xalanc/PlatformSupport/XalanArrayAllocator.hpp.orig \
${WRKSRC}/src/xalanc/XMLSupport/FormatterToText.hpp.orig \
${WRKSRC}/src/xalanc/XPath/ElementPrefixResolverProxy.hpp.orig \
${WRKSRC}/src/xalanc/XPath/NameSpace.hpp.orig \
${WRKSRC}/src/xalanc/XPath/XalanQNameByValue.hpp.orig \
${WRKSRC}/src/xalanc/XSLT/FunctionSystemProperty.hpp.orig \
${WRKSRC}/src/xalanc/XSLT/TopLevelArg.hpp.orig
${CHMOD} 755 ${WRKSRC}/runConfigure ${WRKSRC}/configure
post-install:
.if !defined(WITH_DEBUG)
@ -177,8 +189,8 @@ post-install:
cd ${DOCSDIR} && \
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${_DISTDIR}/${DOCS_TARBALL} ${EXTRACT_AFTER_ARGS} && \
${MV} ${DOCSDIR}/docs/* ${DOCSDIR} && \
${RMDIR} ${DOCSDIR}/docs
${MV} ${DOCSDIR}/Xalan-C_${PORTVERSION:S/./_/g}-docs/* ${DOCSDIR} && \
${RMDIR} ${DOCSDIR}/Xalan-C_${PORTVERSION:S/./_/g}-docs
.endif
post-clean:

View file

@ -38,30 +38,31 @@
${EXAMPLESDIR}/ExternalFunction/
${MKDIR} ${EXAMPLESDIR}/ParsedSourceWrappers
${INSTALL_DATA} \
${WRKSRC}/samples/ParsedSourceWrappers/ParsedSourceWrappers.cpp \
${WRKSRC}/samples/ParsedSourceWrappers/foo.xml \
${WRKSRC}/samples/ParsedSourceWrappers/foo.xsl \
${WRKSRC}/samples/ParsedSourceWrappers/ParsedSourceWrappers.cpp \
${EXAMPLESDIR}/ParsedSourceWrappers/
${MKDIR} ${EXAMPLESDIR}/SerializeNodeSet
${INSTALL_DATA} \
${WRKSRC}/samples/SerializeNodeSet/SerializeNodeSet.cpp \
${WRKSRC}/samples/SerializeNodeSet/foo.xml \
${WRKSRC}/samples/SerializeNodeSet/SerializeNodeSet.cpp \
${EXAMPLESDIR}/SerializeNodeSet/
${MKDIR} ${EXAMPLESDIR}/SimpleTransform
${INSTALL_DATA} \
${WRKSRC}/samples/SimpleTransform/SimpleTransform.cpp \
${WRKSRC}/samples/SimpleTransform/foo.xml \
${WRKSRC}/samples/SimpleTransform/foo.xsl \
${WRKSRC}/samples/SimpleTransform/SimpleTransform.cpp \
${WRKSRC}/samples/SimpleTransform/XalanMemoryManagerImpl.hpp \
${EXAMPLESDIR}/SimpleTransform/
${MKDIR} ${EXAMPLESDIR}/SimpleXPathAPI
${INSTALL_DATA} \
${WRKSRC}/samples/SimpleXPathAPI/SimpleXPathAPI.cpp \
${WRKSRC}/samples/SimpleXPathAPI/foo.xml \
${WRKSRC}/samples/SimpleXPathAPI/SimpleXPathAPI.cpp \
${EXAMPLESDIR}/SimpleXPathAPI/
${MKDIR} ${EXAMPLESDIR}/SimpleXPathCAPI
${INSTALL_DATA} \
${WRKSRC}/samples/SimpleXPathCAPI/SimpleXPathCAPI.c \
${WRKSRC}/samples/SimpleXPathCAPI/foo.xml \
${WRKSRC}/samples/SimpleXPathCAPI/SimpleXPathCAPI.c \
${EXAMPLESDIR}/SimpleXPathCAPI/
${MKDIR} ${EXAMPLESDIR}/StreamTransform
${INSTALL_DATA} \
@ -69,44 +70,44 @@
${EXAMPLESDIR}/StreamTransform/
${MKDIR} ${EXAMPLESDIR}/ThreadSafe
${INSTALL_DATA} \
${WRKSRC}/samples/ThreadSafe/ThreadSafe.cpp \
${WRKSRC}/samples/ThreadSafe/birds.xml \
${WRKSRC}/samples/ThreadSafe/birds.xsl \
${WRKSRC}/samples/ThreadSafe/ThreadSafe.cpp \
${EXAMPLESDIR}/ThreadSafe/
${MKDIR} ${EXAMPLESDIR}/TraceListen
${INSTALL_DATA} \
${WRKSRC}/samples/TraceListen/TraceListen.cpp \
${WRKSRC}/samples/TraceListen/birds.xml \
${WRKSRC}/samples/TraceListen/birds.xsl \
${WRKSRC}/samples/TraceListen/TraceListen.cpp \
${EXAMPLESDIR}/TraceListen/
${MKDIR} ${EXAMPLESDIR}/TransformToXercesDOM
${INSTALL_DATA} \
${WRKSRC}/samples/TransformToXercesDOM/TransformToXercesDOM.cpp \
${WRKSRC}/samples/TransformToXercesDOM/birds.xml \
${WRKSRC}/samples/TransformToXercesDOM/birds.xsl \
${WRKSRC}/samples/TransformToXercesDOM/TransformToXercesDOM.cpp \
${EXAMPLESDIR}/TransformToXercesDOM/
${MKDIR} ${EXAMPLESDIR}/UseStylesheetParam
${INSTALL_DATA} \
${WRKSRC}/samples/UseStylesheetParam/UseStylesheetParam.cpp \
${WRKSRC}/samples/UseStylesheetParam/foo.xml \
${WRKSRC}/samples/UseStylesheetParam/foo.xsl \
${WRKSRC}/samples/UseStylesheetParam/UseStylesheetParam.cpp \
${EXAMPLESDIR}/UseStylesheetParam/
${MKDIR} ${EXAMPLESDIR}/XPathWrapper
${INSTALL_DATA} \
${WRKSRC}/samples/XPathWrapper/TestDriver.cpp \
${WRKSRC}/samples/XPathWrapper/XPathWrapper.cpp \
${WRKSRC}/samples/XPathWrapper/XPathWrapper.hpp \
${WRKSRC}/samples/XPathWrapper/foo.xml \
${EXAMPLESDIR}/XPathWrapper/
${MKDIR} ${EXAMPLESDIR}/XalanTransform
${INSTALL_DATA} \
${WRKSRC}/samples/XalanTransform/XalanTransform.cpp \
${WRKSRC}/samples/XalanTransform/foo.xml \
${WRKSRC}/samples/XalanTransform/foo.xsl \
${WRKSRC}/samples/XalanTransform/XalanTransform.cpp \
${EXAMPLESDIR}/XalanTransform/
${MKDIR} ${EXAMPLESDIR}/XalanTransformerCallback
${INSTALL_DATA} \
${WRKSRC}/samples/XalanTransformerCallback/XalanTransformerCallback.cpp \
${WRKSRC}/samples/XalanTransformerCallback/foo.xml \
${WRKSRC}/samples/XalanTransformerCallback/foo.xsl \
${WRKSRC}/samples/XalanTransformerCallback/XalanTransformerCallback.cpp \
${EXAMPLESDIR}/XalanTransformerCallback/
${MKDIR} ${EXAMPLESDIR}/XPathWrapper
${INSTALL_DATA} \
${WRKSRC}/samples/XPathWrapper/foo.xml \
${WRKSRC}/samples/XPathWrapper/TestDriver.cpp \
${WRKSRC}/samples/XPathWrapper/XPathWrapper.cpp \
${WRKSRC}/samples/XPathWrapper/XPathWrapper.hpp \
${EXAMPLESDIR}/XPathWrapper/

View file

@ -1,4 +1,4 @@
MD5 (Xalan-C_1_8_0-src.tar.gz) = fca5101f56608311f8121591f022bc2c
SIZE (Xalan-C_1_8_0-src.tar.gz) = 1351965
MD5 (Xalan-C_1_8_0-docs.tar.gz) = 3bbd4eff456e7051879558d04db9fa4d
SIZE (Xalan-C_1_8_0-docs.tar.gz) = 8743423
MD5 (Xalan-C_1_9_0-src.tar.gz) = 1c4a91098c1f1823725b4032c18ad630
SIZE (Xalan-C_1_9_0-src.tar.gz) = 1513545
MD5 (Xalan-C_1_9_0-docs.tar.gz) = c3958563bb916ae870025183e11d1087
SIZE (Xalan-C_1_9_0-docs.tar.gz) = 9594865

View file

@ -1,12 +1,112 @@
Xalan-C CVS: xml-xalan/c/src/xalanc/PlatformSupport/XalanArrayAllocator.hpp?r1=1.6&r2=1.7
--- src/xalanc/PlatformSupport/XalanArrayAllocator.hpp.orig Mon Dec 13 21:34:54 2004
+++ src/xalanc/PlatformSupport/XalanArrayAllocator.hpp Mon Dec 13 21:35:22 2004
@@ -170,7 +170,7 @@
ListEntryType& theNewEntry = m_list.back();
--- ./src/xalanc/ICUBridge/ICUFormatNumberFunctor.hpp.orig Sat Mar 5 17:46:13 2005
+++ ./src/xalanc/ICUBridge/ICUFormatNumberFunctor.hpp Sat Mar 5 17:46:23 2005
@@ -120,6 +120,8 @@ struct DecimalFormatCacheStruct
private:
// Resize the vector to the appropriate size...
- theNewEntry.second.resize(theBlockSize, VectorType::value_type(0));
+ theNewEntry.second.resize(theBlockSize, value_type(0));
DecimalFormatCacheStruct();
+
+public:
DecimalFormatCacheStruct(const DecimalFormatCacheStruct& other);
};
--- ./src/xalanc/TestXSLT/process.cpp.orig Sat Dec 25 10:53:35 2004
+++ ./src/xalanc/TestXSLT/process.cpp Sat Dec 25 12:05:48 2004
@@ -628,7 +628,7 @@
}
else if(FormatterListener::OUTPUT_METHOD_TEXT == outputType)
{
- formatter = new FormatterToText( theManager, resultWriter, mimeEncoding);
+ formatter = new FormatterToText( resultWriter, mimeEncoding, true, true, theManager);
}
else if(FormatterListener::OUTPUT_METHOD_HTML == outputType)
{
@@ -656,14 +656,15 @@
FormatterToHTML* const fToHTML =
new FormatterToHTML(
- theManager,
resultWriter,
mimeEncoding,
mediatype,
doctypeSystem,
doctypePublic,
outputIndent,
- indentAmount);
+ indentAmount,
+ true, false,
+ theManager);
fToHTML->setPrefixResolver(&prefixResolver);
--- ./src/xalanc/XMLSupport/FormatterToText.hpp.orig Sat Dec 25 10:50:53 2004
+++ ./src/xalanc/XMLSupport/FormatterToText.hpp Sat Dec 25 10:50:57 2004
@@ -221,7 +221,9 @@
private:
// These are not implemented.
+#if 0
FormatterToText(const FormatterToText&);
+#endif
FormatterToText&
operator=(const FormatterToText&);
--- ./src/xalanc/XPath/ElementPrefixResolverProxy.hpp.orig Sat Dec 25 09:51:20 2004
+++ ./src/xalanc/XPath/ElementPrefixResolverProxy.hpp Sat Dec 25 09:51:28 2004
@@ -86,7 +86,9 @@
private:
//notimplemented
+#if 0
ElementPrefixResolverProxy(const ElementPrefixResolverProxy&);
+#endif
const XalanElement* const m_namespaceContext;
--- ./src/xalanc/XPath/NameSpace.hpp.orig Sat Dec 25 10:17:01 2004
+++ ./src/xalanc/XPath/NameSpace.hpp Sat Dec 25 10:17:15 2004
@@ -191,7 +191,9 @@
}
private:
+#if 0
NameSpace(const NameSpace&);
+#endif
XalanDOMString m_prefix;
--- ./src/xalanc/XPath/XalanQNameByValue.hpp.orig Sat Dec 25 10:30:57 2004
+++ ./src/xalanc/XPath/XalanQNameByValue.hpp Sat Dec 25 10:31:09 2004
@@ -290,7 +290,9 @@
private:
// not implemented
+#if 0
XalanQNameByValue(const XalanQNameByValue& theSource);
+#endif
void
initialize(
const XalanDOMChar* qname,
--- ./src/xalanc/XSLT/FunctionSystemProperty.hpp.orig Sat Dec 25 10:29:12 2004
+++ ./src/xalanc/XSLT/FunctionSystemProperty.hpp Sat Dec 25 10:30:13 2004
@@ -73,7 +73,9 @@
private:
+#if 0
FunctionSystemProperty(const FunctionSystemProperty&);
+#endif
// Not implemented...
FunctionSystemProperty&
--- ./src/xalanc/XSLT/TopLevelArg.hpp.orig Sat Dec 25 10:26:41 2004
+++ ./src/xalanc/XSLT/TopLevelArg.hpp Sat Dec 25 10:27:01 2004
@@ -147,7 +147,9 @@
private:
// not implemented
+#if 0
TopLevelArg(const TopLevelArg& theSource);
+#endif
XalanQNameByValue m_qname;
// Set the number of free spaces accordingly...
theNewEntry.first = theBlockSize - theCount;

View file

@ -1,6 +1,6 @@
--- src/xalanc/Makefile.in.orig Mon Dec 13 22:00:00 2004
+++ src/xalanc/Makefile.in Mon Dec 13 22:01:57 2004
@@ -253,7 +253,7 @@
--- src/xalanc/Makefile.in.orig Mon Mar 7 17:31:00 2005
+++ src/xalanc/Makefile.in Mon Mar 7 17:31:57 2005
@@ -259,22 +259,10 @@ endif ## OS390
$(MKINSTALLDIRS) $(DESTDIR)/$(includedir)/xalanc
for hdir in $(ALL_HEADERS_DIRS); do \
$(MKINSTALLDIRS) $(DESTDIR)/$(includedir)/xalanc/$$hdir; \
@ -9,3 +9,18 @@
$(DESTDIR)/$(includedir)/xalanc/$$hdir \
2> /dev/null; \
done
-ifdef XALAN_USE_ICU
- $(INSTALL_PROGRAM) $(ICUROOT)/lib/$(ICU_LIBI18N_LIB) \
- $(DESTDIR)/$(libdir)
- ifneq ($PLATFORM), OS390)
- rm -f $(DESTIDR)/$(libdir)/$(ICU_LIBI18N_LINK_NAME) && \
- $(LN) -fs $(ICU_LIBI18N_LIB) \
- $(DESTDIR)/$(libdir)/$(ICU_LIBI18N_LINK_NAME)
- rm -f $(DESTDIR)/$(libdir)/$(ICU_LIBI18N_SO_NAME) && \
- $(LN) -fs $(ICU_LIBI18N_LIB) \
- $(DESTDIR)/$(libdir)/$(ICU_LIBI18N_SO_NAME)
- endif ## OS390
-endif
clean: prepare doClean

View file

@ -7,12 +7,15 @@ include/xalanc/DOMSupport/DOMSupportInit.hpp
include/xalanc/DOMSupport/TreeWalker.hpp
include/xalanc/DOMSupport/XalanDocumentPrefixResolver.hpp
include/xalanc/DOMSupport/XalanNamespacesStack.hpp
%%ICUDEP%%include/xalanc/ICUBridge/FunctionICUFormatNumber.hpp
include/xalanc/Harness/XalanFileUtility.hpp
include/xalanc/Harness/XalanHarnessDefinitions.hpp
include/xalanc/Harness/XalanXMLFileReporter.hpp
%%ICUDEP%%include/xalanc/ICUBridge/ICUBridge.hpp
%%ICUDEP%%include/xalanc/ICUBridge/ICUBridgeCleanup.hpp
%%ICUDEP%%include/xalanc/ICUBridge/ICUBridgeCollationCompareFunctor.hpp
%%ICUDEP%%include/xalanc/ICUBridge/ICUBridgeCollationCompareFunctorImpl.hpp
%%ICUDEP%%include/xalanc/ICUBridge/ICUBridgeDefinitions.hpp
%%ICUDEP%%include/xalanc/ICUBridge/ICUFormatNumberFunctor.hpp
%%ICUDEP%%include/xalanc/ICUBridge/ICUXalanNumberFormatFactory.hpp
%%ICUDEP%%include/xalanc/ICUBridge/ICUXalanNumberFormatProxy.hpp
include/xalanc/Include/AIXDefinitions.hpp
@ -27,12 +30,22 @@ include/xalanc/Include/STLHelper.hpp
include/xalanc/Include/SolarisDefinitions.hpp
include/xalanc/Include/TRU64Definitions.hpp
include/xalanc/Include/VCPPDefinitions.hpp
include/xalanc/Include/XalanArrayKeyMap.hpp
include/xalanc/Include/XalanAutoPtr.hpp
include/xalanc/Include/XalanDeque.hpp
include/xalanc/Include/XalanList.hpp
include/xalanc/Include/XalanMap.hpp
include/xalanc/Include/XalanSet.hpp
include/xalanc/Include/XalanMemMgrAutoPtr.hpp
include/xalanc/Include/XalanMemMgrHelper.hpp
include/xalanc/Include/XalanMemMngArrayAllocate.hpp
include/xalanc/Include/XalanMemoryManagement.hpp
include/xalanc/Include/XalanObjectCache.hpp
include/xalanc/Include/XalanObjectStackCache.hpp
include/xalanc/Include/XalanVector.hpp
include/xalanc/Include/XalanVersion.hpp
include/xalanc/PlatformSupport/ArenaAllocator.hpp
include/xalanc/PlatformSupport/ArenaBlock.hpp
include/xalanc/PlatformSupport/ArenaBlockBase.hpp
include/xalanc/PlatformSupport/AttributeListImpl.hpp
include/xalanc/PlatformSupport/AttributeVectorEntry.hpp
include/xalanc/PlatformSupport/AttributeVectorEntryExtended.hpp
@ -66,6 +79,7 @@ include/xalanc/PlatformSupport/XalanDOMStringAllocator.hpp
include/xalanc/PlatformSupport/XalanDOMStringCache.hpp
include/xalanc/PlatformSupport/XalanDOMStringHashTable.hpp
include/xalanc/PlatformSupport/XalanDOMStringPool.hpp
include/xalanc/PlatformSupport/XalanDOMStringReusableAllocator.hpp
include/xalanc/PlatformSupport/XalanDecimalFormatSymbols.hpp
include/xalanc/PlatformSupport/XalanEncodingPropertyCache.hpp
include/xalanc/PlatformSupport/XalanFStreamOutputStream.hpp
@ -295,6 +309,8 @@ include/xalanc/XSLT/XalanElemTextAllocator.hpp
include/xalanc/XSLT/XalanElemTextLiteralAllocator.hpp
include/xalanc/XSLT/XalanElemValueOfAllocator.hpp
include/xalanc/XSLT/XalanElemVariableAllocator.hpp
include/xalanc/XSLT/XalanMatchPatternData.hpp
include/xalanc/XSLT/XalanMatchPatternDataAllocator.hpp
include/xalanc/XSLT/XalanNumberingResourceBundle.hpp
include/xalanc/XSLT/XalanSourceTreeDocumentAllocator.hpp
include/xalanc/XSLT/XalanSourceTreeDocumentFragmentAllocator.hpp
@ -442,9 +458,11 @@ include/xalanc/XercesParserLiaison/XercesTextWrapper.hpp
include/xalanc/XercesParserLiaison/XercesTextWrapperAllocator.hpp
include/xalanc/XercesParserLiaison/XercesWrapperHelper.hpp
include/xalanc/XercesParserLiaison/XercesWrapperNavigator.hpp
include/xalanc/XercesParserLiaison/XercesWrapperNavigatorAllocator.hpp
include/xalanc/XercesParserLiaison/XercesWrapperToXalanNodeMap.hpp
include/xalanc/XercesParserLiaison/XercesWrapperTypes.hpp
@dirrm include/xalanc/DOMSupport
@dirrm include/xalanc/Harness
%%ICUDEP%%@dirrm include/xalanc/ICUBridge
@dirrm include/xalanc/Include
@dirrm include/xalanc/PlatformSupport
@ -501,53 +519,54 @@ lib/%%XALANC_LIB%%
@comment
@comment SAMPLE SRC
@comment
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransformerCallback/XalanTransformerCallback.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransformerCallback/foo.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransformerCallback/foo.xsl
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransformerCallback/XalanTransformerCallback.cpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/XalanTransformerCallback
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransform/XalanTransform.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransform/foo.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransform/foo.xsl
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransform/XalanTransform.cpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/XalanTransform
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/foo.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/TestDriver.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/XPathWrapper.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/XPathWrapper.hpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/foo.xml
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/XPathWrapper
%%NO_SAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/UseStylesheetParam.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/foo.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/foo.xsl
%%NO_SAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/UseStylesheetParam.cpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/UseStylesheetParam
%%NO_SAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/TransformToXercesDOM.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/birds.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/birds.xsl
%%NO_SAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/TransformToXercesDOM.cpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/TransformToXercesDOM
%%NO_SAMPLES%%%%EXAMPLESDIR%%/TraceListen/TraceListen.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/TraceListen/birds.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/TraceListen/birds.xsl
%%NO_SAMPLES%%%%EXAMPLESDIR%%/TraceListen/TraceListen.cpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/TraceListen
%%NO_SAMPLES%%%%EXAMPLESDIR%%/ThreadSafe/ThreadSafe.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/ThreadSafe/birds.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/ThreadSafe/birds.xsl
%%NO_SAMPLES%%%%EXAMPLESDIR%%/ThreadSafe/ThreadSafe.cpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/ThreadSafe
%%NO_SAMPLES%%%%EXAMPLESDIR%%/StreamTransform/StreamTransform.cpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/StreamTransform
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleXPathCAPI/SimpleXPathCAPI.c
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleXPathCAPI/foo.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleXPathCAPI/SimpleXPathCAPI.c
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/SimpleXPathCAPI
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleXPathAPI/SimpleXPathAPI.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleXPathAPI/foo.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleXPathAPI/SimpleXPathAPI.cpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/SimpleXPathAPI
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/SimpleTransform.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/foo.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/foo.xsl
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/SimpleTransform.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/XalanMemoryManagerImpl.hpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/SimpleTransform
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SerializeNodeSet/SerializeNodeSet.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SerializeNodeSet/foo.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/SerializeNodeSet/SerializeNodeSet.cpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/SerializeNodeSet
%%NO_SAMPLES%%%%EXAMPLESDIR%%/ParsedSourceWrappers/ParsedSourceWrappers.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/ParsedSourceWrappers/foo.xml
%%NO_SAMPLES%%%%EXAMPLESDIR%%/ParsedSourceWrappers/foo.xsl
%%NO_SAMPLES%%%%EXAMPLESDIR%%/ParsedSourceWrappers/ParsedSourceWrappers.cpp
%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/ParsedSourceWrappers
%%NO_SAMPLES%%%%EXAMPLESDIR%%/ExternalFunction/ExternalFunction.cpp
%%NO_SAMPLES%%%%EXAMPLESDIR%%/ExternalFunction/foo.xml