- Remove science/netcdf-ftn, science/netcdf3-ftn and science/netcdf4
This commit is contained in:
parent
a98d36b558
commit
bfb61960db
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=352860
8 changed files with 0 additions and 240 deletions
|
@ -103,9 +103,6 @@
|
|||
SUBDIR += netcdf
|
||||
SUBDIR += netcdf-cxx
|
||||
SUBDIR += netcdf-fortran
|
||||
SUBDIR += netcdf-ftn
|
||||
SUBDIR += netcdf3-ftn
|
||||
SUBDIR += netcdf4
|
||||
SUBDIR += nifticlib
|
||||
SUBDIR += openbabel
|
||||
SUBDIR += openkim
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
# Created by: thierry@pompo.net
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= netcdf
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= NetCDF (network Common Data Form), with Fortran support
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../netcdf4
|
||||
|
||||
WITH_FORTRAN= yes
|
||||
|
||||
NO_STAGE= yes
|
||||
.include "${MASTERDIR}/Makefile"
|
|
@ -1,16 +0,0 @@
|
|||
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= netcdf
|
||||
PKGNAMESUFFIX= 3-ftn
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= NetCDF (network Common Data Form), with Fortran support
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../netcdf
|
||||
|
||||
WITH_FORTRAN= yes
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
|
@ -1,82 +0,0 @@
|
|||
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= netcdf
|
||||
PORTVERSION= 4.1.3
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
|
||||
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
|
||||
LOCAL/sunpoet
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT?= Library for machine-independent, array-oriented data access
|
||||
|
||||
CONFLICTS_INSTALL= hdf-4.[0-9]* netcdf-3.[0-9]* netcdf3-3.[0-9]*
|
||||
PORTSCOUT= limit:^4\.
|
||||
|
||||
OPTIONS_DEFINE= DAP FORTRAN SZIP
|
||||
DAP_DESC= Build DAP client and remote testing
|
||||
FORTRAN_DESC= Build library for Fortran
|
||||
SZIP_DESC= SZIP support (required if HDF5 was built with SZIP)
|
||||
|
||||
CONFIGURE_ARGS= --enable-cxx --enable-cxx-4 --enable-netcdf-4 --enable-shared \
|
||||
--with-hdf5=${LOCALBASE} --with-zlib=/usr
|
||||
CPPFLAGS+= -I${LOCALBASE}/include -fPIC -DPIC
|
||||
GNU_CONFIGURE= yes
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
LIB_DEPENDS= hdf5.7:${PORTSDIR}/science/hdf5-18
|
||||
MAKE_ENV= INFODIR="${PREFIX}/${INFO_PATH}" MAKEINFOFLAGS="--no-split"
|
||||
USE_LDCONFIG= yes
|
||||
USES= pathfix
|
||||
|
||||
INFO= netcdf netcdf-c netcdf-cxx netcdf-f77 netcdf-f90 \
|
||||
netcdf-install netcdf-tutorial
|
||||
MAN1= nccopy.1 ncdump.1 ncgen.1 ncgen3.1
|
||||
MAN3= netcdf.3
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MDAP}
|
||||
CONFIGURE_ARGS+=--enable-dap --with-curl=${LOCALBASE} \
|
||||
--with-curl-config=${LOCALBASE}/bin/curl-config
|
||||
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-dap
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MFORTRAN}
|
||||
CPPFLAGS+= -DpgiFortran
|
||||
CONFLICTS+= netcdf-4.*
|
||||
MAN3+= netcdf_f77.3 netcdf_f90.3
|
||||
PKGNAMESUFFIX+= -ftn
|
||||
PLIST_SUB+= FORTRAN=""
|
||||
USES+= fortran
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-f77 --disable-f90
|
||||
CONFLICTS+= netcdf-ftn-4.*
|
||||
PLIST_SUB+= FORTRAN="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MSZIP}
|
||||
CONFIGURE_ARGS+=--with-szlib=${LOCALBASE}
|
||||
LIB_DEPENDS+= sz.2:${PORTSDIR}/science/szip
|
||||
.endif
|
||||
|
||||
post-configure:
|
||||
@cd ${WRKSRC}/man4 && ${SETENV} ${MAKE_ENV} ${MAKE} maintainer-clean-aminfo
|
||||
.for i in ${INFO}
|
||||
@cd ${WRKSRC}/man4 && makeinfo --no-split ${i}.texi
|
||||
.endfor
|
||||
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
${MKDIR} ${DOCSDIR}/
|
||||
cd ${WRKSRC}/man4 && ${INSTALL_DATA} *.html *.pdf *.txt ${DOCSDIR}/
|
||||
.endif
|
||||
|
||||
regression-test test: build
|
||||
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (netcdf-4.1.3.tar.gz) = 44447a72711e2b75cb91c5a235dd6bcf2a6bddd0206614ccac83c1f47af02253
|
||||
SIZE (netcdf-4.1.3.tar.gz) = 11095305
|
|
@ -1,29 +0,0 @@
|
|||
--- cxx4/ncGroup.cpp.orig
|
||||
+++ cxx4/ncGroup.cpp
|
||||
@@ -218,7 +218,7 @@
|
||||
|
||||
// search in child groups of the children
|
||||
if(location == ChildrenOfChildrenGrps || location == AllChildrenGrps || location == AllGrps ) {
|
||||
- map<string,NcGroup>::iterator it;
|
||||
+ multimap<string,NcGroup>::iterator it;
|
||||
multimap<string,NcGroup> groups(getGroups(ChildrenGrps));
|
||||
for (it=groups.begin();it!=groups.end();it++) {
|
||||
multimap<string,NcGroup> childGroups(it->second.getGroups(AllChildrenGrps));
|
||||
@@ -1251,7 +1251,7 @@
|
||||
// search in current group and parent groups.
|
||||
NcGroup tmpGroup(*this);
|
||||
multimap<string,NcDim>::iterator itD;
|
||||
- map<string,NcVar>::iterator itV;
|
||||
+ multimap<string,NcVar>::iterator itV;
|
||||
while(1) {
|
||||
// get the collection of NcDim objects defined in this group.
|
||||
multimap<string,NcDim> dimTmp(tmpGroup.getDims());
|
||||
@@ -1289,7 +1289,7 @@
|
||||
// search in current group and parent groups.
|
||||
multimap<string,NcDim>::iterator itD;
|
||||
NcGroup tmpGroup(*this);
|
||||
- map<string,NcVar>::iterator itV;
|
||||
+ multimap<string,NcVar>::iterator itV;
|
||||
while(1) {
|
||||
// get the collection of NcDim objects defined in this group.
|
||||
multimap<string,NcDim> dimTmp(tmpGroup.getDims());
|
|
@ -1,9 +0,0 @@
|
|||
NetCDF (network Common Data Form) is an interface for array-oriented
|
||||
data access and a library that provides an implementation of the
|
||||
interface. The netCDF library also defines a machine-independent
|
||||
format for representing scientific data. Together, the interface,
|
||||
library, and format support the creation, access, and sharing of
|
||||
scientific data. The netCDF software was developed at the Unidata
|
||||
Program Center in Boulder, Colorado.
|
||||
|
||||
WWW: http://www.unidata.ucar.edu/software/netcdf/
|
|
@ -1,85 +0,0 @@
|
|||
bin/nc-config
|
||||
bin/nccopy
|
||||
bin/ncdump
|
||||
bin/ncgen
|
||||
bin/ncgen3
|
||||
include/ncAtt.h
|
||||
include/ncByte.h
|
||||
include/ncChar.h
|
||||
include/ncCheck.h
|
||||
include/ncCompoundType.h
|
||||
include/ncDim.h
|
||||
include/ncDouble.h
|
||||
include/ncEnumType.h
|
||||
include/ncException.h
|
||||
include/ncFile.h
|
||||
include/ncFloat.h
|
||||
include/ncGroup.h
|
||||
include/ncGroupAtt.h
|
||||
include/ncInt.h
|
||||
include/ncInt64.h
|
||||
include/ncOpaqueType.h
|
||||
include/ncShort.h
|
||||
include/ncString.h
|
||||
include/ncType.h
|
||||
include/ncUbyte.h
|
||||
include/ncUint.h
|
||||
include/ncUint64.h
|
||||
include/ncUshort.h
|
||||
include/ncVar.h
|
||||
include/ncVarAtt.h
|
||||
include/ncVlenType.h
|
||||
include/ncvalues.h
|
||||
include/netcdf
|
||||
include/netcdf.h
|
||||
include/netcdf.hh
|
||||
include/netcdfcpp.h
|
||||
%%FORTRAN%%include/netcdf.inc
|
||||
%%FORTRAN%%include/netcdf.mod
|
||||
%%FORTRAN%%include/typesizes.mod
|
||||
lib/libnetcdf.a
|
||||
lib/libnetcdf.la
|
||||
lib/libnetcdf.so
|
||||
lib/libnetcdf.so.7
|
||||
lib/libnetcdf_c++.a
|
||||
lib/libnetcdf_c++.la
|
||||
lib/libnetcdf_c++.so
|
||||
lib/libnetcdf_c++.so.4
|
||||
lib/libnetcdf_c++4.a
|
||||
lib/libnetcdf_c++4.la
|
||||
lib/libnetcdf_c++4.so
|
||||
lib/libnetcdf_c++4.so.1
|
||||
%%FORTRAN%%lib/libnetcdff.a
|
||||
%%FORTRAN%%lib/libnetcdff.la
|
||||
%%FORTRAN%%lib/libnetcdff.so
|
||||
%%FORTRAN%%lib/libnetcdff.so.5
|
||||
libdata/pkgconfig/netcdf.pc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/nccopy-man-1.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ncdump-man-1.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ncgen-man-1.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ncgen3-man-1.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-man-3.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf_f77-man.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netcdf_f90-man.html
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue