- Convert from using EXTRACT_SUFX to USES=tar:tgz
- Allow to build on PowerPC - Do not try to append to MAKE_ENV, do not try to set REINPLACE_ARGS - Mute MKDIR's, move OPTIONS block where it's typically found - Reformat port description, kill EOL whitespace, and adjust WWW
This commit is contained in:
parent
d6b12505dc
commit
bfcb72208d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=396223
3 changed files with 21 additions and 21 deletions
|
@ -7,27 +7,26 @@ PORTREVISION= 4
|
||||||
CATEGORIES= net parallel
|
CATEGORIES= net parallel
|
||||||
MASTER_SITES= NL/pvm3 ftp://ftp.chg.ru/pub/prog/parallel/pvm3/
|
MASTER_SITES= NL/pvm3 ftp://ftp.chg.ru/pub/prog/parallel/pvm3/
|
||||||
DISTNAME= pvm${PORTVERSION}
|
DISTNAME= pvm${PORTVERSION}
|
||||||
EXTRACT_SUFX= .tgz
|
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
MAINTAINER= ports@FreeBSD.org
|
||||||
COMMENT= Parallel Virtual Machine libraries and environment
|
COMMENT= Parallel Virtual Machine libraries and environment
|
||||||
|
|
||||||
LICENSE= MIT
|
LICENSE= MIT
|
||||||
|
|
||||||
OPTIONS_DEFINE= X11
|
USES= tar:tgz
|
||||||
OPTIONS_DEFAULT=X11
|
|
||||||
OPTIONS_SUB= yes
|
|
||||||
X11_USE= XORG=x11,xaw,xt
|
|
||||||
|
|
||||||
USE_LDCONFIG= yes
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
WRKSRC= ${WRKDIR}/pvm3
|
WRKSRC= ${WRKDIR}/pvm3
|
||||||
MAKE_ENV+= PVM_ROOT=${WRKSRC} SHAREDLDFLAGS="-shared"
|
MAKE_ENV= PVM_ROOT=${WRKSRC} SHAREDLDFLAGS="-shared"
|
||||||
PVM_ROOT_REL= lib/pvm
|
PVM_ROOT_REL= lib/pvm
|
||||||
PVM_ROOT= ${PREFIX}/${PVM_ROOT_REL}
|
PVM_ROOT= ${PREFIX}/${PVM_ROOT_REL}
|
||||||
REINPLACE_ARGS= -i ""
|
|
||||||
SUB_FILES= pkg-message
|
SUB_FILES= pkg-message
|
||||||
NOT_FOR_ARCHS= powerpc
|
|
||||||
|
OPTIONS_DEFINE= X11
|
||||||
|
OPTIONS_DEFAULT= X11
|
||||||
|
OPTIONS_SUB= yes
|
||||||
|
|
||||||
|
X11_USE= XORG=x11,xaw,xt
|
||||||
|
|
||||||
.include <bsd.port.options.mk>
|
.include <bsd.port.options.mk>
|
||||||
|
|
||||||
|
@ -52,9 +51,9 @@ do-build:
|
||||||
EXTRACFLAGS="${CFLAGS} -fpic" shared)
|
EXTRACFLAGS="${CFLAGS} -fpic" shared)
|
||||||
|
|
||||||
do-install:
|
do-install:
|
||||||
${MKDIR} ${STAGEDIR}${PVM_ROOT}/lib/FREEBSD
|
@${MKDIR} ${STAGEDIR}${PVM_ROOT}/lib/FREEBSD
|
||||||
${MKDIR} ${STAGEDIR}${PVM_ROOT}/bin/FREEBSD
|
@${MKDIR} ${STAGEDIR}${PVM_ROOT}/bin/FREEBSD
|
||||||
${MKDIR} ${STAGEDIR}${PVM_ROOT}/conf
|
@${MKDIR} ${STAGEDIR}${PVM_ROOT}/conf
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/FREEBSD/* ${STAGEDIR}${PVM_ROOT}/bin/FREEBSD
|
${INSTALL_PROGRAM} ${WRKSRC}/bin/FREEBSD/* ${STAGEDIR}${PVM_ROOT}/bin/FREEBSD
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/lib/FREEBSD/pvmd3 ${STAGEDIR}${PVM_ROOT}/lib/FREEBSD
|
${INSTALL_PROGRAM} ${WRKSRC}/lib/FREEBSD/pvmd3 ${STAGEDIR}${PVM_ROOT}/lib/FREEBSD
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/lib/FREEBSD/pvm ${STAGEDIR}${PVM_ROOT}/lib/FREEBSD
|
${INSTALL_PROGRAM} ${WRKSRC}/lib/FREEBSD/pvm ${STAGEDIR}${PVM_ROOT}/lib/FREEBSD
|
||||||
|
|
|
@ -1,12 +1,13 @@
|
||||||
--- lib/pvmgetarch.orig 2007-11-29 21:17:02 UTC
|
--- lib/pvmgetarch.orig 2007-11-29 21:17:02 UTC
|
||||||
+++ lib/pvmgetarch
|
+++ lib/pvmgetarch
|
||||||
@@ -79,6 +79,10 @@ if [ -f /bin/uname -o -f /usr/bin/uname
|
@@ -79,6 +79,11 @@ if [ -f /bin/uname -o -f /usr/bin/uname
|
||||||
BSD/OS,i[3456]86 ) ARCH=BSD386 ;;
|
BSD/OS,i[3456]86 ) ARCH=BSD386 ;;
|
||||||
FreeBSD,i[3456]86 ) ARCH=FREEBSD ;;
|
FreeBSD,i[3456]86 ) ARCH=FREEBSD ;;
|
||||||
FreeBSD,alpha ) ARCH=FREEBSD ;;
|
FreeBSD,alpha ) ARCH=FREEBSD ;;
|
||||||
+ FreeBSD,arm* ) ARCH=FREEBSD ;;
|
+ FreeBSD,arm* ) ARCH=FREEBSD ;;
|
||||||
+ FreeBSD,amd64 ) ARCH=FREEBSD ;;
|
+ FreeBSD,amd64 ) ARCH=FREEBSD ;;
|
||||||
+ FreeBSD,ia64 ) ARCH=FREEBSD ;;
|
+ FreeBSD,ia64 ) ARCH=FREEBSD ;;
|
||||||
|
+ FreeBSD,powerpc ) ARCH=FREEBSD ;;
|
||||||
+ FreeBSD,sparc64 ) ARCH=FREEBSD ;;
|
+ FreeBSD,sparc64 ) ARCH=FREEBSD ;;
|
||||||
SUPER-UX,SX-3 ) ARCH=SX3 ;;
|
SUPER-UX,SX-3 ) ARCH=SX3 ;;
|
||||||
uts,* ) ARCH=UTS2 ;;
|
uts,* ) ARCH=UTS2 ;;
|
||||||
|
|
|
@ -1,12 +1,12 @@
|
||||||
PVM (Parallel Virtual Machine) is a portable message-passing programming
|
PVM (Parallel Virtual Machine) is a portable message-passing programming
|
||||||
system, designed to link separate host machines to form a virtual
|
system, designed to link separate host machines to form a virtual machine
|
||||||
machine which is a single, manageable computing resource.
|
which is a single, manageable computing resource.
|
||||||
|
|
||||||
The virtual machine can be composed of hosts of different architectures,
|
The virtual machine can be composed of hosts of different architectures,
|
||||||
located in physically remote locations. PVM applications can be composed of any
|
located in physically remote locations. PVM applications can be composed
|
||||||
number of separate processes, or components, written in a mixture of C,
|
of any number of separate processes, or components, written in a mixture
|
||||||
C++ and Fortran. The system is portable to a wide variety of
|
of C, C++, and Fortran. The system is portable to a wide variety of
|
||||||
architectures, including workstations, multiprocessors, supercomputers and
|
architectures, including workstations, multiprocessors, supercomputers,
|
||||||
PCs.
|
and PCs.
|
||||||
|
|
||||||
WWW: http://www.csm.ornl.gov/pvm/pvm_home.html
|
WWW: http://www.csm.ornl.gov/pvm/
|
||||||
|
|
Loading…
Reference in a new issue