- Take over maintainership

- Cleanup pkg-descr:
  * remove license/attribution is redundant with the corresponding section in
    the manpage
  * fmt -w 80
  * remove double spaces

- Import patchset [1]:
  * Added -fetch and -store options to access cutbuffers
    Code clean-up to get rid of compilation warnings
  * Added -focus option
  * Correctly escape dashes in the manpage
  * Add operations to raise (without mapping) or lower a window, and toggle or
    circulate stacking
  * Add an -property option to specify something different than the name of the
    window to use
  * Add an -print command to print the windows geometry and name
  * Add an -all alias to -names ''
  * Document new functions in manpage

Obtained from:  debian [1]
This commit is contained in:
Emanuel Haupt 2010-05-12 17:36:04 +00:00
parent ec29a59ec3
commit bfd0eb9a4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=254210
4 changed files with 22 additions and 50 deletions

View file

@ -1,23 +1,27 @@
# New ports collection makefile for: xwit
# Date created: 15 June 1998
# Whom: Thomas Gellekum <tg@FreeBSD.org>
# New ports collection makefile for: xwit
# Date created: 15 June 1998
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= xwit
PORTVERSION= 3.4
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR = utilities
MASTER_SITES= XCONTRIB/utilities:source1 CRITICAL:source2
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}:source1 \
${PORTNAME}-patchset-${PORTVERSION}${EXTRACT_SUFX}:source2
MAINTAINER= ports@FreeBSD.org
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= X interface tool
USE_IMAKE= yes
USE_XORG= x11 xext
MAN1= xwit.1
PLIST_FILES= bin/xwit
EXTRA_PATCHES= ${WRKDIR}/${PORTNAME}-patchset-${PORTVERSION}/patch-*
.include <bsd.port.mk>

View file

@ -1,3 +1,6 @@
MD5 (xwit-3.4.tar.gz) = 627a2ff424ae5593be929f3def62dd1e
SHA256 (xwit-3.4.tar.gz) = d915a7f2f8809da41edcc7784c2618be3f8ce179d82d8ace6d27ba264332c729
SIZE (xwit-3.4.tar.gz) = 14536
MD5 (xwit-patchset-3.4.tar.gz) = 0d19e3bc9b054e2aeb2f522c0de090e4
SHA256 (xwit-patchset-3.4.tar.gz) = 24f295b6312cde2052e6f101e650b7972cbfc40777445f512e4a5734c5a59b9a
SIZE (xwit-patchset-3.4.tar.gz) = 11075

View file

@ -1,29 +0,0 @@
--- dsimple.c~ Thu Oct 19 00:59:17 1995
+++ dsimple.c Wed Jul 24 15:49:26 2002
@@ -5,6 +5,8 @@
#include <X11/Xutil.h>
#include <X11/cursorfont.h>
#include <stdio.h>
+#include <stdlib.h>
+
/*
* Other_stuff.h: Definitions of routines in other_stuff.
*
@@ -46,7 +48,7 @@
char *Malloc(size)
unsigned size;
{
- char *data, *malloc();
+ char *data;
if (!(data = malloc(size)))
Fatal_Error("Out of memory!");
@@ -62,7 +64,7 @@
char *ptr;
int size;
{
- char *new_ptr, *realloc();
+ char *new_ptr;
if (!ptr)
return(Malloc(size));

View file

@ -1,16 +1,10 @@
xwit ("x window interface tool") is a hotch-potch collection of simple
routines to call some of those X11 functions that don't already have any
utility commands built around them. The reasoning behind this is that
loosely every X function should be accessible from a shell script.
xwit ("x window interface tool") is a hotch-potch collection of simple routines
to call some of those X11 functions that don't already have any utility commands
built around them. The reasoning behind this is that loosely every X function
should be accessible from a shell script.
For example, XWarpPointer() will move the X pointer, but no utility program
exists to do so on those rare occasions when you could really use it. xwit
will also resize, iconify, pop, and move windows given by name or id,
change an icon, title or name, set the screen saver going, and change
individual key autorepeat settings.
The program is released into the public domain. Only the considerate
will leave credit for the authors.
Mark M Martin. mmm@cetia.fr dec 1993.
David DiGiacomo dd@mv.us.adobe.com
exists to do so on those rare occasions when you could really use it. xwit will
also resize, iconify, pop, and move windows given by name or id, change an icon,
title or name, set the screen saver going, and change individual key autorepeat
settings.