- Update to build20

This commit is contained in:
Dmitry Marakasov 2019-06-25 15:35:21 +00:00
parent d21e6b4878
commit bff4c8bc2b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=505093
6 changed files with 33 additions and 48 deletions

View file

@ -2,12 +2,10 @@
# $FreeBSD$
PORTNAME= widelands
DISTVERSION= build19
PORTREVISION= 18
DISTVERSION= build20
CATEGORIES= games
MASTER_SITES= https://launchpad.net/widelands/${DISTVERSION}/${DISTVERSION}/+download/ \
http://mirror.amdmi3.ru/distfiles/
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Realtime strategy game inspired by Settlers II
@ -27,7 +25,7 @@ CMAKE_ARGS= -DWL_INSTALL_BASEDIR="${PREFIX}" \
-DWL_VERSION="${DISTVERSION}" \
-DWL_OPTIMIZE_FLAGS=""
USE_GL= gl glew
USE_SDL= sdl2 mixer2 image2 net2 ttf2
USE_SDL= sdl2 mixer2 image2 ttf2
PORTDATA= *
PORTDOCS= *

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1494019260
SHA256 (widelands-build19-src.tar.bz2) = e511f9d26828a2b71b64cdfc6674e6e847543b2da73961ab882acca36c7c01a6
SIZE (widelands-build19-src.tar.bz2) = 181609391
TIMESTAMP = 1557150118
SHA256 (widelands-build20.tar.bz2) = 38594d98c74f357d4c31dd8ee2b056bfe921f42935935af915d11b792677bcb2
SIZE (widelands-build20.tar.bz2) = 232364340

View file

@ -1,26 +1,23 @@
--- CMakeLists.txt.orig 2016-11-10 07:28:01 UTC
--- CMakeLists.txt.orig 2019-05-02 05:23:39 UTC
+++ CMakeLists.txt
@@ -93,7 +93,7 @@ endif (NOT CMAKE_BUILD_TYPE OR CMAKE_BUILD_TYPE STREQU
if(CMAKE_BUILD_TYPE STREQUAL "Debug")
set(WL_DEBUG_FLAGS "-g -DDEBUG")
elseif(CMAKE_BUILD_TYPE STREQUAL "Release")
- set(WL_OPTIMIZE_FLAGS "-O3")
+ set(WL_OPTIMIZE_FLAGS "-O3" CACHE STRING "")
@@ -164,7 +164,6 @@ elseif(CMAKE_BUILD_TYPE STREQUAL "RelWithDebInfo")
set(WL_DEBUG_FLAGS "-DNDEBUG -DNOPARACHUTE")
elseif(CMAKE_BUILD_TYPE STREQUAL "RelWithDebInfo")
set(WL_OPTIMIZE_FLAGS "-O3")
@@ -179,8 +179,8 @@ endif()
# Turn some warnings into errors.
wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=format-security")
wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=return-type")
-wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=shadow")
-wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=uninitialized")
+wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Wshadow")
+wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Wuninitialized")
option(OPTION_ASAN "Build with AddressSanitizer" ON)
else()
- message(FATAL_ERROR "Unknown CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}")
endif()
IF (WIN32)
add_definitions(-DMINGW_HAS_SECURE_API)
@@ -225,7 +225,7 @@ if (NOT DEFINED WL_VERSION)
wl_add_flag(WL_GENERIC_CXX_FLAGS "-std=c++11")
@@ -181,7 +180,7 @@ endif(OPTION_ASAN)
# This is set to avoid linker errors when using GLVND-libs on Linux
if("${OpenGL_GL_PREFERENCE}" STREQUAL "GLVND")
- set (CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -lGL")
+ set (CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} ${OpenGL_GL_LIBRARY}")
add_compile_definitions(WL_USE_GLVND)
message(STATUS "Adding linker flags for GLVND.")
endif()
@@ -293,7 +292,7 @@ if (NOT DEFINED WL_VERSION)
else (NOT DEFINED WL_VERSION)
add_custom_target (
InputRevision ALL
@ -29,7 +26,7 @@
)
endif (NOT DEFINED WL_VERSION)
@@ -244,7 +244,7 @@ add_custom_target(_run_all_tests ALL
@@ -312,7 +311,7 @@ add_custom_target(_run_all_tests ALL
install (
FILES ${CMAKE_CURRENT_BINARY_DIR}/VERSION
@ -38,8 +35,11 @@
CONFIGURATIONS Debug;Release
COMPONENT CoreVersionFile
)
@@ -294,7 +294,7 @@ install(
COPYING
@@ -361,10 +360,9 @@ install(
install(
FILES
- COPYING
CREDITS
ChangeLog
- DESTINATION ${WL_INSTALL_BASEDIR}
@ -47,7 +47,7 @@
CONFIGURATIONS Debug;Release
COMPONENT CoreLicenseFiles
)
@@ -302,7 +302,7 @@ install(
@@ -372,7 +370,7 @@ install(
install(
DIRECTORY
doc

View file

@ -1,6 +1,6 @@
--- cmake/WlFunctions.cmake.orig 2016-11-10 07:28:01 UTC
--- cmake/WlFunctions.cmake.orig 2019-05-02 05:23:39 UTC
+++ cmake/WlFunctions.cmake
@@ -276,5 +276,5 @@ function(wl_binary NAME)
@@ -270,5 +270,5 @@ function(wl_binary NAME)
#Quoting the CMake documentation on DESTINATION:
#"If a relative path is given it is interpreted relative to the value of CMAKE_INSTALL_PREFIX"

View file

@ -1,13 +0,0 @@
https://bazaar.launchpad.net/~widelands-dev/widelands/trunk/revision/8641
--- src/graphic/text/bidi.h.orig 2016-11-10 07:28:01 UTC
+++ src/graphic/text/bidi.h
@@ -40,7 +40,7 @@ bool has_rtl_character(std::vector<std::string> input)
// True if a string contains a character from the script's code blocks
bool has_script_character(const char* input, UI::FontSets::Selector script);
UI::FontSet const* find_fontset(const char* word, const UI::FontSets& fontsets);
-std::string icustring2string(const UnicodeString& convertme);
+std::string icustring2string(const icu::UnicodeString& convertme);
std::string icuchar2string(const UChar& convertme);
bool cannot_start_line(const UChar& c);
bool cannot_end_line(const UChar& c);

View file

@ -1,14 +1,13 @@
bin/widelands
bin/wl_map_info
bin/wl_map_object_info
bin/wl_render_richtext
@dir %%DATADIR%%/maps/Archipelago_Sea.wmf/scripting
@dir %%DATADIR%%/maps/Atoll.wmf/scripting
@dir %%DATADIR%%/maps/Calvisson.wmf/scripting
@dir %%DATADIR%%/maps/Checkmate.wmf/scripting
@dir %%DATADIR%%/maps/Comet_Island_v2.wmf/scripting
@dir %%DATADIR%%/maps/Crater.wmf/scripting
@dir %%DATADIR%%/maps/Crossing_the_Horizon.wmf/scripting
@dir %%DATADIR%%/maps/Crossing_the_Horizon_v2.wmf/scripting
@dir %%DATADIR%%/maps/Desert_Tournament.wmf/scripting
@dir %%DATADIR%%/maps/Dolomites_v2.wmf/scripting
@dir %%DATADIR%%/maps/Elven_Forests.wmf/scripting
@ -49,3 +48,4 @@ bin/wl_render_richtext
@dir %%DATADIR%%/maps/Volcanic_Winter.wmf/scripting
@dir %%DATADIR%%/maps/Wideworld.wmf/scripting
@dir %%DATADIR%%/maps/Wisent_Valley.wmf/scripting
@dir %%DATADIR%%/tribes/buildings/markets/barbarians