add ggz-client-libs 0.0.7
The GGZ Gaming Zone - Core Client Libraries
This commit is contained in:
parent
ec12e9166c
commit
c00e6d0d8b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90674
6 changed files with 68 additions and 0 deletions
|
@ -118,6 +118,7 @@
|
|||
SUBDIR += gcompris
|
||||
SUBDIR += gcompris2
|
||||
SUBDIR += gemdropx
|
||||
SUBDIR += ggz-client-libs
|
||||
SUBDIR += gl-117
|
||||
SUBDIR += glasteroids
|
||||
SUBDIR += glchess
|
||||
|
|
34
games/ggz-client-libs/Makefile
Normal file
34
games/ggz-client-libs/Makefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: ggz-client-libs
|
||||
# Date created: Oct 8, 2002
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ggz-client-libs
|
||||
PORTVERSION= 0.0.7
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ggz
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= The GGZ Gaming Zone - Core Client Libraries
|
||||
|
||||
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
|
||||
expat.4:${PORTSDIR}/textproc/expat2 \
|
||||
ggz.1:${PORTSDIR}/games/libggz
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= \
|
||||
CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
CONFIGURE_ARGS= --disable-debug
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN3= ggzcore_h.3 ggzmod_h.3
|
||||
MAN5= ggz.modules.5
|
||||
MAN6= ggz-config.6
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/ggz-client-libs/distinfo
Normal file
1
games/ggz-client-libs/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (ggz-client-libs-0.0.7.tar.gz) = 8a9d10f1817b268ec629283a21664245
|
15
games/ggz-client-libs/files/patch-ltmain.sh
Normal file
15
games/ggz-client-libs/files/patch-ltmain.sh
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- ltmain.sh.orig Wed Oct 8 22:11:50 2003
|
||||
+++ ltmain.sh Wed Oct 8 22:12:05 2003
|
||||
@@ -4325,10 +4325,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false ; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
6
games/ggz-client-libs/pkg-descr
Normal file
6
games/ggz-client-libs/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
GGZ Gaming Zone core client libraries provides the common procedures
|
||||
and utilities required to run the GGZ client and games. The routines
|
||||
are shared by other modules in order to ease coding and promote
|
||||
compatibility and stability.
|
||||
|
||||
WWW: http://www.ggzgamingzone.org/
|
11
games/ggz-client-libs/pkg-plist
Normal file
11
games/ggz-client-libs/pkg-plist
Normal file
|
@ -0,0 +1,11 @@
|
|||
etc/ggz.modules
|
||||
bin/ggz-config
|
||||
include/ggzcore.h
|
||||
include/ggzmod.h
|
||||
include/ggzmod-ggz.h
|
||||
lib/libggzcore.a
|
||||
lib/libggzcore.so
|
||||
lib/libggzcore.so.3
|
||||
lib/libggzmod.a
|
||||
lib/libggzmod.so
|
||||
lib/libggzmod.so.1
|
Loading…
Reference in a new issue