games/cultivation: remove obsoleted port
This commit is contained in:
parent
c195218a48
commit
c03dd32be6
9 changed files with 1 additions and 206 deletions
1
MOVED
1
MOVED
|
@ -17131,3 +17131,4 @@ graphics/py-pyglet150|graphics/py-pyglet|2022-04-16|Has expired: No longer neede
|
|||
games/critterding||2022-04-16|Has expired: Abandonware with last release in 2013, newer version bundles depends and requires Qt4
|
||||
lang/gcc10-devel||2022-04-17|Has expired: Not serving its purpose any longer due to lack of maintenance
|
||||
devel/py-installer03|devel/py-installer|2022-04-17|Remove obsoleted port. Use devel/py-installer instead
|
||||
games/cultivation||2022-04-18|Has expired: Abandonware with last release in 2010, non-portable build system
|
||||
|
|
|
@ -1,56 +0,0 @@
|
|||
PORTNAME= cultivation
|
||||
PORTVERSION= 8
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/v${PORTVERSION}
|
||||
DISTNAME= Cultivation_${PORTVERSION}_UnixSource
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Unique game of conflict and cooperation in a gardening community
|
||||
|
||||
LIB_DEPENDS= libportaudio.so:audio/portaudio
|
||||
|
||||
BROKEN= does not start
|
||||
DEPRECATED= Abandonware with last release in 2010, non-portable build system
|
||||
EXPIRATION_DATE=2022-04-17
|
||||
|
||||
USES= gl gmake xorg
|
||||
USE_XORG= x11 xi xext xmu
|
||||
USE_GL= glut
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/game2
|
||||
BUILD_WRKSRC= ${WRKSRC}/gameSource
|
||||
MAKE_ARGS= CXX=${CXX}
|
||||
|
||||
EXTRA_PATCHES= ${FILESDIR}/portaudio19.patch:-p2
|
||||
|
||||
PLIST_FILES= bin/Cultivation
|
||||
PORTDATA= *
|
||||
PORTDOCS= changeLog.txt how_to_play.txt
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@cd ${WRKSRC} && ${CAT} Makefile.GnuLinux Makefile.common \
|
||||
../minorGems/build/Makefile.minorGems gameSource/Makefile.all \
|
||||
../minorGems/build/Makefile.minorGems_targets > gameSource/Makefile
|
||||
@${REINPLACE_CMD} -e 's|font\.tga|${DATADIR}/font.tga|; \
|
||||
s|language\.txt|${DATADIR}/language.txt|; \
|
||||
s|features\.txt|${DATADIR}/features.txt|' \
|
||||
${BUILD_WRKSRC}/game.cpp
|
||||
@${REINPLACE_CMD} -e 's|"languages"|"${DATADIR}/languages"|' \
|
||||
${WRKSRC}/../minorGems/util/TranslationManager.cpp
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/Cultivation ${STAGEDIR}${PREFIX}/bin
|
||||
${MKDIR} ${STAGEDIR}${DATADIR}/languages
|
||||
${INSTALL_DATA} ${BUILD_WRKSRC}/font.tga ${STAGEDIR}${DATADIR}
|
||||
${INSTALL_DATA} ${BUILD_WRKSRC}/features.txt ${STAGEDIR}${DATADIR}
|
||||
${INSTALL_DATA} ${BUILD_WRKSRC}/language.txt ${STAGEDIR}${DATADIR}
|
||||
${INSTALL_DATA} ${BUILD_WRKSRC}/languages/* ${STAGEDIR}${DATADIR}/languages
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/documentation/${f} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (Cultivation_8_UnixSource.tar.gz) = 001805c03711f0c32b99ed87cdd65f5ffa47b540bd9266ff5948801019ff7da3
|
||||
SIZE (Cultivation_8_UnixSource.tar.gz) = 1125886
|
|
@ -1,22 +0,0 @@
|
|||
--- Makefile.GnuLinux.orig Mon Apr 23 18:30:54 2007
|
||||
+++ Makefile.GnuLinux Tue Aug 14 01:57:08 2007
|
||||
@@ -15,16 +15,16 @@
|
||||
##
|
||||
|
||||
|
||||
-PLATFORM_COMPILE_FLAGS = -DLINUX
|
||||
+PLATFORM_COMPILE_FLAGS = ${CXXFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include -DLINUX
|
||||
|
||||
|
||||
# various GL and X windows librariesneeded for linux
|
||||
# also need portaudio library (which in turn needs pthreads)
|
||||
-PLATFORM_LINK_FLAGS = -L/usr/X11R6/lib -lGL -lglut -lGLU -lX11 ${PORT_AUDIO_PATH}/lib/libportaudio.a -lpthread
|
||||
+PLATFORM_LINK_FLAGS = -L${LOCALBASE}/lib -L${LOCALBASE}/lib -lGL -lglut -lGLU -lX11 -lXi -lXext -lXmu -pthread -lportaudio
|
||||
|
||||
|
||||
# All platforms but OSX support g++ and need no linker hacks
|
||||
-GXX = g++
|
||||
+GXX = ${CXX}
|
||||
LINK_FLAGS =
|
||||
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.common.orig Mon Apr 23 18:30:54 2007
|
||||
+++ Makefile.common Tue Aug 14 01:58:17 2007
|
||||
@@ -52,7 +52,7 @@
|
||||
|
||||
|
||||
|
||||
-COMPILE_FLAGS = -Wall ${DEBUG_FLAG} ${PLATFORM_COMPILE_FLAGS} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} -I${ROOT_PATH} -I${PORT_AUDIO_PATH}/pa_common
|
||||
+COMPILE_FLAGS = -Wall ${PLATFORM_COMPILE_FLAGS} -I${ROOT_PATH}
|
||||
|
||||
|
||||
COMPILE = ${GXX} ${COMPILE_FLAGS} -c
|
|
@ -1,10 +0,0 @@
|
|||
--- gameSource/sound/SoundEffectsBank.cpp.orig 2007-08-09 15:45:15 UTC
|
||||
+++ gameSource/sound/SoundEffectsBank.cpp
|
||||
@@ -10,6 +10,7 @@
|
||||
|
||||
#include "minorGems/util/random/StdRandomSource.h"
|
||||
|
||||
+#include <math.h>
|
||||
|
||||
extern int globalSoundSampleRate;
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
--- gameSource/sound/SoundPlayer.h.orig 2015-05-30 19:01:03 UTC
|
||||
+++ gameSource/sound/SoundPlayer.h
|
||||
@@ -52,9 +52,7 @@
|
||||
#include "SoundFilter.h"
|
||||
#include "PlayableSound.h"
|
||||
|
||||
-#include "minorGems/sound/portaudio/pa_common/portaudio.h"
|
||||
-#include "minorGems/sound/portaudio/pablio/pablio.h"
|
||||
-
|
||||
+#include <portaudio.h>
|
||||
|
||||
#include "minorGems/util/SimpleVector.h"
|
||||
|
|
@ -1,78 +0,0 @@
|
|||
Author: Barry deFreese <bdefreese@debian.org>
|
||||
Description: Patch system to utilize portaudio v19
|
||||
Bug-Debian: http://bugs.debian.org/594015
|
||||
Last-Update: 2013-06-01
|
||||
--- a/game2/gameSource/sound/SoundPlayer.h
|
||||
+++ b/game2/gameSource/sound/SoundPlayer.h
|
||||
@@ -239,7 +239,7 @@
|
||||
char mFadingIn;
|
||||
int mNumFadeFramesRemaining;
|
||||
|
||||
- PortAudioStream *mAudioStream;
|
||||
+ PaStream *mAudioStream;
|
||||
|
||||
// realtime sounds that should be mixed into the next to-speaker call
|
||||
SimpleVector<PlayableSound *> *mRealtimeSounds;
|
||||
--- a/game2/gameSource/sound/SoundPlayer.cpp
|
||||
+++ b/game2/gameSource/sound/SoundPlayer.cpp
|
||||
@@ -52,9 +52,11 @@
|
||||
|
||||
|
||||
// callback passed into portaudio
|
||||
-static int portaudioCallback( void *inputBuffer, void *outputBuffer,
|
||||
+int portaudioCallback( const void *inputBuffer, void *outputBuffer,
|
||||
unsigned long framesPerBuffer,
|
||||
- PaTimestamp outTime, void *userData ) {
|
||||
+ const PaStreamCallbackTimeInfo *outTime,
|
||||
+ PaStreamCallbackFlags statusFlags,
|
||||
+ void *userData ) {
|
||||
|
||||
|
||||
SoundPlayer *player = (SoundPlayer *)userData;
|
||||
@@ -157,21 +159,13 @@
|
||||
|
||||
if( error == paNoError ) {
|
||||
|
||||
- error = Pa_OpenStream(
|
||||
+ error = Pa_OpenDefaultStream(
|
||||
&mAudioStream,
|
||||
- paNoDevice,// default input device
|
||||
0, // no input
|
||||
- paFloat32, // 32 bit floating point input
|
||||
- NULL,
|
||||
- Pa_GetDefaultOutputDeviceID(),
|
||||
2, // stereo output
|
||||
paFloat32, // 32 bit floating point output
|
||||
- NULL,
|
||||
mSampleRate,
|
||||
1024, // frames per buffer
|
||||
- 0, // number of buffers, if zero then use default minimum
|
||||
- paClipOff, // we won't output out of range samples so
|
||||
- // don't bother clipping them
|
||||
portaudioCallback,
|
||||
(void *)this ); // pass self-pointer to callback function
|
||||
|
||||
--- a/game2/gameSource/sound/MusicPlayer.cpp
|
||||
+++ b/game2/gameSource/sound/MusicPlayer.cpp
|
||||
@@ -112,13 +112,14 @@
|
||||
|
||||
// get parts and positions of gardeners
|
||||
int numParts = 0;
|
||||
- Vector3D **positions =
|
||||
- globalWorld->getAllGardenerPositions( &numParts );
|
||||
- MusicPart **musicParts =
|
||||
- globalWorld->getAllGardenerMusicParts( &numParts );
|
||||
- double *volumeModifiers =
|
||||
- globalWorld->getAllGardenerMusicVolumeModifiers( &numParts );
|
||||
-
|
||||
+ Vector3D **positions = NULL;
|
||||
+ MusicPart **musicParts = NULL;
|
||||
+ double *volumeModifiers = NULL;
|
||||
+ if ( globalWorld ){
|
||||
+ positions = globalWorld->getAllGardenerPositions( &numParts );
|
||||
+ musicParts = globalWorld->getAllGardenerMusicParts( &numParts );
|
||||
+ volumeModifiers = globalWorld->getAllGardenerMusicVolumeModifiers( &numParts );
|
||||
+ }
|
||||
|
||||
// get center position from current player position
|
||||
Vector3D *centerPosition = new Vector3D( &globalPlayerCurrentPosition );
|
|
@ -1,14 +0,0 @@
|
|||
Cultivation is quite different from most other games. It is a social
|
||||
simulation, and the primary form of conflict is over land and plant
|
||||
resources---there is no shooting, but there are plenty of angry
|
||||
looks. It is also an evolution simulation. Within the world of
|
||||
Cultivation, you can explore a virtually infinite spectrum of
|
||||
different plant and gardener varieties.
|
||||
|
||||
All of the graphics, sounds, melodies,and other content in Cultivation
|
||||
are 100% procedurally generated at playtime. In other words, there
|
||||
are no hand-painted texture maps---instead, each object has a
|
||||
uniquely "grown" appearance. Every time you play, Cultivation
|
||||
generates fresh visuals, music, and behaviors.
|
||||
|
||||
WWW: http://cultivation.sourceforge.net/
|
Loading…
Reference in a new issue