Fix build with gcc4
This commit is contained in:
parent
5db0a7fbc0
commit
c05e6d2430
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=195086
2 changed files with 16 additions and 4 deletions
|
@ -28,10 +28,6 @@ DOCS_EN= CHANGES README STATUS TUTORIAL
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= Does not compile with GCC 4.2
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${RUBY_MODEXAMPLESDIR}
|
||||
|
|
16
textproc/ruby-xtemplate/files/patch-xt.c
Normal file
16
textproc/ruby-xtemplate/files/patch-xt.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- ext/xt.c.orig Wed May 30 19:05:12 2007
|
||||
+++ ext/xt.c Wed May 30 19:07:43 2007
|
||||
@@ -243,11 +243,12 @@
|
||||
return rb_funcall(children, i_collect, 0);
|
||||
}
|
||||
|
||||
+static VALUE rb_xt_xnode_deep_dup(int, VALUE[], VALUE);
|
||||
+
|
||||
static VALUE
|
||||
rb_xt_xnode_deep_dup_ii(VALUE child, VALUE data)
|
||||
{
|
||||
VALUE node = data;
|
||||
- static VALUE rb_xt_xnode_deep_dup(int, VALUE[], VALUE);
|
||||
|
||||
if( rb_obj_is_kind_of(child, rb_cXNode) ){
|
||||
VALUE argv[1] = {node};
|
Loading…
Reference in a new issue