NewPKI is a PKI based on the OpenSSL low-level API, all the datas are handled
through a database, which provides a much more flexible PKI than with OpenSSL, such as seeking a certificate with a search engine. PR: ports/83385 Submitted by: Vsevolod Stakhov <vsevolod@highsecure.ru>
This commit is contained in:
parent
319e8826c1
commit
c08970fbc3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=139201
7 changed files with 147 additions and 0 deletions
|
@ -227,6 +227,7 @@
|
|||
SUBDIR += nessus-plugins
|
||||
SUBDIR += nessus-plugins-devel
|
||||
SUBDIR += nettle
|
||||
SUBDIR += newpki-lib
|
||||
SUBDIR += nikto
|
||||
SUBDIR += nmap
|
||||
SUBDIR += nmapfe
|
||||
|
|
61
security/newpki-lib/Makefile
Normal file
61
security/newpki-lib/Makefile
Normal file
|
@ -0,0 +1,61 @@
|
|||
# New ports collection makefile for: newpki-lib
|
||||
# Date created: 2005-07-05
|
||||
# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= newpki-lib
|
||||
DISTVERSION= 2.0.0-beta4
|
||||
CATEGORIES= security devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= newpki
|
||||
|
||||
MAINTAINER= vsevolod@highsecure.ru
|
||||
COMMENT= C++ PKI libraries from newpki project
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-2.0.0
|
||||
|
||||
USE_OPENSSL= yes
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS+= --includedir=${PREFIX}/include/newpki
|
||||
|
||||
.if defined(WITHOUT_NLS)
|
||||
PLIST_SUB+= NLS="@comment "
|
||||
CONFIGURE_ARGS+= --disable-nls
|
||||
.else
|
||||
USE_GETTEXT= yes
|
||||
PLIST_SUB+= NLS=""
|
||||
CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
USE_GCC= 3.4
|
||||
USE_INC_LIBTOOL_VER= 15
|
||||
|
||||
patch-autotools:
|
||||
@(cd ${PATCH_WRKSRC}; \
|
||||
for file in ${LIBTOOLFILES}; do \
|
||||
${CP} $$file $$file.tmp; \
|
||||
${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
|
||||
$$file.tmp > $$file; \
|
||||
${RM} $$file.tmp; \
|
||||
done);
|
||||
|
||||
.else
|
||||
USE_LIBTOOL_VER= 15
|
||||
.endif
|
||||
|
||||
pre-patch:
|
||||
@${FIND} ${WRKSRC} -name '*.cpp' -or -name '*.h' | ${XARGS} ${REINPLACE_CMD} -e 's|
||g'
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
security/newpki-lib/distinfo
Normal file
2
security/newpki-lib/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (newpki-lib-2.0.0-beta4.tar.gz) = cdf2f2ba86670498f7c8506181de13a0
|
||||
SIZE (newpki-lib-2.0.0-beta4.tar.gz) = 622720
|
11
security/newpki-lib/files/patch-src_CriticalSection.cpp
Normal file
11
security/newpki-lib/files/patch-src_CriticalSection.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/CriticalSection.cpp.orig Tue Jul 5 03:01:18 2005
|
||||
+++ src/CriticalSection.cpp Tue Jul 5 03:01:33 2005
|
||||
@@ -43,7 +43,7 @@
|
||||
assert(hMutex != NULL);
|
||||
#else
|
||||
pthread_mutexattr_init(&recmutex);
|
||||
- pthread_mutexattr_settype(&recmutex, PTHREAD_MUTEX_RECURSIVE_NP);
|
||||
+ pthread_mutexattr_settype(&recmutex, PTHREAD_MUTEX_RECURSIVE);
|
||||
pthread_mutex_init(&lpCriticalSection, &recmutex);
|
||||
#endif
|
||||
#ifdef _DEBUG
|
11
security/newpki-lib/files/patch-src_mString.cpp
Normal file
11
security/newpki-lib/files/patch-src_mString.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/mString.cpp.orig Tue Jul 5 03:03:22 2005
|
||||
+++ src/mString.cpp Tue Jul 5 03:04:15 2005
|
||||
@@ -1223,7 +1223,7 @@
|
||||
outbuf = &dst[0];
|
||||
outbytesleft = dst.size();
|
||||
|
||||
- if (iconv(UTF8ToLoc, &inbuf, &inbytesleft,
|
||||
+ if (iconv(UTF8ToLoc, (const char **)&inbuf, &inbytesleft,
|
||||
&outbuf, &outbytesleft) == -1)
|
||||
{
|
||||
iconv_close(UTF8ToLoc);
|
5
security/newpki-lib/pkg-descr
Normal file
5
security/newpki-lib/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
NewPKI is a PKI based on the OpenSSL low-level API, all the datas are handled
|
||||
through a database, which provides a much more flexible PKI than with OpenSSL,
|
||||
such as seeking a certificate with a search engine.
|
||||
|
||||
WWW: http://www.newpki.org
|
56
security/newpki-lib/pkg-plist
Normal file
56
security/newpki-lib/pkg-plist
Normal file
|
@ -0,0 +1,56 @@
|
|||
include/newpki/ASN1/Asn1Backup.h
|
||||
include/newpki/ASN1/Asn1Cert.h
|
||||
include/newpki/ASN1/Asn1Conf.h
|
||||
include/newpki/ASN1/Asn1Entity.h
|
||||
include/newpki/ASN1/Asn1Err.h
|
||||
include/newpki/ASN1/Asn1HashVal.h
|
||||
include/newpki/ASN1/Asn1Helper.h
|
||||
include/newpki/ASN1/Asn1Logs.h
|
||||
include/newpki/ASN1/Asn1Req.h
|
||||
include/newpki/ASN1/Asn1Resp.h
|
||||
include/newpki/ASN1/Asn1User.h
|
||||
include/newpki/ASN1/NewPKIObject.h
|
||||
include/newpki/Connection.h
|
||||
include/newpki/CriticalSection.h
|
||||
include/newpki/ExceptionNewPKI.h
|
||||
include/newpki/FileLog.h
|
||||
include/newpki/HashCorrelation.h
|
||||
include/newpki/HashCorrelation_ASN1.h
|
||||
include/newpki/HashTable/HashTable_Dn.h
|
||||
include/newpki/HashTable/HashTable_String.h
|
||||
include/newpki/HashTable/PKI_HashTable.h
|
||||
include/newpki/NewPKI.h
|
||||
include/newpki/Objects.h
|
||||
include/newpki/PEM_DER.h
|
||||
include/newpki/PKI_AUTH_MOD.h
|
||||
include/newpki/PKI_CERT.h
|
||||
include/newpki/PKI_CRL.h
|
||||
include/newpki/PKI_CSR.h
|
||||
include/newpki/PKI_ERR.h
|
||||
include/newpki/PKI_EXT.h
|
||||
include/newpki/PKI_P7B.h
|
||||
include/newpki/PKI_PASSWD.h
|
||||
include/newpki/PKI_PKCS12.h
|
||||
include/newpki/PKI_PLUG_CA.h
|
||||
include/newpki/PKI_PLUG_PUB.h
|
||||
include/newpki/PKI_RSA.h
|
||||
include/newpki/PkiClient.h
|
||||
include/newpki/ReadersWriter.h
|
||||
include/newpki/Semaphore.h
|
||||
include/newpki/SessionsCache.h
|
||||
include/newpki/SslConnection.h
|
||||
include/newpki/SspiConnection.h
|
||||
include/newpki/UnixWinSock.h
|
||||
include/newpki/bio_ms_ssl.h
|
||||
include/newpki/config.h
|
||||
include/newpki/lbintl.h
|
||||
include/newpki/mString.h
|
||||
include/newpki/mVector.h
|
||||
include/newpki/newpki_threads.h
|
||||
lib/libnewpki.a
|
||||
lib/libnewpki.so
|
||||
lib/libnewpki.so.2
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/newpki-lib.mo
|
||||
@dirrm include/newpki/ASN1
|
||||
@dirrm include/newpki/HashTable
|
||||
@dirrm include/newpki
|
Loading…
Reference in a new issue