Update to 1.3.4.
This commit is contained in:
parent
3ea9b25be8
commit
c0949c6ec0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=74793
7 changed files with 55 additions and 43 deletions
|
@ -7,7 +7,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= g-wrap
|
||||
PORTVERSION= 1.1.11
|
||||
PORTVERSION= 1.3.4
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.gnucash.org/pub/g-wrap/source/ \
|
||||
http://people.freebsd.org/~sobomax/
|
||||
|
@ -19,6 +19,7 @@ LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile
|
|||
RUN_DEPENDS= ${LOCALBASE}/share/slib/require.scm:${PORTSDIR}/lang/slib
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_GMAKE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
MAKE_ENV= GUILE_LOAD_PATH=${WRKSRC}
|
||||
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (g-wrap-1.1.11.tar.gz) = 50cd195d85ec72723c64d14c5e6a0437
|
||||
MD5 (g-wrap-1.3.4.tar.gz) = bf29b8b563cc27d9f7fd90a6243653aa
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- Makefile.in.orig Sun Jun 9 02:32:28 2002
|
||||
+++ Makefile.in Sun Jun 9 02:32:32 2002
|
||||
@@ -86,7 +86,7 @@
|
||||
RS_LTLIB_TARGET = @RS_LTLIB_TARGET@
|
||||
RS_SCRIPT = @RS_SCRIPT@
|
||||
VERSION = @VERSION@
|
||||
-SUBDIRS = doc rpm bin libruntime-guile libruntime-rscheme g-wrap g-wrapped example stale test
|
||||
+SUBDIRS = doc rpm bin libruntime-guile libruntime-rscheme g-wrap g-wrapped example stale
|
||||
--- Makefile.in.orig Thu Nov 7 23:40:46 2002
|
||||
+++ Makefile.in Tue Feb 4 20:43:51 2003
|
||||
@@ -144,7 +144,7 @@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-SUBDIRS = doc rpm bin g-wrap example test
|
||||
+SUBDIRS = doc rpm bin g-wrap example
|
||||
|
||||
guilemoduledir = @GUILEMODDIR@
|
||||
guilemodule_DATA = @GUILEMOD_TARGET@
|
||||
|
|
|
@ -11,12 +11,3 @@ $FreeBSD$
|
|||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
@@ -5196,7 +5197,7 @@
|
||||
fi
|
||||
|
||||
# Extract the first word of "rs", so it can be a program name with args.
|
||||
-set dummy rs; ac_word=$2
|
||||
+set dummy rscheme; ac_word=$2
|
||||
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
||||
echo "configure:5202: checking for $ac_word" >&5
|
||||
if eval "test \"`echo '$''{'ac_cv_path_RSCHEME'+set}'`\" = set"; then
|
||||
|
|
11
devel/g-wrap/files/patch-g-wrap_Makefile.in
Normal file
11
devel/g-wrap/files/patch-g-wrap_Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- g-wrap/Makefile.in.orig Tue Feb 4 20:45:49 2003
|
||||
+++ g-wrap/Makefile.in Tue Feb 4 20:46:00 2003
|
||||
@@ -197,7 +197,7 @@
|
||||
|
||||
|
||||
#AM_CFLAGS = -O2 -g -Wall -Wno-uninitialized -Werror
|
||||
-AM_CFLAGS = -O2 -g -Wall -Werror \
|
||||
+AM_CFLAGS = -Wall -Werror \
|
||||
${GW_GLIB_CFLAGS_ADD} \
|
||||
${GW_GUILE_GTK_CFLAGS_ADD}
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- g-wrapped/Makefile.in.orig Thu Jul 26 02:30:32 2001
|
||||
+++ g-wrapped/Makefile.in Sat Aug 17 23:57:39 2002
|
||||
@@ -103,7 +103,7 @@
|
||||
|
||||
#BEGIN TEMP JUNK ============================================================
|
||||
|
||||
-CFLAGS = -O2 -Wall -g -I../libruntime-guile @CFLAGS@
|
||||
+CFLAGS = -Wall -I../libruntime-guile @CFLAGS@
|
||||
|
||||
#I believe libtool won't allow this yet.
|
||||
#EXTRA_LTLIBRARIES=libruntime.la
|
|
@ -1,20 +1,43 @@
|
|||
bin/g-wrap-config
|
||||
include/g-wrap-runtime-guile.h
|
||||
include/g-wrap/g-wrap-compatibility.h
|
||||
include/g-wrap/g-wrap-glib.h
|
||||
include/g-wrap/g-wrap-wct.h
|
||||
info/g-wrap.info
|
||||
info/g-wrap.info-1
|
||||
info/g-wrap.info-2
|
||||
lib/libg-wrap-runtime-guile.a
|
||||
lib/libg-wrap-runtime-guile.so
|
||||
lib/libg-wrap-runtime-guile.so.2
|
||||
lib/libgw-glib.a
|
||||
lib/libgw-glib.so
|
||||
lib/libgw-glib.so.0
|
||||
lib/libgw-gtk.a
|
||||
lib/libgw-gtk.so
|
||||
lib/libgw-gtk.so.0
|
||||
lib/libgw-standard.a
|
||||
lib/libgw-standard.so
|
||||
lib/libgw-standard.so.0
|
||||
lib/libgw-wct.a
|
||||
lib/libgw-wct.so
|
||||
lib/libgw-wct.so.0
|
||||
lib/libgwrap-glib.a
|
||||
lib/libgwrap-glib.so
|
||||
lib/libgwrap-glib.so.1
|
||||
lib/libgwrap-wct.a
|
||||
lib/libgwrap-wct.so
|
||||
lib/libgwrap-wct.so.1
|
||||
share/aclocal/g-wrap.m4
|
||||
share/guile/g-wrap.scm
|
||||
share/guile/g-wrap/enumeration.scm
|
||||
share/guile/g-wrap/g-translate.scm
|
||||
share/guile/g-wrap/guile-types.scm
|
||||
share/guile/g-wrap/gtkobj.scm
|
||||
share/guile/g-wrap/gw-glib-spec.scm
|
||||
share/guile/g-wrap/gw-glib.scm
|
||||
share/guile/g-wrap/gw-gtk-spec.scm
|
||||
share/guile/g-wrap/gw-gtk.scm
|
||||
share/guile/g-wrap/gw-standard-spec.scm
|
||||
share/guile/g-wrap/gw-standard.scm
|
||||
share/guile/g-wrap/gw-wct-spec.scm
|
||||
share/guile/g-wrap/gw-wct.scm
|
||||
share/guile/g-wrap/output-file.scm
|
||||
share/guile/g-wrap/runtime.scm
|
||||
share/guile/g-wrap/simple-type.scm
|
||||
share/guile/g-wrap/sorting.scm
|
||||
share/guile/g-wrapped/gw-runtime-spec.scm
|
||||
share/guile/g-wrapped/libgw-runtime.a
|
||||
share/guile/g-wrapped/libgw-runtime.so
|
||||
share/guile/g-wrapped/libgw-runtime.so.0
|
||||
@dirrm share/guile/g-wrapped
|
||||
@dirrm share/guile/g-wrap
|
||||
|
|
Loading…
Reference in a new issue