Upgrade to 0.8.11.

Requested by:	miwi@
This commit is contained in:
Vanilla I. Shu 2007-04-26 10:05:46 +00:00
parent ca37cc32c5
commit c0b2bc1523
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=190911
8 changed files with 18 additions and 189 deletions

View file

@ -6,8 +6,8 @@
#
PORTNAME= irssi
PORTVERSION= 0.8.10
PORTREVISION?= 3
PORTVERSION= 0.8.11
PORTREVISION?= 0
CATEGORIES?= irc
MASTER_SITES= http://mirror.irssi.org/

View file

@ -1,3 +1,3 @@
MD5 (irssi-0.8.10.tar.bz2) = 4b83d4047670eb75bd14ae1bdd68dc38
SHA256 (irssi-0.8.10.tar.bz2) = 47344b444d78ad5965eb40cc4c8df8450fdc54135e2b058710ee8c500b958d6c
SIZE (irssi-0.8.10.tar.bz2) = 933152
MD5 (irssi-0.8.11.tar.bz2) = b62417fb3dba9e36eaebea0410a67cd3
SHA256 (irssi-0.8.11.tar.bz2) = 425cf24f13bfda05c6a468523cd2874d05675ea1bc4e37a8c284f2f78c2dd6b2
SIZE (irssi-0.8.11.tar.bz2) = 933075

View file

@ -0,0 +1,11 @@
--- docs/Makefile.in.orig Thu Apr 26 02:15:07 2007
+++ docs/Makefile.in Thu Apr 26 17:58:07 2007
@@ -54,7 +54,7 @@
install-recursive installcheck-recursive installdirs-recursive \
pdf-recursive ps-recursive uninstall-info-recursive \
uninstall-recursive
-man1dir = $(mandir)/man1
+man1dir = $(prefix)/man/man1
am__installdirs = "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(docdir)"
NROFF = nroff
MANS = $(man_MANS)

View file

@ -1,10 +0,0 @@
--- src/fe-text/gui-entry.h.orig Sun Jan 15 05:08:57 2006
+++ src/fe-text/gui-entry.h Sun Jan 15 05:09:04 2006
@@ -34,6 +34,7 @@
void gui_entry_set_text(GUI_ENTRY_REC *entry, const char *str);
char *gui_entry_get_text(GUI_ENTRY_REC *entry);
+char *gui_entry_get_text_and_pos(GUI_ENTRY_REC *entry, int *pos);
void gui_entry_insert_text(GUI_ENTRY_REC *entry, const char *str);
void gui_entry_insert_char(GUI_ENTRY_REC *entry, unichar chr);

View file

@ -1,12 +0,0 @@
--- src/irc/dcc/dcc.c.orig Fri Dec 9 01:32:48 2005
+++ src/irc/dcc/dcc.c Thu May 4 13:39:02 2006
@@ -58,8 +58,8 @@
pos = gslist_find_string(dcc_types, type);
if (pos != NULL) {
- dcc_types = g_slist_remove(dcc_types, pos->data);
g_free(pos->data);
+ dcc_types = g_slist_remove(dcc_types, pos->data);
}
}

View file

@ -1,121 +0,0 @@
--- src/fe-common/core/utf8.h.orig Fri Dec 9 01:32:44 2005
+++ src/fe-common/core/utf8.h Mon Dec 12 12:13:50 2005
@@ -18,6 +18,10 @@
Make sure out is at least 6 x length of str. */
void utf16_to_utf8(const unichar *str, char *out);
+/* unichar -> UTF-8 string with position transformed. The NUL is copied as well.
+ Make sure out is at least 6 x length of str. */
+void utf16_to_utf8_with_pos(const unichar *str, int spos, char *out, int *opos);
+
/* XXX I didn't check the encoding range of big5+. This is standard big5. */
#define is_big5_los(lo) (0x40 <= (lo) && (lo) <= 0x7E) /* standard */
#define is_big5_lox(lo) (0x80 <= (lo) && (lo) <= 0xFE) /* extended */
--- src/fe-common/core/utf8.c.orig Fri Dec 9 01:32:44 2005
+++ src/fe-common/core/utf8.c Mon Dec 12 12:15:20 2005
@@ -182,6 +182,24 @@
*out = '\0';
}
+void utf16_to_utf8_with_pos(const unichar *str, int spos, char *out, int *opos)
+{
+ int len;
+ const unichar *sstart = str;
+ char *ostart = out;
+
+ *opos = 0;
+ while (*str != '\0') {
+ len = utf16_char_to_utf8(*str, out);
+ out += len;
+
+ str++;
+ if(str - sstart == spos)
+ *opos = out - ostart;
+ }
+ *out = '\0';
+}
+
static const unichar wcc[] = {
0x0, 0x300, 0x34F, 0x360, 0x363, 0x483, 0x487, 0x488, 0x48A, 0x591,
0x5A2, 0x5A3, 0x5BA, 0x5BB, 0x5BE, 0x5BF, 0x5C0, 0x5C1, 0x5C3, 0x5C4,
--- src/fe-text/gui-entry.c.orig Fri Dec 9 01:32:46 2005
+++ src/fe-text/gui-entry.c Mon Dec 12 12:26:13 2005
@@ -81,6 +81,24 @@
*out = '\0';
}
+void unichars_to_big5_with_pos(const unichar *str, int spos, char *out, int *opos)
+{
+ const unichar *sstart = str;
+ char *ostart = out;
+
+ *opos = 0;
+ while(*str != '\0')
+ {
+ if(*str > 0xff)
+ *out ++ = (*str >> 8) & 0xff;
+ *out ++ = *str & 0xff;
+ str ++;
+ if(str - sstart == spos)
+ *opos = out - ostart;
+ }
+ *out = '\0';
+}
+
int strlen_big5(const unsigned char *str)
{
int len=0;
@@ -367,6 +385,29 @@
else
for (i = 0; i <= entry->text_len; i++)
buf[i] = entry->text[i];
+ }
+ return buf;
+}
+
+char *gui_entry_get_text_and_pos(GUI_ENTRY_REC *entry, int *pos)
+{
+ char *buf;
+ int i;
+
+ g_return_val_if_fail(entry != NULL, NULL);
+
+ buf = g_malloc(entry->text_len*6 + 1);
+ if (entry->utf8)
+ utf16_to_utf8_with_pos(entry->text, entry->pos, buf, pos);
+ else {
+ if(term_type==TERM_TYPE_BIG5)
+ unichars_to_big5_with_pos(entry->text, entry->pos, buf, pos);
+ else
+ {
+ for (i = 0; i <= entry->text_len; i++)
+ buf[i] = entry->text[i];
+ *pos = entry->pos;
+ }
}
return buf;
}
--- src/fe-text/gui-readline.c.orig Fri Dec 9 01:32:46 2005
+++ src/fe-text/gui-readline.c Mon Dec 12 12:32:35 2005
@@ -778,9 +778,7 @@
char *text, *line;
int pos;
- pos = gui_entry_get_pos(active_entry);
-
- text = gui_entry_get_text(active_entry);
+ text = gui_entry_get_text_and_pos(active_entry, &pos);
line = word_complete(active_win, text, &pos, erase);
g_free(text);
@@ -806,9 +804,7 @@
char *text, *line;
int pos;
- pos = gui_entry_get_pos(active_entry);
-
- text = gui_entry_get_text(active_entry);
+ text = gui_entry_get_text_and_pos(active_entry, &pos);
line = auto_word_complete(text, &pos);
g_free(text);

View file

@ -1,41 +0,0 @@
--- src/fe-common/core/formats.c.orig Fri Dec 9 01:32:44 2005
+++ src/fe-common/core/formats.c Mon Sep 25 06:15:26 2006
@@ -376,6 +376,7 @@
GString *tmp;
const char *start;
#ifdef HAVE_GLIB2
+ const char *oldstr;
gboolean utf8;
#endif
g_return_val_if_fail(str != NULL, 0);
@@ -404,7 +405,10 @@
}
#ifdef HAVE_GLIB2
+ oldstr = str;
len -= advance(&str, utf8);
+ if(len < 0)
+ str = oldstr;
#else
len--;
str++;
--- src/fe-text/statusbar.c.orig Fri Dec 9 01:32:46 2005
+++ src/fe-text/statusbar.c Mon Sep 25 10:15:25 2006
@@ -732,7 +732,8 @@
/* they're forcing us smaller than minimum size.. */
len = format_real_length(tmpstr, item->size);
tmpstr[len] = '\0';
- } else {
+ }
+
/* make sure the str is big enough to fill the
requested size, so it won't corrupt screen */
len = format_get_length(tmpstr);
@@ -747,7 +748,6 @@
g_free(fill);
g_free(tmpstr);
tmpstr = tmpstr2;
- }
}
tmpstr2 = update_statusbar_bg(tmpstr, item->bar->color);

View file

@ -120,6 +120,8 @@ include/irssi/src/lib-popt/findme.h
include/irssi/src/lib-popt/popt.h
include/irssi/src/lib-popt/poptint.h
@exec mkdir -p %D/lib/irssi/modules
%%WITH_PROXY%%lib/irssi/modules/libirc_proxy.a
%%WITH_PROXY%%lib/irssi/modules/libirc_proxy.la
%%WITH_PROXY%%lib/irssi/modules/libirc_proxy.so
%%WITH_PROXY%%lib/irssi/modules/libirc_proxy.so.0
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Irssi.pm