net/libiscsi: update to HEAD of 2023-02-08
This fixes the build in 14-current. PR: 269502 Reported by: d8zNeCFG@aon.at (maintainer)
This commit is contained in:
parent
70f3036fe6
commit
c0c0b1bc86
6 changed files with 26 additions and 29 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= libiscsi
|
||||
DISTVERSION= 1.19.0
|
||||
DISTVERSION= 1.19.0.230208
|
||||
CATEGORIES= net
|
||||
|
||||
MAINTAINER= d8zNeCFG@aon.at
|
||||
|
@ -11,11 +11,12 @@ LICENSE_COMB= multi
|
|||
LICENSE_FILE_LGPL21+ = ${WRKSRC}/LICENCE-LGPL-2.1.txt
|
||||
LICENSE_FILE_GPLv2+ = ${WRKSRC}/LICENCE-GPL-2.txt
|
||||
|
||||
USES= autoreconf compiler:c11 libtool pathfix
|
||||
USES= autoreconf compiler:c11 gmake libtool pathfix
|
||||
USE_GITHUB= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
GH_ACCOUNT= sahlberg
|
||||
GH_TAGNAME= 22f7b2656776
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1588264800
|
||||
SHA256 (sahlberg-libiscsi-1.19.0_GH0.tar.gz) = c7848ac722c8361d5064654bc6e926c2be61ef11dd3875020a63931836d806df
|
||||
SIZE (sahlberg-libiscsi-1.19.0_GH0.tar.gz) = 284969
|
||||
TIMESTAMP = 1676144386
|
||||
SHA256 (sahlberg-libiscsi-1.19.0.230208-22f7b2656776_GH0.tar.gz) = e4560a88fc37465ac1ec43354c788141fac4cd459be039ee78df6a49b586b035
|
||||
SIZE (sahlberg-libiscsi-1.19.0.230208-22f7b2656776_GH0.tar.gz) = 293039
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
--- configure.ac.orig 2019-07-13 22:04:44 UTC
|
||||
+++ configure.ac
|
||||
@@ -144,7 +144,8 @@ AC_CACHE_CHECK([for iSER support],libiscsi_cv_HAVE_LIN
|
||||
AC_TRY_COMPILE([
|
||||
--- ./configure.ac.ORIG 2023-02-11 20:12:38.532565000 +0100
|
||||
+++ ./configure.ac 2023-02-11 20:14:27.194137000 +0100
|
||||
@@ -170,7 +170,8 @@
|
||||
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
|
||||
#include <infiniband/verbs.h>
|
||||
#include <rdma/rdma_cma.h>
|
||||
-#include <rdma/rdma_verbs.h>],
|
||||
-#include <rdma/rdma_verbs.h>]],
|
||||
+#include <rdma/rdma_verbs.h>
|
||||
+#error not on FreeBSD],
|
||||
[int ibv = IBV_WC_SEND;],
|
||||
libiscsi_cv_HAVE_LINUX_ISER=yes,libiscsi_cv_HAVE_LINUX_ISER=no)])
|
||||
+#error not on FreeBSD]],
|
||||
[[int ibv = IBV_WC_SEND;]])],
|
||||
[libiscsi_cv_HAVE_LINUX_ISER=yes],[libiscsi_cv_HAVE_LINUX_ISER=no])])
|
||||
if test x"$libiscsi_cv_HAVE_LINUX_ISER" = x"yes"; then
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
--- lib/login.c.orig 2019-07-13 22:04:44 UTC
|
||||
+++ lib/login.c
|
||||
@@ -1242,11 +1242,11 @@ iscsi_process_login_reply(struct iscsi_context *iscsi,
|
||||
|
||||
/* iSER specific keys */
|
||||
if (!strncmp(ptr, "InitiatorRecvDataSegmentLength=", 31)) {
|
||||
- iscsi->initiator_max_recv_data_segment_length = MIN(strtol(ptr + 31, NULL, 10),
|
||||
+ iscsi->initiator_max_recv_data_segment_length = MIN(strtoul(ptr + 31, NULL, 10),
|
||||
iscsi->initiator_max_recv_data_segment_length);
|
||||
}
|
||||
if (!strncmp(ptr, "TargetRecvDataSegmentLength=", 28)) {
|
||||
- iscsi->target_max_recv_data_segment_length = MIN(strtol(ptr + 28, NULL, 10),
|
||||
+ iscsi->target_max_recv_data_segment_length = MIN(strtoul(ptr + 28, NULL, 10),
|
||||
iscsi->target_max_recv_data_segment_length);
|
||||
}
|
||||
|
11
net/libiscsi/files/patch-lib_socket.c
Normal file
11
net/libiscsi/files/patch-lib_socket.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./lib/socket.c.ORIG 2023-02-11 20:12:27.340472000 +0100
|
||||
+++ ./lib/socket.c 2023-02-11 21:13:25.802721000 +0100
|
||||
@@ -140,7 +140,7 @@
|
||||
pdu->next = NULL;
|
||||
}
|
||||
|
||||
-void iscsi_decrement_iface_rr() {
|
||||
+void iscsi_decrement_iface_rr(void) {
|
||||
iface_rr--;
|
||||
}
|
||||
|
|
@ -1,6 +1,7 @@
|
|||
bin/iscsi-inq
|
||||
bin/iscsi-ls
|
||||
bin/iscsi-perf
|
||||
bin/iscsi-pr
|
||||
bin/iscsi-readcapacity16
|
||||
bin/iscsi-swp
|
||||
include/iscsi/iscsi.h
|
||||
|
|
Loading…
Reference in a new issue