- Update to `graphics/appleseed' to version 1.7.1-beta

- OSL support is no longer optional.  It complicated the code and the
  build system, and developers' intention is to make OSL a first-class
  citizen in appleseed; keeping OSL optional did not allow moving in
  that direction
- Add a work-around for Core Working Group (CWG) Defect 253: prior to
  GCC 4.6.4 and Clang 3.9.0, C++ required a user-provided default ctor
  to default-construct a const object [*], and we still have supported
  FreeBSD versions where Clang behaves the old way

[*] https://stackoverflow.com/questions/7411515

Because GitHub releases (tarballs) are not fetched with correct modification
time, set TIMESTAMP to 1501170801 which corresponds to commit ae7f346 tagged
as this release.
This commit is contained in:
Alexey Dokuchaev 2017-12-09 09:33:59 +00:00
parent dd2f123de0
commit c10df5b9df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=455830
4 changed files with 257 additions and 158 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= appleseed
DISTVERSION= 1.6.0-beta
PORTREVISION= 1
DISTVERSION= 1.7.1-beta
CATEGORIES= graphics
MAINTAINER= danfe@FreeBSD.org
@ -14,7 +13,8 @@ LICENSE= MIT
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libpng.so:graphics/png \
libIlmImf.so:graphics/OpenEXR \
libxerces-c.so:textproc/xerces-c3
libxerces-c.so:textproc/xerces-c3 \
liboslexec.so:graphics/openshadinglanguage
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}hq
@ -22,7 +22,7 @@ GH_ACCOUNT= ${PORTNAME}hq
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= not ported to it yet
USES= cmake:outsource
USES= cmake:outsource compiler:env
USE_QT4= moc_build qmake_build rcc_build uic_build opengl
LDFLAGS+= -lboost_atomic
@ -42,28 +42,31 @@ PLIST_SUB= APPHOME=${CMAKE_INSTALL_PREFIX}
SUB_FILES= pkg-message
SUB_LIST:= ${PLIST_SUB}
OPTIONS_DEFINE= CPP11 EXAMPLES OSL DISNEY
OPTIONS_DEFINE= CPP11 EXAMPLES DISNEY
OPTIONS_DEFAULT= DISNEY
OPTIONS_SUB= yes
CPP11_DESC= Build in C++11 mode
OSL_DESC= Open Shading Language support
DISNEY_DESC= Disney material support
CPP11_CMAKE_ON= -DUSE_CPP11:BOOL=ON
EXAMPLES_CMAKE_OFF= -DWITH_SAMPLES:BOOL=OFF
OSL_CMAKE_ON= -DWITH_OSL:BOOL=ON
OSL_LIB_DEPENDS= liboslexec.so:graphics/openshadinglanguage
# src/appleseed/libappleseed.so: undefined reference to `typeinfo for OSL::RendererServices'
OSL_BROKEN= requires RTTI support in LLVM/OSL which is currently missing
DISNEY_CMAKE_ON= -DWITH_DISNEY_MATERIAL:BOOL=ON
DISNEY_LIB_DEPENDS= libOpenImageIO.so:graphics/openimageio \
libSeExprEditor.so:graphics/seexpr
.include <bsd.port.pre.mk>
post-patch:
@${RMDIR} ${WRKSRC}/sandbox/docs/api
.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 39
@${ECHO_MSG} "===> Patching for Core Working Group (CWG) Defect 253 (see r455830)"
@${REINPLACE_CMD} -E 's,const (.*MDF ),\1,' \
${WRKSRC}/src/appleseed/renderer/modeling/bsdf/disneybrdf.cpp \
${WRKSRC}/src/appleseed/renderer/modeling/bsdf/microfacetbrdf.cpp \
${WRKSRC}/src/appleseed/foundation/meta/tests/test_microfacet.cpp
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1481813859
SHA256 (appleseedhq-appleseed-1.6.0-beta_GH0.tar.gz) = 16ec393f62c7f445a3e2719d69a093e789062a712b28583b78c6f56278e98626
SIZE (appleseedhq-appleseed-1.6.0-beta_GH0.tar.gz) = 118483186
TIMESTAMP = 1501170801
SHA256 (appleseedhq-appleseed-1.7.1-beta_GH0.tar.gz) = 9cb6d21ca84a62f6e077038c53a5e91c4aba78aa0bf01ccb7d9792d3cc839fb1
SIZE (appleseedhq-appleseed-1.7.1-beta_GH0.tar.gz) = 152061805

View file

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2016-12-15 14:57:39 UTC
--- CMakeLists.txt.orig 2017-07-27 15:53:21 UTC
+++ CMakeLists.txt
@@ -107,6 +107,10 @@ option (USE_EXTERNAL_ZLIB "Use exter
@@ -106,6 +106,10 @@ option (USE_EXTERNAL_ZLIB "Use exter
option (WITH_CLI "Build appleseed.cli" ON)
option (WITH_STUDIO "Build appleseed.studio" ON)
option (WITH_TOOLS "Build appleseed tools" ON)
@ -9,9 +9,9 @@
+option (WITH_HEADERS "Intall header files (to build samples)" ON)
+option (WITH_TESTS "Install unit tests and benchmarks" ON)
option (WITH_PYTHON "Build Python bindings" ON)
option (WITH_ALEMBIC "Build Alembic support" OFF)
option (WITH_OSL "Build OSL support" OFF)
@@ -172,6 +176,9 @@ else ()
option (WITH_DISNEY_MATERIAL "Build Disney material" OFF)
@@ -168,6 +172,9 @@ else ()
"Edit ${CMAKE_CURRENT_LIST_FILE} to add support for it.")
endif ()
@ -21,7 +21,7 @@
#--------------------------------------------------------------------------------------------------
# Auto-generate version headers.
@@ -297,7 +304,6 @@ endif ()
@@ -262,7 +269,6 @@ endif ()
# Common include paths.
include_directories (
src/appleseed
@ -29,7 +29,7 @@
${PYTHON_INCLUDE_DIRS}
)
@@ -643,7 +649,7 @@ endif ()
@@ -579,7 +585,7 @@ endif ()
find_package (Doxygen)
@ -38,33 +38,36 @@
configure_file (${PROJECT_SOURCE_DIR}/scripts/appleseed.doxyfile.in ${PROJECT_BINARY_DIR}/appleseed.doxyfile @ONLY)
add_custom_target (
doc ${DOXYGEN_EXECUTABLE} ${PROJECT_BINARY_DIR}/appleseed.doxyfile
@@ -692,23 +698,33 @@ endif ()
install (
@@ -627,25 +633,35 @@ install (
DIRECTORY
sandbox/docs
+ DESTINATION .
+)
+
+if (WITH_SAMPLES)
+install (
+ DIRECTORY
sandbox/samples
sandbox/icons
- sandbox/samples
sandbox/settings
- sandbox/share
sandbox/stylesheets
DESTINATION .
)
+endif ()
+if (WITH_SAMPLES)
install (
- CODE "FILE (MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/images)"
- CODE "FILE (MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/images/autosave)"
+ DIRECTORY
+ sandbox/share
+ DESTINATION ..
+ sandbox/samples
+ DESTINATION .
)
+endif ()
+if (WITH_TESTS)
install (
DIRECTORY
+ sandbox/share
+ DESTINATION ..
+)
+
+if (WITH_TESTS)
+install (
+ DIRECTORY
"sandbox/tests/unit benchmarks"
"sandbox/tests/unit tests"
DESTINATION tests
@ -75,7 +78,7 @@
install (
DIRECTORY src/appleseed/foundation
DESTINATION include
@@ -726,3 +742,4 @@ install (
@@ -663,3 +679,4 @@ install (
DESTINATION include
FILES_MATCHING PATTERN "*.h"
)

View file

@ -1,4 +1,12 @@
share/cmake/Modules/FindAppleseed.cmake
share/cmake/Modules/FindImath.cmake
share/cmake/Modules/FindOSL.cmake
share/cmake/Modules/FindOpenEXR.cmake
share/cmake/Modules/FindOpenImageIO.cmake
share/cmake/Modules/FindPartio.cmake
share/cmake/Modules/FindSeExpr.cmake
share/cmake/Modules/FindSeExprEditor.cmake
share/cmake/Modules/FindXerces.cmake
@cwd %%APPHOME%%
bin/animatecamera
bin/appleseed.cli
@ -7,14 +15,14 @@ bin/convertmany.py
bin/convertmeshfile
bin/dumpmetadata
bin/makefluffy
%%OSL%%bin/maketx
%%OSL%%bin/oslc
%%OSL%%bin/oslinfo
bin/maketx
bin/oslc
bin/oslinfo
bin/projecttool
bin/rendermanager.py
bin/rendermany.py
bin/rendernode.py
bin/updatemany.py
bin/updateprojectfile
docs/osl/osl-languagespec.pdf
docs/seexpr/Se_voronoi_1.png
docs/seexpr/Se_voronoi_2.png
@ -22,6 +30,55 @@ docs/seexpr/Se_voronoi_3.png
docs/seexpr/Se_voronoi_4.png
docs/seexpr/Se_voronoi_5.png
docs/seexpr/userdoc.html
icons/appleseed.png
icons/disney_expression.png
icons/disney_expression_hover.png
icons/disney_texture.png
icons/disney_texture_hover.png
icons/project_monitor.png
icons/project_monitor_disabled.png
icons/project_monitor_hover.png
icons/project_new.png
icons/project_new_disabled.png
icons/project_new_hover.png
icons/project_open.png
icons/project_open_disabled.png
icons/project_open_hover.png
icons/project_reload.png
icons/project_reload_disabled.png
icons/project_reload_hover.png
icons/project_save.png
icons/project_save_disabled.png
icons/project_save_hover.png
icons/rendering_settings.png
icons/rendering_settings_disabled.png
icons/rendering_settings_hover.png
icons/rendering_start_final.png
icons/rendering_start_final_disabled.png
icons/rendering_start_final_hover.png
icons/rendering_start_interactive.png
icons/rendering_start_interactive_disabled.png
icons/rendering_start_interactive_hover.png
icons/rendering_stop.png
icons/rendering_stop_disabled.png
icons/rendering_stop_hover.png
icons/renderwidget_clear_frame.png
icons/renderwidget_clear_frame_disabled.png
icons/renderwidget_clear_frame_hover.png
icons/renderwidget_clear_render_region.png
icons/renderwidget_clear_render_region_disabled.png
icons/renderwidget_clear_render_region_hover.png
icons/renderwidget_quicksave_all_aovs.png
icons/renderwidget_quicksave_all_aovs_hover.png
icons/renderwidget_reset_zoom.png
icons/renderwidget_reset_zoom_hover.png
icons/renderwidget_save_all_aovs.png
icons/renderwidget_save_all_aovs_hover.png
icons/renderwidget_set_render_region.png
icons/renderwidget_set_render_region_disabled.png
icons/renderwidget_set_render_region_hover.png
icons/renderwidget_toggle_pixel_inspector.png
icons/renderwidget_toggle_pixel_inspector_hover.png
lib/libappleseed.shared.so
lib/libappleseed.so
%%PORTEXAMPLES%%samples/cpp/basic/CMakeLists.txt
@ -37,6 +94,7 @@ lib/libappleseed.so
%%PORTEXAMPLES%%samples/cpp/heightfield/data/smoothcube.obj
%%PORTEXAMPLES%%samples/cpp/heightfield/heightfield.cpp
%%PORTEXAMPLES%%samples/cpp/heightfield/output/preserve.txt
%%PORTEXAMPLES%%samples/python/basic/README.md
%%PORTEXAMPLES%%samples/python/basic/basic.py
%%PORTEXAMPLES%%samples/python/basic/data/scene.obj
%%PORTEXAMPLES%%samples/python/basic/output/preserve.txt
@ -52,122 +110,157 @@ seexpr/noise/noise.se
seexpr/noise/turbulence.se
settings/appleseed.cli.xml
settings/appleseed.studio.xml
%%OSL%%shaders/README.md
%%OSL%%shaders/color/as_blackbody.oso
%%OSL%%shaders/color/as_color_add.oso
%%OSL%%shaders/color/as_color_build.oso
%%OSL%%shaders/color/as_color_mix.oso
%%OSL%%shaders/color/as_color_multiply.oso
%%OSL%%shaders/color/as_color_saturation.oso
%%OSL%%shaders/color/as_color_split.oso
%%OSL%%shaders/color/as_luminance.oso
%%OSL%%shaders/color/as_wavelength.oso
%%OSL%%shaders/float/as_float_add.oso
%%OSL%%shaders/float/as_float_cast.oso
%%OSL%%shaders/float/as_float_mix.oso
%%OSL%%shaders/float/as_float_multiply.oso
%%OSL%%shaders/float/as_float_pow.oso
%%OSL%%shaders/float/as_float_remap.oso
%%OSL%%shaders/input/as_globals.oso
%%OSL%%shaders/input/as_input.oso
%%OSL%%shaders/input/as_object_input.oso
%%OSL%%shaders/input/as_ray_info.oso
%%OSL%%shaders/material/as_disney_material.oso
%%OSL%%shaders/material/as_material_builder.oso
%%OSL%%shaders/normal/as_bump_map.oso
%%OSL%%shaders/normal/as_normal_map.oso
%%OSL%%shaders/oslutil.h
%%OSL%%shaders/src/color/as_blackbody.osl
%%OSL%%shaders/src/color/as_color_add.osl
%%OSL%%shaders/src/color/as_color_build.osl
%%OSL%%shaders/src/color/as_color_mix.osl
%%OSL%%shaders/src/color/as_color_multiply.osl
%%OSL%%shaders/src/color/as_color_saturation.osl
%%OSL%%shaders/src/color/as_color_split.osl
%%OSL%%shaders/src/color/as_luminance.osl
%%OSL%%shaders/src/color/as_wavelength.osl
%%OSL%%shaders/src/compile_shaders.py
%%OSL%%shaders/src/float/as_float_add.osl
%%OSL%%shaders/src/float/as_float_cast.osl
%%OSL%%shaders/src/float/as_float_mix.osl
%%OSL%%shaders/src/float/as_float_multiply.osl
%%OSL%%shaders/src/float/as_float_pow.osl
%%OSL%%shaders/src/float/as_float_remap.osl
%%OSL%%shaders/src/include/appleseed/color.h
%%OSL%%shaders/src/include/appleseed/microfacet.h
%%OSL%%shaders/src/include/appleseed/transform.h
%%OSL%%shaders/src/include/appleseed/udim.h
%%OSL%%shaders/src/input/as_globals.osl
%%OSL%%shaders/src/input/as_input.osl
%%OSL%%shaders/src/input/as_object_input.osl
%%OSL%%shaders/src/input/as_ray_info.osl
%%OSL%%shaders/src/material/as_disney_material.osl
%%OSL%%shaders/src/material/as_material_builder.osl
%%OSL%%shaders/src/normal/as_bump_map.osl
%%OSL%%shaders/src/normal/as_normal_map.osl
%%OSL%%shaders/src/surface/as_diffuse_surface.osl
%%OSL%%shaders/src/surface/as_emission_surface.osl
%%OSL%%shaders/src/surface/as_glass_surface.osl
%%OSL%%shaders/src/surface/as_glossy_surface.osl
%%OSL%%shaders/src/surface/as_metal_surface.osl
%%OSL%%shaders/src/surface/as_sheen_surface.osl
%%OSL%%shaders/src/surface/as_subsurface_surface.osl
%%OSL%%shaders/src/surface/as_surface_add.osl
%%OSL%%shaders/src/surface/as_surface_mix.osl
%%OSL%%shaders/src/surface/as_surface_multiply.osl
%%OSL%%shaders/src/surface/as_surface_switch.osl
%%OSL%%shaders/src/surface/as_translucent_surface.osl
%%OSL%%shaders/src/surface/as_transparency_surface.osl
%%OSL%%shaders/src/texture2d/as_color_texture.osl
%%OSL%%shaders/src/texture2d/as_noise2d.osl
%%OSL%%shaders/src/texture2d/as_scalar_texture.osl
%%OSL%%shaders/src/texture3d/as_noise3d.osl
%%OSL%%shaders/src/texture3d/as_noise4d.osl
%%OSL%%shaders/src/transform/as_map2d.osl
%%OSL%%shaders/src/transform/as_map3d.osl
%%OSL%%shaders/src/transform/as_transform.osl
%%OSL%%shaders/src/utility/as_condition.osl
%%OSL%%shaders/src/utility/as_switch.osl
%%OSL%%shaders/src/vector/as_anisotropy_dir.osl
%%OSL%%shaders/src/vector/as_vector_add.osl
%%OSL%%shaders/src/vector/as_vector_build.osl
%%OSL%%shaders/src/vector/as_vector_cross.osl
%%OSL%%shaders/src/vector/as_vector_dot.osl
%%OSL%%shaders/src/vector/as_vector_mix.osl
%%OSL%%shaders/src/vector/as_vector_multiply.osl
%%OSL%%shaders/src/vector/as_vector_normalize.osl
%%OSL%%shaders/src/vector/as_vector_split.osl
%%OSL%%shaders/stdosl.h
%%OSL%%shaders/surface/as_diffuse_surface.oso
%%OSL%%shaders/surface/as_emission_surface.oso
%%OSL%%shaders/surface/as_glass_surface.oso
%%OSL%%shaders/surface/as_glossy_surface.oso
%%OSL%%shaders/surface/as_metal_surface.oso
%%OSL%%shaders/surface/as_sheen_surface.oso
%%OSL%%shaders/surface/as_subsurface_surface.oso
%%OSL%%shaders/surface/as_surface_add.oso
%%OSL%%shaders/surface/as_surface_mix.oso
%%OSL%%shaders/surface/as_surface_multiply.oso
%%OSL%%shaders/surface/as_surface_switch.oso
%%OSL%%shaders/surface/as_translucent_surface.oso
%%OSL%%shaders/surface/as_transparency_surface.oso
%%OSL%%shaders/texture2d/as_color_texture.oso
%%OSL%%shaders/texture2d/as_noise2d.oso
%%OSL%%shaders/texture2d/as_scalar_texture.oso
%%OSL%%shaders/texture3d/as_noise3d.oso
%%OSL%%shaders/texture3d/as_noise4d.oso
%%OSL%%shaders/transform/as_map2d.oso
%%OSL%%shaders/transform/as_map3d.oso
%%OSL%%shaders/transform/as_transform.oso
%%OSL%%shaders/utility/as_condition.oso
%%OSL%%shaders/utility/as_switch.oso
%%OSL%%shaders/vector/as_anisotropy_dir.oso
%%OSL%%shaders/vector/as_vector_add.oso
%%OSL%%shaders/vector/as_vector_build.oso
%%OSL%%shaders/vector/as_vector_cross.oso
%%OSL%%shaders/vector/as_vector_dot.oso
%%OSL%%shaders/vector/as_vector_mix.oso
%%OSL%%shaders/vector/as_vector_multiply.oso
%%OSL%%shaders/vector/as_vector_normalize.oso
%%OSL%%shaders/vector/as_vector_split.oso
settings/appleseed.tools.xml
shaders/appleseed/asDisneyMaterial.oso
shaders/appleseed/asGlass.oso
shaders/appleseed/asVoronoi2D.oso
shaders/appleseed/asVoronoi3D.oso
shaders/as_osl_extensions.h
shaders/gaffer/color/as_blackbody.oso
shaders/gaffer/color/as_color_add.oso
shaders/gaffer/color/as_color_build.oso
shaders/gaffer/color/as_color_mix.oso
shaders/gaffer/color/as_color_multiply.oso
shaders/gaffer/color/as_color_saturation.oso
shaders/gaffer/color/as_color_split.oso
shaders/gaffer/color/as_luminance.oso
shaders/gaffer/color/as_wavelength.oso
shaders/gaffer/float/as_float_add.oso
shaders/gaffer/float/as_float_cast.oso
shaders/gaffer/float/as_float_mix.oso
shaders/gaffer/float/as_float_multiply.oso
shaders/gaffer/float/as_float_pow.oso
shaders/gaffer/float/as_float_remap.oso
shaders/gaffer/input/as_globals.oso
shaders/gaffer/input/as_input.oso
shaders/gaffer/input/as_object_input.oso
shaders/gaffer/input/as_ray_info.oso
shaders/gaffer/material/as_disney_material.oso
shaders/gaffer/material/as_material_builder.oso
shaders/gaffer/normal/as_bump_map.oso
shaders/gaffer/normal/as_normal_map.oso
shaders/gaffer/surface/as_diffuse_surface.oso
shaders/gaffer/surface/as_emission_surface.oso
shaders/gaffer/surface/as_glass_surface.oso
shaders/gaffer/surface/as_glossy_surface.oso
shaders/gaffer/surface/as_metal_surface.oso
shaders/gaffer/surface/as_sheen_surface.oso
shaders/gaffer/surface/as_subsurface_surface.oso
shaders/gaffer/surface/as_surface_add.oso
shaders/gaffer/surface/as_surface_mix.oso
shaders/gaffer/surface/as_surface_multiply.oso
shaders/gaffer/surface/as_surface_switch.oso
shaders/gaffer/surface/as_translucent_surface.oso
shaders/gaffer/surface/as_transparency_surface.oso
shaders/gaffer/texture2d/as_color_texture.oso
shaders/gaffer/texture2d/as_noise2d.oso
shaders/gaffer/texture2d/as_scalar_texture.oso
shaders/gaffer/texture3d/as_noise3d.oso
shaders/gaffer/texture3d/as_noise4d.oso
shaders/gaffer/transform/as_map2d.oso
shaders/gaffer/transform/as_map3d.oso
shaders/gaffer/transform/as_transform.oso
shaders/gaffer/utility/as_condition.oso
shaders/gaffer/utility/as_float2_build.oso
shaders/gaffer/utility/as_float2_split.oso
shaders/gaffer/utility/as_switch.oso
shaders/gaffer/vector/as_anisotropy_dir.oso
shaders/gaffer/vector/as_vector_add.oso
shaders/gaffer/vector/as_vector_build.oso
shaders/gaffer/vector/as_vector_cross.oso
shaders/gaffer/vector/as_vector_dot.oso
shaders/gaffer/vector/as_vector_mix.oso
shaders/gaffer/vector/as_vector_multiply.oso
shaders/gaffer/vector/as_vector_normalize.oso
shaders/gaffer/vector/as_vector_split.oso
shaders/include/appleseed/color/as_chromatic_adaptation.h
shaders/include/appleseed/color/as_color_helpers.h
shaders/include/appleseed/color/as_color_transforms.h
shaders/include/appleseed/color/as_colorimetry.h
shaders/include/appleseed/color/as_transfer_functions.h
shaders/include/appleseed/fractal/as_fractal_helpers.h
shaders/include/appleseed/fractal/as_noise_helpers.h
shaders/include/appleseed/fractal/as_noise_tables.h
shaders/include/appleseed/gaffer/color.h
shaders/include/appleseed/gaffer/transform.h
shaders/include/appleseed/gaffer/udim.h
shaders/include/appleseed/material/as_material_helpers.h
shaders/include/appleseed/math/as_math_complex.h
shaders/include/appleseed/math/as_math_helpers.h
shaders/include/appleseed/maya/as_maya_cms_syncolor_idt.h
shaders/include/appleseed/maya/as_maya_fractal_helpers.h
shaders/include/appleseed/maya/as_maya_helpers.h
shaders/include/appleseed/maya/as_maya_layer_helpers.h
shaders/include/appleseed/maya/as_maya_pattern_helpers.h
shaders/include/appleseed/maya/as_maya_ramp_helpers.h
shaders/include/appleseed/maya/as_maya_transform_helpers.h
shaders/include/appleseed/pattern/as_pattern_helpers.h
shaders/maya/as_maya_addDoubleLinear.oso
shaders/maya/as_maya_addMatrix.oso
shaders/maya/as_maya_anisotropic.oso
shaders/maya/as_maya_areaLight.oso
shaders/maya/as_maya_blendColors.oso
shaders/maya/as_maya_blinn.oso
shaders/maya/as_maya_bulge.oso
shaders/maya/as_maya_bump2d.oso
shaders/maya/as_maya_bump3d.oso
shaders/maya/as_maya_checker.oso
shaders/maya/as_maya_clamp.oso
shaders/maya/as_maya_clearCoat.oso
shaders/maya/as_maya_closure2Surface.oso
shaders/maya/as_maya_cloth.oso
shaders/maya/as_maya_cloud.oso
shaders/maya/as_maya_color2Components.oso
shaders/maya/as_maya_components2Color.oso
shaders/maya/as_maya_components2UV.oso
shaders/maya/as_maya_components2Vector.oso
shaders/maya/as_maya_condition.oso
shaders/maya/as_maya_contrast.oso
shaders/maya/as_maya_distanceBetween.oso
shaders/maya/as_maya_doubleShadingSwitch.oso
shaders/maya/as_maya_envChrome.oso
shaders/maya/as_maya_file.oso
shaders/maya/as_maya_fourByFourMatrix.oso
shaders/maya/as_maya_fractal.oso
shaders/maya/as_maya_gammaCorrect.oso
shaders/maya/as_maya_grid.oso
shaders/maya/as_maya_hsvToRgb.oso
shaders/maya/as_maya_lambert.oso
shaders/maya/as_maya_layeredTexture.oso
shaders/maya/as_maya_luminance.oso
shaders/maya/as_maya_mandelbrot.oso
shaders/maya/as_maya_matrixInverse.oso
shaders/maya/as_maya_mountain.oso
shaders/maya/as_maya_movie.oso
shaders/maya/as_maya_multDoubleLinear.oso
shaders/maya/as_maya_multMatrix.oso
shaders/maya/as_maya_multiplyDivide.oso
shaders/maya/as_maya_noise.oso
shaders/maya/as_maya_phong.oso
shaders/maya/as_maya_phongE.oso
shaders/maya/as_maya_place2dTexture.oso
shaders/maya/as_maya_place3dTexture.oso
shaders/maya/as_maya_plusMinusAverage.oso
shaders/maya/as_maya_psdFileTex.oso
shaders/maya/as_maya_quadShadingSwitch.oso
shaders/maya/as_maya_ramp.oso
shaders/maya/as_maya_remapColor.oso
shaders/maya/as_maya_remapHsv.oso
shaders/maya/as_maya_remapValue.oso
shaders/maya/as_maya_reverse.oso
shaders/maya/as_maya_rgbToHsv.oso
shaders/maya/as_maya_samplerInfo.oso
shaders/maya/as_maya_setRange.oso
shaders/maya/as_maya_singleShadingSwitch.oso
shaders/maya/as_maya_stencil.oso
shaders/maya/as_maya_texture2Surface.oso
shaders/maya/as_maya_transposeMatrix.oso
shaders/maya/as_maya_tripleShadingSwitch.oso
shaders/maya/as_maya_uv2Components.oso
shaders/maya/as_maya_vector2Components.oso
shaders/maya/as_maya_vectorProduct.oso
shaders/maya/as_maya_water.oso
shaders/maya/as_maya_wtAddMatrix.oso
shaders/oslutil.h
shaders/stdosl.h
stylesheets/default.qss