Update to the new, open source, version 1.0RC4.

This commit is contained in:
Mike Heffner 2002-07-04 09:03:30 +00:00
parent db59d15a8e
commit c124fa236a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62420
6 changed files with 54 additions and 83 deletions

View file

@ -6,39 +6,23 @@
#
PORTNAME= xforms
PORTVERSION= 0.88
PORTVERSION= 1.0
PORTEPOCH= 1
CATEGORIES= x11-toolkits graphics
MASTER_SITES= ftp://ncmir.ucsd.edu/pub/xforms/${MASTER_SITE_SUBDIR}/
MASTER_SITES= ftp://ncmir.ucsd.edu/pub/xforms/OpenSource/
FULLVERSION= ${PORTVERSION}RC4
DISTNAME= ${PORTNAME}-${FULLVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= mikeh@FreeBSD.ORG
LIB_DEPENDS= c.3:${PORTSDIR}/misc/compat3x
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_X_PREFIX= yes
USE_XPM= yes
USE_IMAKE= yes
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MAN1= fdesign.1 fd2ps.1
MAN5= xforms.5 forms.5
.include <bsd.port.pre.mk>
.if ${MACHINE_ARCH} == "alpha"
MASTER_SITE_SUBDIR= freeBSD-alpha
DISTNAME= bxform-${PORTVERSION:S/.//}
.else
MASTER_SITE_SUBDIR= freeBSD
DISTNAME= bxform-${PORTVERSION:S/.//}-elf
.endif
post-install:
@${LN} -sf ${PREFIX}/lib/libforms.so.0.88 ${PREFIX}/lib/libforms.so.0
@${LN} -sf ${PREFIX}/lib/libforms.so.0.88 ${PREFIX}/lib/libxforms.so.0
@${LN} -sf ${PREFIX}/lib/libforms.a ${PREFIX}/lib/libxforms.a
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,2 +1 @@
MD5 (bxform-088.tgz) = c5451ac858392230ee84a7caea5a153f
MD5 (bxform-088-elf.tgz) = 30d178a335f71422eaf20464ce305854
MD5 (xforms-1.0RC4.tgz) = 1166cec00a56754837ea5bb76df97483

View file

@ -1,20 +1,18 @@
--- mkconfig.h.orig Sun Feb 4 18:49:19 2001
+++ mkconfig.h Sun Feb 4 18:51:40 2001
@@ -10,7 +10,7 @@
--- Imakefile.orig Thu Jun 6 10:45:33 2002
+++ Imakefile Sun Jun 30 21:18:25 2002
@@ -3,13 +3,13 @@
/* Fairly important stuff */
# where the library should be installed
#define DoOptimize YES
-#define OptimizationLevel -O4
+#define OptimizationLevel -O
#define DoWall NO
-LIB_TOPDIR=/usr
+LIB_TOPDIR=${PREFIX}
#define BuildShared YES
#define StaticLink NO
LIB_DIR=$(LIB_TOPDIR)/lib
LIBMODE=644
@@ -18,7 +18,7 @@
HEADER_DIR=$(LIB_TOPDIR)/include
HEADERMODE=644
-#define BuildGL YES
+#define BuildGL NO
-BIN_DIR=/usr/local/bin
+BIN_DIR=${PREFIX}/bin
BINMODE=711
/* Less Important or System Specific */
MAN5_DIR=$(LIB_TOPDIR)/man/man5

View file

@ -1,20 +1,22 @@
$FreeBSD$
--- Makefile.orig Mon Oct 26 05:04:54 1998
+++ Makefile Fri Mar 2 20:32:52 2001
@@ -41,9 +41,13 @@
cp DESIGN/fdesign.1 $(MAN1_DIR); chmod $(MANMODE) $(MAN1_DIR)/fdesign.1
cp fd2ps/fd2ps.1 $(MAN1_DIR); chmod $(MANMODE) $(MAN1_DIR)/fd2ps.1
@if [ ! -f $(MAN5_DIR)/forms.5 ]; then\
- ln -s $(MAN5_DIR)/xforms.5 $(MAN5_DIR)/forms.5;\
+ cp $(MAN5_DIR)/xforms.5 $(MAN5_DIR)/forms.5;\
fi
clean:
(cd DEMOS; make $@)
empty:
(cd DEMOS; make $@)
--- fdesign/Imakefile.orig Fri Jun 28 02:23:08 2002
+++ fdesign/Imakefile Fri Jun 28 02:23:51 2002
@@ -78,6 +78,8 @@
INCDIR = XFormsNonstandardInstallDir/include
#endif
+EXTRA_LDOPTIONS = $(FORMSLIB)
+
+# add blank all target
+all:
+
EXTRA_INCLUDES = \
$(SNPINC) \
-I$(BUILDINCDIR) \
--- demos/Imakefile.orig Fri Jun 28 02:26:52 2002
+++ demos/Imakefile Fri Jun 28 02:27:23 2002
@@ -137,6 +137,8 @@
DEPSNPLIB = $(SNPLIBDIR)/libformssnp.a
#endif
+EXTRA_LDOPTIONS = $(FORMSLIB)
+
EXTRA_INCLUDES = \
$(SNPINC) \
-I$(BUILDINCDIR) \

View file

@ -1,23 +1,10 @@
This is the binary distribution of XForms, a graphical user interface
This is the source distribution of XForms, a graphical user interface
toolkit for X Window Systems. It should work under X11 R4, R5 & R6.
Documentation on XForms is available via anonymous FTP from
<ftp://einstein.phys.uwm.edu/pub/xforms/>.
The entire XForms distribution is also accessible at
WWW: http://bragg.phys.uwm.edu/xforms/
There is also a mailing list for XForms. Send an empty message
to <xforms-request@bob.usuf2.usuhs.mil> with one of the following headers
subscribe (your_name) Your_EmailAddress
unsubscribe (your_name) Your_EmailAddress
to get on and off the list.
To use the mailing list, send your message to
<xforms@bob.usuf2.usuhs.mil>
Remember your message will be sent to many people. Please DO NOT
send subscribe/unsubscribe messages to the list.
XForms features a rich set of objects, such as buttons, scrollbars,
and menus etc. integrated into an easy and efficient object/event
callback execution model that allows fast and easy construction of
X-applications. In addition, the library is extensible and new objects
can easily be created and added to the library.
WWW: http://world.std.com/~xforms/

View file

@ -1,9 +1,10 @@
bin/fd2ps
bin/fdesign
include/forms.h
include/X11/flimage.h
include/X11/forms.h
lib/libflimage.a
lib/libflimage.so
lib/libflimage.so.1
lib/libforms.a
lib/libforms.so
lib/libforms.so.0
lib/libforms.so.0.88
lib/libxforms.a
lib/libxforms.so.0
lib/libforms.so.1