devel/electron25: update to 25.3.1
Changelog: - https://github.com/electron/electron/releases/tag/v25.3.0 - https://github.com/electron/electron/releases/tag/v25.3.1 Reported by: GitHub (watch releases)
This commit is contained in:
parent
61075201a0
commit
c12bef0cd1
16 changed files with 92 additions and 85 deletions
|
@ -2,10 +2,12 @@ PORTNAME= electron
|
|||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= ${ELECTRON_VER:S/-beta./.b/}
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/:chromium \
|
||||
MASTER_SITES= https://github.com/tagattie/FreeBSD-Electron/releases/download/v25.3.1/:chromium \
|
||||
https://commondatastorage.googleapis.com/chromium-nodejs/:chromium_node \
|
||||
https://commondatastorage.googleapis.com/chromium-fonts/:chromium_testfonts
|
||||
PKGNAMESUFFIX= ${ELECTRON_VER_MAJOR}
|
||||
DISTFILES= chromium-${CHROMIUM_VER}${EXTRACT_SUFX}:chromium \
|
||||
${CHROMIUM_NODE_MODULES_HASH}:chromium_node \
|
||||
${CHROMIUM_TEST_FONTS_HASH}:chromium_testfonts \
|
||||
electron-yarn-cache-${ELECTRON_VER}${EXTRACT_SUFX}:prefetch
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
@ -205,7 +207,9 @@ SNDIO_VARS= GN_ARGS+=use_sndio=true
|
|||
SNDIO_VARS_OFF= GN_ARGS+=use_sndio=false
|
||||
|
||||
# See ${WRKSRC}/electron/DEPS for CHROMIUM_VER
|
||||
CHROMIUM_VER= 114.0.5735.134
|
||||
CHROMIUM_VER= 114.0.5735.243
|
||||
# See ${WRKSRC}/third_party/node/node_modules.tar.gz.sha1 for CHROMIUM_NODE_MODULES_HASH
|
||||
CHROMIUM_NODE_MODULES_HASH= de0af8ec3401004cd1a420ab25892880330464c8
|
||||
# See ${WRKSRC}/third_party/test_fonts/test_fonts.tar.gz.sha1 for CHROMIUM_TEST_FONTS_HASH
|
||||
CHROMIUM_TEST_FONTS_HASH= 336e775eec536b2d785cc80eff6ac39051931286
|
||||
# See ${WRKSRC}/electron/DEPS for NODE_VER
|
||||
|
@ -219,7 +223,7 @@ REACTIVEOBJC_VER= 74ab5baccc6f7202c8ac69a8d1e152c29dc1ea76
|
|||
# See ${WRKSRC}/electron/DEPS for MANTLE_VER
|
||||
MANTLE_VER= 78d3966b3c331292ea29ec38661b25df0a245948
|
||||
|
||||
YARN_TIMESTAMP= 1687657399
|
||||
YARN_TIMESTAMP= 1689920505
|
||||
|
||||
.include "Makefile.version"
|
||||
.include <bsd.port.pre.mk>
|
||||
|
@ -317,6 +321,7 @@ post-extract:
|
|||
${WRKSRC}/third_party/squirrel.mac/vendor/ReactiveObjC
|
||||
${MV} ${WRKDIR}/${PORTNAME}-${ELECTRON_VER}/${GH_PROJECT_mantle}-${MANTLE_VER} \
|
||||
${WRKSRC}/third_party/squirrel.mac/vendor/Mantle
|
||||
${MV} ${WRKDIR}/${PORTNAME}-${ELECTRON_VER}/node_modules ${WRKSRC}/third_party/node
|
||||
${MV} ${WRKDIR}/${PORTNAME}-${ELECTRON_VER}/test_fonts ${WRKSRC}/third_party/test_fonts
|
||||
# Install node modules for electron
|
||||
${MV} ${WRKDIR}/${PORTNAME}-${ELECTRON_VER}/yarn-offline-cache ${WRKDIR}
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
ELECTRON_VER= 25.2.0
|
||||
ELECTRON_VER= 25.3.1
|
||||
ELECTRON_VER_MAJOR= ${ELECTRON_VER:C/\..*//}
|
||||
|
|
|
@ -1,12 +1,14 @@
|
|||
TIMESTAMP = 1687658600
|
||||
SHA256 (electron/chromium-114.0.5735.134.tar.xz) = d95118cc7f23b38761d4563cb426a000a1bccc8e395210f19255d6f6e8fd02c9
|
||||
SIZE (electron/chromium-114.0.5735.134.tar.xz) = 1570567768
|
||||
TIMESTAMP = 1689924314
|
||||
SHA256 (electron/chromium-114.0.5735.243.tar.xz) = 59d3d13796599a22638274a85c77fb4bf273e995ab3c3054314803fc8cbaf225
|
||||
SIZE (electron/chromium-114.0.5735.243.tar.xz) = 1414281296
|
||||
SHA256 (electron/de0af8ec3401004cd1a420ab25892880330464c8) = 401097f07b4feb3e03ce7c2412e978b32aea5334f4fbaf26f873e60e8bb92647
|
||||
SIZE (electron/de0af8ec3401004cd1a420ab25892880330464c8) = 8880520
|
||||
SHA256 (electron/336e775eec536b2d785cc80eff6ac39051931286) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
|
||||
SIZE (electron/336e775eec536b2d785cc80eff6ac39051931286) = 32624734
|
||||
SHA256 (electron/electron-yarn-cache-25.2.0.tar.xz) = a856b07198655aa443fd4ac71c43d74f5951da976d75dd4b89932224e4e2d2f4
|
||||
SIZE (electron/electron-yarn-cache-25.2.0.tar.xz) = 41288976
|
||||
SHA256 (electron/electron-electron-v25.2.0_GH0.tar.gz) = f39621faed175cfe4023e74c0c720f4bcf277ae7d03205cf02d265e37c6e09ac
|
||||
SIZE (electron/electron-electron-v25.2.0_GH0.tar.gz) = 11268356
|
||||
SHA256 (electron/electron-yarn-cache-25.3.1.tar.xz) = 9282b310822d9a782b34fd8b8e7e49aee2472c678ae26a88d634039c4b3e6bfa
|
||||
SIZE (electron/electron-yarn-cache-25.3.1.tar.xz) = 41289008
|
||||
SHA256 (electron/electron-electron-v25.3.1_GH0.tar.gz) = 10fbdf0a327ec6567c5d3e1712225c6543ce3bde5eb5dba7929b61d9aa3e9f32
|
||||
SIZE (electron/electron-electron-v25.3.1_GH0.tar.gz) = 11270244
|
||||
SHA256 (electron/nodejs-node-v18.15.0_GH0.tar.gz) = 33c4b5b77c98398a3c0d99a146f602d164e014ff3a5713697beef1a971faf573
|
||||
SIZE (electron/nodejs-node-v18.15.0_GH0.tar.gz) = 111925667
|
||||
SHA256 (electron/nodejs-nan-16fa32231e2ccd89d2804b3f765319128b20c4ac_GH0.tar.gz) = 3807ae6a1e451a29f068540472f100f9718d457c60ac62f2f8469d1d57475d39
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- chrome/browser/policy/configuration_policy_handler_list_factory.cc.orig 2023-05-25 00:41:43 UTC
|
||||
--- chrome/browser/policy/configuration_policy_handler_list_factory.cc.orig 2023-07-21 06:38:11 UTC
|
||||
+++ chrome/browser/policy/configuration_policy_handler_list_factory.cc
|
||||
@@ -206,12 +206,12 @@
|
||||
#include "components/spellcheck/browser/pref_names.h"
|
||||
|
@ -32,8 +32,8 @@
|
|||
{ key::kFullscreenAllowed,
|
||||
prefs::kFullscreenAllowed,
|
||||
base::Value::Type::BOOLEAN },
|
||||
@@ -1431,7 +1431,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
base::Value::Type::BOOLEAN },
|
||||
@@ -1434,7 +1434,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
base::Value::Type::INTEGER },
|
||||
#endif // BUILDFLAG(IS_CHROMEOS_ASH)
|
||||
|
||||
-#if BUILDFLAG(IS_LINUX)
|
||||
|
@ -41,7 +41,7 @@
|
|||
{ key::kGSSAPILibraryName,
|
||||
prefs::kGSSAPILibraryName,
|
||||
base::Value::Type::STRING },
|
||||
@@ -1501,18 +1501,18 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
@@ -1504,18 +1504,18 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
prefs::kTotalMemoryLimitMb,
|
||||
base::Value::Type::INTEGER },
|
||||
#endif // BUILDFLAG(IS_WIN) || BUILDFLAG(IS_MAC)
|
||||
|
@ -63,7 +63,7 @@
|
|||
{ key::kDefaultBrowserSettingEnabled,
|
||||
prefs::kDefaultBrowserSettingEnabled,
|
||||
base::Value::Type::BOOLEAN },
|
||||
@@ -1525,7 +1525,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
@@ -1528,7 +1528,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
#endif // BUILDFLAG(IS_WIN) || BUILDFLAG(IS_MAC) || BUILDFLAG(IS_LINUX)
|
||||
// || BUILDFLAG(IS_FUCHSIA)
|
||||
#if BUILDFLAG(IS_WIN) || BUILDFLAG(IS_MAC) || BUILDFLAG(IS_LINUX) \
|
||||
|
@ -72,7 +72,7 @@
|
|||
{ key::kAutoplayAllowed,
|
||||
prefs::kAutoplayAllowed,
|
||||
base::Value::Type::BOOLEAN },
|
||||
@@ -1629,7 +1629,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
@@ -1632,7 +1632,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
base::Value::Type::BOOLEAN },
|
||||
#endif // !BUILDFLAG(IS_ANDROID) && !BUILDFLAG(IS_CHROMEOS)
|
||||
|
||||
|
@ -81,7 +81,7 @@
|
|||
{ key::kAlternativeBrowserPath,
|
||||
browser_switcher::prefs::kAlternativeBrowserPath,
|
||||
base::Value::Type::STRING },
|
||||
@@ -1725,13 +1725,13 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
@@ -1728,13 +1728,13 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
base::Value::Type::BOOLEAN },
|
||||
#endif // BUILDFLAG(IS_CHROMEOS)
|
||||
|
||||
|
@ -97,7 +97,7 @@
|
|||
{ key::kAuthNegotiateDelegateByKdcPolicy,
|
||||
prefs::kAuthNegotiateDelegateByKdcPolicy,
|
||||
base::Value::Type::BOOLEAN },
|
||||
@@ -1762,7 +1762,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
@@ -1765,7 +1765,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
#endif // BUILDFLAG(CHROME_ROOT_STORE_POLICY_SUPPORTED)
|
||||
|
||||
#if BUILDFLAG(IS_WIN) || BUILDFLAG(IS_MAC) || BUILDFLAG(IS_LINUX) || \
|
||||
|
@ -106,7 +106,7 @@
|
|||
{ key::kEnforceLocalAnchorConstraintsEnabled,
|
||||
prefs::kEnforceLocalAnchorConstraintsEnabled,
|
||||
base::Value::Type::BOOLEAN },
|
||||
@@ -1844,7 +1844,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
@@ -1847,7 +1847,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
ash::prefs::kUrlParameterToAutofillSAMLUsername,
|
||||
base::Value::Type::STRING },
|
||||
#endif // BUILDFLAG(IS_CHROMEOS_ASH)
|
||||
|
@ -115,7 +115,7 @@
|
|||
{ key::kHighEfficiencyModeEnabled,
|
||||
performance_manager::user_tuning::prefs::kHighEfficiencyModeEnabled,
|
||||
base::Value::Type::BOOLEAN },
|
||||
@@ -1889,7 +1889,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
@@ -1892,7 +1892,7 @@ const PolicyToPreferenceMapEntry kSimplePolicyMap[] =
|
||||
policy::policy_prefs::kForceEnablePepperVideoDecoderDevAPI,
|
||||
base::Value::Type::BOOLEAN },
|
||||
#endif // BUILDFLAG(ENABLE_PPAPI)
|
||||
|
@ -124,7 +124,7 @@
|
|||
{ key::kOutOfProcessSystemDnsResolutionEnabled,
|
||||
prefs::kOutOfProcessSystemDnsResolutionEnabled,
|
||||
base::Value::Type::BOOLEAN },
|
||||
@@ -2156,7 +2156,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
@@ -2159,7 +2159,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
#endif // BUILDFLAG(IS_ANDROID)
|
||||
|
||||
#if BUILDFLAG(IS_WIN) || BUILDFLAG(IS_MAC) || BUILDFLAG(IS_LINUX) || \
|
||||
|
@ -133,7 +133,7 @@
|
|||
handlers->AddHandler(
|
||||
std::make_unique<enterprise_idle::IdleTimeoutPolicyHandler>());
|
||||
handlers->AddHandler(
|
||||
@@ -2213,7 +2213,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
@@ -2216,7 +2216,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
key::kBrowsingDataLifetime, browsing_data::prefs::kBrowsingDataLifetime,
|
||||
chrome_schema));
|
||||
|
||||
|
@ -142,7 +142,7 @@
|
|||
handlers->AddHandler(std::make_unique<LocalSyncPolicyHandler>());
|
||||
handlers->AddHandler(std::make_unique<ThemeColorPolicyHandler>());
|
||||
#endif // BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_MAC) || BUILDFLAG(IS_WIN)
|
||||
@@ -2248,7 +2248,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
@@ -2251,7 +2251,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
std::vector<std::unique_ptr<ConfigurationPolicyHandler>>
|
||||
signin_legacy_policies;
|
||||
#if BUILDFLAG(IS_ANDROID) || BUILDFLAG(IS_MAC) || BUILDFLAG(IS_WIN) || \
|
||||
|
@ -151,7 +151,7 @@
|
|||
signin_legacy_policies.push_back(std::make_unique<SimplePolicyHandler>(
|
||||
key::kForceBrowserSignin, prefs::kForceBrowserSignin,
|
||||
base::Value::Type::BOOLEAN));
|
||||
@@ -2604,7 +2604,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
@@ -2607,7 +2607,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
#endif
|
||||
|
||||
#if BUILDFLAG(ENABLE_SPELLCHECK)
|
||||
|
@ -160,7 +160,7 @@
|
|||
handlers->AddHandler(std::make_unique<SpellcheckLanguagePolicyHandler>());
|
||||
handlers->AddHandler(
|
||||
std::make_unique<SpellcheckLanguageBlocklistPolicyHandler>(
|
||||
@@ -2612,7 +2612,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
@@ -2615,7 +2615,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
#endif // BUILDFLAG(IS_CHROMEOS) || BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_WIN)
|
||||
#endif // BUILDFLAG(ENABLE_SPELLCHECK)
|
||||
|
||||
|
@ -169,7 +169,7 @@
|
|||
handlers->AddHandler(std::make_unique<SimplePolicyHandler>(
|
||||
key::kAllowSystemNotifications, prefs::kAllowSystemNotifications,
|
||||
base::Value::Type::BOOLEAN));
|
||||
@@ -2625,7 +2625,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
@@ -2628,7 +2628,7 @@ std::unique_ptr<ConfigurationPolicyHandlerList> BuildH
|
||||
handlers->AddHandler(
|
||||
std::make_unique<first_party_sets::FirstPartySetsOverridesPolicyHandler>(
|
||||
chrome_schema));
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- electron/shell/browser/api/electron_api_desktop_capturer.cc.orig 2023-03-08 02:34:17 UTC
|
||||
--- electron/shell/browser/api/electron_api_desktop_capturer.cc.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/shell/browser/api/electron_api_desktop_capturer.cc
|
||||
@@ -36,7 +36,7 @@
|
||||
#include "third_party/webrtc/modules/desktop_capture/win/dxgi_duplicator_controller.h"
|
||||
|
@ -18,7 +18,7 @@
|
|||
// Private function in ui/base/x/x11_display_util.cc
|
||||
std::map<x11::RandR::Output, int> GetMonitors(int version,
|
||||
x11::RandR* randr,
|
||||
@@ -296,7 +296,7 @@ void DesktopCapturer::UpdateSourcesList(DesktopMediaLi
|
||||
@@ -348,7 +348,7 @@ void DesktopCapturer::UpdateSourcesList(DesktopMediaLi
|
||||
for (auto& source : screen_sources) {
|
||||
source.display_id = base::NumberToString(source.media_list_source.id.id);
|
||||
}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- electron/shell/browser/api/electron_api_web_contents.cc.orig 2023-06-14 06:17:49 UTC
|
||||
--- electron/shell/browser/api/electron_api_web_contents.cc.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/shell/browser/api/electron_api_web_contents.cc
|
||||
@@ -153,11 +153,11 @@
|
||||
@@ -154,11 +154,11 @@
|
||||
#include "ui/base/cocoa/defaults_utils.h"
|
||||
#endif
|
||||
|
||||
|
@ -14,7 +14,7 @@
|
|||
#include "ui/gfx/font_render_params.h"
|
||||
#endif
|
||||
|
||||
@@ -519,7 +519,7 @@ absl::optional<base::TimeDelta> GetCursorBlinkInterval
|
||||
@@ -520,7 +520,7 @@ absl::optional<base::TimeDelta> GetCursorBlinkInterval
|
||||
ui::TextInsertionCaretBlinkPeriodFromDefaults());
|
||||
if (system_value)
|
||||
return *system_value;
|
||||
|
@ -23,7 +23,7 @@
|
|||
if (auto* linux_ui = ui::LinuxUi::instance())
|
||||
return linux_ui->GetCursorBlinkInterval();
|
||||
#elif BUILDFLAG(IS_WIN)
|
||||
@@ -989,7 +989,7 @@ void WebContents::InitWithSessionAndOptions(
|
||||
@@ -975,7 +975,7 @@ void WebContents::InitWithSessionAndOptions(
|
||||
accept_languages.pop_back();
|
||||
prefs->accept_languages = accept_languages;
|
||||
|
||||
|
@ -32,7 +32,7 @@
|
|||
// Update font settings.
|
||||
static const gfx::FontRenderParams params(
|
||||
gfx::GetFontRenderParams(gfx::FontRenderParamsQuery(), nullptr));
|
||||
@@ -2639,7 +2639,7 @@ void WebContents::ForcefullyCrashRenderer() {
|
||||
@@ -2627,7 +2627,7 @@ void WebContents::ForcefullyCrashRenderer() {
|
||||
|
||||
content::RenderProcessHost* rph = rwh->GetProcess();
|
||||
if (rph) {
|
||||
|
@ -41,7 +41,7 @@
|
|||
// A generic |CrashDumpHungChildProcess()| is not implemented for Linux.
|
||||
// Instead we send an explicit IPC to crash on the renderer's IO thread.
|
||||
rph->ForceCrash();
|
||||
@@ -3310,7 +3310,7 @@ void WebContents::CopyImageAt(int x, int y) {
|
||||
@@ -3298,7 +3298,7 @@ void WebContents::CopyImageAt(int x, int y) {
|
||||
void WebContents::Focus() {
|
||||
// Focusing on WebContents does not automatically focus the window on macOS
|
||||
// and Linux, do it manually to match the behavior on Windows.
|
||||
|
@ -50,7 +50,7 @@
|
|||
if (owner_window())
|
||||
owner_window()->Focus(true);
|
||||
#endif
|
||||
@@ -4122,7 +4122,7 @@ ui::ImageModel WebContents::GetDevToolsWindowIcon() {
|
||||
@@ -4112,7 +4112,7 @@ ui::ImageModel WebContents::GetDevToolsWindowIcon() {
|
||||
}
|
||||
#endif
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- electron/shell/browser/api/electron_api_web_contents.h.orig 2023-05-31 14:28:29 UTC
|
||||
--- electron/shell/browser/api/electron_api_web_contents.h.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/shell/browser/api/electron_api_web_contents.h
|
||||
@@ -727,7 +727,7 @@ class WebContents : public ExclusiveAccessContext,
|
||||
@@ -731,7 +731,7 @@ class WebContents : public ExclusiveAccessContext,
|
||||
#if defined(TOOLKIT_VIEWS) && !BUILDFLAG(IS_MAC)
|
||||
ui::ImageModel GetDevToolsWindowIcon() override;
|
||||
#endif
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- electron/shell/browser/electron_browser_main_parts.cc.orig 2023-05-31 14:28:29 UTC
|
||||
--- electron/shell/browser/electron_browser_main_parts.cc.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/shell/browser/electron_browser_main_parts.cc
|
||||
@@ -74,7 +74,7 @@
|
||||
#include "ui/wm/core/wm_state.h"
|
||||
|
@ -72,7 +72,7 @@
|
|||
auto* linux_ui = ui::GetDefaultLinuxUi();
|
||||
CHECK(linux_ui);
|
||||
linux_ui_getter_ = std::make_unique<LinuxUiGetterImpl>();
|
||||
@@ -535,7 +535,7 @@ void ElectronBrowserMainParts::WillRunMainMessageLoop(
|
||||
@@ -537,7 +537,7 @@ void ElectronBrowserMainParts::WillRunMainMessageLoop(
|
||||
}
|
||||
|
||||
void ElectronBrowserMainParts::PostCreateMainMessageLoop() {
|
||||
|
@ -81,7 +81,7 @@
|
|||
std::string app_name = electron::Browser::Get()->GetName();
|
||||
#endif
|
||||
#if BUILDFLAG(IS_LINUX)
|
||||
@@ -545,7 +545,9 @@ void ElectronBrowserMainParts::PostCreateMainMessageLo
|
||||
@@ -547,7 +547,9 @@ void ElectronBrowserMainParts::PostCreateMainMessageLo
|
||||
std::move(shutdown_cb),
|
||||
content::GetUIThreadTaskRunner({content::BrowserTaskType::kUserInput}));
|
||||
bluez::DBusBluezManagerWrapperLinux::Initialize();
|
||||
|
@ -91,7 +91,7 @@
|
|||
// Set up crypt config. This needs to be done before anything starts the
|
||||
// network service, as the raw encryption key needs to be shared with the
|
||||
// network service for encrypted cookie storage.
|
||||
@@ -637,7 +639,7 @@ void ElectronBrowserMainParts::PostMainMessageLoopRun(
|
||||
@@ -639,7 +641,7 @@ void ElectronBrowserMainParts::PostMainMessageLoopRun(
|
||||
fake_browser_process_->PostMainMessageLoopRun();
|
||||
content::DevToolsAgentHost::StopRemoteDebuggingPipeHandler();
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- electron/shell/browser/native_window.cc.orig 2023-02-06 19:29:11 UTC
|
||||
--- electron/shell/browser/native_window.cc.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/shell/browser/native_window.cc
|
||||
@@ -196,7 +196,7 @@ void NativeWindow::InitFromOptions(const gin_helper::D
|
||||
@@ -197,7 +197,7 @@ void NativeWindow::InitFromOptions(const gin_helper::D
|
||||
} else {
|
||||
SetSizeConstraints(size_constraints);
|
||||
}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- electron/shell/browser/native_window_views.cc.orig 2023-06-14 06:17:49 UTC
|
||||
--- electron/shell/browser/native_window_views.cc.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/shell/browser/native_window_views.cc
|
||||
@@ -42,7 +42,7 @@
|
||||
@@ -43,7 +43,7 @@
|
||||
#include "ui/wm/core/shadow_types.h"
|
||||
#include "ui/wm/core/window_util.h"
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
#include "base/strings/string_util.h"
|
||||
#include "shell/browser/browser.h"
|
||||
#include "shell/browser/linux/unity_service.h"
|
||||
@@ -276,7 +276,7 @@ NativeWindowViews::NativeWindowViews(const gin_helper:
|
||||
@@ -277,7 +277,7 @@ NativeWindowViews::NativeWindowViews(const gin_helper:
|
||||
params.parent = parent->GetNativeWindow();
|
||||
|
||||
params.native_widget = new ElectronDesktopNativeWidgetAura(this);
|
||||
|
@ -18,7 +18,7 @@
|
|||
std::string name = Browser::Get()->GetName();
|
||||
// Set WM_WINDOW_ROLE.
|
||||
params.wm_role_name = "browser-window";
|
||||
@@ -301,7 +301,7 @@ NativeWindowViews::NativeWindowViews(const gin_helper:
|
||||
@@ -302,7 +302,7 @@ NativeWindowViews::NativeWindowViews(const gin_helper:
|
||||
std::string window_type;
|
||||
options.Get(options::kType, &window_type);
|
||||
|
||||
|
@ -27,7 +27,7 @@
|
|||
// Set _GTK_THEME_VARIANT to dark if we have "dark-theme" option set.
|
||||
bool use_dark_theme = false;
|
||||
if (options.Get(options::kDarkTheme, &use_dark_theme) && use_dark_theme) {
|
||||
@@ -403,7 +403,7 @@ NativeWindowViews::NativeWindowViews(const gin_helper:
|
||||
@@ -404,7 +404,7 @@ NativeWindowViews::NativeWindowViews(const gin_helper:
|
||||
if (window)
|
||||
window->AddPreTargetHandler(this);
|
||||
|
||||
|
@ -36,7 +36,7 @@
|
|||
// On linux after the widget is initialized we might have to force set the
|
||||
// bounds if the bounds are smaller than the current display
|
||||
SetBounds(gfx::Rect(GetPosition(), bounds.size()), false);
|
||||
@@ -563,7 +563,7 @@ bool NativeWindowViews::IsVisible() {
|
||||
@@ -564,7 +564,7 @@ bool NativeWindowViews::IsVisible() {
|
||||
bool NativeWindowViews::IsEnabled() {
|
||||
#if BUILDFLAG(IS_WIN)
|
||||
return ::IsWindowEnabled(GetAcceleratedWidget());
|
||||
|
@ -45,7 +45,7 @@
|
|||
#if defined(USE_OZONE_PLATFORM_X11)
|
||||
if (IsX11())
|
||||
return !event_disabler_.get();
|
||||
@@ -621,7 +621,7 @@ void NativeWindowViews::SetEnabledInternal(bool enable
|
||||
@@ -622,7 +622,7 @@ void NativeWindowViews::SetEnabledInternal(bool enable
|
||||
#endif
|
||||
}
|
||||
|
||||
|
@ -54,7 +54,7 @@
|
|||
void NativeWindowViews::Maximize() {
|
||||
if (IsVisible()) {
|
||||
widget()->Maximize();
|
||||
@@ -752,7 +752,7 @@ void NativeWindowViews::SetBounds(const gfx::Rect& bou
|
||||
@@ -753,7 +753,7 @@ void NativeWindowViews::SetBounds(const gfx::Rect& bou
|
||||
}
|
||||
#endif
|
||||
|
||||
|
@ -63,7 +63,7 @@
|
|||
// On Linux and Windows the minimum and maximum size should be updated with
|
||||
// window size when window is not resizable.
|
||||
if (!resizable_) {
|
||||
@@ -988,7 +988,7 @@ bool NativeWindowViews::IsClosable() {
|
||||
@@ -989,7 +989,7 @@ bool NativeWindowViews::IsClosable() {
|
||||
return false;
|
||||
}
|
||||
return !(info.fState & MFS_DISABLED);
|
||||
|
@ -72,7 +72,7 @@
|
|||
return true;
|
||||
#endif
|
||||
}
|
||||
@@ -1376,7 +1376,7 @@ void NativeWindowViews::SetProgressBar(double progress
|
||||
@@ -1377,7 +1377,7 @@ void NativeWindowViews::SetProgressBar(double progress
|
||||
NativeWindow::ProgressState state) {
|
||||
#if BUILDFLAG(IS_WIN)
|
||||
taskbar_host_.SetProgressBar(GetAcceleratedWidget(), progress, state);
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- electron/shell/common/api/electron_api_clipboard.cc.orig 2023-01-24 16:58:16 UTC
|
||||
--- electron/shell/common/api/electron_api_clipboard.cc.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/shell/common/api/electron_api_clipboard.cc
|
||||
@@ -54,7 +54,7 @@ std::string Clipboard::Read(const std::string& format_
|
||||
@@ -55,7 +55,7 @@ std::string Clipboard::Read(const std::string& format_
|
||||
ui::ClipboardFormatType::CustomPlatformType(format_string));
|
||||
bool rawFormatAvailable = clipboard->IsFormatAvailable(
|
||||
rawFormat, ui::ClipboardBuffer::kCopyPaste, /* data_dst = */ nullptr);
|
||||
|
@ -9,12 +9,12 @@
|
|||
if (!rawFormatAvailable) {
|
||||
rawFormatAvailable = clipboard->IsFormatAvailable(
|
||||
rawFormat, ui::ClipboardBuffer::kSelection, /* data_dst = */ nullptr);
|
||||
@@ -70,7 +70,7 @@ std::string Clipboard::Read(const std::string& format_
|
||||
@@ -71,7 +71,7 @@ std::string Clipboard::Read(const std::string& format_
|
||||
custom_format_names =
|
||||
clipboard->ExtractCustomPlatformNames(ui::ClipboardBuffer::kCopyPaste,
|
||||
/* data_dst = */ nullptr);
|
||||
-#if BUILDFLAG(IS_LINUX)
|
||||
+#if BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_BSD)
|
||||
if (custom_format_names.find(format_string) == custom_format_names.end()) {
|
||||
if (!base::Contains(custom_format_names, format_string)) {
|
||||
custom_format_names =
|
||||
clipboard->ExtractCustomPlatformNames(ui::ClipboardBuffer::kSelection,
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- electron/spec/api-browser-window-spec.ts.orig 2023-06-20 12:38:26 UTC
|
||||
--- electron/spec/api-browser-window-spec.ts.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/spec/api-browser-window-spec.ts
|
||||
@@ -61,7 +61,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -65,7 +65,7 @@ describe('BrowserWindow module', () => {
|
||||
}).not.to.throw();
|
||||
});
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
const appPath = path.join(fixtures, 'apps', 'xwindow-icon');
|
||||
const appProcess = childProcess.spawn(process.execPath, [appPath]);
|
||||
await once(appProcess, 'exit');
|
||||
@@ -1097,7 +1097,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -1101,7 +1101,7 @@ describe('BrowserWindow module', () => {
|
||||
|
||||
describe('BrowserWindow.minimize()', () => {
|
||||
// TODO(codebytere): Enable for Linux once maximize/minimize events work in CI.
|
||||
|
@ -18,7 +18,7 @@
|
|||
const minimize = once(w, 'minimize');
|
||||
w.minimize();
|
||||
await minimize;
|
||||
@@ -1114,7 +1114,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -1118,7 +1118,7 @@ describe('BrowserWindow module', () => {
|
||||
});
|
||||
|
||||
// TODO(dsanders11): Enable for Linux once CI plays nice with these kinds of tests
|
||||
|
@ -27,7 +27,7 @@
|
|||
const maximize = once(w, 'maximize');
|
||||
const shown = once(w, 'show');
|
||||
w.maximize();
|
||||
@@ -1151,7 +1151,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -1155,7 +1155,7 @@ describe('BrowserWindow module', () => {
|
||||
expect(w.isFocused()).to.equal(true);
|
||||
});
|
||||
|
||||
|
@ -36,7 +36,7 @@
|
|||
const w1 = new BrowserWindow({ show: false });
|
||||
const w2 = new BrowserWindow({ show: false });
|
||||
const w3 = new BrowserWindow({ show: false });
|
||||
@@ -1218,7 +1218,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -1222,7 +1222,7 @@ describe('BrowserWindow module', () => {
|
||||
expect(w.isFocused()).to.equal(false);
|
||||
});
|
||||
|
||||
|
@ -45,7 +45,7 @@
|
|||
const w1 = new BrowserWindow({ show: false });
|
||||
const w2 = new BrowserWindow({ show: false });
|
||||
const w3 = new BrowserWindow({ show: false });
|
||||
@@ -1618,7 +1618,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -1622,7 +1622,7 @@ describe('BrowserWindow module', () => {
|
||||
});
|
||||
});
|
||||
|
||||
|
@ -54,7 +54,7 @@
|
|||
it('checks normal bounds when maximized', async () => {
|
||||
const bounds = w.getBounds();
|
||||
const maximize = once(w, 'maximize');
|
||||
@@ -1798,7 +1798,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -1802,7 +1802,7 @@ describe('BrowserWindow module', () => {
|
||||
});
|
||||
});
|
||||
|
||||
|
@ -63,7 +63,7 @@
|
|||
it('checks normal bounds when minimized', async () => {
|
||||
const bounds = w.getBounds();
|
||||
const minimize = once(w, 'minimize');
|
||||
@@ -2764,7 +2764,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -2768,7 +2768,7 @@ describe('BrowserWindow module', () => {
|
||||
describe('BrowserWindow.setOpacity(opacity)', () => {
|
||||
afterEach(closeAllWindows);
|
||||
|
||||
|
@ -72,7 +72,7 @@
|
|||
it('make window with initial opacity', () => {
|
||||
const w = new BrowserWindow({ show: false, opacity: 0.5 });
|
||||
expect(w.getOpacity()).to.equal(0.5);
|
||||
@@ -2790,7 +2790,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -2794,7 +2794,7 @@ describe('BrowserWindow module', () => {
|
||||
});
|
||||
});
|
||||
|
||||
|
@ -81,7 +81,7 @@
|
|||
it('sets 1 regardless of parameter', () => {
|
||||
const w = new BrowserWindow({ show: false });
|
||||
w.setOpacity(0);
|
||||
@@ -3719,7 +3719,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -3723,7 +3723,7 @@ describe('BrowserWindow module', () => {
|
||||
expect(test.nodeTimers).to.equal(true);
|
||||
expect(test.nodeUrl).to.equal(true);
|
||||
|
||||
|
@ -90,7 +90,7 @@
|
|||
expect(test.creationTime).to.be.null('creation time');
|
||||
expect(test.systemMemoryInfo).to.be.null('system memory info');
|
||||
} else {
|
||||
@@ -4225,7 +4225,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -4229,7 +4229,7 @@ describe('BrowserWindow module', () => {
|
||||
});
|
||||
});
|
||||
|
||||
|
@ -99,7 +99,7 @@
|
|||
afterEach(closeAllWindows);
|
||||
it('emits an event when window is maximized', async () => {
|
||||
const w = new BrowserWindow({ show: false });
|
||||
@@ -4496,7 +4496,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -4500,7 +4500,7 @@ describe('BrowserWindow module', () => {
|
||||
// TODO(zcbenz):
|
||||
// This test does not run on Linux CI. See:
|
||||
// https://github.com/electron/electron/issues/28699
|
||||
|
@ -108,7 +108,7 @@
|
|||
const w = new BrowserWindow({});
|
||||
const maximize = once(w, 'maximize');
|
||||
w.maximize();
|
||||
@@ -4513,7 +4513,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -4517,7 +4517,7 @@ describe('BrowserWindow module', () => {
|
||||
});
|
||||
|
||||
// TODO(dsanders11): Enable once maximize event works on Linux again on CI
|
||||
|
@ -117,7 +117,7 @@
|
|||
afterEach(closeAllWindows);
|
||||
it('should show the window if it is not currently shown', async () => {
|
||||
const w = new BrowserWindow({ show: false });
|
||||
@@ -4550,7 +4550,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -4554,7 +4554,7 @@ describe('BrowserWindow module', () => {
|
||||
|
||||
// TODO(dsanders11): Enable once minimize event works on Linux again.
|
||||
// See https://github.com/electron/electron/issues/28699
|
||||
|
@ -126,7 +126,7 @@
|
|||
const w = new BrowserWindow();
|
||||
const minimize = once(w, 'minimize');
|
||||
w.minimize();
|
||||
@@ -4983,7 +4983,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -4987,7 +4987,7 @@ describe('BrowserWindow module', () => {
|
||||
});
|
||||
|
||||
// On Linux there is no "resizable" property of a window.
|
||||
|
@ -135,7 +135,7 @@
|
|||
const w = new BrowserWindow({ show: false });
|
||||
expect(w.resizable).to.be.true('resizable');
|
||||
|
||||
@@ -5073,7 +5073,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -5077,7 +5077,7 @@ describe('BrowserWindow module', () => {
|
||||
});
|
||||
});
|
||||
|
||||
|
@ -144,7 +144,7 @@
|
|||
// Not implemented on Linux.
|
||||
afterEach(closeAllWindows);
|
||||
|
||||
@@ -6179,7 +6179,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -6183,7 +6183,7 @@ describe('BrowserWindow module', () => {
|
||||
describe('"transparent" option', () => {
|
||||
afterEach(closeAllWindows);
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- electron/spec/api-menu-spec.ts.orig 2023-05-31 14:28:29 UTC
|
||||
--- electron/spec/api-menu-spec.ts.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/spec/api-menu-spec.ts
|
||||
@@ -882,7 +882,7 @@ describe('Menu module', function () {
|
||||
@@ -886,7 +886,7 @@ describe('Menu module', function () {
|
||||
// https://github.com/electron/electron/issues/35724
|
||||
// Maximizing window is enough to trigger the bug
|
||||
// FIXME(dsanders11): Test always passes on CI, even pre-fix
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- electron/spec/api-protocol-spec.ts.orig 2023-06-14 06:17:49 UTC
|
||||
--- electron/spec/api-protocol-spec.ts.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/spec/api-protocol-spec.ts
|
||||
@@ -1513,7 +1513,7 @@ describe('protocol module', () => {
|
||||
@@ -1534,7 +1534,7 @@ describe('protocol module', () => {
|
||||
});
|
||||
|
||||
// TODO(nornagon): this test doesn't pass on Linux currently, investigate.
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- electron/spec/api-tray-spec.ts.orig 2021-01-22 23:55:24 UTC
|
||||
--- electron/spec/api-tray-spec.ts.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/spec/api-tray-spec.ts
|
||||
@@ -125,7 +125,7 @@ describe('tray module', () => {
|
||||
@@ -129,7 +129,7 @@ describe('tray module', () => {
|
||||
describe('tray.getBounds()', () => {
|
||||
afterEach(() => { tray.destroy(); });
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- electron/spec/chromium-spec.ts.orig 2023-05-31 14:28:29 UTC
|
||||
--- electron/spec/chromium-spec.ts.orig 2023-07-19 13:20:24 UTC
|
||||
+++ electron/spec/chromium-spec.ts
|
||||
@@ -470,13 +470,13 @@ describe('command line switches', () => {
|
||||
it('should not set an invalid locale', async () => testLocale('asdfkl', `${currentLocale}|${currentSystemLocale}|${currentPreferredLanguages}`));
|
||||
|
@ -18,7 +18,7 @@
|
|||
});
|
||||
|
||||
describe('--remote-debugging-pipe switch', () => {
|
||||
@@ -2283,12 +2283,12 @@ describe('font fallback', () => {
|
||||
@@ -2324,12 +2324,12 @@ describe('font fallback', () => {
|
||||
expect(fonts[0].familyName).to.equal('Arial');
|
||||
} else if (process.platform === 'darwin') {
|
||||
expect(fonts[0].familyName).to.equal('Helvetica');
|
||||
|
@ -33,7 +33,7 @@
|
|||
const html = `
|
||||
<html lang="ja-JP">
|
||||
<head>
|
||||
@@ -2682,7 +2682,7 @@ describe('navigator.clipboard.write', () => {
|
||||
@@ -2723,7 +2723,7 @@ describe('navigator.clipboard.write', () => {
|
||||
});
|
||||
});
|
||||
|
||||
|
|
Loading…
Reference in a new issue