Add njam 1.00, fast paced multiplayer pac-man clone.
PR: 59284 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>
This commit is contained in:
parent
df46065807
commit
c15363157b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94038
6 changed files with 192 additions and 0 deletions
|
@ -275,6 +275,7 @@
|
|||
SUBDIR += nibbles
|
||||
SUBDIR += nighthawk
|
||||
SUBDIR += nil
|
||||
SUBDIR += njam
|
||||
SUBDIR += nonsense
|
||||
SUBDIR += nwnusers
|
||||
SUBDIR += oilwar
|
||||
|
|
37
games/njam/Makefile
Normal file
37
games/njam/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
# New ports collection makefile for: njam
|
||||
# Date created: 10 November 2003
|
||||
# Whom: <janos.mohacsi@bsd.hu>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= njam
|
||||
PORTVERSION= 1.00
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
||||
|
||||
MAINTAINER= janos.mohacsi@bsd.hu
|
||||
COMMENT= Fast paced multiplayer pac-man clone
|
||||
|
||||
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
|
||||
SDL_image.10:${PORTSDIR}/graphics/sdl_image \
|
||||
SDL_net.0:${PORTSDIR}/net/sdl_net
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_SDL= yes
|
||||
DOC_FILES= assassin.gif award-2.gif cookie.gif doc-editor.html \
|
||||
doc.html doc2.html door.gif freezer.gif ghactive.gif \
|
||||
ghinactive.gif hunter.gif invisible.gif juice.gif \
|
||||
sample.gif shaddy.gif skin000.gif skin001.gif skin003.gif \
|
||||
teleport.gif thinline.gif trap.gif
|
||||
|
||||
post-install:
|
||||
.ifndef(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/html/* ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/njam/distinfo
Normal file
1
games/njam/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (njam-1.00-src.tar.gz) = 88b276a1334477295fc3ba3cc44e05fd
|
65
games/njam/files/patch-Makefile
Normal file
65
games/njam/files/patch-Makefile
Normal file
|
@ -0,0 +1,65 @@
|
|||
--- Makefile.orig Fri Oct 17 01:16:56 2003
|
||||
+++ Makefile Sat Nov 15 19:28:16 2003
|
||||
@@ -20,7 +20,7 @@
|
||||
|
||||
# directory where the games are installed (/usr, /usr/local, ... or something)
|
||||
ifndef PREFIX
|
||||
-PREFIX=/usr
|
||||
+PREFIX=/usr/local
|
||||
endif
|
||||
|
||||
PROGRAM = njam
|
||||
@@ -29,15 +29,15 @@
|
||||
|
||||
# If you hate warnings under Cygwin use these flags instead
|
||||
# MY_CFLAGS = -I/usr/local/include/SDL -Dmain=SDL_main -DWIN32 -Uunix -mno-cygwin
|
||||
-MY_CFLAGS = `sdl-config --cflags`
|
||||
+MY_CFLAGS += `sdl11-config --cflags`
|
||||
|
||||
%.o: %.cpp
|
||||
- $(CC) -O3 -c $(MY_CFLAGS) $< -o $@
|
||||
+ $(CC) -c $(MY_CFLAGS) $< -o $@
|
||||
|
||||
all: $(PROGRAM)
|
||||
|
||||
$(PROGRAM): $(OBJECTS)
|
||||
- $(CC) `sdl-config --libs` -o$(PROGRAM) $(OBJECTS) -lSDL -lSDL_mixer -lSDL_net -lSDL_image
|
||||
+ $(CC) `sdl11-config --libs` -o$(PROGRAM) $(OBJECTS) -lSDL_mixer -lSDL_net -lSDL_image
|
||||
|
||||
clean:
|
||||
$(RM) *.o
|
||||
@@ -45,25 +45,15 @@
|
||||
$(RM) $(PROGRAM).exe
|
||||
|
||||
install:
|
||||
- mkdir -m 755 -p $(PREFIX)/games/njam
|
||||
- mkdir -m 755 -p $(PREFIX)/games/njam/data
|
||||
- mkdir -m 755 -p $(PREFIX)/games/njam/skins
|
||||
- mkdir -m 755 -p $(PREFIX)/games/njam/html
|
||||
- mkdir -m 755 -p $(PREFIX)/games/njam/levels
|
||||
- install -o root -g games -m 755 njam $(PREFIX)/games/njam
|
||||
- install -o root -g games -m 644 data/* $(PREFIX)/games/njam/data
|
||||
- install -o root -g games -m 644 skins/* $(PREFIX)/games/njam/skins
|
||||
- install -o root -g games -m 644 html/* $(PREFIX)/games/njam/html
|
||||
- install -o root -g games -m 6777 levels/* $(PREFIX)/games/njam/levels
|
||||
- echo '#!/bin/sh' > /usr/bin/njam
|
||||
- echo '$(PREFIX)/games/njam/njam $$1' >> /usr/bin/njam
|
||||
- chmod 755 /usr/bin/njam
|
||||
- @echo
|
||||
- @echo ------------------ Install completed ------------------------------
|
||||
- @echo Type \"njam\" to play the game.
|
||||
- @echo You can link \"$(PREFIX)/games/njam/njam\" into menus/toolbars.
|
||||
- @echo -------------------------------------------------------------------
|
||||
- @echo
|
||||
+ mkdir -m 755 -p $(PREFIX)/share/njam
|
||||
+ mkdir -m 755 -p $(PREFIX)/share/njam/data
|
||||
+ mkdir -m 755 -p $(PREFIX)/share/njam/skins
|
||||
+ mkdir -m 755 -p $(PREFIX)/share/njam/levels
|
||||
+ install -o root -g games -m 755 njam $(PREFIX)/share/njam
|
||||
+ install -o root -g games -m 644 data/* $(PREFIX)/share/njam/data
|
||||
+ install -o root -g games -m 644 skins/* $(PREFIX)/share/njam/skins
|
||||
+ install -o root -g games -m 644 levels/* $(PREFIX)/share/njam/levels
|
||||
+ ln -s $(PREFIX)/share/njam/njam $(PREFIX)/bin/njam
|
||||
|
||||
uninstall:
|
||||
rm -rf $(PREFIX)/games/njam
|
15
games/njam/pkg-descr
Normal file
15
games/njam/pkg-descr
Normal file
|
@ -0,0 +1,15 @@
|
|||
Njam is fast-paced cross-platform pac-man-like game. In this arcade you
|
||||
move through the maze eating cookies and collecting powerups while trying
|
||||
to avoid ghosts who chase you.
|
||||
Features:
|
||||
|
||||
* Single and multiplayer mode (local or network)
|
||||
* Duel mode (players compete each other to get more points)
|
||||
* Non-duel mode (players cooperate to finish as many levels as they can)
|
||||
* Great music and sound effects
|
||||
* Customizable level skins
|
||||
* Many different levels
|
||||
* Integrated level editor
|
||||
* Open Source (GPL Licence)
|
||||
|
||||
WWW: http://njam.sourceforge.net/
|
73
games/njam/pkg-plist
Normal file
73
games/njam/pkg-plist
Normal file
|
@ -0,0 +1,73 @@
|
|||
bin/njam
|
||||
share/njam/data/ORIGINAL.COOP
|
||||
share/njam/data/ORIGINAL.DUEL
|
||||
share/njam/data/bonus.wav
|
||||
share/njam/data/dali.xm
|
||||
share/njam/data/dead.wav
|
||||
share/njam/data/dead2.wav
|
||||
share/njam/data/dead3.wav
|
||||
share/njam/data/enter-ip.jpg
|
||||
share/njam/data/font-blue.bmp
|
||||
share/njam/data/font-yellow.bmp
|
||||
share/njam/data/freeze.wav
|
||||
share/njam/data/gameover.jpg
|
||||
share/njam/data/hiscore.jpg
|
||||
share/njam/data/invisible.wav
|
||||
share/njam/data/juice.wav
|
||||
share/njam/data/kill.wav
|
||||
share/njam/data/kill2.wav
|
||||
share/njam/data/kill3.wav
|
||||
share/njam/data/killply.wav
|
||||
share/njam/data/levelset.jpg
|
||||
share/njam/data/mainmenu.jpg
|
||||
share/njam/data/mapend.wav
|
||||
share/njam/data/mapend2.wav
|
||||
share/njam/data/netsend.jpg
|
||||
share/njam/data/network.bmp
|
||||
share/njam/data/njamicon.bmp
|
||||
share/njam/data/options.jpg
|
||||
share/njam/data/ritam.s3m
|
||||
share/njam/data/satisfy.xm
|
||||
share/njam/data/script.txt
|
||||
share/njam/data/sprites.bmp
|
||||
share/njam/data/stats.jpg
|
||||
share/njam/data/teleport.wav
|
||||
share/njam/data/trapdoor.wav
|
||||
share/njam/data/tripleding.wav
|
||||
share/njam/data/win1.jpg
|
||||
share/njam/data/win2.jpg
|
||||
share/njam/data/win3.jpg
|
||||
share/njam/data/win4.jpg
|
||||
share/njam/levels/ORIGINAL.COOP
|
||||
share/njam/levels/ORIGINAL.DUEL
|
||||
share/njam/njam
|
||||
share/njam/skins/Back000.bmp
|
||||
share/njam/skins/Back001.bmp
|
||||
share/njam/skins/Back002.bmp
|
||||
@dirrm share/njam/data
|
||||
@dirrm share/njam/levels
|
||||
@dirrm share/njam/skins
|
||||
@dirrm share/njam
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/assassin.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/award-2.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cookie.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-editor.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc2.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/door.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/freezer.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ghactive.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ghinactive.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/hunter.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/invisible.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/juice.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sample.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/shaddy.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/skin000.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/skin001.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/skin003.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/teleport.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/thinline.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/trap.gif
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue