www/py-pyocclient: Update to 0.6

PR:		251393
Approved by:	lwhsu
This commit is contained in:
Guangyuan Yang 2020-12-19 04:09:27 +00:00
parent b28873f0e4
commit c17ee23cbf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=558429
3 changed files with 4 additions and 34 deletions

View file

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= pyocclient
PORTVERSION= 0.4
PORTVERSION= 0.6
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1512341546
SHA256 (pyocclient-0.4.tar.gz) = d8604f32cf10497a06e57b163b5f9c9bbe2e874a3606c39beeb1453133d563a6
SIZE (pyocclient-0.4.tar.gz) = 24285
TIMESTAMP = 1606367296
SHA256 (pyocclient-0.6.tar.gz) = a33ddcbbd2ec22d9bc7d76b71dd77896c557221153d1428759780b5fb8fe8fa3
SIZE (pyocclient-0.6.tar.gz) = 28995

View file

@ -1,30 +0,0 @@
Fix reading of utf-8 formatted files in setup script and fix build
with Python 3.x.
https://github.com/owncloud/pyocclient/commit/aa6b4374a779bf0f9e060117b2e8d1e810342bc8
--- setup.py.orig 2017-01-26 05:22:41 UTC
+++ setup.py
@@ -3,18 +3,19 @@
# vim: expandtab shiftwidth=4 softtabstop=4
#
from setuptools import setup
+import io
version = '0.4'
long_description = (
- open('README.rst').read()
+ io.open('README.rst', encoding='utf-8').read()
+ '\n' +
'Contributors\n'
'============\n'
+ '\n' +
- open('docs/source/CONTRIBUTORS.rst').read()
+ io.open('docs/source/CONTRIBUTORS.rst', encoding='utf-8').read()
+ '\n' +
- open('CHANGES.rst').read()
+ io.open('CHANGES.rst', encoding='utf-8').read()
+ '\n')
setup(