Update to 1.3.2 && change MAINTAINER.

PR:		21643
Submitted by:	Jeremy Shaffner <jeremy@external.org> (new MAINTAINER)
This commit is contained in:
Will Andrews 2000-09-30 00:39:20 +00:00
parent ec33bec011
commit c19e9bbcd8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33258
8 changed files with 151 additions and 26 deletions

View file

@ -6,34 +6,47 @@
#
PORTNAME= e93
PORTVERSION= 1.2.7
CATEGORIES= editors tcl82
PORTVERSION= 1.3.2
CATEGORIES= editors tcl82 tk82
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= editors
DISTNAME= ${PORTNAME}-1.2r7X
DISTNAME= ${PORTNAME}-1.3r2X
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
MAINTAINER= jeremy@external.org
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82 \
tk82.1:${PORTSDIR}/x11-toolkits/tk82
MAKEFILE= makefile
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
NO_CDROM= "Asks a question about reading the license on install"
.if !defined(PACKAGE_BUILDING)
IS_INTERACTIVE= yes # asks "ok?" about license
pre-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/REQ ${PKGNAME} INSTALL
.endif
do-install:
${MKDIR} ${PREFIX}/lib/e93 ${PREFIX}/share/doc/e93
${MKDIR} ${PREFIX}/share/doc/e93 ${PREFIX}/lib/e93lib/images \
${PREFIX}/lib/e93lib/highlightschemes \
${PREFIX}/lib/e93lib/modules \
${PREFIX}/lib/e93lib/syntaxmaps
(cd ${WRKSRC}; \
${INSTALL_PROGRAM} e93 ${PREFIX}/bin; \
${INSTALL_DATA} .e93rc ${PREFIX}/lib/e93; \
${INSTALL_DATA} LICENSE.TXT ${PREFIX}/share/doc/e93/LICENSE.TXT; \
${INSTALL_PROGRAM} e93 ${PREFIX}/bin; \
${INSTALL_SCRIPT} e93r ${PREFIX}/bin; \
${INSTALL_DATA} LICENSE.TXT ${PREFIX}/share/doc/e93; \
${INSTALL_DATA} README.e93 ${PREFIX}/share/doc/e93; \
${INSTALL_DATA} README.regex ${PREFIX}/share/doc/e93; \
${INSTALL_DATA} README.syntaxmaps ${PREFIX}/share/doc/e93; \
)
(cd ${WRKSRC}/e93lib; \
${INSTALL_DATA} e93rc.tcl ${PREFIX}/lib/e93lib; \
${INSTALL_DATA} images/about.ppm ${PREFIX}/lib/e93lib/images; \
${INSTALL_DATA} highlightschemes/schemes.tcl ${PREFIX}/lib/e93lib/highlightschemes; \
${INSTALL_DATA} modules/c.tcl ${PREFIX}/lib/e93lib/modules; \
${INSTALL_DATA} syntaxmaps/unknown.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
${INSTALL_DATA} syntaxmaps/asm.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
${INSTALL_DATA} syntaxmaps/html.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
${INSTALL_DATA} syntaxmaps/java.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
${INSTALL_DATA} syntaxmaps/tcl.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
${INSTALL_DATA} syntaxmaps/vhdl.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
${INSTALL_DATA} syntaxmaps/text.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
${INSTALL_DATA} syntaxmaps/c.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
)
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (e93-1.2r7X.tar.gz) = 8873614f47957d2736d49254a62a1b14
MD5 (e93-1.3r2X.tgz) = 21e07a5745cf7fb48fbaf0046cdd1bb9

View file

@ -0,0 +1,44 @@
--- machdef.mk.orig Fri Sep 29 02:47:44 2000
+++ machdef.mk Fri Sep 29 02:50:54 2000
@@ -27,33 +27,32 @@
#
# e93 will install its single executable "e93" in $PREFIX/bin
# and it will place a directory called "e93lib" in $PREFIX/lib
-PREFIX=/usr/local
# The following lines may need to be altered if the Tcl
# files are located elsewhere on your system:
-TCL_INCLUDE=-I/usr/local/include
-TCL_LIB=-L/usr/local/lib
+TCL_INCLUDE=-I${LOCALBASE}/include/tcl8.2
+TCL_LIB=-L${LOCALBASE}/lib
# uncomment and change if you want to link with specific versions of Tcl/Tk
-#TCL_VERSION=8.3
+TCL_VERSION=82
+TK_INCLUDE=-I${LOCALBASE}/include/tk8.2
# The following lines may need to be altered if the X include and library
# files are located elsewhere on your system:
-X_INCLUDE=-I/usr/X11R6/include
-X_LIB=-L/usr/X11R6/lib
+X_INCLUDE=-I${X11BASE}/include
+X_LIB=-L${X11BASE}/lib
# if your system needs some extra libraries, add them here:
-EXTRALIBS=-lm -ldl
+EXTRALIBS=-lm
# Uncomment this line if running Solaris:
#MACHINESPEC=-DSOLARIS
# set compiler to use
-CC=gcc
# set some compiler options
-OPTIONS=-O2 -Wall -x c++ -g
+OPTIONS=-Wall -x c++
#OPTIONS = -Wall -O2 -x c++ -mcpu=21164a -Wa,-m21164a -g

View file

@ -0,0 +1,11 @@
--- Makefile.orig Sun Sep 24 18:33:49 2000
+++ Makefile Sun Sep 24 18:34:49 2000
@@ -21,7 +21,7 @@
# Include machine/platform specific information
include machdef.mk
-CFLAGS=-I. $(TCL_INCLUDE) $(X_INCLUDE) $(OPTIONS) $(MACHINESPEC)
+CFLAGS+=-I. $(TCL_INCLUDE) ${TK_INCLUDE} $(X_INCLUDE) $(OPTIONS) $(MACHINESPEC)
OBJECTS = \
e93.o \

View file

@ -0,0 +1,11 @@
--- xgui/Makefile.orig Sun Sep 24 23:32:13 2000
+++ xgui/Makefile Sun Sep 24 23:32:30 2000
@@ -17,7 +17,7 @@
# Include machine/platform specific information into the build
include ../machdef.mk
-CFLAGS=-I. $(TCL_INCLUDE) $(X_INCLUDE) $(OPTIONS) $(MACHINESPEC) -DPREFIX=\"$(PREFIX)\"
+CFLAGS+=-I. $(TCL_INCLUDE) $(TK_INCLUDE) $(X_INCLUDE) $(OPTIONS) $(MACHINESPEC) -DPREFIX=\"$(PREFIX)\"
OBJECTS = \
globals.o \

View file

@ -0,0 +1,11 @@
--- e93r.orig Fri Sep 29 03:29:30 2000
+++ e93r Fri Sep 29 03:33:59 2000
@@ -25,7 +25,7 @@
# NOTE: you may have to adjust the wish to e.g. /usr/local/bin/wish8.3
# restart using wish \
-exec wish "$0" "$@"
+exec wish8.2 "$0" "$@"
# check presence of another e93
set e93present ""

View file

@ -1,6 +1,22 @@
This is e93-1.2.5rX, a nifty little editor based on Tcl/Tk.
e93 is a portable window based text editor oriented to the needs of
programmers. It was begun in 1993 (thus the name). It uses the mouse,
selections, cut/copy/paste, and closely follows the model of editors
on the Macintosh and NeXT platforms.
Note that this requires a .e93rc file in the user's home directory.
You can find this file in /usr/X11R6/lib/e93.
* e93 supports columnar selection. It achieves this by allowing multiple pieces
of the text to be selected simultaneously (this is perhaps its most unique
feature).
Satoshi
* e93 imposes no limits on the line length, file length, or number of
simultaneous files which it can edit.
* e93 is able to handle all 8-bit binary codes without complaint, or confusion.
* e93 is highly configurable without recompiling because scripts which control
the editor can be written in Tcl.
* e93 supports user-configurable syntax highlighting.
WWW: http://www.e93.org
- Jeremy Shaffner <jeremy@external.org>

View file

@ -1,5 +1,24 @@
bin/e93
lib/e93/.e93rc
bin/e93r
lib/e93lib/highlightschemes/schemes.tcl
lib/e93lib/modules/c.tcl
lib/e93lib/syntaxmaps/unknown.tcl
lib/e93lib/syntaxmaps/asm.tcl
lib/e93lib/syntaxmaps/html.tcl
lib/e93lib/syntaxmaps/java.tcl
lib/e93lib/syntaxmaps/tcl.tcl
lib/e93lib/syntaxmaps/vhdl.tcl
lib/e93lib/syntaxmaps/text.tcl
lib/e93lib/syntaxmaps/c.tcl
lib/e93lib/images/about.ppm
lib/e93lib/e93rc.tcl
share/doc/e93/README.e93
share/doc/e93/README.regex
share/doc/e93/README.syntaxmaps
share/doc/e93/LICENSE.TXT
@dirrm lib/e93
@dirrm lib/e93lib/highlightschemes
@dirrm lib/e93lib/modules
@dirrm lib/e93lib/syntaxmaps
@dirrm lib/e93lib/images
@dirrm lib/e93lib
@dirrm share/doc/e93