OSD Picture-in-Picture is a VDR PlugIn that displays the current channel in a small box on the screen (default upper right corner). You can switch up and down now, watching the progress of the previous channel in the box. Quality is not too good yet, and only I-Frames are displayed. WWW: http://projects.vdr-developer.org/projects/show/plg-osdpip
This commit is contained in:
parent
871aa3a299
commit
c1b0932491
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=271803
7 changed files with 95 additions and 0 deletions
|
@ -340,6 +340,7 @@
|
|||
SUBDIR += vdr-plugin-femon
|
||||
SUBDIR += vdr-plugin-infosatepg
|
||||
SUBDIR += vdr-plugin-iptv
|
||||
SUBDIR += vdr-plugin-osdpip
|
||||
SUBDIR += vic
|
||||
SUBDIR += vlc
|
||||
SUBDIR += vodcatcher
|
||||
|
|
38
multimedia/vdr-plugin-osdpip/Makefile
Normal file
38
multimedia/vdr-plugin-osdpip/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
# New ports collection makefile for: vdr-plugin-osdpip
|
||||
# Date created: Wed Apr 14 18:11:42 CEST 2010
|
||||
# Whom: Juergen Lock <nox@freebsd.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= vdr-plugin-osdpip
|
||||
PORTVERSION= 0.1.0
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://projects.vdr-developer.org/attachments/download/267/
|
||||
DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= nox@FreeBSD.org
|
||||
COMMENT= Video Disk Recorder - picture-in-picture plugin
|
||||
|
||||
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
|
||||
|
||||
DIST_SUBDIR= vdr
|
||||
PATCH_STRIP= -p1
|
||||
HAVE_CONFIGURE= yes
|
||||
PORTDOCS= COPYING README
|
||||
MAKE_JOBS_SAFE= yes
|
||||
WRKSRC= ${WRKDIR}/${PLUGIN}-${DISTVERSION}
|
||||
|
||||
.include "${.CURDIR}/../vdr/Makefile.plugins"
|
||||
|
||||
post-patch: post-patch-plugin
|
||||
|
||||
post-install: post-install-pluginlocales
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
multimedia/vdr-plugin-osdpip/distinfo
Normal file
2
multimedia/vdr-plugin-osdpip/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (vdr/vdr-osdpip-0.1.0.tgz) = 40f5e8acc57c82d922b0a415bb0f12ac3cb68c014f9bafd090b71ded6a25a821
|
||||
SIZE (vdr/vdr-osdpip-0.1.0.tgz) = 52090
|
9
multimedia/vdr-plugin-osdpip/files/patch-Makefile
Normal file
9
multimedia/vdr-plugin-osdpip/files/patch-Makefile
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- osdpip-0.1.0/Makefile.orig
|
||||
+++ osdpip-0.1.0/Makefile
|
||||
@@ -171,3 +173,6 @@ dist: clean
|
||||
|
||||
clean:
|
||||
@-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot
|
||||
+
|
||||
+install:
|
||||
+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
|
15
multimedia/vdr-plugin-osdpip/files/patch-vdr-osdpip-0.1.0
Normal file
15
multimedia/vdr-plugin-osdpip/files/patch-vdr-osdpip-0.1.0
Normal file
|
@ -0,0 +1,15 @@
|
|||
diff -ur orig/osdpip-0.1.0/Makefile osdpip-0.1.0/Makefile
|
||||
--- orig/osdpip-0.1.0/Makefile 2010-03-27 16:38:13.000000000 +0100
|
||||
+++ osdpip-0.1.0/Makefile 2010-03-29 09:35:59.000000000 +0200
|
||||
@@ -155,7 +155,11 @@
|
||||
|
||||
libvdr-$(PLUGIN).so: $(OBJS)
|
||||
$(CXX) $(CXXFLAGS) -shared -o $@ $^ $(LIBS)
|
||||
+ifdef FREEBSD
|
||||
+ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
|
||||
+else
|
||||
@cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
|
||||
+endif
|
||||
|
||||
dist: clean
|
||||
@-rm -rf $(TMPDIR)/$(ARCHIVE)
|
8
multimedia/vdr-plugin-osdpip/pkg-descr
Normal file
8
multimedia/vdr-plugin-osdpip/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
http://www.linuxtv.org/vdrwiki/index.php/Osdpip-plugin
|
||||
|
||||
OSD Picture-in-Picture is a VDR PlugIn that displays the current channel
|
||||
in a small box on the screen (default upper right corner). You can switch
|
||||
up and down now, watching the progress of the previous channel in the box.
|
||||
Quality is not too good yet, and only I-Frames are displayed.
|
||||
|
||||
WWW: http://projects.vdr-developer.org/projects/show/plg-osdpip
|
22
multimedia/vdr-plugin-osdpip/pkg-plist
Normal file
22
multimedia/vdr-plugin-osdpip/pkg-plist
Normal file
|
@ -0,0 +1,22 @@
|
|||
lib/vdr/libvdr-osdpip.so.1.7.17
|
||||
%%NLS%%share/locale/ca_ES/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/cs_CZ/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/da_DK/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/de_DE/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/el_GR/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/es_ES/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/et_EE/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/fi_FI/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/fr_FR/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/hr_HR/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/hu_HU/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/it_IT/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/nl_NL/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/nn_NO/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/pl_PL/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/pt_PT/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/ro_RO/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/ru_RU/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/sl_SI/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/sv_SE/LC_MESSAGES/vdr-osdpip.mo
|
||||
%%NLS%%share/locale/tr_TR/LC_MESSAGES/vdr-osdpip.mo
|
Loading…
Reference in a new issue