- Install complete list of components

- Bump PORTREVISION for package change

PR:		202724
Submitted by:	<bigangrygreenguy@gmail.com>
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2015-09-20 20:19:18 +00:00
parent 550e05b2ad
commit c1b73cf1db
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=397414
6 changed files with 110 additions and 3 deletions

View file

@ -3,6 +3,7 @@
PORTNAME= debhelper
PORTVERSION= 9.20150101
PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${PORTVERSION}
@ -19,4 +20,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
SHEBANG_FILES= dh*
post-patch:
@${RM} ${WRKSRC}/*.orig
.include <bsd.port.mk>

View file

@ -1,6 +1,13 @@
--- Makefile.orig 2013-11-11 03:11:15.000000000 +0800
+++ Makefile 2014-07-01 01:06:16.800481843 +0800
@@ -88,17 +88,16 @@
--- Makefile.orig 2014-11-16 15:43:09 UTC
+++ Makefile
@@ -1,5 +1,5 @@
# List of files of dh_* commands. Sorted for debhelper man page.
-COMMANDS=$(shell find . -maxdepth 1 -type f -perm /100 -name "dh_*" -printf "%f\n" | sort)
+COMMANDS=$(shell find . -maxdepth 1 -type f -perm +a+x -name "dh_*" -print | cut -c3- | sort)
# Find deprecated commands by looking at their synopsis.
DEPRECATED=$(shell egrep -l '^dh_.* - .*deprecated' $(COMMANDS))
@@ -88,17 +88,16 @@ endif
done;
install:

View file

@ -0,0 +1,14 @@
--- dh_fixperms.orig 2015-09-19 09:06:22 UTC
+++ dh_fixperms
@@ -57,8 +57,10 @@ foreach my $package (@{$dh{DOPACKAGES}})
}
# General permissions fixing.
+ #complex_doit("find $tmp $find_options -print0",
+ # "2>/dev/null | xargs -0r chown --no-dereference 0:0");
complex_doit("find $tmp $find_options -print0",
- "2>/dev/null | xargs -0r chown --no-dereference 0:0");
+ "2>/dev/null | xargs -0r chown 0:0");
complex_doit("find $tmp ! -type l $find_options -print0",
"2>/dev/null | xargs -0r chmod go=rX,u+rw,a-s");

View file

@ -0,0 +1,12 @@
--- dh_installman.orig 2015-09-19 09:06:22 UTC
+++ dh_installman
@@ -201,7 +201,8 @@ foreach my $package (@{$dh{DOPACKAGES}})
}
# Now utf-8 conversion.
- if (defined `man --version`) {
+ my $man_version = `man --version 2> /dev/null`;
+ if (defined $man_version && length($man_version)) {
foreach my $dir (qw{usr/share/man}) {
next unless -e "$tmp/$dir";
find(sub {

View file

@ -0,0 +1,13 @@
--- dh_perl.orig 2015-09-19 09:06:22 UTC
+++ dh_perl
@@ -143,8 +143,8 @@ foreach my $package (@{$dh{DOPACKAGES}})
# only one directory is installed into.
foreach my $dir ("$tmp/$vendorlib", "$tmp/$vendorarch") {
if (-d $dir) {
- doit("rmdir", "--ignore-fail-on-non-empty", "--parents",
- "$dir");
+ # doit("rmdir", "--ignore-fail-on-non-empty", "--parents", "$dir");
+ doit_noerror("rmdir", "$dir");
}
}
}

View file

@ -1,4 +1,61 @@
bin/dh
bin/dh_auto_build
bin/dh_auto_clean
bin/dh_auto_configure
bin/dh_auto_install
bin/dh_auto_test
bin/dh_bugfiles
bin/dh_builddeb
bin/dh_clean
bin/dh_compress
bin/dh_desktop
bin/dh_fixperms
bin/dh_gconf
bin/dh_gencontrol
bin/dh_icons
bin/dh_install
bin/dh_installcatalogs
bin/dh_installchangelogs
bin/dh_installcron
bin/dh_installdeb
bin/dh_installdebconf
bin/dh_installdirs
bin/dh_installdocs
bin/dh_installemacsen
bin/dh_installexamples
bin/dh_installgsettings
bin/dh_installifupdown
bin/dh_installinfo
bin/dh_installinit
bin/dh_installlogcheck
bin/dh_installlogrotate
bin/dh_installman
bin/dh_installmanpages
bin/dh_installmenu
bin/dh_installmime
bin/dh_installmodules
bin/dh_installpam
bin/dh_installppp
bin/dh_installudev
bin/dh_installwm
bin/dh_installxfonts
bin/dh_link
bin/dh_lintian
bin/dh_listpackages
bin/dh_makeshlibs
bin/dh_md5sums
bin/dh_movefiles
bin/dh_perl
bin/dh_prep
bin/dh_scrollkeeper
bin/dh_shlibdeps
bin/dh_strip
bin/dh_suidregister
bin/dh_testdir
bin/dh_testroot
bin/dh_ucf
bin/dh_undocumented
bin/dh_usrlocal
bin/maintscript-helper
bin/postinst-emacsen
bin/postinst-icons