Update to 2.2.0.
This commit is contained in:
parent
ff2c6bd74e
commit
c203ad6aaa
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188700
15 changed files with 75 additions and 255 deletions
|
@ -8,8 +8,7 @@
|
|||
PORTNAME?= openoffice.org
|
||||
PORTVERSION?= ${OOOVERSION}
|
||||
CATEGORIES+= editors java
|
||||
MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOVERSION}/&,} \
|
||||
http://openoffice.lunarshells.com/sources/ \
|
||||
MASTER_SITES+= http://openoffice.lunarshells.com/sources/ \
|
||||
http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
|
||||
http://ooopackages.good-day.net/pub/OpenOffice.org/cws/:cws \
|
||||
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
|
||||
|
@ -30,12 +29,12 @@ MAINTAINER= openoffice@FreeBSD.org
|
|||
COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
|
||||
|
||||
.if defined(WITH_CWS)
|
||||
PORTNAME:= openoffice.org-${OOOVERSION}-${WITH_CWS}
|
||||
DISTFILES+= ${CWSARCHIVE}:cws
|
||||
PORTNAME:= openoffice.org-${OOOVERSION}-${WITH_CWS}
|
||||
DISTFILES+= ${CWSARCHIVE}:cws
|
||||
.endif
|
||||
CWSARCHIVE= ${WITH_CWS}.tar.gz
|
||||
CWSARCHIVE= ${WITH_CWS}.tar.gz
|
||||
|
||||
OOOVERSION= 2.1.0
|
||||
OOOVERSION= 2.2.0
|
||||
NO_LATEST_LINK= yes
|
||||
USE_GNOME= gtk20
|
||||
MOZILLA_VERSION= 1.7.5
|
||||
|
@ -71,12 +70,12 @@ GCC_TARGET= x86_64-portbld-freebsd${OSREL}
|
|||
FREEBSD_ENV_SET= FreeBSDAMDEnv.Set
|
||||
.else
|
||||
GCC_TARGET= ${ARCH}-portbld-freebsd${OSREL}
|
||||
FREEBSD_ENV_SET= FreeBSDIntelEnv.Set
|
||||
FREEBSD_ENV_SET= FreeBSDX86Env.Set
|
||||
.endif
|
||||
|
||||
CODELINE= 680
|
||||
MILESTONE?= 6
|
||||
OOOTAG?= OOE680_m${MILESTONE}
|
||||
MILESTONE?= 14
|
||||
OOOTAG?= OOF680_m${MILESTONE}
|
||||
OOOSRC?= OOo_${OOOTAG}_source${EXTRACT_SUFX}
|
||||
INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
|
||||
EXECBASE?= openoffice.org-${OOOVERSION}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
MD5 (openoffice.org2.0/OOo_OOE680_m6_source.tar.bz2) = baa88794cb08d1a11169ae90ec25c0c4
|
||||
SHA256 (openoffice.org2.0/OOo_OOE680_m6_source.tar.bz2) = 492e702455a43c9c1b97266e74d3adc03815178e272c6f79b8e29c1089977e19
|
||||
SIZE (openoffice.org2.0/OOo_OOE680_m6_source.tar.bz2) = 272194113
|
||||
MD5 (openoffice.org2.0/OOo_OOF680_m14_source.tar.bz2) = 18b097f98c1ed0e825d38916bea6ae29
|
||||
SHA256 (openoffice.org2.0/OOo_OOF680_m14_source.tar.bz2) = 5e42507ef080545741fe19fc6f2ff94e00aac8f5f86d5d2601e9325b0ddd8468
|
||||
SIZE (openoffice.org2.0/OOo_OOF680_m14_source.tar.bz2) = 268670061
|
||||
MD5 (openoffice.org2.0/unowinreg.dll) = e3a0b76dcd876f3d721ee7183729153d
|
||||
SHA256 (openoffice.org2.0/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
|
||||
SIZE (openoffice.org2.0/unowinreg.dll) = 6144
|
||||
|
|
|
@ -1,12 +1,8 @@
|
|||
Index: berkeleydb/db-4.2.52.patch
|
||||
===================================================================
|
||||
RCS file: /cvs/external/berkeleydb/db-4.2.52.patch,v
|
||||
retrieving revision 1.13
|
||||
diff -u -r1.13 db-4.2.52.patch
|
||||
--- berkeleydb/db-4.2.52.patch 25 Jul 2006 10:23:22 -0000 1.13
|
||||
+++ berkeleydb/db-4.2.52.patch 23 Aug 2006 02:24:30 -0000
|
||||
@@ -313,6 +313,20 @@
|
||||
! $(SLO)$/btree_auto.obj
|
||||
diff -u -r1.17 db-4.2.52.patch
|
||||
--- berkeleydb/db-4.2.52.patch 1 Dec 2006 12:59:45 -0000 1.17
|
||||
+++ berkeleydb/db-4.2.52.patch 23 Jan 2007 07:10:29 -0000
|
||||
@@ -54,6 +54,20 @@
|
||||
! SLOFILES= $(SLO)$/strcasecmp.obj
|
||||
!
|
||||
! .INCLUDE : target.mk
|
||||
+*** misc/db-4.2.52.NC/dist/config.hin Wed Dec 3 16:10:00 2003
|
||||
|
@ -23,13 +19,13 @@ diff -u -r1.13 db-4.2.52.patch
|
|||
+ /* Define to 1 if you have the <ndir.h> header file, and it defines `DIR'. */
|
||||
+ #undef HAVE_NDIR_H
|
||||
+
|
||||
*** misc/db-4.2.52.NC/clib/makefile.mk Tue Jul 25 09:33:00 2006
|
||||
--- misc/build/db-4.2.52.NC/clib/makefile.mk Tue Jul 25 09:05:20 2006
|
||||
*** misc/db-4.2.52.NC/common/makefile.mk 2006-12-01 13:57:33.000000000 +0100
|
||||
--- misc/build/db-4.2.52.NC/common/makefile.mk 2006-12-01 13:57:19.000000000 +0100
|
||||
***************
|
||||
@@ -554,6 +568,76 @@
|
||||
fi
|
||||
|
||||
# Commands to make compiler produce verbose output that lists
|
||||
@@ -306,6 +320,76 @@
|
||||
hardcode_libdir_flag_spec_CXX='${wl}-rpath,$libdir'
|
||||
export_dynamic_flag_spec_CXX='${wl}--export-dynamic'
|
||||
whole_archive_flag_spec_CXX='${wl}--whole-archive$convenience ${wl}--no-whole-archive'
|
||||
+***************
|
||||
+*** 28556,28561 ****
|
||||
+--- 28556,28606 ----
|
||||
|
@ -100,10 +96,10 @@ diff -u -r1.13 db-4.2.52.patch
|
|||
+ _ACEOF
|
||||
+
|
||||
+
|
||||
*** misc/db-4.2.52.NC/dist/ltmain.sh Sat Apr 26 19:45:37 2003
|
||||
--- misc/build/db-4.2.52.NC/dist/ltmain.sh Tue Jul 25 09:05:20 2006
|
||||
*** misc/db-4.2.52.NC/dist/ltmain.sh 2003-04-26 19:45:37.000000000 +0200
|
||||
--- misc/build/db-4.2.52.NC/dist/ltmain.sh 2006-12-01 13:57:19.000000000 +0100
|
||||
***************
|
||||
@@ -1010,3 +1094,39 @@
|
||||
@@ -1059,3 +1143,39 @@
|
||||
! $(SLO)$/xa_map.obj
|
||||
!
|
||||
! .INCLUDE : target.mk
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
it also includes the following patch
|
||||
http://www.go-oo.org/patches/64bit/sixtyfour-warnings-fpicker.diff
|
||||
from i66686 (dupe of i66666)
|
||||
Index: tools/inc/solar.h
|
||||
===================================================================
|
||||
RCS file: /cvs/util/tools/inc/solar.h,v
|
||||
retrieving revision 1.44
|
||||
diff -u -r1.44 solar.h
|
||||
--- tools/inc/solar.h 26 Apr 2006 20:42:59 -0000 1.44
|
||||
+++ tools/inc/solar.h 23 Jun 2006 13:32:04 -0000
|
||||
@@ -55,9 +55,6 @@
|
||||
#define FALSE 0
|
||||
#endif
|
||||
|
||||
-#undef NULL
|
||||
-#define NULL 0
|
||||
-
|
||||
#ifdef _SOLAR__PRIVATE
|
||||
#undef _SOLAR__PRIVATE
|
||||
#endif
|
||||
|
|
@ -1,34 +0,0 @@
|
|||
--- binfilter/inc/bf_svx/svdobj.hxx.orig Mon Oct 23 13:47:55 2006
|
||||
+++ binfilter/inc/bf_svx/svdobj.hxx Mon Oct 23 13:48:08 2006
|
||||
@@ -265,7 +265,7 @@
|
||||
{}
|
||||
virtual ~SdrObjUserData();
|
||||
|
||||
- virtual SdrObjUserData* Clone(SdrObject* pObj1) const = NULL;
|
||||
+ virtual SdrObjUserData* Clone(SdrObject* pObj1) const = 0;
|
||||
UINT32 GetInventor() const { return nInventor; }
|
||||
UINT16 GetId() const { return nIdentifier; }
|
||||
virtual void WriteData(SvStream& rOut);
|
||||
|
||||
--- svx/inc/svdobj.hxx.orig Mon Oct 23 12:56:33 2006
|
||||
+++ svx/inc/svdobj.hxx Mon Oct 23 12:56:50 2006
|
||||
@@ -323,7 +323,7 @@
|
||||
{}
|
||||
virtual ~SdrObjUserData();
|
||||
|
||||
- virtual SdrObjUserData* Clone(SdrObject* pObj1) const = NULL;
|
||||
+ virtual SdrObjUserData* Clone(SdrObject* pObj1) const = 0;
|
||||
UINT32 GetInventor() const { return nInventor; }
|
||||
UINT16 GetId() const { return nIdentifier; }
|
||||
//BFS01virtual void WriteData(SvStream& rOut);
|
||||
--- sc/source/ui/inc/csvcontrol.hxx~ Fri Sep 9 06:17:47 2005
|
||||
+++ sc/source/ui/inc/csvcontrol.hxx Sat Nov 4 08:46:16 2006
|
||||
@@ -444,7 +444,7 @@
|
||||
|
||||
protected:
|
||||
/** Derived classes create a new accessible object here. */
|
||||
- virtual ScAccessibleCsvControl* ImplCreateAccessible() = NULL;
|
||||
+ virtual ScAccessibleCsvControl* ImplCreateAccessible() = 0;
|
||||
};
|
||||
|
||||
|
|
@ -8,8 +8,7 @@
|
|||
PORTNAME?= openoffice.org
|
||||
PORTVERSION?= ${OOOVERSION}
|
||||
CATEGORIES+= editors java
|
||||
MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOVERSION}/&,} \
|
||||
http://openoffice.lunarshells.com/sources/ \
|
||||
MASTER_SITES+= http://openoffice.lunarshells.com/sources/ \
|
||||
http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
|
||||
http://ooopackages.good-day.net/pub/OpenOffice.org/cws/:cws \
|
||||
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
|
||||
|
@ -30,12 +29,12 @@ MAINTAINER= openoffice@FreeBSD.org
|
|||
COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
|
||||
|
||||
.if defined(WITH_CWS)
|
||||
PORTNAME:= openoffice.org-${OOOVERSION}-${WITH_CWS}
|
||||
DISTFILES+= ${CWSARCHIVE}:cws
|
||||
PORTNAME:= openoffice.org-${OOOVERSION}-${WITH_CWS}
|
||||
DISTFILES+= ${CWSARCHIVE}:cws
|
||||
.endif
|
||||
CWSARCHIVE= ${WITH_CWS}.tar.gz
|
||||
CWSARCHIVE= ${WITH_CWS}.tar.gz
|
||||
|
||||
OOOVERSION= 2.1.0
|
||||
OOOVERSION= 2.2.0
|
||||
NO_LATEST_LINK= yes
|
||||
USE_GNOME= gtk20
|
||||
MOZILLA_VERSION= 1.7.5
|
||||
|
@ -71,12 +70,12 @@ GCC_TARGET= x86_64-portbld-freebsd${OSREL}
|
|||
FREEBSD_ENV_SET= FreeBSDAMDEnv.Set
|
||||
.else
|
||||
GCC_TARGET= ${ARCH}-portbld-freebsd${OSREL}
|
||||
FREEBSD_ENV_SET= FreeBSDIntelEnv.Set
|
||||
FREEBSD_ENV_SET= FreeBSDX86Env.Set
|
||||
.endif
|
||||
|
||||
CODELINE= 680
|
||||
MILESTONE?= 6
|
||||
OOOTAG?= OOE680_m${MILESTONE}
|
||||
MILESTONE?= 14
|
||||
OOOTAG?= OOF680_m${MILESTONE}
|
||||
OOOSRC?= OOo_${OOOTAG}_source${EXTRACT_SUFX}
|
||||
INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
|
||||
EXECBASE?= openoffice.org-${OOOVERSION}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
MD5 (openoffice.org2.0/OOo_OOE680_m6_source.tar.bz2) = baa88794cb08d1a11169ae90ec25c0c4
|
||||
SHA256 (openoffice.org2.0/OOo_OOE680_m6_source.tar.bz2) = 492e702455a43c9c1b97266e74d3adc03815178e272c6f79b8e29c1089977e19
|
||||
SIZE (openoffice.org2.0/OOo_OOE680_m6_source.tar.bz2) = 272194113
|
||||
MD5 (openoffice.org2.0/OOo_OOF680_m14_source.tar.bz2) = 18b097f98c1ed0e825d38916bea6ae29
|
||||
SHA256 (openoffice.org2.0/OOo_OOF680_m14_source.tar.bz2) = 5e42507ef080545741fe19fc6f2ff94e00aac8f5f86d5d2601e9325b0ddd8468
|
||||
SIZE (openoffice.org2.0/OOo_OOF680_m14_source.tar.bz2) = 268670061
|
||||
MD5 (openoffice.org2.0/unowinreg.dll) = e3a0b76dcd876f3d721ee7183729153d
|
||||
SHA256 (openoffice.org2.0/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
|
||||
SIZE (openoffice.org2.0/unowinreg.dll) = 6144
|
||||
|
|
|
@ -1,12 +1,8 @@
|
|||
Index: berkeleydb/db-4.2.52.patch
|
||||
===================================================================
|
||||
RCS file: /cvs/external/berkeleydb/db-4.2.52.patch,v
|
||||
retrieving revision 1.13
|
||||
diff -u -r1.13 db-4.2.52.patch
|
||||
--- berkeleydb/db-4.2.52.patch 25 Jul 2006 10:23:22 -0000 1.13
|
||||
+++ berkeleydb/db-4.2.52.patch 23 Aug 2006 02:24:30 -0000
|
||||
@@ -313,6 +313,20 @@
|
||||
! $(SLO)$/btree_auto.obj
|
||||
diff -u -r1.17 db-4.2.52.patch
|
||||
--- berkeleydb/db-4.2.52.patch 1 Dec 2006 12:59:45 -0000 1.17
|
||||
+++ berkeleydb/db-4.2.52.patch 23 Jan 2007 07:10:29 -0000
|
||||
@@ -54,6 +54,20 @@
|
||||
! SLOFILES= $(SLO)$/strcasecmp.obj
|
||||
!
|
||||
! .INCLUDE : target.mk
|
||||
+*** misc/db-4.2.52.NC/dist/config.hin Wed Dec 3 16:10:00 2003
|
||||
|
@ -23,13 +19,13 @@ diff -u -r1.13 db-4.2.52.patch
|
|||
+ /* Define to 1 if you have the <ndir.h> header file, and it defines `DIR'. */
|
||||
+ #undef HAVE_NDIR_H
|
||||
+
|
||||
*** misc/db-4.2.52.NC/clib/makefile.mk Tue Jul 25 09:33:00 2006
|
||||
--- misc/build/db-4.2.52.NC/clib/makefile.mk Tue Jul 25 09:05:20 2006
|
||||
*** misc/db-4.2.52.NC/common/makefile.mk 2006-12-01 13:57:33.000000000 +0100
|
||||
--- misc/build/db-4.2.52.NC/common/makefile.mk 2006-12-01 13:57:19.000000000 +0100
|
||||
***************
|
||||
@@ -554,6 +568,76 @@
|
||||
fi
|
||||
|
||||
# Commands to make compiler produce verbose output that lists
|
||||
@@ -306,6 +320,76 @@
|
||||
hardcode_libdir_flag_spec_CXX='${wl}-rpath,$libdir'
|
||||
export_dynamic_flag_spec_CXX='${wl}--export-dynamic'
|
||||
whole_archive_flag_spec_CXX='${wl}--whole-archive$convenience ${wl}--no-whole-archive'
|
||||
+***************
|
||||
+*** 28556,28561 ****
|
||||
+--- 28556,28606 ----
|
||||
|
@ -100,10 +96,10 @@ diff -u -r1.13 db-4.2.52.patch
|
|||
+ _ACEOF
|
||||
+
|
||||
+
|
||||
*** misc/db-4.2.52.NC/dist/ltmain.sh Sat Apr 26 19:45:37 2003
|
||||
--- misc/build/db-4.2.52.NC/dist/ltmain.sh Tue Jul 25 09:05:20 2006
|
||||
*** misc/db-4.2.52.NC/dist/ltmain.sh 2003-04-26 19:45:37.000000000 +0200
|
||||
--- misc/build/db-4.2.52.NC/dist/ltmain.sh 2006-12-01 13:57:19.000000000 +0100
|
||||
***************
|
||||
@@ -1010,3 +1094,39 @@
|
||||
@@ -1059,3 +1143,39 @@
|
||||
! $(SLO)$/xa_map.obj
|
||||
!
|
||||
! .INCLUDE : target.mk
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
it also includes the following patch
|
||||
http://www.go-oo.org/patches/64bit/sixtyfour-warnings-fpicker.diff
|
||||
from i66686 (dupe of i66666)
|
||||
Index: tools/inc/solar.h
|
||||
===================================================================
|
||||
RCS file: /cvs/util/tools/inc/solar.h,v
|
||||
retrieving revision 1.44
|
||||
diff -u -r1.44 solar.h
|
||||
--- tools/inc/solar.h 26 Apr 2006 20:42:59 -0000 1.44
|
||||
+++ tools/inc/solar.h 23 Jun 2006 13:32:04 -0000
|
||||
@@ -55,9 +55,6 @@
|
||||
#define FALSE 0
|
||||
#endif
|
||||
|
||||
-#undef NULL
|
||||
-#define NULL 0
|
||||
-
|
||||
#ifdef _SOLAR__PRIVATE
|
||||
#undef _SOLAR__PRIVATE
|
||||
#endif
|
||||
|
|
@ -1,34 +0,0 @@
|
|||
--- binfilter/inc/bf_svx/svdobj.hxx.orig Mon Oct 23 13:47:55 2006
|
||||
+++ binfilter/inc/bf_svx/svdobj.hxx Mon Oct 23 13:48:08 2006
|
||||
@@ -265,7 +265,7 @@
|
||||
{}
|
||||
virtual ~SdrObjUserData();
|
||||
|
||||
- virtual SdrObjUserData* Clone(SdrObject* pObj1) const = NULL;
|
||||
+ virtual SdrObjUserData* Clone(SdrObject* pObj1) const = 0;
|
||||
UINT32 GetInventor() const { return nInventor; }
|
||||
UINT16 GetId() const { return nIdentifier; }
|
||||
virtual void WriteData(SvStream& rOut);
|
||||
|
||||
--- svx/inc/svdobj.hxx.orig Mon Oct 23 12:56:33 2006
|
||||
+++ svx/inc/svdobj.hxx Mon Oct 23 12:56:50 2006
|
||||
@@ -323,7 +323,7 @@
|
||||
{}
|
||||
virtual ~SdrObjUserData();
|
||||
|
||||
- virtual SdrObjUserData* Clone(SdrObject* pObj1) const = NULL;
|
||||
+ virtual SdrObjUserData* Clone(SdrObject* pObj1) const = 0;
|
||||
UINT32 GetInventor() const { return nInventor; }
|
||||
UINT16 GetId() const { return nIdentifier; }
|
||||
//BFS01virtual void WriteData(SvStream& rOut);
|
||||
--- sc/source/ui/inc/csvcontrol.hxx~ Fri Sep 9 06:17:47 2005
|
||||
+++ sc/source/ui/inc/csvcontrol.hxx Sat Nov 4 08:46:16 2006
|
||||
@@ -444,7 +444,7 @@
|
||||
|
||||
protected:
|
||||
/** Derived classes create a new accessible object here. */
|
||||
- virtual ScAccessibleCsvControl* ImplCreateAccessible() = NULL;
|
||||
+ virtual ScAccessibleCsvControl* ImplCreateAccessible() = 0;
|
||||
};
|
||||
|
||||
|
|
@ -8,8 +8,7 @@
|
|||
PORTNAME?= openoffice.org
|
||||
PORTVERSION?= ${OOOVERSION}
|
||||
CATEGORIES+= editors java
|
||||
MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOVERSION}/&,} \
|
||||
http://openoffice.lunarshells.com/sources/ \
|
||||
MASTER_SITES+= http://openoffice.lunarshells.com/sources/ \
|
||||
http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
|
||||
http://ooopackages.good-day.net/pub/OpenOffice.org/cws/:cws \
|
||||
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
|
||||
|
@ -30,12 +29,12 @@ MAINTAINER= openoffice@FreeBSD.org
|
|||
COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
|
||||
|
||||
.if defined(WITH_CWS)
|
||||
PORTNAME:= openoffice.org-${OOOVERSION}-${WITH_CWS}
|
||||
DISTFILES+= ${CWSARCHIVE}:cws
|
||||
PORTNAME:= openoffice.org-${OOOVERSION}-${WITH_CWS}
|
||||
DISTFILES+= ${CWSARCHIVE}:cws
|
||||
.endif
|
||||
CWSARCHIVE= ${WITH_CWS}.tar.gz
|
||||
CWSARCHIVE= ${WITH_CWS}.tar.gz
|
||||
|
||||
OOOVERSION= 2.1.0
|
||||
OOOVERSION= 2.2.0
|
||||
NO_LATEST_LINK= yes
|
||||
USE_GNOME= gtk20
|
||||
MOZILLA_VERSION= 1.7.5
|
||||
|
@ -71,12 +70,12 @@ GCC_TARGET= x86_64-portbld-freebsd${OSREL}
|
|||
FREEBSD_ENV_SET= FreeBSDAMDEnv.Set
|
||||
.else
|
||||
GCC_TARGET= ${ARCH}-portbld-freebsd${OSREL}
|
||||
FREEBSD_ENV_SET= FreeBSDIntelEnv.Set
|
||||
FREEBSD_ENV_SET= FreeBSDX86Env.Set
|
||||
.endif
|
||||
|
||||
CODELINE= 680
|
||||
MILESTONE?= 6
|
||||
OOOTAG?= OOE680_m${MILESTONE}
|
||||
MILESTONE?= 14
|
||||
OOOTAG?= OOF680_m${MILESTONE}
|
||||
OOOSRC?= OOo_${OOOTAG}_source${EXTRACT_SUFX}
|
||||
INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
|
||||
EXECBASE?= openoffice.org-${OOOVERSION}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
MD5 (openoffice.org2.0/OOo_OOE680_m6_source.tar.bz2) = baa88794cb08d1a11169ae90ec25c0c4
|
||||
SHA256 (openoffice.org2.0/OOo_OOE680_m6_source.tar.bz2) = 492e702455a43c9c1b97266e74d3adc03815178e272c6f79b8e29c1089977e19
|
||||
SIZE (openoffice.org2.0/OOo_OOE680_m6_source.tar.bz2) = 272194113
|
||||
MD5 (openoffice.org2.0/OOo_OOF680_m14_source.tar.bz2) = 18b097f98c1ed0e825d38916bea6ae29
|
||||
SHA256 (openoffice.org2.0/OOo_OOF680_m14_source.tar.bz2) = 5e42507ef080545741fe19fc6f2ff94e00aac8f5f86d5d2601e9325b0ddd8468
|
||||
SIZE (openoffice.org2.0/OOo_OOF680_m14_source.tar.bz2) = 268670061
|
||||
MD5 (openoffice.org2.0/unowinreg.dll) = e3a0b76dcd876f3d721ee7183729153d
|
||||
SHA256 (openoffice.org2.0/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
|
||||
SIZE (openoffice.org2.0/unowinreg.dll) = 6144
|
||||
|
|
|
@ -1,12 +1,8 @@
|
|||
Index: berkeleydb/db-4.2.52.patch
|
||||
===================================================================
|
||||
RCS file: /cvs/external/berkeleydb/db-4.2.52.patch,v
|
||||
retrieving revision 1.13
|
||||
diff -u -r1.13 db-4.2.52.patch
|
||||
--- berkeleydb/db-4.2.52.patch 25 Jul 2006 10:23:22 -0000 1.13
|
||||
+++ berkeleydb/db-4.2.52.patch 23 Aug 2006 02:24:30 -0000
|
||||
@@ -313,6 +313,20 @@
|
||||
! $(SLO)$/btree_auto.obj
|
||||
diff -u -r1.17 db-4.2.52.patch
|
||||
--- berkeleydb/db-4.2.52.patch 1 Dec 2006 12:59:45 -0000 1.17
|
||||
+++ berkeleydb/db-4.2.52.patch 23 Jan 2007 07:10:29 -0000
|
||||
@@ -54,6 +54,20 @@
|
||||
! SLOFILES= $(SLO)$/strcasecmp.obj
|
||||
!
|
||||
! .INCLUDE : target.mk
|
||||
+*** misc/db-4.2.52.NC/dist/config.hin Wed Dec 3 16:10:00 2003
|
||||
|
@ -23,13 +19,13 @@ diff -u -r1.13 db-4.2.52.patch
|
|||
+ /* Define to 1 if you have the <ndir.h> header file, and it defines `DIR'. */
|
||||
+ #undef HAVE_NDIR_H
|
||||
+
|
||||
*** misc/db-4.2.52.NC/clib/makefile.mk Tue Jul 25 09:33:00 2006
|
||||
--- misc/build/db-4.2.52.NC/clib/makefile.mk Tue Jul 25 09:05:20 2006
|
||||
*** misc/db-4.2.52.NC/common/makefile.mk 2006-12-01 13:57:33.000000000 +0100
|
||||
--- misc/build/db-4.2.52.NC/common/makefile.mk 2006-12-01 13:57:19.000000000 +0100
|
||||
***************
|
||||
@@ -554,6 +568,76 @@
|
||||
fi
|
||||
|
||||
# Commands to make compiler produce verbose output that lists
|
||||
@@ -306,6 +320,76 @@
|
||||
hardcode_libdir_flag_spec_CXX='${wl}-rpath,$libdir'
|
||||
export_dynamic_flag_spec_CXX='${wl}--export-dynamic'
|
||||
whole_archive_flag_spec_CXX='${wl}--whole-archive$convenience ${wl}--no-whole-archive'
|
||||
+***************
|
||||
+*** 28556,28561 ****
|
||||
+--- 28556,28606 ----
|
||||
|
@ -100,10 +96,10 @@ diff -u -r1.13 db-4.2.52.patch
|
|||
+ _ACEOF
|
||||
+
|
||||
+
|
||||
*** misc/db-4.2.52.NC/dist/ltmain.sh Sat Apr 26 19:45:37 2003
|
||||
--- misc/build/db-4.2.52.NC/dist/ltmain.sh Tue Jul 25 09:05:20 2006
|
||||
*** misc/db-4.2.52.NC/dist/ltmain.sh 2003-04-26 19:45:37.000000000 +0200
|
||||
--- misc/build/db-4.2.52.NC/dist/ltmain.sh 2006-12-01 13:57:19.000000000 +0100
|
||||
***************
|
||||
@@ -1010,3 +1094,39 @@
|
||||
@@ -1059,3 +1143,39 @@
|
||||
! $(SLO)$/xa_map.obj
|
||||
!
|
||||
! .INCLUDE : target.mk
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
it also includes the following patch
|
||||
http://www.go-oo.org/patches/64bit/sixtyfour-warnings-fpicker.diff
|
||||
from i66686 (dupe of i66666)
|
||||
Index: tools/inc/solar.h
|
||||
===================================================================
|
||||
RCS file: /cvs/util/tools/inc/solar.h,v
|
||||
retrieving revision 1.44
|
||||
diff -u -r1.44 solar.h
|
||||
--- tools/inc/solar.h 26 Apr 2006 20:42:59 -0000 1.44
|
||||
+++ tools/inc/solar.h 23 Jun 2006 13:32:04 -0000
|
||||
@@ -55,9 +55,6 @@
|
||||
#define FALSE 0
|
||||
#endif
|
||||
|
||||
-#undef NULL
|
||||
-#define NULL 0
|
||||
-
|
||||
#ifdef _SOLAR__PRIVATE
|
||||
#undef _SOLAR__PRIVATE
|
||||
#endif
|
||||
|
|
@ -1,34 +0,0 @@
|
|||
--- binfilter/inc/bf_svx/svdobj.hxx.orig Mon Oct 23 13:47:55 2006
|
||||
+++ binfilter/inc/bf_svx/svdobj.hxx Mon Oct 23 13:48:08 2006
|
||||
@@ -265,7 +265,7 @@
|
||||
{}
|
||||
virtual ~SdrObjUserData();
|
||||
|
||||
- virtual SdrObjUserData* Clone(SdrObject* pObj1) const = NULL;
|
||||
+ virtual SdrObjUserData* Clone(SdrObject* pObj1) const = 0;
|
||||
UINT32 GetInventor() const { return nInventor; }
|
||||
UINT16 GetId() const { return nIdentifier; }
|
||||
virtual void WriteData(SvStream& rOut);
|
||||
|
||||
--- svx/inc/svdobj.hxx.orig Mon Oct 23 12:56:33 2006
|
||||
+++ svx/inc/svdobj.hxx Mon Oct 23 12:56:50 2006
|
||||
@@ -323,7 +323,7 @@
|
||||
{}
|
||||
virtual ~SdrObjUserData();
|
||||
|
||||
- virtual SdrObjUserData* Clone(SdrObject* pObj1) const = NULL;
|
||||
+ virtual SdrObjUserData* Clone(SdrObject* pObj1) const = 0;
|
||||
UINT32 GetInventor() const { return nInventor; }
|
||||
UINT16 GetId() const { return nIdentifier; }
|
||||
//BFS01virtual void WriteData(SvStream& rOut);
|
||||
--- sc/source/ui/inc/csvcontrol.hxx~ Fri Sep 9 06:17:47 2005
|
||||
+++ sc/source/ui/inc/csvcontrol.hxx Sat Nov 4 08:46:16 2006
|
||||
@@ -444,7 +444,7 @@
|
||||
|
||||
protected:
|
||||
/** Derived classes create a new accessible object here. */
|
||||
- virtual ScAccessibleCsvControl* ImplCreateAccessible() = NULL;
|
||||
+ virtual ScAccessibleCsvControl* ImplCreateAccessible() = 0;
|
||||
};
|
||||
|
||||
|
Loading…
Reference in a new issue