- compile in FreeBSD version string
- add support for slave ports PR: 137612 Submitted by: Anonymous
This commit is contained in:
parent
08819b4e6f
commit
c216e0e34f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=239439
2 changed files with 30 additions and 4 deletions
|
@ -7,19 +7,34 @@
|
|||
|
||||
PORTNAME= miniupnpc
|
||||
PORTVERSION= 1.3
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://miniupnp.free.fr/files/
|
||||
|
||||
MAINTAINER= dinoex@FreeBSD.org
|
||||
COMMENT= UPnP IGD client lightweight library
|
||||
COMMENT?= UPnP IGD client lightweight library
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CONFIGURE_SCRIPT= updateminiupnpcstrings.sh
|
||||
MAKE_ENV+= INSTALLPREFIX=${PREFIX}
|
||||
CFLAGS+= -fPIC
|
||||
USE_LDCONFIG= yes
|
||||
MAN3= miniupnpc.3
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !defined(SLAVE_PORT)
|
||||
MAN3= miniupnpc.3
|
||||
.endif
|
||||
|
||||
.if defined(WITH_DEBUG)
|
||||
CFLAGS+= -DDEBUG
|
||||
.endif
|
||||
|
||||
.if !defined(SLAVE_PORT)
|
||||
post-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/man3/miniupnpc.3 ${PREFIX}/man/man3/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
11
net/miniupnpc/files/patch-updateminiupnpcstrings.sh
Normal file
11
net/miniupnpc/files/patch-updateminiupnpcstrings.sh
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- updateminiupnpcstrings.sh~
|
||||
+++ updateminiupnpcstrings.sh
|
||||
@@ -27,7 +27,7 @@ fi
|
||||
|
||||
echo "Detected OS [$OS_NAME] version [$OS_VERSION]"
|
||||
|
||||
-EXPR="s/OS_STRING\s\".*\"/OS_STRING \"${OS_NAME}\/${OS_VERSION}\"/"
|
||||
+EXPR="/OS_STRING/s|\".*\"|\"${OS_NAME}/${OS_VERSION}\"|"
|
||||
#echo $EXPR
|
||||
echo "Backuping $FILE to $FILE.bak."
|
||||
cp $FILE $FILE.bak
|
Loading…
Reference in a new issue