Remove system-tools-backends
Abandonware from the gnome2 era
This commit is contained in:
parent
9f3fe7d50e
commit
c25b257db9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=550710
8 changed files with 1 additions and 170 deletions
1
MOVED
1
MOVED
|
@ -15630,3 +15630,4 @@ graphics/evince-lite|graphics/evince@lite|2020-09-26|Has been replaced by a flav
|
|||
x11/gnome3-lite|x11/gnome3@lite|2020-09-29|Has been replaced by a flavor
|
||||
graphics/py-gimp||2020-09-29|Has expired: Uses deprecated version of python
|
||||
net/libproxy-gnome2||2020-09-30|Removed gnome2 port not depended on
|
||||
sysutils/system-tools-backends||2020-09-30|Abandonware from gnome2 era
|
||||
|
|
|
@ -1284,7 +1284,6 @@
|
|||
SUBDIR += syslog-ng329
|
||||
SUBDIR += syslogger
|
||||
SUBDIR += sysrc
|
||||
SUBDIR += system-tools-backends
|
||||
SUBDIR += sysvbanner
|
||||
SUBDIR += tai64nfrac
|
||||
SUBDIR += tarsnap
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/trunk/sysutils/system-tools-backends/Makefile 18610 2013-06-30 16:33:05Z marcus $
|
||||
|
||||
PORTNAME= system-tools-backends
|
||||
PORTVERSION= 2.10.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils gnome
|
||||
MASTER_SITES= GNOME
|
||||
DIST_SUBDIR= gnome2
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= Backend system admin scripts for gnome-system-tools
|
||||
|
||||
BUILD_DEPENDS= p5-Net-DBus>=0:devel/p5-Net-DBus
|
||||
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
|
||||
libpolkit-gobject-1.so:sysutils/polkit
|
||||
RUN_DEPENDS= p5-Net-DBus>=0:devel/p5-Net-DBus
|
||||
|
||||
USES= gettext-tools gmake gnome pathfix perl5 pkgconfig shebangfix \
|
||||
tar:bzip2
|
||||
SHEBANG_FILES= SystemToolsBackends.pl.in
|
||||
USE_GNOME= intlhack glib20
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME_SUBR= yes
|
||||
CONFIGURE_ARGS= --with-stb-group=wheel \
|
||||
--localstatedir=/var
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (gnome2/system-tools-backends-2.10.2.tar.bz2) = 1dbe5177df46a9c7250735e05e77129fe7ec04840771accfa87690111ca2c670
|
||||
SIZE (gnome2/system-tools-backends-2.10.2.tar.bz2) = 448939
|
|
@ -1,20 +0,0 @@
|
|||
--- Utils/Platform.pm.orig 2010-03-31 12:55:43.000000000 +0400
|
||||
+++ Utils/Platform.pm 2012-03-15 18:24:46.000000000 +0400
|
||||
@@ -73,6 +73,8 @@
|
||||
"freebsd-6" => [ "FreeBSD", "6", "" ],
|
||||
"freebsd-7" => [ "FreeBSD", "7", "" ],
|
||||
"freebsd-8" => [ "FreeBSD", "8", "" ],
|
||||
+ "freebsd-9" => [ "FreeBSD", "9", "" ],
|
||||
+ "freebsd-10" => [ "FreeBSD", "10", "" ],
|
||||
"gentoo" => [ "Gentoo Linux", "", "" ],
|
||||
"vlos-1.2" => [ "Vida Linux OS", "1.2" ],
|
||||
"archlinux" => [ "Arch Linux", "", "" ],
|
||||
@@ -126,6 +128,8 @@
|
||||
"freebsd-6" => "freebsd-5",
|
||||
"freebsd-7" => "freebsd-5",
|
||||
"freebsd-8" => "freebsd-5",
|
||||
+ "freebsd-9" => "freebsd-5",
|
||||
+ "freebsd-10" => "freebsd-5",
|
||||
"openna-1.0" => "redhat-6.2",
|
||||
"pld-1.1" => "pld-1.0",
|
||||
"pld-1.99" => "pld-1.0",
|
|
@ -1,11 +0,0 @@
|
|||
--- dispatcher/main.c.orig 2009-03-17 02:57:49.000000000 +0100
|
||||
+++ dispatcher/main.c 2009-04-16 10:05:33.000000000 +0200
|
||||
@@ -48,7 +48,7 @@ daemonize (void)
|
||||
setsid ();
|
||||
|
||||
if ((pidfile_fd = open (LOCALSTATEDIR "/run/system-tools-backends.pid",
|
||||
- O_CREAT | O_WRONLY,
|
||||
+ O_CREAT | O_WRONLY, 0600,
|
||||
S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH)) != -1)
|
||||
{
|
||||
str = g_strdup_printf ("%d", getpid ());
|
|
@ -1,4 +0,0 @@
|
|||
System-tools-backends is a collection of scripts (mostly Perl) used by
|
||||
gnome-system-tools to perform system administration tasks.
|
||||
|
||||
WWW: http://www.gnome.org/projects/gst/
|
|
@ -1,101 +0,0 @@
|
|||
etc/dbus-1/system.d/org.freedesktop.SystemToolsBackends.conf
|
||||
sbin/system-tools-backends
|
||||
libdata/pkgconfig/system-tools-backends-2.0.pc
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.GroupConfig2.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.GroupsConfig2.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.HostsConfig.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.IfacesConfig.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.NFSConfig.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.NTPConfig.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.Platform.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.SMBConfig.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.SelfConfig2.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.ServiceConfig2.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.ServicesConfig.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.TimeConfig.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.UserConfig2.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.UsersConfig2.service
|
||||
share/dbus-1/system-services/org.freedesktop.SystemToolsBackends.service
|
||||
share/locale/ar/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/bg/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/bn_IN/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/ca/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/cs/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/da/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/de/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/el/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/en_GB/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/es/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/et/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/eu/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/fi/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/fr/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/gl/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/gu/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/he/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/hi/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/hu/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/it/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/ja/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/kn/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/nb/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/nds/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/or/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/pa/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/pl/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/pt/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/ro/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/sl/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/sr/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/sr@latin/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/sv/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/ta/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/te/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/th/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/tr/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/uk/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/zh_HK/LC_MESSAGES/system-tools-backends.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/system-tools-backends.mo
|
||||
share/polkit-1/actions/org.freedesktop.SystemToolsBackends.policy
|
||||
share/system-tools-backends-2.0/files/general_gprs_chatscript
|
||||
share/system-tools-backends-2.0/files/general_isdn_ppp_options
|
||||
share/system-tools-backends-2.0/files/general_pppoe_ppp_options
|
||||
share/system-tools-backends-2.0/scripts/GroupConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/GroupsConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/HostsConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/IfacesConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/Init/Services.pm
|
||||
share/system-tools-backends-2.0/scripts/Init/ServicesList.pm
|
||||
share/system-tools-backends-2.0/scripts/NFSConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/NTPConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/Network/Hosts.pm
|
||||
share/system-tools-backends-2.0/scripts/Network/Ifaces.pm
|
||||
share/system-tools-backends-2.0/scripts/Platform.pm
|
||||
share/system-tools-backends-2.0/scripts/SMBConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/SelfConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/ServiceConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/ServicesConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/Shares/NFS.pm
|
||||
share/system-tools-backends-2.0/scripts/Shares/SMB.pm
|
||||
share/system-tools-backends-2.0/scripts/StbObject.pm
|
||||
share/system-tools-backends-2.0/scripts/SystemToolsBackends.pl
|
||||
share/system-tools-backends-2.0/scripts/Time/NTP.pm
|
||||
share/system-tools-backends-2.0/scripts/Time/TimeDate.pm
|
||||
share/system-tools-backends-2.0/scripts/TimeConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/UserConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/Users/Groups.pm
|
||||
share/system-tools-backends-2.0/scripts/Users/Shells.pm
|
||||
share/system-tools-backends-2.0/scripts/Users/Users.pm
|
||||
share/system-tools-backends-2.0/scripts/UsersConfig.pm
|
||||
share/system-tools-backends-2.0/scripts/Utils/Backend.pm
|
||||
share/system-tools-backends-2.0/scripts/Utils/DBus.pm
|
||||
share/system-tools-backends-2.0/scripts/Utils/File.pm
|
||||
share/system-tools-backends-2.0/scripts/Utils/Monitor.pm
|
||||
share/system-tools-backends-2.0/scripts/Utils/Parse.pm
|
||||
share/system-tools-backends-2.0/scripts/Utils/Platform.pm
|
||||
share/system-tools-backends-2.0/scripts/Utils/Replace.pm
|
||||
share/system-tools-backends-2.0/scripts/Utils/Report.pm
|
||||
share/system-tools-backends-2.0/scripts/Utils/Util.pm
|
||||
share/system-tools-backends-2.0/scripts/Utils/XML.pm
|
Loading…
Reference in a new issue