- Unbreak
- Chase warnings
This commit is contained in:
parent
3e0a826f1a
commit
c261e36369
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=215690
4 changed files with 28 additions and 14 deletions
|
@ -21,10 +21,4 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
|
|||
|
||||
MAN3= Net::ARP.3
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "amd64"
|
||||
BROKEN= Does not compile on amd64
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,9 +1,8 @@
|
|||
--- arp.h.orig 2008-01-06 21:14:49.000000000 +0800
|
||||
+++ arp.h 2008-01-06 21:15:11.000000000 +0800
|
||||
@@ -55,4 +55,6 @@
|
||||
--- arp.h.orig 2007-08-16 09:38:44.000000000 +0200
|
||||
+++ arp.h 2008-06-24 14:47:24.000000000 +0200
|
||||
@@ -54,5 +54,3 @@
|
||||
u_char dest_add[ETH_ALEN]; // dest mac
|
||||
u_char dest_ip[IP_ALEN]; // dest ip
|
||||
};
|
||||
|
||||
+#ifndef __i386__
|
||||
extern struct ether_addr *ether_aton (__const char *__asc) __THROW;
|
||||
+#endif
|
||||
-
|
||||
-extern struct ether_addr *ether_aton (__const char *__asc) __THROW;
|
||||
|
|
11
net/p5-Net-ARP/files/patch-arp_lookup_bsd.c
Normal file
11
net/p5-Net-ARP/files/patch-arp_lookup_bsd.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- arp_lookup_bsd.c.orig 2006-09-20 11:19:00.000000000 +0200
|
||||
+++ arp_lookup_bsd.c 2008-06-24 14:57:10.000000000 +0200
|
||||
@@ -18,6 +18,8 @@
|
||||
See the GNU General Public License for more details.
|
||||
*/
|
||||
|
||||
+#include <string.h>
|
||||
+#include <stdlib.h>
|
||||
#include <sys/file.h>
|
||||
#include <sys/socket.h>
|
||||
#include <net/if_dl.h>
|
10
net/p5-Net-ARP/files/patch-ppport.h
Normal file
10
net/p5-Net-ARP/files/patch-ppport.h
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- ppport.h.orig 2008-06-24 12:35:16.000000000 +0000
|
||||
+++ ppport.h 2008-06-24 12:35:40.000000000 +0000
|
||||
@@ -220,6 +220,7 @@
|
||||
/* Replace: 0 */
|
||||
#endif
|
||||
|
||||
+#undef PERL_UNUSED_DECL
|
||||
#ifdef HASATTRIBUTE
|
||||
# if (defined(__GNUC__) && defined(__cplusplus)) || defined(__INTEL_COMPILER)
|
||||
# define PERL_UNUSED_DECL
|
Loading…
Reference in a new issue