- Update to version 2.0.4.
- Remove from virtual category "net" and add to "www". - Remove pkg-message.in and patch-libprozilla_src_Makefile.in (now the upstream version installs headers under a "prozilla" subdirectory). - Change pkg-plist and remove patch-libprozilla_ltmain.sh to install .la (libtool archive) files. Approved by: garga (mentor)
This commit is contained in:
parent
b890fe08d7
commit
c26d558871
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=159892
6 changed files with 10 additions and 59 deletions
|
@ -6,9 +6,8 @@
|
|||
#
|
||||
|
||||
PORTNAME= prozilla
|
||||
PORTVERSION= 2.0.3
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= ftp net
|
||||
PORTVERSION= 2.0.4
|
||||
CATEGORIES= ftp www
|
||||
MASTER_SITES= http://prozilla.genesys.ro/downloads/prozilla/tarballs/
|
||||
|
||||
MAINTAINER= alepulver@FreeBSD.org
|
||||
|
@ -21,17 +20,11 @@ USE_GMAKE= yes
|
|||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
|
||||
CPPFLAGS= ${CFLAGS} -I${LOCALBASE}/include
|
||||
LDFLAGS= -L${LOCALBASE}/lib
|
||||
|
||||
MAN1= proz.1
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
PKGMESSAGE= ${FILESDIR}/pkg-message
|
||||
|
||||
post-install:
|
||||
@${ECHO_CMD}
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${ECHO_CMD}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (prozilla-2.0.3.tar.bz2) = 0a3b9c179ffd7390e52a2b6f6f98111d
|
||||
SHA256 (prozilla-2.0.3.tar.bz2) = 4caf32abd8152fd00aecb9483429e702ae9888292c020f8013d65c3333be530e
|
||||
SIZE (prozilla-2.0.3.tar.bz2) = 879687
|
||||
MD5 (prozilla-2.0.4.tar.bz2) = 220f03968ddac79c2d6b48a507cd9c71
|
||||
SHA256 (prozilla-2.0.4.tar.bz2) = 0fda675f6032543a73a4cd0dec02fd16b35708694f5dbae235354751e00616ac
|
||||
SIZE (prozilla-2.0.4.tar.bz2) = 745429
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
--- libprozilla/ltmain.sh.orig Fri Jan 28 12:29:23 2005
|
||||
+++ libprozilla/ltmain.sh Fri Nov 25 13:05:58 2005
|
||||
@@ -5620,10 +5620,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
@ -1,17 +0,0 @@
|
|||
--- libprozilla/src/Makefile.in.orig Sun Dec 11 21:19:15 2005
|
||||
+++ libprozilla/src/Makefile.in Sun Feb 12 20:29:58 2006
|
||||
@@ -226,11 +226,11 @@
|
||||
|
||||
install-includeHEADERS: $(include_HEADERS)
|
||||
@$(NORMAL_INSTALL)
|
||||
- $(mkinstalldirs) $(DESTDIR)$(includedir)
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(includedir)/prozilla
|
||||
@list='$(include_HEADERS)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
|
||||
- echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(includedir)/$$p"; \
|
||||
- $(INSTALL_DATA) $$d$$p $(DESTDIR)$(includedir)/$$p; \
|
||||
+ echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(includedir)/prozilla/$$p"; \
|
||||
+ $(INSTALL_DATA) $$d$$p $(DESTDIR)$(includedir)/prozilla/$$p; \
|
||||
done
|
||||
|
||||
uninstall-includeHEADERS:
|
|
@ -1,11 +0,0 @@
|
|||
==============================================================================
|
||||
|
||||
ProZilla has been installed!
|
||||
|
||||
The libprozilla header files are now installed in a "prozilla" subdirectory to
|
||||
avoid problems caused by the file named "common.h".
|
||||
|
||||
Now to compile a program that uses libprozilla you have to add the
|
||||
"-I%%PREFIX%%/include/prozilla" flag to the compiler.
|
||||
|
||||
==============================================================================
|
|
@ -3,6 +3,7 @@ include/prozilla/common.h
|
|||
include/prozilla/netrc.h
|
||||
include/prozilla/prozilla.h
|
||||
lib/libprozilla.a
|
||||
lib/libprozilla.la
|
||||
share/locale/fr/LC_MESSAGES/proz.mo
|
||||
share/locale/it/LC_MESSAGES/.mo
|
||||
share/locale/it/LC_MESSAGES/proz.mo
|
||||
|
|
Loading…
Reference in a new issue