Install mod_caucho.so during 'install' target rather than 'build' target. This
will fix an error I introduced with my last commit. PR: 85460 Reported by: Boris Kovalenko <boris@tagnet.ru> Submitted by: maintainer
This commit is contained in:
parent
c7e7e3269f
commit
c26ee9220a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=141710
3 changed files with 24 additions and 18 deletions
|
@ -132,6 +132,12 @@ post-build:
|
|||
|
||||
do-install:
|
||||
@${SETENV} RUNASUSER=${RUNASUSER} GROUP=${GROUP} ${SH} ${WRKDIR}/install.sh
|
||||
.if (defined(WITH_APACHE2) && (${WITH_APACHE2} == yes || ${WITH_APACHE2} == YES))
|
||||
${APXS} -i -n caucho -a ${WRKSRC}/modules/c/src/apache2/.libs/mod_caucho.so
|
||||
.endif
|
||||
.if (defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
|
||||
${APXS} -i -n caucho -a ${WRKSRC}/modules/c/src/apache1/.libs/mod_caucho.so
|
||||
.endif
|
||||
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} "********************************************************************************"
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- modules/c/src/apache1/Makefile.in.orig Mon Oct 11 11:34:53 2004
|
||||
+++ modules/c/src/apache1/Makefile.in Mon Oct 11 12:44:59 2004
|
||||
@@ -38,8 +38,7 @@
|
||||
$(LIBTOOL) --mode=install $(CP) mod_caucho.la $(apache_libexec)
|
||||
- rm -f $(apache_libexec)/mod_caucho.la
|
||||
- rm -f $(apache_libexec)/mod_caucho.a
|
||||
--- modules/c/src/apache1/Makefile.in.orig Sat Mar 5 22:18:38 2005
|
||||
+++ modules/c/src/apache1/Makefile.in Thu Sep 1 12:44:50 2005
|
||||
@@ -35,11 +35,6 @@
|
||||
$(CC) -c $(INCLUDES) $(CFLAGS) $<
|
||||
|
||||
install : mod_caucho.la
|
||||
- $(LIBTOOL) --mode=install $(CP) mod_caucho.la $(apache_libexec)
|
||||
- - rm -f $(apache_libexec)/mod_caucho.la
|
||||
- - rm -f $(apache_libexec)/mod_caucho.a
|
||||
- sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
|
||||
- -resin_home $(resin_home)
|
||||
+ %%APXS%% -e -a -n caucho mod_caucho.so
|
||||
|
||||
clean :
|
||||
- rm *.o *.lo *.la *.so .libs
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- modules/c/src/apache2/Makefile.in.orig Mon Oct 11 11:34:53 2004
|
||||
+++ modules/c/src/apache2/Makefile.in Mon Oct 11 12:44:59 2004
|
||||
@@ -38,8 +38,7 @@
|
||||
$(LIBTOOL) --mode=install $(CP) mod_caucho.la $(apache_libexec)
|
||||
- rm -f $(apache_libexec)/mod_caucho.la
|
||||
- rm -f $(apache_libexec)/mod_caucho.a
|
||||
--- modules/c/src/apache2/Makefile.in.orig Thu Sep 1 12:32:43 2005
|
||||
+++ modules/c/src/apache2/Makefile.in Thu Sep 1 12:32:49 2005
|
||||
@@ -35,11 +35,6 @@
|
||||
$(CC) -c $(INCLUDES) $(CFLAGS) $<
|
||||
|
||||
install : mod_caucho.la
|
||||
- $(LIBTOOL) --mode=install $(CP) mod_caucho.la $(apache_libexec)
|
||||
- - rm -f $(apache_libexec)/mod_caucho.la
|
||||
- - rm -f $(apache_libexec)/mod_caucho.a
|
||||
- sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
|
||||
- -resin_home $(resin_home)
|
||||
+ %%APXS%% -e -a -n caucho mod_caucho.so
|
||||
|
||||
clean :
|
||||
- rm *.o *.lo *.la *.so .libs
|
||||
|
|
Loading…
Reference in a new issue