Update to 0.2.0.
PR: ports/123730 Submitted by: Seiya Yanagita <s_yanagita@ybb.ne.jp> (maintainer)
This commit is contained in:
parent
a9d51ca6b2
commit
c2a1d89ba5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=213286
7 changed files with 19 additions and 96 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= scim-uim
|
||||
PORTVERSION= 0.1.4
|
||||
PORTREVISION= 8
|
||||
PORTVERSION= 0.2.0
|
||||
CATEGORIES= japanese
|
||||
MASTER_SITES= SF \
|
||||
http://freedesktop.org/~suzhe/sources/
|
||||
|
@ -20,7 +19,6 @@ BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
|
|||
LIB_DEPENDS= uim:${PORTSDIR}/textproc/uim
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GNOME= lthack
|
||||
USE_ICONV= yes
|
||||
USE_GMAKE= yes
|
||||
|
@ -31,16 +29,11 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
EXTRA_PATCHES= ${FILESDIR}/extra-patch-aa ${FILESDIR}/extra-patch-ab
|
||||
.if ${OSVERSION} < 500035
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
|
||||
RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
|
||||
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-4-stable
|
||||
IGNORE= does not build on FreeBSD < 5.x
|
||||
.else
|
||||
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -lintl"
|
||||
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (scim-uim-0.1.4.tar.gz) = e4a1f7731a62ca8dd81c0204e5fb96d6
|
||||
SHA256 (scim-uim-0.1.4.tar.gz) = 44196eca4e7bbb7666dd9a7b410f0cf7a6392b9044d0c25e6752389c262fd4aa
|
||||
SIZE (scim-uim-0.1.4.tar.gz) = 329980
|
||||
MD5 (scim-uim-0.2.0.tar.gz) = 3841556bc0e5a94b1a268751432712d3
|
||||
SHA256 (scim-uim-0.2.0.tar.gz) = 457eb89f40dda70f813c0b401aaec8b397e7daa340d53136aba3b97407533e13
|
||||
SIZE (scim-uim-0.2.0.tar.gz) = 344389
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- src/scim_uim_imengine.cpp.orig Thu Nov 11 20:27:26 2004
|
||||
+++ src/scim_uim_imengine.cpp Thu Nov 11 20:28:09 2004
|
||||
@@ -36,6 +36,7 @@
|
||||
|
||||
#include <scim.h>
|
||||
#include "scim_uim_imengine.h"
|
||||
+#include <cstdio>
|
||||
|
||||
#define scim_module_init uim_LTX_scim_module_init
|
||||
#define scim_module_exit uim_LTX_scim_module_exit
|
|
@ -1,50 +0,0 @@
|
|||
--- src/scim_uim_imengine.cpp.orig 2005-08-08 12:08:34.000000000 +0900
|
||||
+++ src/scim_uim_imengine.cpp 2008-05-18 16:02:49.000000000 +0900
|
||||
@@ -33,6 +33,7 @@
|
||||
#endif
|
||||
|
||||
#include <scim.h>
|
||||
+#include <uim-util.h>
|
||||
#include "scim_uim_imengine.h"
|
||||
|
||||
#define scim_module_init uim_LTX_scim_module_init
|
||||
@@ -823,39 +824,6 @@
|
||||
}
|
||||
}
|
||||
|
||||
-void
|
||||
-UIMInstance::uim_surrounding_text_request_cb (void *ptr)
|
||||
-{
|
||||
- UIMInstance *this_ptr = static_cast <UIMInstance *> (ptr);
|
||||
- if (this_ptr) {
|
||||
-
|
||||
- SCIM_DEBUG_IMENGINE(2) << "uim_surrounding_text_request_cb.\n";
|
||||
-
|
||||
- WideString wstr;
|
||||
- int cursor;
|
||||
-
|
||||
- if (this_ptr->get_surrounding_text (wstr, cursor)) {
|
||||
- String str = utf8_wcstombs (wstr);
|
||||
- uim_set_surrounding_text (this_ptr->m_uc, str.c_str (), cursor, wstr.length ());
|
||||
- }
|
||||
- }
|
||||
-}
|
||||
-
|
||||
-int
|
||||
-UIMInstance::uim_surrounding_text_delete_cb (void *ptr, int offset, int len)
|
||||
-{
|
||||
- UIMInstance *this_ptr = static_cast <UIMInstance *> (ptr);
|
||||
- int ret = -1;
|
||||
-
|
||||
- if (this_ptr) {
|
||||
- SCIM_DEBUG_IMENGINE(2) << "uim_surrounding_text_delete_cb.\n";
|
||||
-
|
||||
- if (this_ptr->delete_surrounding_text (offset, len))
|
||||
- ret = 0;
|
||||
- }
|
||||
-
|
||||
- return ret;
|
||||
-}
|
||||
/*
|
||||
vi:ts=4:nowrap:ai:expandtab
|
||||
*/
|
|
@ -1,12 +0,0 @@
|
|||
--- src/scim_uim_imengine.h.orig Mon Mar 26 17:12:19 2007
|
||||
+++ src/scim_uim_imengine.h Mon Mar 26 17:12:55 2007
|
||||
@@ -104,9 +104,6 @@
|
||||
static void uim_cand_select_cb (void *ptr, int index);
|
||||
static void uim_cand_shift_page_cb (void *ptr, int dir);
|
||||
static void uim_cand_deactive_cb (void *ptr);
|
||||
-
|
||||
- static void uim_surrounding_text_request_cb (void *ptr);
|
||||
- static int uim_surrounding_text_delete_cb (void *ptr, int offset, int len);
|
||||
};
|
||||
#endif
|
||||
/*
|
|
@ -1,10 +0,0 @@
|
|||
--- src/Makefile.in.orig Wed Feb 8 11:53:06 2006
|
||||
+++ src/Makefile.in Wed Feb 8 11:53:28 2006
|
||||
@@ -211,7 +211,6 @@
|
||||
uim_la_LDFLAGS = -avoid-version \
|
||||
-rpath $(moduledir) \
|
||||
-module \
|
||||
- @LIBTOOL_EXPORT_OPTIONS@ \
|
||||
@SCIM_LIBS@ \
|
||||
@UIM_LIBS@
|
||||
|
12
japanese/scim-uim/files/patch-src_scim_uim_imengine.cpp
Normal file
12
japanese/scim-uim/files/patch-src_scim_uim_imengine.cpp
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/scim_uim_imengine.cpp.orig 2008-05-19 00:54:00.000000000 +0900
|
||||
+++ src/scim_uim_imengine.cpp 2008-05-19 00:55:43.000000000 +0900
|
||||
@@ -34,7 +34,8 @@
|
||||
|
||||
#include <scim.h>
|
||||
#include "scim_uim_imengine.h"
|
||||
-#include <uim/uim-compat-scm.h>
|
||||
+#include <uim/uim-scm.h>
|
||||
+#include <uim/uim-util.h>
|
||||
|
||||
#define scim_module_init uim_LTX_scim_module_init
|
||||
#define scim_module_exit uim_LTX_scim_module_exit
|
Loading…
Reference in a new issue