- Update to 0.1.2

PR:		ports/160122
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Dennis Herrmann 2011-08-31 22:01:28 +00:00
parent 653563709b
commit c2ccb90d44
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=280915
10 changed files with 12 additions and 208 deletions

View file

@ -6,21 +6,21 @@
#
PORTNAME= libjit
PORTVERSION= 0.1.0
PORTREVISION= 1
PORTVERSION= 0.1.2
CATEGORIES= lang
MASTER_SITES= http://download.savannah.gnu.org/releases/dotgnu-pnet/
MASTER_SITES= SAVANNAH/dotgnu-pnet/libjit-releases
MAINTAINER= ports@FreeBSD.org
COMMENT= Libjit implements Just-In-Time compilation functionality
BROKEN= does not fetch
LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
USE_AUTOTOOLS= libtool
USE_GNOME= gnomehack
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
INFO= libjit
MAN3= libjit.3
@ -36,15 +36,7 @@ BROKEN= Fails to compile: internal gcc error
.endif
post-patch:
# fix for amd64, Upstream forgot a header file
${CP} ${FILESDIR}/extra-jit-rules-interp.h ${WRKSRC}/jit/jit-rules-interp.h
@${REINPLACE_CMD} -e 's|#undef HAVE_TGMATH_H||' \
${WRKSRC}/config.h.in
post-configure:
.if ${ARCH} != "amd64"
@${REINPLACE_CMD} -e 's|$$pic_flag -DPIC||' \
${WRKSRC}/libtool
.endif
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
SHA256 (libjit-0.1.0.tar.gz) = 8d04ff4fcb99aea354b0ff0000e91b04a5c403b0d63cfc3c49115617b363d271
SIZE (libjit-0.1.0.tar.gz) = 1092908
SHA256 (libjit-0.1.2.tar.gz) = f1650938b8f7cd1cd5280f6197f02c2161841d7d66beecf8f9c2d4115cb195d0
SIZE (libjit-0.1.2.tar.gz) = 1195466

View file

@ -1,103 +0,0 @@
/*
* jit-rules-interp.h - Rules that define the interpreter characteristics.
*
* Copyright (C) 2004 Southern Storm Software, Pty Ltd.
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
* the Free Software Foundation; either version 2 of the License, or
* (at your option) any later version.
*
* This program is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU General Public License for more details.
*
* You should have received a copy of the GNU General Public License
* along with this program; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
#ifndef _JIT_RULES_INTERP_H
#define _JIT_RULES_INTERP_H
#include "jit-interp.h"
#ifdef __cplusplus
extern "C" {
#endif
/*
* Information about all of the registers, in allocation order.
*/
#define JIT_REG_INFO \
{"r0", 0, -1, JIT_REG_ALL | JIT_REG_CALL_USED | \
JIT_REG_IN_STACK}, \
{"r1", 1, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r2", 2, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r3", 3, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r4", 4, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r5", 5, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r6", 6, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r7", 7, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r8", 8, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r9", 9, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r10", 10, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r11", 11, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r12", 12, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r13", 13, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r14", 14, -1, JIT_REG_ALL | JIT_REG_CALL_USED | JIT_REG_IN_STACK}, \
{"r15", 15, -1, JIT_REG_ALL | JIT_REG_CALL_USED | \
JIT_REG_IN_STACK},
#define JIT_NUM_REGS 16
#define JIT_NUM_GLOBAL_REGS 0
#define JIT_REG_STACK 1
#define JIT_REG_STACK_START 0
#define JIT_REG_STACK_END 15
/*
* Define to 1 if we should always load values into registers
* before operating on them. i.e. the CPU does not have reg-mem
* and mem-reg addressing modes.
*/
#define JIT_ALWAYS_REG_REG 1
/*
* The maximum number of bytes to allocate for the prolog.
* This may be shortened once we know the true prolog size.
*/
#define JIT_PROLOG_SIZE jit_function_interp_size
/*
* Preferred alignment for the start of functions.
*/
#define JIT_FUNCTION_ALIGNMENT (sizeof(void *))
/*
* Define this to 1 if the platform allows reads and writes on
* any byte boundary. Define to 0 if only properly-aligned
* memory accesses are allowed.
*/
#define JIT_ALIGN_OVERRIDES 0
/*
* Extra state information that is added to the "jit_gencode" structure.
*/
#define jit_extra_gen_state \
int working_area; \
int max_working_area; \
int extra_working_space
#define jit_extra_gen_init(gen) \
do { \
(gen)->working_area = 0; \
(gen)->max_working_area = 0; \
(gen)->extra_working_space = 0; \
} while (0)
#define jit_extra_gen_cleanup(gen) do { ; } while (0)
#ifdef __cplusplus
};
#endif
#endif /* _JIT_RULES_INTERP_H */

View file

@ -1,12 +0,0 @@
--- jit/jit-apply.c.orig Tue Apr 27 00:21:55 2004
+++ jit/jit-apply.c Tue Apr 27 00:23:21 2004
@@ -23,6 +23,9 @@
#include "jit-apply-rules.h"
#include "jit-apply-func.h"
#include "jit-cache.h"
+#ifdef __FreeBSD__
+ #include <stdlib.h>
+#endif
#if HAVE_ALLOCA_H
#include <alloca.h>
#endif

View file

@ -1,12 +0,0 @@
--- jit/jit-insn.c.orig Tue Apr 27 00:22:44 2004
+++ jit/jit-insn.c Tue Apr 27 00:23:09 2004
@@ -21,6 +21,9 @@
#include "jit-internal.h"
#include "jit-rules.h"
#include <config.h>
+#ifdef __FreeBSD__
+ #include <stdlib.h>
+#endif
#if HAVE_ALLOCA_H
#include <alloca.h>
#endif

View file

@ -1,12 +0,0 @@
--- jit/jit-interp.c.orig Sun Aug 8 14:47:39 2004
+++ jit/jit-interp.c Sun Aug 8 14:48:08 2004
@@ -33,6 +33,9 @@
#if HAVE_ALLOCA_H
#include <alloca.h>
#endif
+#ifdef __FreeBSD__
+ #include <stdlib.h>
+#endif
#ifdef JIT_WIN32_PLATFORM
#include <malloc.h>
#ifndef alloca

View file

@ -1,12 +0,0 @@
--- tools/gen-apply.c.orig Tue Apr 27 00:26:20 2004
+++ tools/gen-apply.c Tue Apr 27 00:26:40 2004
@@ -22,6 +22,9 @@
#include "jit-apply-func.h"
#include <stdio.h>
#include <config.h>
+#ifdef __FreeBSD__
+ #include <stdlib.h>
+#endif
#if HAVE_ALLOCA_H
#include <alloca.h>
#endif

View file

@ -1,38 +0,0 @@
--- ltmain.sh.orig 2008-11-09 00:28:51.000000000 +0800
+++ ltmain.sh 2008-11-09 00:32:32.000000000 +0800
@@ -3420,7 +3420,7 @@
if test "$?" -eq 0 ; then
ldd_output=`ldd conftest`
for i in $deplibs; do
- name="`expr $i : '-l\(.*\)'`"
+ name="`expr X$i : 'X-l\(.*\)'`"
# If $name is empty we are operating on a -L argument.
if test "$name" != "" && test "$name" -ne "0"; then
if test "X$allow_libtool_libs_with_static_runtimes" = "Xyes" ; then
@@ -3457,7 +3457,7 @@
# Error occurred in the first compile. Let's try to salvage
# the situation: Compile a separate program for each library.
for i in $deplibs; do
- name="`expr $i : '-l\(.*\)'`"
+ name="`expr X$i : 'X-l\(.*\)'`"
# If $name is empty we are operating on a -L argument.
if test "$name" != "" && test "$name" != "0"; then
$rm conftest
@@ -3509,7 +3509,7 @@
set dummy $deplibs_check_method
file_magic_regex=`expr "$deplibs_check_method" : "$2 \(.*\)"`
for a_deplib in $deplibs; do
- name="`expr $a_deplib : '-l\(.*\)'`"
+ name="`expr X$a_deplib : 'X-l\(.*\)'`"
# If $name is empty we are operating on a -L argument.
if test "$name" != "" && test "$name" != "0"; then
if test "X$allow_libtool_libs_with_static_runtimes" = "Xyes" ; then
@@ -3578,7 +3578,7 @@
set dummy $deplibs_check_method
match_pattern_regex=`expr "$deplibs_check_method" : "$2 \(.*\)"`
for a_deplib in $deplibs; do
- name="`expr $a_deplib : '-l\(.*\)'`"
+ name="`expr X$a_deplib : 'X-l\(.*\)'`"
# If $name is empty we are operating on a -L argument.
if test -n "$name" && test "$name" != "0"; then
if test "X$allow_libtool_libs_with_static_runtimes" = "Xyes" ; then

View file

@ -9,4 +9,4 @@ libjit on a machine for which a native code generator is not yet available,
then libjit will fall back to interpreting the code. This way, you don't need
to write your own interpreter for your bytecode format if you don't want to.
WWW: http://www.southern-storm.com.au/libjit.html
WWW: http://www.gnu.org/software/dotgnu/

View file

@ -1,5 +1,5 @@
include/jit/jit-arch.h
include/jit/jit-apply.h
include/jit/jit-arch.h
include/jit/jit-block.h
include/jit/jit-common.h
include/jit/jit-context.h
@ -19,6 +19,7 @@ include/jit/jit-objmodel.h
include/jit/jit-opcode.h
include/jit/jit-plus.h
include/jit/jit-type.h
include/jit/jit-unwind.h
include/jit/jit-util.h
include/jit/jit-value.h
include/jit/jit-walk.h