Add p5-File-RsyncP 0.44, perl Rsync client.
PR: 61240 Submitted by: Lars Thegler <lars@thegler.dk>
This commit is contained in:
parent
fec3f1ec6d
commit
c31ff7536d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=97990
11 changed files with 224 additions and 0 deletions
|
@ -451,6 +451,7 @@
|
|||
SUBDIR += p5-Cflow
|
||||
SUBDIR += p5-EasyTCP
|
||||
SUBDIR += p5-File-Rsync
|
||||
SUBDIR += p5-File-RsyncP
|
||||
SUBDIR += p5-Filesys-SmbClient
|
||||
SUBDIR += p5-Frontier-RPC
|
||||
SUBDIR += p5-Geo-IP
|
||||
|
|
28
net/p5-File-RsyncP/Makefile
Normal file
28
net/p5-File-RsyncP/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# New ports collection makefile for: p5-File-RsyncP
|
||||
# Date created: Mon Dec 22 10:30:25 GMT 2003
|
||||
# Whom: Lars Thegler <lars@thegler.dk>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= File-RsyncP
|
||||
PORTVERSION= 0.44
|
||||
CATEGORIES= net perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= File
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= lars@thegler.dk
|
||||
COMMENT= Perl Rsync client
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3= File::RsyncP.3 \
|
||||
File::RsyncP::Digest.3 \
|
||||
File::RsyncP::FileList.3 \
|
||||
File::RsyncP::FileIO.3
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name \*.orig -delete
|
||||
|
||||
.include <bsd.port.mk>
|
1
net/p5-File-RsyncP/distinfo
Normal file
1
net/p5-File-RsyncP/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (File-RsyncP-0.44.tar.gz) = 1c238af568362c8ed6da7d2691fda1bb
|
12
net/p5-File-RsyncP/files/patch-Digest.xs
Normal file
12
net/p5-File-RsyncP/files/patch-Digest.xs
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- Digest/Digest.xs.orig Sat Jan 10 16:27:37 2004
|
||||
+++ Digest/Digest.xs Sat Jan 10 16:28:38 2004
|
||||
@@ -169,8 +169,7 @@
|
||||
}
|
||||
|
||||
SV *
|
||||
-blockDigestUpdate(context, dataV, blockSize=700, blockLastLen=0, \
|
||||
- md4DigestLen=16, seed=0)
|
||||
+blockDigestUpdate(context, dataV, blockSize=700, blockLastLen=0, md4DigestLen=16, seed=0)
|
||||
PREINIT:
|
||||
STRLEN len;
|
||||
INPUT:
|
20
net/p5-File-RsyncP/files/patch-FileIO.pm
Normal file
20
net/p5-File-RsyncP/files/patch-FileIO.pm
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- lib/File/RsyncP/FileIO.pm.orig Thu Jul 24 04:33:37 2003
|
||||
+++ lib/File/RsyncP/FileIO.pm Mon Jan 12 10:57:29 2004
|
||||
@@ -44,7 +44,7 @@
|
||||
use File::Find;
|
||||
use Data::Dumper;
|
||||
|
||||
-our $VERSION = '0.44';
|
||||
+use vars qw($VERSION); $VERSION = '0.44';
|
||||
|
||||
use constant S_IFMT => 0170000; # type of file
|
||||
use constant S_IFDIR => 0040000; # directory
|
||||
@@ -664,7 +664,7 @@
|
||||
|
||||
foreach my $str ( @logStr ) {
|
||||
next if ( $str eq "" );
|
||||
- $fio->{logHandler}($str);
|
||||
+ $fio->{logHandler}->($str);
|
||||
}
|
||||
}
|
||||
|
40
net/p5-File-RsyncP/files/patch-FileList.pm
Normal file
40
net/p5-File-RsyncP/files/patch-FileList.pm
Normal file
|
@ -0,0 +1,40 @@
|
|||
--- FileList/FileList.pm.orig Mon Jan 12 10:52:48 2004
|
||||
+++ FileList/FileList.pm Mon Jan 12 10:53:50 2004
|
||||
@@ -39,14 +39,13 @@
|
||||
|
||||
package File::RsyncP::FileList;
|
||||
|
||||
-use 5.006;
|
||||
use strict;
|
||||
-use warnings;
|
||||
|
||||
require Exporter;
|
||||
require DynaLoader;
|
||||
|
||||
-our @ISA = qw(Exporter AutoLoader DynaLoader);
|
||||
+use vars qw(@ISA %EXPORT_TAGS @EXPORT_OK @EXPORT $VERSION);
|
||||
+@ISA = qw(Exporter AutoLoader DynaLoader);
|
||||
|
||||
# Items to export into callers namespace by default. Note: do not export
|
||||
# names by default without a very good reason. Use EXPORT_OK instead.
|
||||
@@ -55,16 +54,16 @@
|
||||
# This allows declaration use File::RsyncP::FileList ':all';
|
||||
# If you do not need this, moving things directly into @EXPORT or @EXPORT_OK
|
||||
# will save memory.
|
||||
-our %EXPORT_TAGS = ( 'all' => [ qw(
|
||||
+%EXPORT_TAGS = ( 'all' => [ qw(
|
||||
|
||||
) ] );
|
||||
|
||||
-our @EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
|
||||
+@EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
|
||||
|
||||
-our @EXPORT = qw(
|
||||
+@EXPORT = qw(
|
||||
|
||||
);
|
||||
-our $VERSION = '0.44';
|
||||
+$VERSION = '0.44';
|
||||
|
||||
bootstrap File::RsyncP::FileList $VERSION;
|
||||
|
45
net/p5-File-RsyncP/files/patch-FileList.xs
Normal file
45
net/p5-File-RsyncP/files/patch-FileList.xs
Normal file
|
@ -0,0 +1,45 @@
|
|||
--- FileList/FileList.xs.orig Thu Jul 24 04:33:37 2003
|
||||
+++ FileList/FileList.xs Mon Jan 12 10:27:51 2004
|
||||
@@ -93,8 +93,9 @@
|
||||
PROTOTYPES: DISABLE
|
||||
|
||||
File::RsyncP::FileList
|
||||
-new(packname = "File::RsyncP::FileList", SV* opts = NULL)
|
||||
+new(packname = "File::RsyncP::FileList", opts = NULL)
|
||||
char *packname
|
||||
+ SV* opts
|
||||
CODE:
|
||||
{
|
||||
RETVAL = flist_new();
|
||||
@@ -187,14 +188,14 @@
|
||||
if ( file->sum )
|
||||
hv_store(rh, "sum", 3, newSVpv(file->sum, 0), 0);
|
||||
hv_store(rh, "name", 4, newSVpv(f_name(file), 0), 0);
|
||||
- hv_store(rh, "uid", 3, newSVuv(file->uid), 0);
|
||||
- hv_store(rh, "gid", 3, newSVuv(file->gid), 0);
|
||||
- hv_store(rh, "mode", 4, newSVuv(file->mode), 0);
|
||||
- hv_store(rh, "mtime", 5, newSVuv(file->modtime), 0);
|
||||
+ hv_store(rh, "uid", 3, newSViv(file->uid), 0);
|
||||
+ hv_store(rh, "gid", 3, newSViv(file->gid), 0);
|
||||
+ hv_store(rh, "mode", 4, newSViv(file->mode), 0);
|
||||
+ hv_store(rh, "mtime", 5, newSViv(file->modtime), 0);
|
||||
hv_store(rh, "size", 4, newSVnv(file->length), 0);
|
||||
hv_store(rh, "dev", 3, newSVnv(file->dev), 0);
|
||||
hv_store(rh, "inode", 5, newSVnv(file->inode), 0);
|
||||
- hv_store(rh, "rdev", 4, newSVuv(file->rdev), 0);
|
||||
+ hv_store(rh, "rdev", 4, newSViv(file->rdev), 0);
|
||||
RETVAL = newRV((SV*)rh);
|
||||
}
|
||||
OUTPUT:
|
||||
@@ -210,9 +211,10 @@
|
||||
}
|
||||
|
||||
void
|
||||
-encode(flist, SV* data)
|
||||
+encode(flist, data)
|
||||
INPUT:
|
||||
File::RsyncP::FileList flist
|
||||
+ SV* data
|
||||
CODE:
|
||||
{
|
||||
struct file_struct file, *fileCopy;
|
38
net/p5-File-RsyncP/files/patch-RsyncP.pm
Normal file
38
net/p5-File-RsyncP/files/patch-RsyncP.pm
Normal file
|
@ -0,0 +1,38 @@
|
|||
--- lib/File/RsyncP.pm.orig Thu Jul 24 04:33:37 2003
|
||||
+++ lib/File/RsyncP.pm Mon Jan 12 10:31:36 2004
|
||||
@@ -48,7 +48,7 @@
|
||||
use Getopt::Long;
|
||||
use Data::Dumper;
|
||||
|
||||
-our $VERSION = '0.44';
|
||||
+use vars qw($VERSION); $VERSION = '0.44';
|
||||
|
||||
use constant S_IFMT => 0170000; # type of file
|
||||
use constant S_IFDIR => 0040000; # directory
|
||||
@@ -267,7 +267,7 @@
|
||||
close(RSYNC);
|
||||
$rs->{fh} = *FH;
|
||||
$rs->{rsyncPID} = $pid;
|
||||
- $rs->{pidHandler}($rs->{rsyncPID}, $rs->{childPID})
|
||||
+ $rs->{pidHandler}->($rs->{rsyncPID}, $rs->{childPID})
|
||||
if ( defined($rs->{pidHandler}) );
|
||||
#
|
||||
# Write our version and get the remote version
|
||||
@@ -391,7 +391,7 @@
|
||||
$rs->{childFh} = *RH;
|
||||
$rs->{childPID} = $pid;
|
||||
$rs->log("Child PID is $pid") if ( $rs->{logLevel} >= 2 );
|
||||
- $rs->{pidHandler}($rs->{rsyncPID}, $rs->{childPID})
|
||||
+ $rs->{pidHandler}->($rs->{rsyncPID}, $rs->{childPID})
|
||||
if ( defined($rs->{pidHandler}) );
|
||||
setsockopt($rs->{fh}, SOL_SOCKET, SO_SNDBUF, 8 * 65536);
|
||||
setsockopt($rs->{childFh}, SOL_SOCKET, SO_RCVBUF, 8 * 65536);
|
||||
@@ -1088,7 +1088,7 @@
|
||||
|
||||
foreach my $str ( @logStr ) {
|
||||
next if ( $str eq "" );
|
||||
- $rs->{logHandler}($str);
|
||||
+ $rs->{logHandler}->($str);
|
||||
}
|
||||
}
|
||||
|
16
net/p5-File-RsyncP/files/patch-md4.h
Normal file
16
net/p5-File-RsyncP/files/patch-md4.h
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- Digest/md4.h.orig Mon Jan 12 10:37:04 2004
|
||||
+++ Digest/md4.h Mon Jan 12 10:44:59 2004
|
||||
@@ -38,6 +38,13 @@
|
||||
unsigned char rsyncBug;
|
||||
} MD4_CTX;
|
||||
|
||||
+#define MD4Init myMD4Init
|
||||
+#define MD4Update myMD4Update
|
||||
+#define MD4Final myMD4Final
|
||||
+#define MD4Encode myMD4Encode
|
||||
+#define MD4FinalRsync myMD4FinalRsync
|
||||
+#define MD4Decode myMD4Decode
|
||||
+
|
||||
void MD4Init PROTO_LIST ((MD4_CTX *));
|
||||
void MD4Update PROTO_LIST
|
||||
((MD4_CTX *, unsigned char *, unsigned int));
|
6
net/p5-File-RsyncP/pkg-descr
Normal file
6
net/p5-File-RsyncP/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
File::RsyncP is a perl implementation of an Rsync client. It is
|
||||
compatible with Rsync 2.5.5 (protocol version 26). It can send or
|
||||
receive files, either by running rsync on the remote machine, or
|
||||
connecting to an rsyncd deamon on the remote machine.
|
||||
|
||||
WWW: http://search.cpan.org/dist/File-RsyncP
|
17
net/p5-File-RsyncP/pkg-plist
Normal file
17
net/p5-File-RsyncP/pkg-plist
Normal file
|
@ -0,0 +1,17 @@
|
|||
%%SITE_PERL%%/%%PERL_ARCH%%/File/RsyncP.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/File/RsyncP/Digest.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/File/RsyncP/FileIO.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/File/RsyncP/FileList.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/RsyncP/Digest/Digest.so
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/RsyncP/Digest/Digest.bs
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/RsyncP/Digest/autosplit.ix
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/RsyncP/FileList/FileList.so
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/RsyncP/FileList/FileList.bs
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/RsyncP/FileList/autosplit.ix
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/RsyncP/.packlist
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/RsyncP/Digest 2>/dev/null || true
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/RsyncP/FileList 2>/dev/null || true
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/RsyncP 2>/dev/null || true
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/File/RsyncP 2>/dev/null || true
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/File 2>/dev/null || true
|
Loading…
Reference in a new issue