hebrew/he2: Remove expired port

2024-01-16 hebrew/he2: Upstream last release was in 2001
This commit is contained in:
Muhammad Moinur Rahman 2024-01-17 18:11:00 +01:00
parent c61309e21b
commit c33696d39d
No known key found for this signature in database
GPG Key ID: BDB9B5A617C0BC91
14 changed files with 1 additions and 134 deletions

1
MOVED
View File

@ -2943,3 +2943,4 @@ japanese/jed||2024-01-17|Has expired: Upstream site vaporized and returns NXDOMA
editors/fte||2024-01-17|Has expired: Upstream last release was in 2001
chinese/celvis||2024-01-17|Has expired: Last upstream release was in 2001
x11-clocks/intclock||2024-01-17|Has expired: Upstream website vaporized
hebrew/he2||2024-01-17|Has expired: Upstream last release was in 2001

View File

@ -3,7 +3,6 @@
SUBDIR += aspell
SUBDIR += culmus
SUBDIR += elmar-fonts
SUBDIR += he2
SUBDIR += hspell
SUBDIR += hunspell
SUBDIR += libreoffice

View File

@ -1,28 +0,0 @@
PORTNAME= he2
PORTVERSION= 0.61
PORTREVISION= 3
CATEGORIES= hebrew editors
MASTER_SITES= SF/${PORTNAME}/HebrewEditor/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Editor for editing (primarily LaTeX) Hebrew files
WWW= https://www.sourceforge.net/projects/he2/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Upstream last release was in 2001
EXPIRATION_DATE= 2024-01-16
RUN_DEPENDS= iw-elmar-fonts>0:hebrew/elmar-fonts
USES= gmake ncurses
USE_CXXSTD= c++98
GNU_CONFIGURE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-lcurses -ltermcap|-lncurses|' \
${WRKSRC}/he2/Makefile.in ${WRKSRC}/he2/Makefile.am
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (he2-0.61.tar.gz) = 4a8d65089f671114815cc853a01e9106945e593acaa277e19df07ead9ed1897f
SIZE (he2-0.61.tar.gz) = 476620

View File

@ -1,11 +0,0 @@
--- he2/HebrewEditor.cxx.orig 2001-03-24 08:36:42 UTC
+++ he2/HebrewEditor.cxx
@@ -224,7 +224,7 @@ HebrewEditor::HebrewEditor(int argc, char **argv){
screen->Refresh() ;
screen->GetMaxYX(&sizey, &sizex) ;
- buffers = new (Edit *)[MAX_BUFFER_COUNT] ;
+ buffers = new Edit *[MAX_BUFFER_COUNT] ;
aString filename ;
bufferCount = 0 ;
if (argc > 1) {

View File

@ -1,11 +0,0 @@
--- he2/Makefile.in.orig 2001-03-24 08:54:33 UTC
+++ he2/Makefile.in
@@ -582,7 +582,7 @@ install-data-local:
$(INSTALL_DATA) $(srcdir)/data/espell.wor $(DESTDIR)/$(datadir)/he2/espell.wor
$(INSTALL_DATA) $(srcdir)/data/hspell.wor $(DESTDIR)/$(datadir)/he2/hspell.wor
$(INSTALL_DATA) $(srcdir)/data/laxet.wor $(DESTDIR)/$(datadir)/he2/laxet.wor
- $(INSTALL_DATA) $(srcdir)/data/.he2rc $(DESTDIR)/$(datadir)/he2/.he2rc
+ $(INSTALL_DATA) $(srcdir)/data/.he2rc $(DESTDIR)/$(datadir)/he2/.he2rc.sample
install-exec-local:
$(mkinstalldirs) $(bindir)

View File

@ -1,13 +0,0 @@
--- he2/hebSegment.cxx.orig 2001-03-14 09:04:03 UTC
+++ he2/hebSegment.cxx
@@ -869,8 +869,8 @@ char *hebrew_segment_starters[] = { "\\R{", "\\section
#define alpha "abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ"
#define anum "0123456789*+=-?@!%^&~:'\".,;()`<>/|_"
-#define alphanum alpha ## "0123456789*+=-?@!%^&~:'\".,;()`<>/|"
-#define all alphanum ## "${}^[]"
+#define alphanum alpha "0123456789*+=-?@!%^&~:'\".,;()`<>/|"
+#define all alphanum "${}^[]"
int
hebSegment::_processLatexCommand(char *buffer, char **str, modeStack& stack)
{

View File

@ -1,11 +0,0 @@
--- he2/hebString.cxx.orig 2001-03-14 09:04:03 UTC
+++ he2/hebString.cxx
@@ -21,7 +21,7 @@
#include "hebString.h"
#include <string.h>
-#include <iostream.h>
+#include <iostream>
#include <assert.h>

View File

@ -1,11 +0,0 @@
--- he2/aDictionary.cxx.orig 2001-03-14 09:04:03 UTC
+++ he2/aDictionary.cxx
@@ -128,7 +128,7 @@ aDictionary::findMatchingWords(int accuracyLevel, char
return 0 ; // nothing to look for
}
- char **res = new (char *)[result_count_max] ;
+ char **res = new char *[result_count_max] ;
int *res_dist = new int[result_count_max] ;
int last_res= 0 ;
char *str, **pstr ;

View File

@ -1,11 +0,0 @@
--- he2/aString.h.orig 2001-03-14 09:04:03 UTC
+++ he2/aString.h
@@ -162,7 +162,6 @@ friend char *areplicate(char c, int count) ;
void delete_ch(int at) ;
friend char *areplicate(char c, int count) ;
} ;
-
-
+char *areplicate(char c, int count) ;
#endif

View File

@ -1,11 +0,0 @@
--- he2/he2.in.orig 2001-03-13 11:30:14 UTC
+++ he2/he2.in
@@ -2,7 +2,7 @@ if test "$DISPLAY." != "." ; then
export HEDIR=#datadir#/he2
if test "$DISPLAY." != "." ; then
export HE2_NEW_SHELL_ON_SUSPEND=1
- xterm +sb -fn heb8x13 -geometry 90x40 -T "Hebrew Editor" -e he2-bin $*
+ xterm +sb -fn heb-new8x14 -geometry 90x40 -T "Hebrew Editor" -e he2-bin $*
else
export HE2_NEW_SHELL_ON_SUSPEND=
he2-bin $*

View File

@ -1,5 +0,0 @@
The Hebrew Editor package is intended mostly for Hebrew speaking users for
creating and editing Hebrew/English LaTeX documents.
This package provides a text (terminal) based word processor (in the spirit
of the good-old DOS days word processors) which is extremely LaTeX oriented.

View File

@ -1,11 +0,0 @@
[
{ type: install
message: <<EOM
I've installed a sample config file for you in
${PREFIX}/share/he2/.he2rc.sample
You may want to copy it to either your home directory, or to a file named
${PREFIX}/share/he2/.he2rc to set some system-wide defaults.
EOM
}
]

View File

@ -1,8 +0,0 @@
bin/he2
bin/he2-bin
bin/laxet
%%DATADIR%%/.he2rc.sample
%%DATADIR%%/HE-Tutorial.h
%%DATADIR%%/espell.wor
%%DATADIR%%/hspell.wor
%%DATADIR%%/laxet.wor