-- Remove libgmp dependency. It's not used (openssl BN is used).
-- We don't have <des.h> anymore. Use <openssl/des.h>.
This commit is contained in:
parent
75e0e76533
commit
c35c9933e8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=76053
3 changed files with 23 additions and 2 deletions
|
@ -17,8 +17,6 @@ MASTER_SITE_SUBDIR= LOCAL_PORTS
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= OpenBSD IKE daemon
|
||||
|
||||
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
|
||||
|
||||
# this is not compatible with cross build - there's no other way
|
||||
.if !exists(/usr/include/netinet6/ipsec.h)
|
||||
BROKEN= "requires IPsec support"
|
||||
|
|
11
security/isakmpd/files/patch-Makefile.sysdep
Normal file
11
security/isakmpd/files/patch-Makefile.sysdep
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- sysdep/freebsd/Makefile.sysdep.orig Fri Feb 21 10:14:47 2003
|
||||
+++ sysdep/freebsd/Makefile.sysdep Thu Aug 29 01:39:36 2002
|
||||
@@ -42,7 +42,7 @@
|
||||
LIBSYSDEPDIR= ${.CURDIR}/sysdep/common/libsysdep
|
||||
.endif
|
||||
|
||||
-LDADD+= -lgmp ${LIBSYSDEPDIR}/libsysdep.a -lipsec -L/usr/local/lib
|
||||
+LDADD+= ${LIBSYSDEPDIR}/libsysdep.a -lipsec -L/usr/local/lib
|
||||
DPADD+= ${LIBGMP} ${LIBSYSDEPDIR}/libsysdep.a
|
||||
|
||||
CFLAGS+= -DHAVE_GETNAMEINFO -DHAVE_GETIFADDRS \
|
12
security/isakmpd/files/patch-crypto.h
Normal file
12
security/isakmpd/files/patch-crypto.h
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- crypto.h.orig Fri Feb 21 10:11:51 2003
|
||||
+++ crypto.h Fri Feb 21 10:11:58 2003
|
||||
@@ -49,7 +49,8 @@
|
||||
|
||||
#else
|
||||
|
||||
-#include <des.h>
|
||||
+#define OPENSSL_DES_LIBDES_COMPATIBILITY
|
||||
+#include <openssl/des.h>
|
||||
#ifdef USE_BLOWFISH
|
||||
#include <blf.h>
|
||||
#endif
|
Loading…
Reference in a new issue