- Fix build
PR: 184870 Submitted by: Ports Fury
This commit is contained in:
parent
d0300e4017
commit
c361f92abc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=341052
3 changed files with 34 additions and 9 deletions
|
@ -8,23 +8,28 @@ CATEGORIES= textproc
|
|||
MASTER_SITES= http://alioth.debian.org/frs/download.php/1469/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A diff application for semistructured data such as XML files
|
||||
COMMENT= Diff application for semistructured data such as XML files
|
||||
|
||||
LICENSE= GPLv2 # (or later)
|
||||
|
||||
USE_AUTOTOOLS= automake14
|
||||
USE_BZIP2= yes
|
||||
USES= pkgconfig
|
||||
USE_GNOME= libxml2
|
||||
MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include \
|
||||
-I${LOCALBASE}/include/libxml2"
|
||||
USE_GNOME= libxml2
|
||||
USE_GCC= any
|
||||
USE_AUTOTOOLS= automake14
|
||||
|
||||
PLIST_FILES= bin/xmldiff
|
||||
|
||||
NO_STAGE= yes
|
||||
post-extract:
|
||||
@${FIND} ${WRKSRC} -type l -delete
|
||||
|
||||
post-patch:
|
||||
.for f in config.guess config.sub install-sh missing mkinstalldirs
|
||||
@${LN} -sf ${AUTOMAKE_DIR}/${f} ${WRKSRC}/${f}
|
||||
.endfor
|
||||
@${REINPLACE_CMD} -e 's,"getopt\.h",<unistd.h>,' \
|
||||
${WRKSRC}/src/main.cc
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|^CXXFLAGS|AM_CPPFLAGS|' ${WRKSRC}/src/Makefile.am
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|"getopt\.h"|<unistd.h>|' ${WRKSRC}/src/main.cc
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
10
textproc/ssddiff/files/patch-src__rel_count.h
Normal file
10
textproc/ssddiff/files/patch-src__rel_count.h
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/rel_count.h.orig
|
||||
+++ src/rel_count.h
|
||||
@@ -13,6 +13,7 @@
|
||||
#define SSD_REL_COUNT_H
|
||||
#include "config.h"
|
||||
#include "rel_eqclass.h"
|
||||
+#include <climits>
|
||||
#include <vector>
|
||||
#include <ext/hash_map>
|
||||
|
10
textproc/ssddiff/files/patch-src__ustring.h
Normal file
10
textproc/ssddiff/files/patch-src__ustring.h
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/ustring.h.orig
|
||||
+++ src/ustring.h
|
||||
@@ -14,6 +14,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
+#include <cstring>
|
||||
#include <iostream>
|
||||
#include <map>
|
||||
#include <ext/hash_map>
|
Loading…
Reference in a new issue