Add gnome-user-share, an application that lets GNOME users share a personal,

public file space via WebDAV.  The resulting share will automatically be
visible in Nautilus.
This commit is contained in:
Joe Marcus Clarke 2004-11-26 22:16:16 +00:00
parent d33bc206ed
commit c3892fcb48
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=122533
8 changed files with 101 additions and 0 deletions

View file

@ -136,6 +136,7 @@
SUBDIR += geolizer
SUBDIR += gforge
SUBDIR += glibwww
SUBDIR += gnome-user-share
SUBDIR += gnuinfo
SUBDIR += goose
SUBDIR += grail

View file

@ -0,0 +1,37 @@
# New ports collection makefile for: gnome-user-share
# Date created: 26 November 2004
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gnome-user-share
PORTVERSION= 0.3
CATEGORIES= www deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.3
DIST_SUBDIR= gnome2
MAINTAINER= marcus@FreeBSD.org
COMMENT= Personal file-sharing service for the GNOME Desktop
LIB_DEPENDS= howl:${PORTSDIR}/net/howl
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_APACHE= yes
APACHE_PORT= www/apache2
USE_GNOME= gnomeprefix gnomehack intlhack libglade2 gconf2
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= desktop_gnome_file_sharing.schemas
post-patch:
@${REINPLACE_CMD} -e 's|/etc/httpd/modules|${LOCALBASE}/libexec/apache2|g' \
${WRKSRC}/dav_user.conf
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
MD5 (gnome2/gnome-user-share-0.3.tar.bz2) = 2f760af8691d5a7202aa2d52f286d965
SIZE (gnome2/gnome-user-share-0.3.tar.bz2) = 219045

View file

@ -0,0 +1,9 @@
--- dav_user.conf.orig Fri Nov 26 15:50:13 2004
+++ dav_user.conf Fri Nov 26 15:50:22 2004
@@ -1,5 +1,6 @@
ServerRoot ${HOME}/.gnome2/user-share
PidFile pid
+LockFile lock
LogLevel crit
#LogLevel info
ErrorLog log

View file

@ -0,0 +1,10 @@
--- file-share-properties.c.orig Fri Nov 26 14:53:54 2004
+++ file-share-properties.c Fri Nov 26 14:54:07 2004
@@ -1,6 +1,7 @@
#include "config.h"
#include <string.h>
+#include <stdio.h>
#include <gtk/gtk.h>
#include <glib/gi18n.h>

View file

@ -0,0 +1,26 @@
--- user_share.c.orig Fri Nov 26 04:33:51 2004
+++ user_share.c Fri Nov 26 17:12:13 2004
@@ -59,6 +59,14 @@
return -1;
}
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__APPLE__)
+ /* XXX This exposes a potential race condition, but without this,
+ * httpd will not start on the above listed platforms due to the fact
+ * that SO_REUSEADDR is also needed when Apache binds to the listening
+ * socket. At this time, Apache does not support that socket option.
+ */
+ close (sock);
+#endif
return ntohs (addr.sin_port);
}
@@ -171,7 +179,7 @@
char *free1, *free2;
gboolean res;
char *argv[10];
- char *env[10];;
+ char *env[10];
int i;
gint status;
char *pid_filename;

View file

@ -0,0 +1,11 @@
gnome-user-share is a small package that binds together various free
software projects to bring easy to use user-level file sharing to the
masses.
The program is meant to run in the background when the user is logged
in, and when file sharing is enabled a webdav server is started that
shares the $HOME/Public folder. The share is then published to all
computers on the local network using mDNS/rendezvous, so that it shows
up in the Network location in Gnome.
-- gnome-user-share README

View file

@ -0,0 +1,5 @@
bin/gnome-file-share-properties
libexec/gnome-user-share
share/gnome/gnome-user-share/dav_user.conf
share/gnome/gnome-user-share/file-share-properties.glade
@dirrm share/gnome/gnome-user-share